]> git.pld-linux.org Git - packages/pida.git/blame - pida.spec
- release 5
[packages/pida.git] / pida.spec
CommitLineData
ecb6b3ca 1# TODO:
2# - investigate the documentation format in doc
ecb6b3ca 3# - verify if such a big version jump actually works
6bfc3d1d 4# - move .po files to glibc dir and test if it works
59ac13b3 5# are these used afterall, as they are .po sources not .mo compiled
6bfc3d1d 6# - moo_stub is just sample? kill it and can make package noarch.
ecb6b3ca 7#
b4d7d842
MWP
8%define realname PIDA
9#
64e7236a 10Summary: A framework for integrated development
aa504356 11Summary(pl.UTF-8): Szkielet do programowania zintegrowanego
64e7236a 12Name: pida
14ca2239 13Version: 0.5.1
53b6bec1 14Release: 5
64e7236a
AM
15License: GPL
16Group: Development/Tools
b4d7d842 17Source0: http://pida.googlecode.com/files/%{realname}-%{version}.tar.gz
14ca2239 18# Source0-md5: d24bbdc2c07172062cf55dffe58c85f6
8a944c88 19Source1: %{name}.desktop
f897d35c 20URL: http://pida.berlios.de/
72354d77 21BuildRequires: python-devel
d9d81bd3 22BuildRequires: python-pygtk-devel
72354d77 23BuildRequires: python-setuptools
687255d6 24BuildRequires: rpm-pythonprov
8a944c88 25Requires: python-gnome-desktop-gtksourceview
be3b976b 26Requires: python-gnome-gconf
ecb6b3ca 27Requires: python-kiwi
6bfc3d1d 28Requires: python-vte
64e7236a
AM
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
64e7236a
AM
31%description
32PIDA is an integrated development environment (IDE) for UNIX-like
33operating systems.
34
35Unique Features:
36- Vim embedding
37- File browser that understands version status information for CVS,
38 Subversion, Darcs, Monotone, Mercurial, Bazaar-ng and Arch
687255d6 39- Built in GTK+ rapid application development
64e7236a
AM
40- Many more unique and obsessive touches
41
7b05534b
JR
42%description -l pl.UTF-8
43PIDA to zintegrowane środowisko programistyczne (IDE) dla uniksowych
44systemów operacyjnych.
687255d6
JB
45
46Unikalne cechy:
47- osadzony Vim
7b05534b
JR
48- przeglądarka plików uwzględniająca informacje o stanie wersji dla
49 systemów kontroli wersji CVS, Subversion, Darcs, Monotone, Mercurial,
72354d77 50 Bazaar-ng i Arch
7b05534b
JR
51- wbudowane środowisko szybkiego tworzenia aplikacji GTK+
52- wiele innych unikalnych i pożądanych drobiazgów
687255d6 53
64e7236a 54%prep
b4d7d842 55%setup -q -n %{realname}-%{version}
64e7236a
AM
56
57%build
58python setup.py build
59
60%install
61rm -rf $RPM_BUILD_ROOT
8a944c88 62install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
64e7236a
AM
63
64python setup.py install \
65 --install-data=%{_datadir}/%{name} \
6bfc3d1d
ER
66 --root=$RPM_BUILD_ROOT \
67 --optimize=2
64e7236a 68
b4d7d842 69cp $RPM_BUILD_ROOT%{py_sitedir}/%{name}/resources/pixmaps/pida-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}
8a944c88 70install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
6bfc3d1d 71%py_postclean
8a944c88 72
64e7236a
AM
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%files
77%defattr(644,root,root,755)
14ca2239 78%doc AUTHORS README
6bfc3d1d
ER
79%attr(755,root,root) %{_bindir}/pida
80%attr(755,root,root) %{_bindir}/pida-remote
81
82# see todo at top of the spec
a3b701c5
ER
83%dir %{py_sitedir}/pida/resources/locale
84%dir %{py_sitedir}/pida/services/appcontroller/locale
85%dir %{py_sitedir}/pida/services/buffer/locale
86%dir %{py_sitedir}/pida/services/bugreport/locale
87%dir %{py_sitedir}/pida/services/commander/locale
88%dir %{py_sitedir}/pida/services/editor/locale
89%dir %{py_sitedir}/pida/services/filemanager/locale
90%dir %{py_sitedir}/pida/services/grepper/locale
91%dir %{py_sitedir}/pida/services/help/locale
92%dir %{py_sitedir}/pida/services/manhole/locale
93%dir %{py_sitedir}/pida/services/notify/locale
94%dir %{py_sitedir}/pida/services/openwith/locale
95%dir %{py_sitedir}/pida/services/optionsmanager/locale
96%dir %{py_sitedir}/pida/services/plugins/locale
97%dir %{py_sitedir}/pida/services/project/locale
98%dir %{py_sitedir}/pida/services/sessions/locale
99%dir %{py_sitedir}/pida/services/shortcuts/locale
100%dir %{py_sitedir}/pida/services/versioncontrol/locale
101%dir %{py_sitedir}/pida/services/webbrowser/locale
102%dir %{py_sitedir}/pida/services/window/locale
c8825a35
ER
103%lang(fr) %{py_sitedir}/pida/resources/locale/fr_FR
104%lang(fr) %{py_sitedir}/pida/services/appcontroller/locale/fr_FR
105%lang(fr) %{py_sitedir}/pida/services/buffer/locale/fr_FR
106%lang(fr) %{py_sitedir}/pida/services/bugreport/locale/fr_FR
107%lang(fr) %{py_sitedir}/pida/services/commander/locale/fr_FR
108%lang(fr) %{py_sitedir}/pida/services/editor/locale/fr_FR
109%lang(fr) %{py_sitedir}/pida/services/filemanager/locale/fr_FR
110%lang(fr) %{py_sitedir}/pida/services/grepper/locale/fr_FR
111%lang(fr) %{py_sitedir}/pida/services/help/locale/fr_FR
112%lang(fr) %{py_sitedir}/pida/services/manhole/locale/fr_FR
113%lang(fr) %{py_sitedir}/pida/services/notify/locale/fr_FR
114%lang(fr) %{py_sitedir}/pida/services/openwith/locale/fr_FR
115%lang(fr) %{py_sitedir}/pida/services/optionsmanager/locale/fr_FR
116%lang(fr) %{py_sitedir}/pida/services/plugins/locale/fr_FR
117%lang(fr) %{py_sitedir}/pida/services/project/locale/fr_FR
118%lang(fr) %{py_sitedir}/pida/services/sessions/locale/fr_FR
119%lang(fr) %{py_sitedir}/pida/services/shortcuts/locale/fr_FR
120%lang(fr) %{py_sitedir}/pida/services/versioncontrol/locale/fr_FR
121%lang(fr) %{py_sitedir}/pida/services/webbrowser/locale/fr_FR
122%lang(fr) %{py_sitedir}/pida/services/window/locale/fr_FR
6bfc3d1d 123
6c72fbd0
ER
124%if "%{py_ver}" > "2.4"
125%{py_sitedir}/*-*.egg-info
126%{py_sitedir}/*-*.egg-info
6d46eb0a 127%{py_sitedir}/*-py2.*.egg-info
6c72fbd0 128%endif
6d46eb0a 129
c8825a35 130%dir %{py_sitedir}/pida
6bfc3d1d
ER
131%attr(755,root,root) %{py_sitedir}/moo_stub.so
132%{py_sitedir}/pida/*.py[co]
6bfc3d1d
ER
133%{py_sitedir}/pida/core
134%{py_sitedir}/pida/editors
135%dir %{py_sitedir}/pida/resources
136%{py_sitedir}/pida/resources/glade
137%{py_sitedir}/pida/resources/pixmaps
138%{py_sitedir}/pida/resources/uidef
139%dir %{py_sitedir}/pida/services
140%dir %{py_sitedir}/pida/services/appcontroller
141%{py_sitedir}/pida/services/appcontroller/*.py[co]
142%{py_sitedir}/pida/services/appcontroller/service.pida
143%{py_sitedir}/pida/services/appcontroller/uidef
144%dir %{py_sitedir}/pida/services/buffer
145%{py_sitedir}/pida/services/buffer/glade
146%{py_sitedir}/pida/services/buffer/*.py[co]
147%{py_sitedir}/pida/services/buffer/service.pida
af50c188 148%{py_sitedir}/pida/services/buffer/uidef
6bfc3d1d
ER
149%dir %{py_sitedir}/pida/services/bugreport
150%{py_sitedir}/pida/services/bugreport/glade
151%{py_sitedir}/pida/services/bugreport/*.py[co]
152%{py_sitedir}/pida/services/bugreport/service.pida
153%{py_sitedir}/pida/services/bugreport/uidef
154%dir %{py_sitedir}/pida/services/commander
155%{py_sitedir}/pida/services/commander/*.py[co]
156%{py_sitedir}/pida/services/commander/service.pida
157%{py_sitedir}/pida/services/commander/uidef
158%dir %{py_sitedir}/pida/services/contexts
159%{py_sitedir}/pida/services/contexts/*.py[co]
160%{py_sitedir}/pida/services/contexts/service.pida
161%{py_sitedir}/pida/services/contexts/uidef
162%dir %{py_sitedir}/pida/services/editor
163%{py_sitedir}/pida/services/editor/*.py[co]
164%{py_sitedir}/pida/services/editor/service.pida
165%dir %{py_sitedir}/pida/services/filemanager
166%{py_sitedir}/pida/services/filemanager/*.py[co]
167%{py_sitedir}/pida/services/filemanager/service.pida
168%{py_sitedir}/pida/services/filemanager/uidef
169%dir %{py_sitedir}/pida/services/filewatcher
170%{py_sitedir}/pida/services/filewatcher/*.py[co]
171%{py_sitedir}/pida/services/filewatcher/service.pida
172%dir %{py_sitedir}/pida/services/grepper
173%{py_sitedir}/pida/services/grepper/glade
174%{py_sitedir}/pida/services/grepper/*.py[co]
175%{py_sitedir}/pida/services/grepper/service.pida
176%{py_sitedir}/pida/services/grepper/uidef
177%dir %{py_sitedir}/pida/services/help
178%{py_sitedir}/pida/services/help/*.py[co]
179%{py_sitedir}/pida/services/help/service.pida
180%{py_sitedir}/pida/services/help/uidef
181%dir %{py_sitedir}/pida/services/manhole
182%{py_sitedir}/pida/services/manhole/*.py[co]
183%{py_sitedir}/pida/services/manhole/service.pida
184%{py_sitedir}/pida/services/manhole/uidef
185%dir %{py_sitedir}/pida/services/notify
186%{py_sitedir}/pida/services/notify/*.py[co]
187%{py_sitedir}/pida/services/notify/service.pida
188%{py_sitedir}/pida/services/notify/uidef
189%dir %{py_sitedir}/pida/services/openwith
190%{py_sitedir}/pida/services/openwith/glade
191%{py_sitedir}/pida/services/openwith/*.py[co]
192%{py_sitedir}/pida/services/openwith/service.pida
193%{py_sitedir}/pida/services/openwith/uidef
194%dir %{py_sitedir}/pida/services/optionsmanager
195%{py_sitedir}/pida/services/optionsmanager/glade
196%{py_sitedir}/pida/services/optionsmanager/*.py[co]
197%{py_sitedir}/pida/services/optionsmanager/service.pida
198%{py_sitedir}/pida/services/optionsmanager/uidef
199%dir %{py_sitedir}/pida/services/plugins
200%{py_sitedir}/pida/services/plugins/glade
201%{py_sitedir}/pida/services/plugins/*.py[co]
202%{py_sitedir}/pida/services/plugins/service.pida
203%{py_sitedir}/pida/services/plugins/uidef
204%dir %{py_sitedir}/pida/services/project
205%{py_sitedir}/pida/services/project/glade
206%{py_sitedir}/pida/services/project/*.py[co]
207%{py_sitedir}/pida/services/project/service.pida
208%{py_sitedir}/pida/services/project/uidef
209%{py_sitedir}/pida/services/*.py[co]
210%dir %{py_sitedir}/pida/services/rpc
211%{py_sitedir}/pida/services/rpc/*.py[co]
212%{py_sitedir}/pida/services/rpc/service.pida
213%dir %{py_sitedir}/pida/services/sessions
214%{py_sitedir}/pida/services/sessions/*.py[co]
215%{py_sitedir}/pida/services/sessions/service.pida
216%{py_sitedir}/pida/services/sessions/uidef
217%dir %{py_sitedir}/pida/services/shortcuts
218%{py_sitedir}/pida/services/shortcuts/*.py[co]
219%{py_sitedir}/pida/services/shortcuts/service.pida
220%{py_sitedir}/pida/services/shortcuts/uidef
221%dir %{py_sitedir}/pida/services/statusbar
222%{py_sitedir}/pida/services/statusbar/*.py[co]
223%{py_sitedir}/pida/services/statusbar/service.pida
224%dir %{py_sitedir}/pida/services/versioncontrol
225%{py_sitedir}/pida/services/versioncontrol/glade
226%{py_sitedir}/pida/services/versioncontrol/*.py[co]
227%{py_sitedir}/pida/services/versioncontrol/service.pida
228%{py_sitedir}/pida/services/versioncontrol/uidef
229%dir %{py_sitedir}/pida/services/webbrowser
230%{py_sitedir}/pida/services/webbrowser/*.py[co]
231%{py_sitedir}/pida/services/webbrowser/service.pida
232%{py_sitedir}/pida/services/webbrowser/uidef
233%dir %{py_sitedir}/pida/services/window
234%{py_sitedir}/pida/services/window/*.py[co]
235%{py_sitedir}/pida/services/window/service.pida
236%{py_sitedir}/pida/services/window/uidef
237%{py_sitedir}/pida/ui
238%{py_sitedir}/pida/utils
239
8a944c88
RK
240%{_pixmapsdir}/*.png
241%{_desktopdir}/*.desktop
This page took 0.094196 seconds and 4 git commands to generate.