]> git.pld-linux.org Git - packages/pida.git/blame - pida.spec
- packaging fixes
[packages/pida.git] / pida.spec
CommitLineData
ecb6b3ca 1# TODO:
2# - investigate the documentation format in doc
ecb6b3ca 3# - verify if such a big version jump actually works
6bfc3d1d
ER
4# - move .po files to glibc dir and test if it works
5# - moo_stub is just sample? kill it and can make package noarch.
ecb6b3ca 6#
b4d7d842
MWP
7%define realname PIDA
8#
64e7236a 9Summary: A framework for integrated development
aa504356 10Summary(pl.UTF-8): Szkielet do programowania zintegrowanego
64e7236a 11Name: pida
14ca2239 12Version: 0.5.1
6bfc3d1d 13Release: 1
64e7236a
AM
14License: GPL
15Group: Development/Tools
b4d7d842 16Source0: http://pida.googlecode.com/files/%{realname}-%{version}.tar.gz
14ca2239 17# Source0-md5: d24bbdc2c07172062cf55dffe58c85f6
8a944c88 18Source1: %{name}.desktop
f897d35c 19URL: http://pida.berlios.de/
72354d77 20BuildRequires: python-devel
d9d81bd3 21BuildRequires: python-pygtk-devel
72354d77 22BuildRequires: python-setuptools
687255d6 23BuildRequires: rpm-pythonprov
8a944c88 24Requires: python-gnome-desktop-gtksourceview
be3b976b 25Requires: python-gnome-gconf
ecb6b3ca 26Requires: python-kiwi
6bfc3d1d 27Requires: python-vte
64e7236a
AM
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
64e7236a
AM
30%description
31PIDA is an integrated development environment (IDE) for UNIX-like
32operating systems.
33
34Unique Features:
35- Vim embedding
36- File browser that understands version status information for CVS,
37 Subversion, Darcs, Monotone, Mercurial, Bazaar-ng and Arch
687255d6 38- Built in GTK+ rapid application development
64e7236a
AM
39- Many more unique and obsessive touches
40
7b05534b
JR
41%description -l pl.UTF-8
42PIDA to zintegrowane środowisko programistyczne (IDE) dla uniksowych
43systemów operacyjnych.
687255d6
JB
44
45Unikalne cechy:
46- osadzony Vim
7b05534b
JR
47- przeglądarka plików uwzględniająca informacje o stanie wersji dla
48 systemów kontroli wersji CVS, Subversion, Darcs, Monotone, Mercurial,
72354d77 49 Bazaar-ng i Arch
7b05534b
JR
50- wbudowane środowisko szybkiego tworzenia aplikacji GTK+
51- wiele innych unikalnych i pożądanych drobiazgów
687255d6 52
64e7236a 53%prep
b4d7d842 54%setup -q -n %{realname}-%{version}
64e7236a
AM
55
56%build
57python setup.py build
58
59%install
60rm -rf $RPM_BUILD_ROOT
8a944c88 61install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
64e7236a
AM
62
63python setup.py install \
64 --install-data=%{_datadir}/%{name} \
6bfc3d1d
ER
65 --root=$RPM_BUILD_ROOT \
66 --optimize=2
64e7236a 67
b4d7d842 68cp $RPM_BUILD_ROOT%{py_sitedir}/%{name}/resources/pixmaps/pida-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}
8a944c88 69install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
6bfc3d1d 70%py_postclean
8a944c88 71
64e7236a
AM
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%files
76%defattr(644,root,root,755)
14ca2239 77%doc AUTHORS README
6bfc3d1d
ER
78%attr(755,root,root) %{_bindir}/pida
79%attr(755,root,root) %{_bindir}/pida-remote
80
81# see todo at top of the spec
82%lang(fr) %{py_sitedir}/pida/resources/locale/fr_FR/LC_MESSAGES/pida.po
83%lang(fr) %{py_sitedir}/pida/services/appcontroller/locale/fr_FR/LC_MESSAGES/appcontroller.po
84%lang(fr) %{py_sitedir}/pida/services/buffer/locale/fr_FR/LC_MESSAGES/buffer.po
85%lang(fr) %{py_sitedir}/pida/services/bugreport/locale/fr_FR/LC_MESSAGES/bugreport.po
86%lang(fr) %{py_sitedir}/pida/services/commander/locale/fr_FR/LC_MESSAGES/commander.po
87%lang(fr) %{py_sitedir}/pida/services/editor/locale/fr_FR/LC_MESSAGES/editor.po
88%lang(fr) %{py_sitedir}/pida/services/filemanager/locale/fr_FR/LC_MESSAGES/filemanager.po
89%lang(fr) %{py_sitedir}/pida/services/grepper/locale/fr_FR/LC_MESSAGES/grepper.po
90%lang(fr) %{py_sitedir}/pida/services/help/locale/fr_FR/LC_MESSAGES/help.po
91%lang(fr) %{py_sitedir}/pida/services/manhole/locale/fr_FR/LC_MESSAGES/manhole.po
92%lang(fr) %{py_sitedir}/pida/services/notify/locale/fr_FR/LC_MESSAGES/notify.po
93%lang(fr) %{py_sitedir}/pida/services/openwith/locale/fr_FR/LC_MESSAGES/openwith.po
94%lang(fr) %{py_sitedir}/pida/services/optionsmanager/locale/fr_FR/LC_MESSAGES/optionsmanager.po
95%lang(fr) %{py_sitedir}/pida/services/plugins/locale/fr_FR/LC_MESSAGES/plugins.po
96%lang(fr) %{py_sitedir}/pida/services/project/locale/fr_FR/LC_MESSAGES/project.po
97%lang(fr) %{py_sitedir}/pida/services/sessions/locale/fr_FR/LC_MESSAGES/sessions.po
98%lang(fr) %{py_sitedir}/pida/services/shortcuts/locale/fr_FR/LC_MESSAGES/shortcuts.po
99%lang(fr) %{py_sitedir}/pida/services/versioncontrol/locale/fr_FR/LC_MESSAGES/versioncontrol.po
100%lang(fr) %{py_sitedir}/pida/services/webbrowser/locale/fr_FR/LC_MESSAGES/webbrowser.po
101%lang(fr) %{py_sitedir}/pida/services/window/locale/fr_FR/LC_MESSAGES/window.po
102
103%{py_sitedir}/*-py2.5.egg-info
104%attr(755,root,root) %{py_sitedir}/moo_stub.so
105%{py_sitedir}/pida/*.py[co]
106
107%{py_sitedir}/pida/core
108%{py_sitedir}/pida/editors
109%dir %{py_sitedir}/pida/resources
110%{py_sitedir}/pida/resources/glade
111%{py_sitedir}/pida/resources/pixmaps
112%{py_sitedir}/pida/resources/uidef
113%dir %{py_sitedir}/pida/services
114%dir %{py_sitedir}/pida/services/appcontroller
115%{py_sitedir}/pida/services/appcontroller/*.py[co]
116%{py_sitedir}/pida/services/appcontroller/service.pida
117%{py_sitedir}/pida/services/appcontroller/uidef
118%dir %{py_sitedir}/pida/services/buffer
119%{py_sitedir}/pida/services/buffer/glade
120%{py_sitedir}/pida/services/buffer/*.py[co]
121%{py_sitedir}/pida/services/buffer/service.pida
122%{py_sitedir}/pida/services/buffer/uidef/buffer-file-menu.xml
123%{py_sitedir}/pida/services/buffer/uidef/buffer.xml
124%dir %{py_sitedir}/pida/services/bugreport
125%{py_sitedir}/pida/services/bugreport/glade
126%{py_sitedir}/pida/services/bugreport/*.py[co]
127%{py_sitedir}/pida/services/bugreport/service.pida
128%{py_sitedir}/pida/services/bugreport/uidef
129%dir %{py_sitedir}/pida/services/commander
130%{py_sitedir}/pida/services/commander/*.py[co]
131%{py_sitedir}/pida/services/commander/service.pida
132%{py_sitedir}/pida/services/commander/uidef
133%dir %{py_sitedir}/pida/services/contexts
134%{py_sitedir}/pida/services/contexts/*.py[co]
135%{py_sitedir}/pida/services/contexts/service.pida
136%{py_sitedir}/pida/services/contexts/uidef
137%dir %{py_sitedir}/pida/services/editor
138%{py_sitedir}/pida/services/editor/*.py[co]
139%{py_sitedir}/pida/services/editor/service.pida
140%dir %{py_sitedir}/pida/services/filemanager
141%{py_sitedir}/pida/services/filemanager/*.py[co]
142%{py_sitedir}/pida/services/filemanager/service.pida
143%{py_sitedir}/pida/services/filemanager/uidef
144%dir %{py_sitedir}/pida/services/filewatcher
145%{py_sitedir}/pida/services/filewatcher/*.py[co]
146%{py_sitedir}/pida/services/filewatcher/service.pida
147%dir %{py_sitedir}/pida/services/grepper
148%{py_sitedir}/pida/services/grepper/glade
149%{py_sitedir}/pida/services/grepper/*.py[co]
150%{py_sitedir}/pida/services/grepper/service.pida
151%{py_sitedir}/pida/services/grepper/uidef
152%dir %{py_sitedir}/pida/services/help
153%{py_sitedir}/pida/services/help/*.py[co]
154%{py_sitedir}/pida/services/help/service.pida
155%{py_sitedir}/pida/services/help/uidef
156%dir %{py_sitedir}/pida/services/manhole
157%{py_sitedir}/pida/services/manhole/*.py[co]
158%{py_sitedir}/pida/services/manhole/service.pida
159%{py_sitedir}/pida/services/manhole/uidef
160%dir %{py_sitedir}/pida/services/notify
161%{py_sitedir}/pida/services/notify/*.py[co]
162%{py_sitedir}/pida/services/notify/service.pida
163%{py_sitedir}/pida/services/notify/uidef
164%dir %{py_sitedir}/pida/services/openwith
165%{py_sitedir}/pida/services/openwith/glade
166%{py_sitedir}/pida/services/openwith/*.py[co]
167%{py_sitedir}/pida/services/openwith/service.pida
168%{py_sitedir}/pida/services/openwith/uidef
169%dir %{py_sitedir}/pida/services/optionsmanager
170%{py_sitedir}/pida/services/optionsmanager/glade
171%{py_sitedir}/pida/services/optionsmanager/*.py[co]
172%{py_sitedir}/pida/services/optionsmanager/service.pida
173%{py_sitedir}/pida/services/optionsmanager/uidef
174%dir %{py_sitedir}/pida/services/plugins
175%{py_sitedir}/pida/services/plugins/glade
176%{py_sitedir}/pida/services/plugins/*.py[co]
177%{py_sitedir}/pida/services/plugins/service.pida
178%{py_sitedir}/pida/services/plugins/uidef
179%dir %{py_sitedir}/pida/services/project
180%{py_sitedir}/pida/services/project/glade
181%{py_sitedir}/pida/services/project/*.py[co]
182%{py_sitedir}/pida/services/project/service.pida
183%{py_sitedir}/pida/services/project/uidef
184%{py_sitedir}/pida/services/*.py[co]
185%dir %{py_sitedir}/pida/services/rpc
186%{py_sitedir}/pida/services/rpc/*.py[co]
187%{py_sitedir}/pida/services/rpc/service.pida
188%dir %{py_sitedir}/pida/services/sessions
189%{py_sitedir}/pida/services/sessions/*.py[co]
190%{py_sitedir}/pida/services/sessions/service.pida
191%{py_sitedir}/pida/services/sessions/uidef
192%dir %{py_sitedir}/pida/services/shortcuts
193%{py_sitedir}/pida/services/shortcuts/*.py[co]
194%{py_sitedir}/pida/services/shortcuts/service.pida
195%{py_sitedir}/pida/services/shortcuts/uidef
196%dir %{py_sitedir}/pida/services/statusbar
197%{py_sitedir}/pida/services/statusbar/*.py[co]
198%{py_sitedir}/pida/services/statusbar/service.pida
199%dir %{py_sitedir}/pida/services/versioncontrol
200%{py_sitedir}/pida/services/versioncontrol/glade
201%{py_sitedir}/pida/services/versioncontrol/*.py[co]
202%{py_sitedir}/pida/services/versioncontrol/service.pida
203%{py_sitedir}/pida/services/versioncontrol/uidef
204%dir %{py_sitedir}/pida/services/webbrowser
205%{py_sitedir}/pida/services/webbrowser/*.py[co]
206%{py_sitedir}/pida/services/webbrowser/service.pida
207%{py_sitedir}/pida/services/webbrowser/uidef
208%dir %{py_sitedir}/pida/services/window
209%{py_sitedir}/pida/services/window/*.py[co]
210%{py_sitedir}/pida/services/window/service.pida
211%{py_sitedir}/pida/services/window/uidef
212%{py_sitedir}/pida/ui
213%{py_sitedir}/pida/utils
214
8a944c88
RK
215%{_pixmapsdir}/*.png
216%{_desktopdir}/*.desktop
This page took 0.073927 seconds and 4 git commands to generate.