]> git.pld-linux.org Git - packages/phpMyAdmin.git/blame - phpMyAdmin.spec
- updated to 4.8.5 (solves CVE-2019-6798, CVE-2019-6799)
[packages/phpMyAdmin.git] / phpMyAdmin.spec
CommitLineData
fdda4e42
ER
1# TODO
2# - add codepress (http://codepress.org/index.php) patch
d2811cfc 3# - use system jquery (js/jquery), tcpdf (libraries/tcpdf) and php-gettext (libraries/gettext)
d8c0193b 4Summary: phpMyAdmin - web-based MySQL administration
7f70cea7 5Summary(pl.UTF-8): phpMyAdmin - administracja bazami MySQL przez WWW
78a895aa 6Name: phpMyAdmin
7c730d7c 7Version: 4.8.5
5052d2c7 8Release: 1
c6adf9fe 9License: GPL v2
78a895aa 10Group: Applications/Databases/Interfaces
37684297 11Source0: https://files.phpmyadmin.net/phpMyAdmin/%{version}/%{name}-%{version}-all-languages.tar.xz
7c730d7c 12# Source0-md5: e3737a28fff076003e56a83fe1920d04
1bdc8ed0 13Source1: apache.conf
59d81573 14Source2: %{name}-lighttpd.conf
d0c3620a 15Patch0: %{name}-config.patch
77cf866b
ER
16Patch1: %{name}-ServerSelectDisplayName.patch
17Patch2: %{name}-ServerSelectDisplayName-config.patch
c3f22269
JB
18URL: http://www.phpmyadmin.net/
19BuildRequires: rpmbuild(macros) >= 1.268
88c63352
ER
20BuildRequires: tar >= 1:1.22
21BuildRequires: xz
054dddf6
ŁK
22# phpMyAdmin doesn't support mysql < 5.5 and won't work with php < 5.3
23Requires: mysql-libs >= 5.5
17e2933d 24Requires: php(core) >= 5.3
58fb24fd
ER
25Requires: php(ctype)
26Requires: php(filter)
27Requires: php(json)
28Requires: php(mbstring)
29Requires: php(mcrypt)
30Requires: php(mysql)
31Requires: php(pcre)
32Requires: php(session)
33Requires: php(simplexml)
f935b243 34Requires: webapps
9c9eb38c 35Requires: webserver(access)
bef21c33 36Requires: webserver(alias)
88c63352 37Requires(triggerpostun): sed >= 4.0
37684297 38Suggests: php(mysqli)
7bb50a64 39Suggests: webserver(indexfile)
7e902492 40Suggests: webserver(php)
89cacb94 41BuildArch: noarch
78a895aa
PG
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
7e9b99de 44%define _appdir %{_datadir}/%{name}
f935b243
ER
45%define _webapps /etc/webapps
46%define _webapp %{name}
47%define _sysconfdir %{_webapps}/%{_webapp}
78a895aa
PG
48
49%description
50phpMyAdmin can administer a whole MySQL-server (needs a super-user)
51but also a single database. To accomplish the latter you'll need a
52properly set up MySQL-user who can read/write only the desired
53database. It's up to you to look up the appropiate part in the MySQL
54manual. Currently phpMyAdmin can:
1d23e58d 55- create and drop databases
56- create, copy, drop and alter tables
57- delete, edit and add fields
58- execute any SQL-statement, even batch-queries
59- manage keys on fields
60- load text files into tables
37684297
ER
61- create and read dumps of tables
62- export and import data to CSV values
1d23e58d 63- administer multiple servers and single databases
ffe964b1
TP
64- check referencial integrity
65- create complex queries automatically connecting required tables
66- create PDF graphics of your database layout
37684297 67- communicate in more than 72 different languages
78a895aa 68
27fed873
JR
69%description -l pl.UTF-8
70phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
71uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
72Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
73baz, którymi chcemy administrować (więcej informacji w odpowiedniej
74podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
75- tworzyć i usuwać bazy
76- wykonywać create, copy, drop oraz alter na tabelach
77- dodawać, usuwać i modyfikować pola
78- wykonywać dowolne zapytania SQL
79- zarządzać kluczami na rekordach
80- wczytywać tekst z plików do tabel
37684297 81- obsługiwać ponad 72 języków
27fed873
JR
82- zarządzać wieloma serwerami i pojedynczymi bazami danych
83- eksportować i importować dane do wartości CSV
84- tworzyć i czytać zrzuty tabel
78a895aa 85
78a895aa 86%prep
fb6eaade 87%setup -q -n %{name}-%{version}-all-languages
8677f286 88%patch0 -p1
fd72dd52 89%patch1 -p1
aae97293 90%patch2 -p0
78a895aa 91
218e7bb6
ER
92# cleanup backups after patching
93find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
94
fd72dd52 95%{__rm} .editorconfig .eslintignore .eslintrc.json composer.json composer.lock package.json phpcs.xml.dist yarn.lock
802c4032 96
78a895aa
PG
97%install
98rm -rf $RPM_BUILD_ROOT
591b67f6 99install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
f935b243 100
802c4032 101cp -a . $RPM_BUILD_ROOT%{_appdir}
78a895aa 102
1bdc8ed0 103cp -p libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
802c4032 104ln -s %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
aac07012 105
1bdc8ed0
ER
106cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
107cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
108cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
aac07012 109
802c4032 110# packaged as doc
fd72dd52 111%{__rm} $RPM_BUILD_ROOT%{_appdir}/{CONTRIBUTING.md,ChangeLog,DCO,LICENSE,README,RELEASE-DATE-*,CODE_OF_CONDUCT.md}
802c4032
ER
112# cleanup not packaged stuff
113%{__rm} -r $RPM_BUILD_ROOT%{_appdir}/{doc,examples,setup,sql}
114
78a895aa 115%clean
95798666 116rm -rf $RPM_BUILD_ROOT
78a895aa 117
879dcd55 118%triggerin -- apache1 < 1.3.37-3, apache1-base
f935b243 119%webapp_register apache %{_webapp}
aac07012 120
879dcd55 121%triggerun -- apache1 < 1.3.37-3, apache1-base
f935b243
ER
122%webapp_unregister apache %{_webapp}
123
223a219a 124%triggerin -- apache < 2.2.0, apache-base
f935b243
ER
125%webapp_register httpd %{_webapp}
126
223a219a 127%triggerun -- apache < 2.2.0, apache-base
f935b243 128%webapp_unregister httpd %{_webapp}
aac07012 129
59d81573
PG
130%triggerin -- lighttpd
131%webapp_register lighttpd %{_webapp}
132
133%triggerun -- lighttpd
134%webapp_unregister lighttpd %{_webapp}
135
78a895aa
PG
136%files
137%defattr(644,root,root,755)
802c4032 138%doc CONTRIBUTING.md ChangeLog DCO LICENSE README examples/
f935b243
ER
139%dir %attr(750,root,http) %{_sysconfdir}
140%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
141%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
59d81573 142%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
f935b243
ER
143%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
144%dir %{_appdir}
f935b243 145%{_appdir}/*.css
f935b243 146%{_appdir}/*.php
81443609 147%{_appdir}/favicon.ico
fd72dd52
ER
148%{_appdir}/js
149%{_appdir}/libraries
150%{_appdir}/locale
6f66c54e 151%{_appdir}/robots.txt
fd72dd52
ER
152%{_appdir}/themes
153%{_appdir}/templates
154%{_appdir}/vendor
This page took 0.460128 seconds and 5 git commands to generate.