]> git.pld-linux.org Git - packages/php4.git/blame - php4.spec
- release 4
[packages/php4.git] / php4.spec
CommitLineData
95decd1b 1#
e5798a47
JB
2# TODO:
3# - make additional headers added by mail patch configurable
5db1f7fc 4# - /var/run/php group not owned
e5798a47 5#
b6f861c7
JB
6# Conditional build:
7%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
9ee9d278 8%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
75ebc985 9%bcond_with hardening # build with hardening patch applied (http://www.hardened-php.net/)
b6f861c7
JB
10%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
11%bcond_with java # with Java extension module (BR: jdk)
12%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
13%bcond_with oracle # with oracle extension module (BR: proprietary libs)
14%bcond_without cpdf # without cpdf extension module
15%bcond_without curl # without CURL extension module
16%bcond_without domxslt # without DOM XSLT/EXSLT support in DOM XML extension module
9ee9d278 17%bcond_without fribidi # without FriBiDi extension module
b6f861c7
JB
18%bcond_without imap # without IMAP extension module
19%bcond_without interbase # without InterBase extension module
20%bcond_without ldap # without LDAP extension module
21%bcond_without mhash # without mhash extension module
22%bcond_without ming # without ming extension module
23%bcond_without mm # without mm support for session storage
24%bcond_without mnogosearch # without mnogosearch extension module
25%bcond_without msession # without msession extension module
26%bcond_without mssql # without MS SQL extension module
27%bcond_without odbc # without ODBC extension module
28%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
29%bcond_without pcre # without PCRE extension module
9ee9d278 30%bcond_without pdf # without PDF extension module
b6f861c7 31%bcond_without pgsql # without PostgreSQL extension module
11f81df6 32%bcond_without pspell # without pspell extension module
b6f861c7 33%bcond_without recode # without recode extension module
ff5548f5 34%bcond_without qtdom # without Qt DOM extension module
b6f861c7 35%bcond_without snmp # without SNMP extension module
9ee9d278 36%bcond_without sybase # without Sybase and Sybase-CT extension modules
b6f861c7
JB
37%bcond_without wddx # without WDDX extension module
38%bcond_without xmlrpc # without XML-RPC extension module
39%bcond_without xml # without XML and DOMXML extension modules
40%bcond_without xslt # without XSLT extension module
9ee9d278 41%bcond_without yaz # without YAZ extension module
74c09513
ER
42%bcond_without apache1 # disable building apache 1.3.x module
43%bcond_without apache2 # disable building apache 2.x module
44%bcond_with zts # enable-experimental-zts
285c3089 45
74c09513
ER
46%define apxs1 /usr/sbin/apxs1
47%define apxs2 /usr/sbin/apxs
285c3089 48
74c09513
ER
49# mm is not thread safe
50# ext/session/mod_mm.c:37:3: #error mm is not thread-safe
51%if %{with zts}
b6f861c7 52%undefine with_mm
b65cb5d0 53%endif
285c3089 54
41670838 55%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
b6f861c7 56%undefine with_interbase
ffb7a641 57%endif
285c3089 58
9ee9d278 59# x86-only lib
ffb7a641 60%ifnarch %{ix86}
b6f861c7 61%undefine with_msession
7f2d8ce7 62%endif
285c3089 63
b6f861c7 64%include /usr/lib/rpm/macros.php
5b453425 65Summary: The PHP HTML-embedded scripting language for use with Apache
66Summary(fr): Le langage de script embarque-HTML PHP pour Apache
7e581113 67