]> git.pld-linux.org Git - packages/php4.git/blame - php4.spec
- rebuild with versioned zts and debug provides; rel 16
[packages/php4.git] / php4.spec
CommitLineData
95decd1b 1#
d04affdd
JR
2# Do NOT build openssl as shared module or
3# fsockopen('tls://host',...) will not work!
4#
e5798a47
JB
5# TODO:
6# - make additional headers added by mail patch configurable
5db1f7fc 7# - /var/run/php group not owned
7443f062
ER
8#11:26:36 <@glen> php4-common-4.4.0-14 marks heimdal-libs-0.7.1-1 (cap heimdal-libs)
9#11:26:36 <@glen> heimdal-libs-0.7.1-1 marks openldap-libs-2.2.29-1 (cap liblber-2.2.so.7()(64bit))
10#11:26:36 <@glen> openldap-libs-2.2.29-1 marks cyrus-sasl-2.1.21-3 (cap cyrus-sasl)
11#11:27:00 <@glen> php5-common doesn't have such deps
e5798a47 12#
b6f861c7
JB
13# Conditional build:
14%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
9ee9d278 15%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
75ebc985 16%bcond_with hardening # build with hardening patch applied (http://www.hardened-php.net/)
b6f861c7
JB
17%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
18%bcond_with java # with Java extension module (BR: jdk)
19%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
20%bcond_with oracle # with oracle extension module (BR: proprietary libs)
21%bcond_without cpdf # without cpdf extension module
22%bcond_without curl # without CURL extension module
23%bcond_without domxslt # without DOM XSLT/EXSLT support in DOM XML extension module
9ee9d278 24%bcond_without fribidi # without FriBiDi extension module
b6f861c7
JB
25%bcond_without imap # without IMAP extension module
26%bcond_without interbase # without InterBase extension module
27%bcond_without ldap # without LDAP extension module
28%bcond_without mhash # without mhash extension module
29%bcond_without ming # without ming extension module
30%bcond_without mm # without mm support for session storage
31%bcond_without mnogosearch # without mnogosearch extension module
32%bcond_without msession # without msession extension module
33%bcond_without mssql # without MS SQL extension module
34%bcond_without odbc # without ODBC extension module
35%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
36%bcond_without pcre # without PCRE extension module
9ee9d278 37%bcond_without pdf # without PDF extension module
b6f861c7 38%bcond_without pgsql # without PostgreSQL extension module
11f81df6 39%bcond_without pspell # without pspell extension module
b6f861c7 40%bcond_without recode # without recode extension module
ff5548f5 41%bcond_without qtdom # without Qt DOM extension module
b6f861c7 42%bcond_without snmp # without SNMP extension module
9ee9d278 43%bcond_without sybase # without Sybase and Sybase-CT extension modules
b6f861c7
JB
44%bcond_without wddx # without WDDX extension module
45%bcond_without xmlrpc # without XML-RPC extension module
46%bcond_without xml # without XML and DOMXML extension modules
47%bcond_without xslt # without XSLT extension module
9ee9d278 48%bcond_without yaz # without YAZ extension module
74c09513
ER
49%bcond_without apache1 # disable building apache 1.3.x module
50%bcond_without apache2 # disable building apache 2.x module
02f996b3 51%bcond_without zts # disable experimental-zts
285c3089 52
74c09513
ER
53%define apxs1 /usr/sbin/apxs1
54%define apxs2 /usr/sbin/apxs
285c3089 55
74c09513
ER
56# mm is not thread safe
57# ext/session/mod_mm.c:37:3: #error mm is not thread-safe
be4aca3a 58%if %{with zts}
b6f861c7 59%undefine with_mm
b65cb5d0 60%endif
285c3089 61
41670838 62%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
b6f861c7 63%undefine with_interbase
ffb7a641 64%endif
285c3089 65
9ee9d278 66# x86-only lib
ffb7a641 67%ifnarch %{ix86}
b6f861c7 68%undefine with_msession
7f2d8ce7 69%endif
285c3089 70
5b453425 71Summary: The PHP HTML-embedded scripting language for use with Apache
72Summary(fr): Le langage de script embarque-HTML PHP pour Apache
7e581113 73