]> git.pld-linux.org Git - packages/php4-pecl-http.git/blame - php4-pecl-http.spec
- converted to UTF-8
[packages/php4-pecl-http.git] / php4-pecl-http.spec
CommitLineData
919731ea
AG
1%define _modname http
2%define _fmodname pecl_http
a01b0949 3%define _status stable
27c68ecd 4%define _sysconfdir /etc/php4
1ec7060b 5%define extensionsdir %(php-config --extension-dir 2>/dev/null)
919731ea
AG
6
7Summary: %{_modname} - extended HTTP support
5a3b7264 8Summary(pl.UTF-8): %{_modname} - rozszerzona obsługa protokołu HTTP
919731ea 9Name: php4-pecl-%{_modname}
86c38239 10Version: 1.3.3
323af3da 11Release: 1
a01b0949 12License: BSD
919731ea
AG
13Group: Development/Languages/PHP
14Source0: http://pecl.php.net/get/%{_fmodname}-%{version}.tgz
86c38239 15# Source0-md5: 96c16435936eab288d5fdd5750e3f863
919731ea 16URL: http://pecl.php.net/package/pecl_http/
d97deeb7 17BuildRequires: php4-devel >= 3:4.3.0
957625e2 18BuildRequires: rpmbuild(macros) >= 1.322
37b697de 19%{?requires_php_extension}
139f5bdc 20Requires: %{_sysconfdir}/conf.d
919731ea
AG
21Obsoletes: php-pear-%{_modname}
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
919731ea 24%description
a01b0949
AG
25This HTTP extension aims to provide a convenient and powerful set of
26functionality for one of PHPs major applications.
27
28It eases handling of HTTP urls, dates, redirects, headers and
29messages, provides means for negotiation of clients preferred language
30and charset, as well as a convenient way to send any arbitrary data
31with caching and resuming capabilities.
32
33It provides powerful request functionality, if built with CURL
34support. Parallel requests are available for PHP 5 and greater.
35
36Currently implemented features include:
919731ea
AG
37- Building absolute URIs
38- RFC compliant HTTP redirects
39- RFC compliant HTTP date handling
40- Parsing of HTTP headers and messages
41- Caching by "Last-Modified" and/or ETag (with 'on the fly' option for
42 ETag generation from buffered output)
43- Sending data/files/streams with (multiple) ranges support
44- Negotiating user preferred language/charset
d97deeb7
ER
45- Convenient request functions to HEAD/GET/POST if libcurl is
46 available
919731ea 47- HTTP auth hooks (Basic)
d97deeb7
ER
48- PHP5 classes: HttpUtil, HttpResponse, HttpRequest, HttpRequestPool,
49 HttpMessage
919731ea
AG
50
51In PECL status of this extension is: %{_status}.
52
5a3b7264
JR
53%description -l pl.UTF-8
54To rozszerzenie HTTP ma na celu dostarczenie wygodnego i potężnego
55zestawu funkcjonalności do jednego z najważniejszych zastosowań PHP.
a01b0949 56
5a3b7264
JR
57Ułatwia obsługę adresów HTTP, dat, przekierowań, nagłówków i
58wiadmości, dostarcza sposób do negocjacji preferowanego języka i
59strony kodowej klienta, jak również wygodnego sposobu wysyłania
60dowolnego rodzaju danych z możliwością keszowania oraz wznawiania
61transferów.
a01b0949 62
5a3b7264
JR
63Rozszerzenie dostracza potężne możliwości zapytań, jeśli zbudowane
64jest ze wsparciem dla CURL. Równoległe zapytania są dostępne od wersji
a01b0949
AG
65PHP 5.
66
5a3b7264
JR
67Aktualnie zaimplementowane możliwości to między innymi:
68- tworzenie bezwzględnych URI
919731ea 69- zgodne z RFC przekierowania HTTP
5a3b7264
JR
70- zgodna z RFC obsługa daty HTTP
71- przetwarzanie nagłówków i wiadomości HTTP
72- buforowanie z użyciem "Last-Modified" i/lub ETagów (z opcję
73 generowania "w locie" ETagów z buforowanego wyjścia)
74- wysyłanie danych/plików/strumieni z obsługą (wielu) przedziałów
75- negocjacja preferowanego przez użytkownika języka/zestawu znaków
76- wygodne funkcje do żądań HEAD/GET/POST jeśli dostępna jest libcurl
77- wywołania HTTP auth (Basic)
d97deeb7
ER
78- klasy PHP5: HttpUtil, HttpResponse, HttpRequest, HttpRequestPool,
79 HttpMessage
919731ea
AG
80
81To rozszerzenie ma w PECL status: %{_status}.
82
83%prep
84%setup -q -c
85
86%build
87cd %{_fmodname}-%{version}
88phpize
89%configure
90%{__make}
91
92%install
93rm -rf $RPM_BUILD_ROOT
f0ff75df 94install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
919731ea
AG
95
96install %{_fmodname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}/%{_modname}.so
f0ff75df
AG
97cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
98; Enable %{_modname} extension module
99extension=%{_modname}.so
100EOF
919731ea
AG
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post
f0ff75df
AG
106[ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
107[ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
919731ea 108
f0ff75df
AG
109%postun
110if [ "$1" = 0 ]; then
111 [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
112 [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
919731ea
AG
113fi
114
115%files
116%defattr(644,root,root,755)
a01b0949 117%doc %{_fmodname}-%{version}/{KnownIssues.txt,docs}
d97deeb7 118%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
919731ea 119%attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.084609 seconds and 4 git commands to generate.