]> git.pld-linux.org Git - packages/php.git/blame - php.spec
- conflict on php4-common package to prevent breaking partially updated systems
[packages/php.git] / php.spec
CommitLineData
82bb3a40 1# TODO:
8c91402c
AM
2# - think of including support for:
3# - mcve,
4# - ovrimos,
5# - pfpro,
8c91402c 6# These extensions BuildRequires proprietary libraries...
d0822c6c
JB
7# - deal with modules removed from php and not moved to PECL
8# (existing only in php4):
737e42ad 9# db, hyperwave, java, mcal, overload, qtdom
1017a8f0 10# and removed from php 5.1:
60218d7e 11# cpdf, fam, yp, oracle
8c9b39ce
ER
12# and removed from php 5.1.3:
13# msession
7aa94fdb
ER
14# and removed from php 5.2:
15# filepro, hw
1ffa7abd 16# - mime_magic can't handle new "string/*" entries in magic.mime
9091cd7b 17# thus doesn't work with system magic.mime database
6392ee57 18# - make additional headers added by mail patch configurable
543a3683 19# - apply -hardened patch by default ?
768d3bda 20# - modularize session, standard (output from pure php -m)?
82bb3a40 21#
6f91d99f
JB
22# Conditional build:
23%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
6e4962cf 24%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
43d48a12 25%bcond_with hardening # build with hardening patch applied (http://www.hardened-php.net/)
6f91d99f 26%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
6f91d99f 27%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
ffda81cd 28%bcond_without curl # without CURL extension module
696cac8d 29%bcond_without filter # without filter extension module
6f91d99f 30%bcond_without imap # without IMAP extension module
da7819f0 31%bcond_with interbase # with InterBase extension module
6f91d99f
JB
32%bcond_without ldap # without LDAP extension module
33%bcond_without mhash # without mhash extension module
420fb8d4 34%bcond_without mime_magic # without mime-magic module
6f91d99f
JB
35%bcond_without ming # without ming extension module
36%bcond_without mm # without mm support for session storage
6f91d99f 37%bcond_without mssql # without MS SQL extension module
ffda81cd 38%bcond_without mysqli # without mysqli support (Requires mysql > 4.1)
6f91d99f
JB
39%bcond_without odbc # without ODBC extension module
40%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
41%bcond_without pcre # without PCRE extension module
6f91d99f 42%bcond_without pgsql # without PostgreSQL extension module
274395e3 43%bcond_without pspell # without pspell extension module
6f91d99f 44%bcond_without recode # without recode extension module
6f91d99f 45%bcond_without snmp # without SNMP extension module
8c91402c 46%bcond_without sqlite # without SQLite extension module
41a6f471 47%bcond_without sybase # without Sybase extension module
4cc60252 48%bcond_without sybase_ct # without Sybase-CT extension module
8c91402c 49%bcond_without tidy # without Tidy extension module
6f91d99f
JB
50%bcond_without wddx # without WDDX extension module
51%bcond_without xmlrpc # without XML-RPC extension module
aa39c584 52%bcond_without apache1 # disable building apache 1.3.x module
3f700db8 53%bcond_without apache2 # disable building apache 2.x module
e8c48c38 54%bcond_without fcgi # disable building FCGI SAPI
1a64b68d 55%bcond_without zts # disable experimental-zts
8938ce4f 56%bcond_with versioning # build with experimental versioning (to load php4/php5 into same apache)
74f7e4ba 57
3f700db8
ER
58%define apxs1 /usr/sbin/apxs1
59%define apxs2 /usr/sbin/apxs
60
6f91d99f 61# some problems with apache 2.x
3f700db8 62%if %{with apache2}
6f91d99f 63%undefine with_mm
ab092fe1 64%endif
3f700db8 65
1ce8316b 66%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
6f91d99f 67%undefine with_interbase
52bba439 68%endif
3f700db8 69
f6477c6e 70%if !%{with apache1} && !%{with apache2}
8d79014f
ER
71ERROR: You need to select at least one Apache SAPI to build shared modules.
72%endif
73
696cac8d
ER
74# filter depends on pcre
75%if %{without pcre}
76%undefine with_filter
77%endif
78
101768a9 79%define _rel 0.22
c256acfe 80Summary: PHP: Hypertext Preprocessor
0c6ea8ca
JB
81Summary(fr): Le langage de script embarque-HTML PHP
82