]> git.pld-linux.org Git - projects/template-specs.git/blame - php-pecl.spec
- update
[projects/template-specs.git] / php-pecl.spec
CommitLineData
fc1df23f
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
5%define modname -
6Summary: %{modname} -
7Summary(pl.UTF-8): %{modname} -
8Name: php-pecl-%{modname}
a7223ec4
AG
9Version: 1.0
10Release: 1
4099af7d 11License: PHP 3.01
a7223ec4 12Group: Development/Languages/PHP
fc1df23f 13Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
dc5e1efb 14# Source0-md5: -
796e9b9e 15URL: http://pecl.php.net/package/Modname/
05e722ff 16BuildRequires: php-devel >= 4:5.0.4
7c5d3695 17BuildRequires: rpmbuild(macros) >= 1.519
672c5afc 18%{?requires_php_extension}
a7223ec4
AG
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
a7223ec4
AG
21%description
22
9be49f18 23%description -l pl.UTF-8
a7223ec4 24
a7223ec4 25%prep
05e722ff 26%setup -qc
fc1df23f 27mv %{modname}-%{version}/* .
a7223ec4
AG
28
29%build
a7223ec4
AG
30phpize
31%configure
32%{__make}
33
34%install
35rm -rf $RPM_BUILD_ROOT
f6dd55ea 36install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
9c71ffdc
ER
37install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
38install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
a7223ec4 39
852624ea 40%{__make} install \
852624ea 41 INSTALL_ROOT=$RPM_BUILD_ROOT \
6e284c47 42 EXTENSION_DIR=%{php_extensiondir}
fc1df23f
ER
43cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
44; Enable %{modname} extension module
45extension=%{modname}.so
ceb2ba66 46EOF
a7223ec4 47
9c71ffdc
ER
48cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49
a7223ec4
AG
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%post
6e284c47 54%php_webserver_restart
a7223ec4 55
ceb2ba66
AG
56%postun
57if [ "$1" = 0 ]; then
6e284c47 58 %php_webserver_restart
a7223ec4
AG
59fi
60
61%files
62%defattr(644,root,root,755)
f8cfa67b 63%doc CREDITS EXPERIMENTAL
fc1df23f
ER
64%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
65%attr(755,root,root) %{php_extensiondir}/%{modname}.so
9c71ffdc 66%{_examplesdir}/%{name}-%{version}
This page took 0.051112 seconds and 4 git commands to generate.