]> git.pld-linux.org Git - packages/php-pecl-zendopcache.git/blame - php-pecl-zendopcache.spec
document all .ini file settings. description taken from README
[packages/php-pecl-zendopcache.git] / php-pecl-zendopcache.spec
CommitLineData
43eeafa3
ER
1# NOTE:
2# This version of Zend OPcache is compatible with PHP 5.2.*, 5.3.*, 5.4.*
3# and PHP-5.5 development branch. PHP 5.2 support may be removed in the future.
4%define modname zendopcache
5Summary: Zend Optimizer+ - PHP code optimizer
6Summary(pl.UTF-8): Zend Optimizer+ - optymalizator kodu PHP
7Name: php-pecl-%{modname}
8Version: 7.0.1
022f8857 9Release: 1
43eeafa3
ER
10License: PHP 3.01
11Group: Libraries
12Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
13# Source0-md5: 3a0a43a4819c72763bc35ecf5689221e
223ba653 14Source1: %{modname}.ini
43eeafa3
ER
15URL: http://pecl.php.net/package/zendopcache
16BuildRequires: php-devel >= 4:5.0.4
17BuildRequires: rpmbuild(macros) >= 1.519
18%{?requires_php_extension}
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22The Zend OPcache provides faster PHP execution through opcode caching
23and optimization. It improves PHP performance by storing precompiled
24script bytecode in the shared memory. This eliminates the stages of
25reading code from the disk and compiling it on future access. In
26addition, it applies a few bytecode optimization patterns that make
27code execution faster.
28
29%prep
30%setup -qc
31mv %{modname}-%{version}/* .
32
33%build
34phpize
35%configure
36%{__make}
37
38%install
39rm -rf $RPM_BUILD_ROOT
40%{__make} install \
41 EXTENSION_DIR=%{php_extensiondir} \
42 INSTALL_ROOT=$RPM_BUILD_ROOT
43
43eeafa3
ER
44# NOTE: In case you are going to use Zend OPcache together with Xdebug,
45# be sure that Xdebug is loaded after OPcache. "php -v" must show Xdebug
46# after OPcache.
47install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
223ba653 48sed -e 's,@extensiondir@,%{php_extensiondir},' %{SOURCE1} > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
43eeafa3
ER
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%post
54%php_webserver_restart
55
56%postun
57if [ "$1" = 0 ]; then
58 %php_webserver_restart
59fi
60
61%files
62%defattr(644,root,root,755)
63%doc README LICENSE
64%attr(755,root,root) %{php_extensiondir}/opcache.so
65%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php/conf.d/%{modname}.ini
This page took 0.139883 seconds and 4 git commands to generate.