]> git.pld-linux.org Git - packages/php-pecl-xslcache.git/blame - php-pecl-xslcache.spec
- cleanup, requires devel package to build
[packages/php-pecl-xslcache.git] / php-pecl-xslcache.spec
CommitLineData
58838bce 1#
2# Conditional build:
3%bcond_without tests # build without tests
4
5%define modname xslcache
6Summary: %{modname} - A modification of PHP's standard XSL extension that caches the parsed XSL stylesheet representation
7Summary(pl.UTF-8): %{modname} - modyfikacja standardowego rozszerzenia XSL PHP, które buforuje przetworzone reprezentacje arkuszów stylów XSL
8Name: php-pecl-%{modname}
9Version: 0.7.1
10Release: 1
11License: PHP 3.01
12Group: Development/Languages/PHP
13Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
14# Source0-md5: 1e32327f62122055ece6f78fa2b851b2
15URL: http://pecl.php.net/package/xslcache
fb30ee94 16BuildRequires: libxslt-devel >= 1.1.0
58838bce 17BuildRequires: php-devel >= 3:5.0.0
18BuildRequires: rpmbuild(macros) >= 1.519
19%{?requires_php_extension}
20Requires: php-common >= 4:5.0.4
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24The XSL Cache extension is a modification of PHP's standard XSL
25extension that caches the parsed XSL stylesheet representation between
26sessions for 2.5x boost in performance for sites that repeatedly apply
27the same transform. Although there is still some further work that
28could be done on the extension, this code is already proving
29beneficial in production use for a few applications on the New York
30Times' website.
31
58838bce 32%prep
33%setup -q -c
34mv %{modname}-%{version}/* .
35
36%build
37phpize
38%configure \
39 --with-xslcache=%{_libdir} \
40 --with-xsl-exsl-dir=%{_libdir}
41%{__make}
42
43%install
58838bce 44install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
58838bce 45
46%{__make} install \
47 INSTALL_ROOT=$RPM_BUILD_ROOT \
48 EXTENSION_DIR=%{php_extensiondir}
49cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
50; Enable %{modname} extension module
51extension=%{modname}.so
52EOF
53
58838bce 54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%post
58%php_webserver_restart
59
60%postun
61if [ "$1" = 0 ]; then
62 %php_webserver_restart
63fi
64
65%files
66%defattr(644,root,root,755)
fb30ee94 67%doc CREDITS
58838bce 68%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
69%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.071163 seconds and 4 git commands to generate.