]> git.pld-linux.org Git - packages/php-pecl-xslcache.git/blame - php-pecl-xslcache.spec
- obsolete old php name
[packages/php-pecl-xslcache.git] / php-pecl-xslcache.spec
CommitLineData
70869304 1%define php_name php%{?php_suffix}
bc0b38b7 2%define modname xslcache
58838bce 3Summary: %{modname} - A modification of PHP's standard XSL extension that caches the parsed XSL stylesheet representation
4Summary(pl.UTF-8): %{modname} - modyfikacja standardowego rozszerzenia XSL PHP, które buforuje przetworzone reprezentacje arkuszów stylów XSL
70869304 5Name: %{php_name}-pecl-%{modname}
bc0b38b7 6Version: 0.7.2
100717a7 7Release: 4
58838bce 8License: PHP 3.01
9Group: Development/Languages/PHP
10Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
bc0b38b7 11# Source0-md5: 8c8570503baf7c9711f2d7bf842c292d
58838bce 12URL: http://pecl.php.net/package/xslcache
100717a7 13BuildRequires: %{php_name}-devel >= 3:5.0.4
8ad34e97 14BuildRequires: libxslt-devel >= 1.1.0
70869304 15BuildRequires: rpmbuild(macros) >= 1.650
58838bce 16%{?requires_php_extension}
8ad34e97 17Provides: php(%{modname}) = %{version}
100717a7 18Obsoletes: php-pecl-xslcache < 0.7.2-3
58838bce 19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22The XSL Cache extension is a modification of PHP's standard XSL
23extension that caches the parsed XSL stylesheet representation between
24sessions for 2.5x boost in performance for sites that repeatedly apply
25the same transform. Although there is still some further work that
26could be done on the extension, this code is already proving
27beneficial in production use for a few applications on the New York
28Times' website.
29
58838bce 30%prep
31%setup -q -c
32mv %{modname}-%{version}/* .
33
34%build
35phpize
36%configure \
bc0b38b7 37 --with-xslcache=%{_libdir}
58838bce 38%{__make}
39
40%install
e91f8a5e 41rm -rf $RPM_BUILD_ROOT
58838bce 42install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
58838bce 43
44%{__make} install \
45 INSTALL_ROOT=$RPM_BUILD_ROOT \
46 EXTENSION_DIR=%{php_extensiondir}
47cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
48; Enable %{modname} extension module
49extension=%{modname}.so
50EOF
51
58838bce 52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%post
56%php_webserver_restart
57
58%postun
59if [ "$1" = 0 ]; then
60 %php_webserver_restart
61fi
62
63%files
64%defattr(644,root,root,755)
fb30ee94 65%doc CREDITS
58838bce 66%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
67%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.0768 seconds and 4 git commands to generate.