]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blame - php-pecl-xdebug.spec
define xdebug.cli_color
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
CommitLineData
d412cdf0 1%define php_name php%{?php_suffix}
266b1c9d
ER
2%define modname xdebug
3%define status stable
266b1c9d
ER
4Summary: %{modname} - provides functions for functions traces and profiling
5Summary(pl.UTF-8): %{modname} - funkcje do śledzenia i profilowania funkcji
05ed2ac4 6Name: %{php_name}-pecl-%{modname}
6842e384
ER
7Version: 2.2.5
8Release: 1
fe451dff
ER
9# The Xdebug License, version 1.01
10# (Based on "The PHP License", version 3.0)
11License: PHP
d6c5cc9f 12Group: Development/Languages/PHP
472e26b5 13Source0: http://www.xdebug.org/files/xdebug-%{version}.tgz
6842e384 14# Source0-md5: 7e571ce8eb6fa969fd8263969019849d
05ed2ac4 15Source1: %{modname}.ini
6d9ef3e4 16URL: http://www.xdebug.org/
d412cdf0 17BuildRequires: %{php_name}-devel >= 4:5.2.17-8
e8a9b5ad 18BuildRequires: libedit-devel
aba255b5 19BuildRequires: libtool
8096f627 20BuildRequires: rpmbuild(macros) >= 1.650
3464b421 21%{?requires_zend_extension}
5423a009 22Provides: php(%{modname}) = %{version}
b8ab7bee 23Obsoletes: php-pecl-xdebug < 2.2.4-1
022c051a 24Conflicts: ZendOptimizer
d6c5cc9f
AG
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
d6c5cc9f 27%description
cc7edbad
JB
28The Xdebug extension helps you debugging your script by providing a
29lot of valuable debug information. The debug information that Xdebug
30can provide includes the following:
82a74d97
AG
31
32- stack and function traces in error messages with:
20519407
ER
33 - full parameter display for user defined functions
34 - function name, file name and line indications
fe451dff
ER
35 - support for member functions
36- memory allocation
82a74d97
AG
37- protection for infinite recursions
38
39Xdebug also provides:
d6c5cc9f 40
82a74d97 41- profiling information for PHP scripts
fe451dff 42- code coverage analysis
82a74d97 43- capabilities to debug your scripts interactively with a debug client
98b3abb8 44
266b1c9d 45In PECL status of this package is: %{status}.
98b3abb8 46
2c8c4667
JR
47%description -l pl.UTF-8
48Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
49dużo wartościowych informacji. Informacje przydatne do śledzenia,
50które może zapewnić Xdebug, obejmują:
cc7edbad 51
2c8c4667
JR
52- śledzenie stosu i funkcji w komunikatach błędów wraz z:
53 - pełnym wyświetlaniem parametrów dla funkcji zdefiniowanych przez
54 użytkownika
55 - nazwami funkcji, nazwami plików i numerami linii
56 - obsługą metod klas
57- przydzielanie pamięci
58- zabezpieczenie przed nieskończoną rekurencją
cc7edbad 59
2c8c4667 60Xdebug dostarcza także:
cc7edbad 61
2c8c4667
JR
62- informacje do profilowania skryptów PHP
63- analizę wywołań skryptu
64- możliwość śledzenia skryptów interaktywnie przy pomocy klienta
cc7edbad
JB
65 odpluskwiacza
66
266b1c9d 67To rozszerzenie ma w PECL status: %{status}.
d6c5cc9f
AG
68
69%prep
266b1c9d
ER
70%setup -qc
71mv %{modname}-%{version}*/* .
aba255b5 72chmod +x debugclient/configure
d6c5cc9f 73
7c227a4b 74%{__sed} -e 's#^;zend_extension.*#zend_extension=%{php_extensiondir}/%{modname}.so#' %{SOURCE1} > %{modname}.ini
50d01b8c 75
aba255b5 76%build
dcaafe35 77# libtool 2.2 build fix
266b1c9d
ER
78if [ -f %{_aclocaldir}/ltsugar.m4 ]; then
79 cat %{_aclocaldir}/ltsugar.m4 >> config.m4
80 cat %{_aclocaldir}/ltsugar.m4 >> debugclient/aclocal.m4
81
82 cat %{_aclocaldir}/ltversion.m4 >> config.m4
83 cat %{_aclocaldir}/ltversion.m4 >> debugclient/aclocal.m4
84
85 cat %{_aclocaldir}/lt~obsolete.m4 >> config.m4
86 cat %{_aclocaldir}/lt~obsolete.m4 >> debugclient/aclocal.m4
87
88 cat %{_aclocaldir}/ltoptions.m4 >> config.m4
89 cat %{_aclocaldir}/ltoptions.m4 >> debugclient/aclocal.m4
90
91 cat %{_aclocaldir}/libtool.m4 >> debugclient/aclocal.m4
dcaafe35 92fi
50d01b8c 93
d6c5cc9f
AG
94phpize
95%configure
96%{__make}
e8a9b5ad 97cd debugclient
b79d4446 98install /usr/share/automake/{config.*,depcomp} .
aba255b5 99%{__libtoolize}
e8a9b5ad
AM
100%{__aclocal}
101%{__autoconf}
102%configure \
103 --with-libedit
104%{__make}
d6c5cc9f
AG
105
106%install
107rm -rf $RPM_BUILD_ROOT
266b1c9d 108install -d $RPM_BUILD_ROOT{%{_bindir},%{php_sysconfdir}/conf.d,%{php_extensiondir}}
d6c5cc9f 109
2ba22e49 110install -p debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{modname}%{?php_suffix}-debugclient
266b1c9d
ER
111install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
112cp -a %{modname}.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
d6c5cc9f
AG
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post
bc9b2fd3 118%php_webserver_restart
d6c5cc9f 119
eb5447da
AG
120%postun
121if [ "$1" = 0 ]; then
bc9b2fd3 122 %php_webserver_restart
d6c5cc9f
AG
123fi
124
125%files
126%defattr(644,root,root,755)
6b8a44ef 127%doc README NEWS CREDITS contrib/xt.vim
266b1c9d
ER
128%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
129%attr(755,root,root) %{php_extensiondir}/%{modname}.so
2ba22e49 130%attr(755,root,root) %{_bindir}/xdebug*-debugclient
This page took 0.101703 seconds and 4 git commands to generate.