]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blame - php-pecl-xdebug.spec
- converted to UTF-8
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
CommitLineData
d6c5cc9f 1%define _modname xdebug
82a74d97 2%define _status stable
eb5447da
AG
3%define _sysconfdir /etc/php
4%define extensionsdir %(php-config --extension-dir 2>/dev/null)
d6c5cc9f 5Summary: %{_modname} - provides functions for functions traces and profiling
2c8c4667 6Summary(pl.UTF-8): %{_modname} - funkcje do śledzenia i profilowania funkcji
d6c5cc9f 7Name: php-pecl-%{_modname}
e8a9b5ad 8Version: 2.0.0
bc9b2fd3
AG
9%define _snap RC2
10%define _rel 1
9e09f0c7 11Release: 1.%{_snap}.%{_rel}
82a74d97 12License: BSD style
d6c5cc9f 13Group: Development/Languages/PHP
e8a9b5ad 14Source0: http://pecl.php.net/get/%{_modname}-%{version}%{_snap}.tgz
bc9b2fd3 15# Source0-md5: 2abef81227a5d60af45ad0792e2fd996
b2694d1f 16URL: http://pecl.php.net/package/xdebug/
e8a9b5ad 17BuildRequires: libedit-devel
d6c5cc9f 18BuildRequires: libtool
eb5447da 19BuildRequires: php-devel >= 3:5.0.0
bc9b2fd3 20BuildRequires: rpmbuild(macros) >= 1.344
eb5447da 21Requires: %{_sysconfdir}/conf.d
3464b421 22%{?requires_zend_extension}
022c051a 23Conflicts: ZendOptimizer
d6c5cc9f
AG
24Obsoletes: php-pear-%{_modname}
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
d6c5cc9f 27%description
cc7edbad
JB
28The Xdebug extension helps you debugging your script by providing a
29lot of valuable debug information. The debug information that Xdebug
30can provide includes the following:
82a74d97
AG
31
32- stack and function traces in error messages with:
20519407
ER
33 - full parameter display for user defined functions
34 - function name, file name and line indications
35 - support for member functions memory allocation
82a74d97
AG
36- protection for infinite recursions
37
38Xdebug also provides:
d6c5cc9f 39
82a74d97
AG
40- profiling information for PHP scripts
41- script execution analysis
42- capabilities to debug your scripts interactively with a debug client
98b3abb8 43
04534014 44In PECL status of this package is: %{_status}.
98b3abb8 45
2c8c4667
JR
46%description -l pl.UTF-8
47Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
48dużo wartościowych informacji. Informacje przydatne do śledzenia,
49które może zapewnić Xdebug, obejmują:
cc7edbad 50
2c8c4667
JR
51- śledzenie stosu i funkcji w komunikatach błędów wraz z:
52 - pełnym wyświetlaniem parametrów dla funkcji zdefiniowanych przez
53 użytkownika
54 - nazwami funkcji, nazwami plików i numerami linii
55 - obsługą metod klas
56- przydzielanie pamięci
57- zabezpieczenie przed nieskończoną rekurencją
cc7edbad 58
2c8c4667 59Xdebug dostarcza także:
cc7edbad 60
2c8c4667
JR
61- informacje do profilowania skryptów PHP
62- analizę wywołań skryptu
63- możliwość śledzenia skryptów interaktywnie przy pomocy klienta
cc7edbad
JB
64 odpluskwiacza
65
66To rozszerzenie ma w PECL status: %{_status}.
d6c5cc9f
AG
67
68%prep
7c14f68c 69%setup -q -c
fed8f480 70chmod +x %{_modname}-%{version}%{_snap}/debugclient/configure
d6c5cc9f
AG
71
72%build
e8a9b5ad 73cd %{_modname}-%{version}%{_snap}
d6c5cc9f
AG
74phpize
75%configure
76%{__make}
e8a9b5ad 77cd debugclient
5edec2dc 78install /usr/share/automake/config.* .
e8a9b5ad
AM
79%{__libtoolize}
80%{__aclocal}
81%{__autoconf}
82%configure \
83 --with-libedit
84%{__make}
d6c5cc9f
AG
85
86%install
87rm -rf $RPM_BUILD_ROOT
eb5447da 88install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/conf.d,%{extensionsdir}}
d6c5cc9f 89
e8a9b5ad
AM
90install %{_modname}-*/debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{_modname}-debugclient
91install %{_modname}-*/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
eb5447da
AG
92cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
93; Enable %{_modname} extension module
75194d17 94zend_extension%{?zend_zts:_ts}=%{extensionsdir}/%{_modname}.so
eb5447da 95EOF
d6c5cc9f
AG
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post
bc9b2fd3 101%php_webserver_restart
d6c5cc9f 102
eb5447da
AG
103%postun
104if [ "$1" = 0 ]; then
bc9b2fd3 105 %php_webserver_restart
d6c5cc9f
AG
106fi
107
108%files
109%defattr(644,root,root,755)
2a08eaa2 110%doc %{_modname}-*/{README,NEWS,Changelog,CREDITS,xt.vim}
eb5447da 111%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
d6c5cc9f 112%attr(755,root,root) %{extensionsdir}/%{_modname}.so
e8a9b5ad 113%attr(755,root,root) %{_bindir}/*
This page took 0.191445 seconds and 4 git commands to generate.