]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blame - php-pecl-xdebug.spec
- up to 2.1.0RC1
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
CommitLineData
266b1c9d
ER
1%define modname xdebug
2%define status stable
3%define subver RC1
4%define rel 1
5Summary: %{modname} - provides functions for functions traces and profiling
6Summary(pl.UTF-8): %{modname} - funkcje do śledzenia i profilowania funkcji
7Name: php-pecl-%{modname}
459645dc 8Version: 2.1.0
266b1c9d 9Release: 0.%{subver}.%{rel}
82a74d97 10License: BSD style
d6c5cc9f 11Group: Development/Languages/PHP
266b1c9d
ER
12Source0: http://www.xdebug.org/files/xdebug-%{version}%{subver}.tgz
13# Source0-md5: 0fc89649daaf5d71f1cd6721268545e8
336ff3f6 14Source1: %{name}.ini
6d9ef3e4 15URL: http://www.xdebug.org/
e8a9b5ad 16BuildRequires: libedit-devel
aba255b5 17BuildRequires: libtool
266b1c9d
ER
18BuildRequires: php-devel >= 3:5.0.4
19BuildRequires: rpmbuild(macros) >= 1.519
3464b421 20%{?requires_zend_extension}
022c051a 21Conflicts: ZendOptimizer
d6c5cc9f
AG
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
d6c5cc9f 24%description
cc7edbad
JB
25The Xdebug extension helps you debugging your script by providing a
26lot of valuable debug information. The debug information that Xdebug
27can provide includes the following:
82a74d97
AG
28
29- stack and function traces in error messages with:
20519407
ER
30 - full parameter display for user defined functions
31 - function name, file name and line indications
32 - support for member functions memory allocation
82a74d97
AG
33- protection for infinite recursions
34
35Xdebug also provides:
d6c5cc9f 36
82a74d97
AG
37- profiling information for PHP scripts
38- script execution analysis
39- capabilities to debug your scripts interactively with a debug client
98b3abb8 40
266b1c9d 41In PECL status of this package is: %{status}.
98b3abb8 42
2c8c4667
JR
43%description -l pl.UTF-8
44Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
45dużo wartościowych informacji. Informacje przydatne do śledzenia,
46które może zapewnić Xdebug, obejmują:
cc7edbad 47
2c8c4667
JR
48- śledzenie stosu i funkcji w komunikatach błędów wraz z:
49 - pełnym wyświetlaniem parametrów dla funkcji zdefiniowanych przez
50 użytkownika
51 - nazwami funkcji, nazwami plików i numerami linii
52 - obsługą metod klas
53- przydzielanie pamięci
54- zabezpieczenie przed nieskończoną rekurencją
cc7edbad 55
2c8c4667 56Xdebug dostarcza także:
cc7edbad 57
2c8c4667
JR
58- informacje do profilowania skryptów PHP
59- analizę wywołań skryptu
60- możliwość śledzenia skryptów interaktywnie przy pomocy klienta
cc7edbad
JB
61 odpluskwiacza
62
266b1c9d 63To rozszerzenie ma w PECL status: %{status}.
d6c5cc9f
AG
64
65%prep
266b1c9d
ER
66%setup -qc
67mv %{modname}-%{version}*/* .
aba255b5 68chmod +x debugclient/configure
d6c5cc9f 69
266b1c9d 70%{__sed} -e 's#^;zend_extension.*#zend_extension%{?zend_zts:_ts}=%{php_extensiondir}/%{modname}.so#' %{SOURCE1} > %{modname}.ini
50d01b8c 71
aba255b5 72%build
dcaafe35 73# libtool 2.2 build fix
266b1c9d
ER
74if [ -f %{_aclocaldir}/ltsugar.m4 ]; then
75 cat %{_aclocaldir}/ltsugar.m4 >> config.m4
76 cat %{_aclocaldir}/ltsugar.m4 >> debugclient/aclocal.m4
77
78 cat %{_aclocaldir}/ltversion.m4 >> config.m4
79 cat %{_aclocaldir}/ltversion.m4 >> debugclient/aclocal.m4
80
81 cat %{_aclocaldir}/lt~obsolete.m4 >> config.m4
82 cat %{_aclocaldir}/lt~obsolete.m4 >> debugclient/aclocal.m4
83
84 cat %{_aclocaldir}/ltoptions.m4 >> config.m4
85 cat %{_aclocaldir}/ltoptions.m4 >> debugclient/aclocal.m4
86
87 cat %{_aclocaldir}/libtool.m4 >> debugclient/aclocal.m4
dcaafe35 88fi
50d01b8c 89
d6c5cc9f
AG
90phpize
91%configure
92%{__make}
e8a9b5ad 93cd debugclient
b79d4446 94install /usr/share/automake/{config.*,depcomp} .
aba255b5 95%{__libtoolize}
e8a9b5ad
AM
96%{__aclocal}
97%{__autoconf}
98%configure \
99 --with-libedit
100%{__make}
d6c5cc9f
AG
101
102%install
103rm -rf $RPM_BUILD_ROOT
266b1c9d 104install -d $RPM_BUILD_ROOT{%{_bindir},%{php_sysconfdir}/conf.d,%{php_extensiondir}}
d6c5cc9f 105
266b1c9d
ER
106install -p debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{modname}-debugclient
107install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
108cp -a %{modname}.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
d6c5cc9f
AG
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post
bc9b2fd3 114%php_webserver_restart
d6c5cc9f 115
eb5447da
AG
116%postun
117if [ "$1" = 0 ]; then
bc9b2fd3 118 %php_webserver_restart
d6c5cc9f
AG
119fi
120
121%files
122%defattr(644,root,root,755)
aba255b5 123%doc README NEWS Changelog CREDITS xt.vim
266b1c9d
ER
124%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
125%attr(755,root,root) %{php_extensiondir}/%{modname}.so
126%attr(755,root,root) %{_bindir}/xdebug-debugclient
This page took 0.11181 seconds and 4 git commands to generate.