]> git.pld-linux.org Git - packages/php-pecl-newt.git/blame - php-pecl-newt.spec
- adds missing #ifdefs arond newt_listbox_item_count
[packages/php-pecl-newt.git] / php-pecl-newt.spec
CommitLineData
f8f8625a
AG
1%define _modname newt
2%define _status alpha
3
4Summary: %{_modname} - Extension for RedHat Newt windowing library
5Summary(pl): %{_modname} - Rozszerzenie biblioteki Newt
6Name: php-pecl-%{_modname}
7Version: 0.2
d12a3629 8Release: 1
f8f8625a
AG
9License: PHP 2.02
10Group: Development/Languages/PHP
11Source0: http://pecl.php.net/get/%{_modname}-%{version}.tgz
12# Source0-md5: 7a5816b24032188545a31d51b2527800
13Patch0: %{name}-compile_fix.patch
d12a3629 14Patch1: %{name}-missing_ifdefs.patch
f8f8625a
AG
15URL: http://pecl.php.net/package/newt/
16BuildRequires: libtool
17BuildRequires: php-devel >= 4.3.0
18Requires: php-common >= 4.3.0
19Obsoletes: php-pear-%{_modname}
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%define _sysconfdir /etc/php
23%define extensionsdir %{_libdir}/php
24
25%description
26PHP-NEWT - PHP language extension for RedHat Newt library, a
27terminal-based window and widget library for writing applications with
28user friendly interface. Once this extension is enabled in PHP it will
29provide the use of Newt widgets, such as windows, buttons, checkboxes,
30radiobuttons, labels, editboxes, scrolls, textareas, scales, etc. Use
31of this extension if very similar to the original Newt API fo C
32programming language.
33
34In PECL status of this extension is: %{_status}.
35
36#%description -l pl
37#
38#To rozszerzenie ma w PECL status: %{_status}.
39
40%prep
41%setup -q -c
42cd %{_modname}-%{version}
43%patch0 -p1
d12a3629 44%patch1 -p1
f8f8625a
AG
45
46%build
47cd %{_modname}-%{version}
48phpize
49%configure
50%{__make}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54install -d $RPM_BUILD_ROOT%{extensionsdir}
55
56install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%post
62%{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
63
64%preun
65if [ "$1" = "0" ]; then
66 %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
67fi
68
69%files
70%defattr(644,root,root,755)
71%doc %{_modname}-%{version}/{CREDITS,TODO}
72%attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.289719 seconds and 4 git commands to generate.