]> git.pld-linux.org Git - packages/php-pecl-htscanner.git/blame - php-pecl-htscanner.spec
- obsolete old php name
[packages/php-pecl-htscanner.git] / php-pecl-htscanner.spec
CommitLineData
8a8bfd9d
ER
1%define php_name php%{?php_suffix}
2%define modname htscanner
3%define status stable
4Summary: %{modname} - PHP module to emulate .htaccess support in PHP engine
5Summary(pl.UTF-8): %{modname} - moduł PHP do emulacji obsługi .htaccess w silniku PHP
6Name: %{php_name}-pecl-htscanner
970c3295 7Version: 1.0.1
0c96e292 8Release: 8
86f32982 9License: PHP 3.01
e68fcc29 10Group: Development/Languages/PHP
52239da2 11Source0: http://pecl.php.net/get/htscanner-%{version}.tgz
970c3295 12# Source0-md5: 7fbef47361933fd932a2ff8f44849f0e
86f32982 13URL: http://pecl.php.net/package/htscanner/
0c96e292 14BuildRequires: %{php_name}-devel >= 3:5.0.4
8a8bfd9d 15BuildRequires: rpmbuild(macros) >= 1.650
e68fcc29 16%{?requires_php_extension}
3e1211c4 17Provides: php(%{modname}) = %{version}
0c96e292 18Obsoletes: php-pecl-htscanner < 1.0.1-7
e68fcc29
AG
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
52239da2
AG
22When using a CGI version of PHP (plain old CGI or Fast-CGI) Apache
23can't pass any PHP settings from htaccess files it parses. This can be
24solved by giving each user it's own php.ini file, but I didn't like
25that solution.
26
27This extension parses these configuration files (in most cases
28.htaccess) and changes the settings. It will search all directories
29for a configuration file from the docroot until the directory where
30the request scripts is found.
e68fcc29 31
8a8bfd9d 32In PECL status of this extension is: %{status}.
e68fcc29 33
e6c2ac6c 34%description -l pl.UTF-8
52239da2
AG
35Przy używaniu PHP w wersji CGI (zwykłej CGI lub Fast-CGI) Apache nie
36może przekazać ustawień PHP z plików htaccess. Można to rozwiązać
37dając każdemu użytkownikowi własny plik php.ini, ale nie wszystkim to
38rozwiązanie odpowiada.
39
40To rozszerzenie analizuje wspomniane pliki konfiguracyjne (w
41większości przypadków .htaccess) i zmienia ustawienia. Szuka pliku
42konfiguracyjnego we kwszystkich katalogach od głównego (DocumentRoot)
43co katalogu zawierającego żadane skrypty.
e68fcc29 44
8a8bfd9d 45To rozszerzenie ma w PECL status: %{status}.
e68fcc29
AG
46
47%prep
52239da2
AG
48%setup -q -n htscanner-%{version}
49
e68fcc29 50%build
e68fcc29 51phpize
52239da2
AG
52%configure \
53 --enable-htscanner
e68fcc29
AG
54%{__make}
55
56%install
57rm -rf $RPM_BUILD_ROOT
e68fcc29 58%{__make} install \
52239da2
AG
59 INSTALL_ROOT=$RPM_BUILD_ROOT
60
61install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
8a8bfd9d
ER
62cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
63; Enable %{modname} extension module
64extension=%{modname}.so
52239da2
AG
65
66;htscanner.config_file = .htaccess
67;htscanner.default_docroot = /
68;htscanner.default_ttl = 300
69;htscanner.stop_on_error = 0
e68fcc29
AG
70EOF
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%post
76%php_webserver_restart
77
78%postun
79if [ "$1" = 0 ]; then
80 %php_webserver_restart
81fi
82
83%files
84%defattr(644,root,root,755)
52239da2 85%doc CREDITS README
8a8bfd9d
ER
86%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
87%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.05005 seconds and 4 git commands to generate.