]> git.pld-linux.org Git - packages/php-pecl-funcall.git/blame - php-pecl-funcall.spec
- release 2
[packages/php-pecl-funcall.git] / php-pecl-funcall.spec
CommitLineData
08b18a12
AG
1%define _modname funcall
2%define _status stable
3Summary: %{_modname} - Add callbacks for any function/method
4Summary(pl.UTF-8): %{_modname} - odwołania dla dowolnej funkcji / metody
5Name: php-pecl-%{_modname}
4c590d43 6Version: 0.2.5
48b8c59e 7Release: 2
1ff691cb 8License: New BSD
08b18a12
AG
9Group: Development/Languages/PHP
10Source0: http://pecl.php.net/get/%{_modname}-%{version}.tgz
4c590d43 11# Source0-md5: 0c4f2a989d3b21f1dab56b9959fb9fe8
08b18a12
AG
12URL: http://pecl.php.net/package/funcall/
13BuildRequires: php-devel >= 3:5.0.0
14BuildRequires: rpmbuild(macros) >= 1.344
15%{?requires_php_extension}
16Requires: php-common >= 4:5.0.4
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20Call callbacks before or after specified functions/methods being
21called.
22
23In PECL status of this extension is: %{_status}.
24
25%description -l pl.UTF-8
26Rozszerzenie to pozwala na wykonywanie odwołań przed lub po wywołaniu
27określonej funkcji / metody.
28
29To rozszerzenie ma w PECL status: %{_status}.
30
31%prep
32%setup -q -c
33
34%build
35cd %{_modname}-%{version}
36phpize
37%configure
38%{__make}
39
40%install
41rm -rf $RPM_BUILD_ROOT
42install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
43
44%{__make} install \
45 -C %{_modname}-%{version} \
46 INSTALL_ROOT=$RPM_BUILD_ROOT \
47 EXTENSION_DIR=%{php_extensiondir}
48cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
49; Enable %{_modname} extension module
50extension=%{_modname}.so
51EOF
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%post
57%php_webserver_restart
58
59%postun
60if [ "$1" = 0 ]; then
61 %php_webserver_restart
62fi
63
64%files
65%defattr(644,root,root,755)
66%doc %{_modname}-%{version}/{TODO,funcall.php}
67%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
68%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.489381 seconds and 4 git commands to generate.