]> git.pld-linux.org Git - packages/php-pecl-dbx.git/blame - php-pecl-dbx.spec
- rel. 8
[packages/php-pecl-dbx.git] / php-pecl-dbx.spec
CommitLineData
3f680b54
AG
1%define _modname dbx
2%define _status stable
3f680b54 3Summary: %{_modname} - database abstraction functions
cb5e8988 4Summary(pl.UTF-8): %{_modname} - funkcje abstrakcji baz danych
3f680b54
AG
5Name: php-pecl-%{_modname}
6Version: 1.1.0
e529bd17 7Release: 8
3f680b54
AG
8License: PHP 2.02
9Group: Development/Languages/PHP
10Source0: http://pecl.php.net/get/%{_modname}-%{version}.tgz
11# Source0-md5: 82d1091c75e047c4a8f9aea7b279e13b
12URL: http://pecl.php.net/package/dbx/
3f680b54 13BuildRequires: php-devel >= 3:5.0.0
6b750153 14BuildRequires: rpmbuild(macros) >= 1.344
3b345264 15%{?requires_php_extension}
6b750153 16Requires: php-common >= 4:5.0.4
83550c6f 17Obsoletes: php-dbx
3f680b54
AG
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
3f680b54
AG
20%description
21The dbx module is a database abstraction layer. The dbx functions
22allow you to access all supported databases using a single calling
23convention. The dbx-functions themselves do not interface directly to
24the databases, but interface to the modules that are used to support
25these databases.
26
27The currently supported databases are MySQL, ODBC, Oracle (oci8), MS
28SQL Server, PostgreSQL, FrontBase, Sybase-CT and SQLite.
29
30In PECL status of this extension is: %{_status}.
31
dcc3470d
JR
32%description -l pl.UTF-8
33Moduł dbx to warstwa abstrakcji baz danych. Funkcje dbx pozwalają na
34dostęp do wspieranych baz danych przy użyciu spójnej konwencji.
35Funkcje dbx jako takie nie są bezpośrednim interfejsem do bazy danych,
36ale interfejsem do modułów do obsługi baz danych.
3f680b54
AG
37
38Aktualnie wspierane bazy danych to MySQL, ODBC, Oracle (oci8), MS SQL
39Server, PostgreSQL, FrontBase, Sybase-CT oraz SQLite.
40
41To rozszerzenie ma w PECL status: %{_status}.
42
43%prep
44%setup -q -c
45
46%build
47cd %{_modname}-%{version}
48phpize
49%configure
50%{__make}
51
52%install
53rm -rf $RPM_BUILD_ROOT
6b750153 54install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
3f680b54 55
6b750153
ER
56install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
57cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
3b345264
ER
58; Enable %{_modname} extension module
59extension=%{_modname}.so
60EOF
3f680b54
AG
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%post
6b750153 66%php_webserver_restart
3f680b54 67
3b345264
ER
68%postun
69if [ "$1" = 0 ]; then
6b750153 70 %php_webserver_restart
3f680b54
AG
71fi
72
73%files
74%defattr(644,root,root,755)
75%doc %{_modname}-%{version}/CREDITS
6b750153
ER
76%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
77%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.097856 seconds and 4 git commands to generate.