]> git.pld-linux.org Git - packages/php-pecl-dbx.git/blame - php-pecl-dbx.spec
- php 5.5 rebuild
[packages/php-pecl-dbx.git] / php-pecl-dbx.spec
CommitLineData
e3eff1a9 1%define php_name php%{?php_suffix}
9620a303
ER
2%define modname dbx
3%define status stable
4Summary: %{modname} - database abstraction functions
5Summary(pl.UTF-8): %{modname} - funkcje abstrakcji baz danych
e3eff1a9 6Name: %{php_name}-pecl-%{modname}
bc9bfcc8 7Version: 1.1.2
3cc96ac2 8Release: 3
3f680b54
AG
9License: PHP 2.02
10Group: Development/Languages/PHP
bc9bfcc8
ER
11Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
12# Source0-md5: 8cac1af119e6afa519853bfd3a911bbb
3f680b54 13URL: http://pecl.php.net/package/dbx/
e3eff1a9
ER
14BuildRequires: %{php_name}-devel >= 4:5.0.4
15BuildRequires: rpmbuild(macros) >= 1.650
3b345264 16%{?requires_php_extension}
83550c6f 17Obsoletes: php-dbx
778b1dee 18Provides: php(%{modname}) = %{version}
3f680b54
AG
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
3f680b54
AG
21%description
22The dbx module is a database abstraction layer. The dbx functions
23allow you to access all supported databases using a single calling
24convention. The dbx-functions themselves do not interface directly to
25the databases, but interface to the modules that are used to support
26these databases.
27
28The currently supported databases are MySQL, ODBC, Oracle (oci8), MS
29SQL Server, PostgreSQL, FrontBase, Sybase-CT and SQLite.
30
9620a303 31In PECL status of this extension is: %{status}.
3f680b54 32
dcc3470d
JR
33%description -l pl.UTF-8
34Moduł dbx to warstwa abstrakcji baz danych. Funkcje dbx pozwalają na
35dostęp do wspieranych baz danych przy użyciu spójnej konwencji.
36Funkcje dbx jako takie nie są bezpośrednim interfejsem do bazy danych,
37ale interfejsem do modułów do obsługi baz danych.
3f680b54
AG
38
39Aktualnie wspierane bazy danych to MySQL, ODBC, Oracle (oci8), MS SQL
40Server, PostgreSQL, FrontBase, Sybase-CT oraz SQLite.
41
9620a303 42To rozszerzenie ma w PECL status: %{status}.
3f680b54
AG
43
44%prep
9620a303 45%setup -qc
fc824c90 46mv %{modname}-*/* .
3f680b54
AG
47
48%build
3f680b54
AG
49phpize
50%configure
51%{__make}
52
53%install
54rm -rf $RPM_BUILD_ROOT
6b750153 55install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
9620a303
ER
56install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
57cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
58; Enable %{modname} extension module
59extension=%{modname}.so
3b345264 60EOF
3f680b54
AG
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%post
6b750153 66%php_webserver_restart
3f680b54 67
3b345264
ER
68%postun
69if [ "$1" = 0 ]; then
6b750153 70 %php_webserver_restart
3f680b54
AG
71fi
72
73%files
74%defattr(644,root,root,755)
9620a303
ER
75%doc CREDITS
76%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
77%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.07478 seconds and 4 git commands to generate.