]> git.pld-linux.org Git - packages/php-dirs.git/blame - php-dirs.spec
add php70 to php search list
[packages/php-dirs.git] / php-dirs.spec
CommitLineData
0f165b1d
ER
1# TODO
2# - move tmpwatch S: to php-session package (as session files file storage no
3# longer can cleanup itself due dir perms)
0bcfd373
ER
4Summary: Common dirs for PHP
5Summary(pl.UTF-8): Wspólne katalogi dla PHP
a8668484 6Name: php-dirs
21e70d86 7Version: 1.7
0bcfd373 8Release: 1
a8668484
ER
9License: GPL
10Group: Base
ee96ae59 11Source0: php-session.sh
56b17828 12Source1: %{name}.tmpfiles
21e70d86 13Source2: crontab
05ac7df2 14BuildRequires: rpmbuild(macros) >= 1.644
31b41079
ER
15Requires(postun): /usr/sbin/groupdel
16Requires(pre): /usr/bin/getgid
17Requires(pre): /usr/sbin/groupadd
c29d80f3 18Suggests: tmpwatch
0bcfd373 19Conflicts: php-pear < 4:1.4-2
31b41079 20Provides: group(http)
a8668484
ER
21BuildArch: noarch
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
21e70d86
ER
24%define _libexecdir %{_prefix}/lib
25
a8668484 26%description
0bcfd373 27Common directories for PHP.
a8668484 28
f4cc5fb9 29%description -l pl.UTF-8
0bcfd373 30Wspólne katalogi dla PHP.
cce45ac9 31
a8668484
ER
32%prep
33
34%install
35rm -rf $RPM_BUILD_ROOT
21e70d86 36install -d $RPM_BUILD_ROOT{/etc/cron.d,/var/{cache,log,run}/php,/var/log/archive/php} \
56b17828 37 $RPM_BUILD_ROOT%{_docdir}/phpdoc \
21e70d86 38 $RPM_BUILD_ROOT%{_libexecdir} \
05ac7df2 39 $RPM_BUILD_ROOT%{systemdtmpfilesdir}
56b17828 40
21e70d86 41install -p %{SOURCE0} $RPM_BUILD_ROOT%{_libexecdir}
05ac7df2 42cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
21e70d86 43cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/php-session
a8668484 44
0bcfd373
ER
45while read dir; do
46 install -d $RPM_BUILD_ROOT$dir
47done <<EOF
48%{php_data_dir}/tests
49%{php_data_dir}/Symfony/Bridge
50%{php_data_dir}/Symfony/Component
51EOF
52
a8668484
ER
53%clean
54rm -rf $RPM_BUILD_ROOT
55
31b41079
ER
56%pre
57%groupadd -g 51 http
58
59%postun
60if [ "$1" = "0" ]; then
61 %groupremove http
62fi
63
a8668484
ER
64%files
65%defattr(644,root,root,755)
21e70d86 66%config(noreplace) %verify(not md5 mtime size) /etc/cron.d/php-session
05ac7df2 67%{systemdtmpfilesdir}/%{name}.conf
21e70d86 68%attr(755,root,root) %{_libexecdir}/php-session.sh
0bcfd373
ER
69%{php_data_dir}
70
dea06829 71%dir %{_docdir}/phpdoc
05ac7df2 72%attr(775,root,http) %dir %verify(not group mode) /var/log/php
ec175e53 73%attr(770,root,root) %dir %verify(not group mode) /var/log/archive/php
0bcfd373 74
ebe84aa1
ER
75# no +r, so only predictable names can be used. currently php-soap wsdl cache is there
76%attr(730,root,http) %dir %verify(not group mode) /var/cache/php
0bcfd373
ER
77
78# http needs only +x for directory
79# (otherwise it knows session file names and can read it contents)
4ce953dd
ER
80# keep o+x for fcgi.sock (lighttpd)
81%attr(731,root,http) %dir %verify(not group mode) /var/run/php
This page took 0.09507 seconds and 4 git commands to generate.