]> git.pld-linux.org Git - projects/template-specs.git/blame - perl.spec
- tabs in preamble
[projects/template-specs.git] / perl.spec
CommitLineData
02ecf1a7
ER
1# NOTE
2# - you should consider using pldcpan for new perl packages
654cb390 3#
26510aed 4# Conditional build:
59b8ae11 5%bcond_without autodeps # don't BR packages needed only for resolving deps
460ed0bf 6%bcond_without tests # do not perform "make test"
654cb390 7#
2fd42c2b 8%include /usr/lib/rpm/macros.perl
02ecf1a7
ER
9%define pdir PDIR
10%define pnam PNAM
3299adc7 11Summary: -
ce39d734 12Summary(pl.UTF-8): -
02ecf1a7 13Name: perl-PDIR-PNAM
3299adc7
SZ
14Version: -
15Release: -
350c7060 16# note if it is "same as perl"
c38fb6bc 17License: (enter GPL/LGPL/BSD/BSD-like/Artistic/other license name here)
2fd42c2b 18Group: Development/Languages/Perl
abddec0e 19Source0: http://www.cpan.org/modules/by-module/PDIR/%{pdir}-%{pnam}-%{version}.tar.gz
02ecf1a7 20Patch0: %{name}-foo.patch
8f218f52 21# most of CPAN modules have generic URL (substitute pdir and pnam here)
8073c682 22URL: http://search.cpan.org/dist/PDIR-PNAM/
a34f5786 23BuildRequires: perl-devel >= 1:5.8.0
107a0f90 24BuildRequires: rpm-perlprov >= 4.1-13
3299adc7 25BuildRequires: -
59b8ae11 26%if %{with autodeps} || %{with tests}
c96533b1 27BuildRequires: perl-
28BuildRequires: perl-
29%endif
3299adc7 30Requires: -
3299adc7
SZ
31Provides: -
32Obsoletes: -
2fd42c2b
SZ
33BuildArch: noarch
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
0a7131e1 36%define _noautoreq 'perl(anything_fake_or_conditional)'
c38fb6bc 37
2fd42c2b 38%description
3299adc7 39
9be49f18 40%description -l pl.UTF-8
3299adc7 41
2fd42c2b 42%prep
9b30721b 43%setup -q -n %{pdir}-%{pnam}-%{version}
2fd42c2b 44%patch0 -p1
2fd42c2b
SZ
45
46%build
c38fb6bc 47# Don't use pipes here: they generally don't work. Apply a patch.
193c54ad 48%{__perl} Makefile.PL \
49 INSTALLDIRS=vendor
3e914c93 50
2fd42c2b 51%{__make}
ede9f904 52# if module isn't noarch, use:
3e914c93
JB
53# %{__make} \
54# OPTIMIZE="%{rpmcflags}"
0473ffe6 55
460ed0bf 56%{?with_tests:%{__make} test}
2fd42c2b
SZ
57
58%install
59rm -rf $RPM_BUILD_ROOT
60
b9179971 61%{__make} pure_install \
2fd42c2b 62 DESTDIR=$RPM_BUILD_ROOT
2fd42c2b 63
2fd42c2b
SZ
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(644,root,root,755)
ede9f904 69%doc Changes README
02ecf1a7 70# NOTE it's mostly easier to copy unpackaged filelist here, and run adapter over the spec.
ede9f904 71# use macros:
abddec0e
JB
72#%%{perl_vendorlib}/PDIR...
73#%%{perl_vendorarch}/PDIR...
193c54ad 74%{_mandir}/man3/*
This page took 0.093644 seconds and 4 git commands to generate.