]> git.pld-linux.org Git - projects/template-specs.git/blame - perl.spec
- CHANGES is quite common too
[projects/template-specs.git] / perl.spec
CommitLineData
76919b8f 1#
2############################################################
3#
02ecf1a7 4# NOTE
76919b8f 5# - use the SOURCES/pldcpan.pl script for new perl packages
c060e1e5 6# also available in pldcpan package.
76919b8f 7#
8############################################################
654cb390 9#
26510aed 10# Conditional build:
59b8ae11 11%bcond_without autodeps # don't BR packages needed only for resolving deps
460ed0bf 12%bcond_without tests # do not perform "make test"
654cb390 13#
2fd42c2b 14%include /usr/lib/rpm/macros.perl
02ecf1a7
ER
15%define pdir PDIR
16%define pnam PNAM
3299adc7 17Summary: -
ce39d734 18Summary(pl.UTF-8): -
02ecf1a7 19Name: perl-PDIR-PNAM
3299adc7
SZ
20Version: -
21Release: -
350c7060 22# note if it is "same as perl"
3f2b9700 23#License: GPL v1+ or Artistic
c38fb6bc 24License: (enter GPL/LGPL/BSD/BSD-like/Artistic/other license name here)
2fd42c2b 25Group: Development/Languages/Perl
abddec0e 26Source0: http://www.cpan.org/modules/by-module/PDIR/%{pdir}-%{pnam}-%{version}.tar.gz
3f2b9700 27# Source0-md5:
02ecf1a7 28Patch0: %{name}-foo.patch
8f218f52 29# most of CPAN modules have generic URL (substitute pdir and pnam here)
8073c682 30URL: http://search.cpan.org/dist/PDIR-PNAM/
a34f5786 31BuildRequires: perl-devel >= 1:5.8.0
107a0f90 32BuildRequires: rpm-perlprov >= 4.1-13
3299adc7 33BuildRequires: -
59b8ae11 34%if %{with autodeps} || %{with tests}
c96533b1 35BuildRequires: perl-
36BuildRequires: perl-
37%endif
3299adc7 38Requires: -
3299adc7
SZ
39Provides: -
40Obsoletes: -
2fd42c2b
SZ
41BuildArch: noarch
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
0a7131e1 44%define _noautoreq 'perl(anything_fake_or_conditional)'
c38fb6bc 45
2fd42c2b 46%description
3299adc7 47
9be49f18 48%description -l pl.UTF-8
3299adc7 49
2fd42c2b 50%prep
9b30721b 51%setup -q -n %{pdir}-%{pnam}-%{version}
2fd42c2b 52%patch0 -p1
2fd42c2b 53
4072b963
ER
54# fix #!/usr/bin/env perl -w -> #!/usr/bin/perl:
55%{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' tofu
56
2fd42c2b 57%build
c38fb6bc 58# Don't use pipes here: they generally don't work. Apply a patch.
193c54ad 59%{__perl} Makefile.PL \
60 INSTALLDIRS=vendor
3e914c93 61
2fd42c2b 62%{__make}
ede9f904 63# if module isn't noarch, use:
3e914c93 64# %{__make} \
870ecbf3 65# CC="%{__cc}"
3e914c93 66# OPTIMIZE="%{rpmcflags}"
0473ffe6 67
460ed0bf 68%{?with_tests:%{__make} test}
2fd42c2b
SZ
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
b9179971 73%{__make} pure_install \
2fd42c2b 74 DESTDIR=$RPM_BUILD_ROOT
2fd42c2b 75
2fd42c2b
SZ
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%files
80%defattr(644,root,root,755)
ede9f904 81%doc Changes README
02ecf1a7 82# NOTE it's mostly easier to copy unpackaged filelist here, and run adapter over the spec.
ede9f904 83# use macros:
abddec0e
JB
84#%%{perl_vendorlib}/PDIR...
85#%%{perl_vendorarch}/PDIR...
193c54ad 86%{_mandir}/man3/*
This page took 0.089285 seconds and 4 git commands to generate.