]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- up to 7.54u1
[packages/opera.git] / opera.spec
CommitLineData
11dece16 1# TODO:
da8a77bf 2# - move translations into a separate, noarch package
6239047a 3#
ec0c336f
AM
4%bcond_without shared # static or shared version
5%bcond_without distributable # distributable or not
6%bcond_without incall # include all tarballs into src.rpm (but splitted into shared/static)
e56cf118 7%bcond_with snap # snap version
09f2d772 8
e56cf118 9%if %{with snap}
eca4b8ed 10%define ver 7.60
6fe34fc1 11%define fix %{nil}
0d67d240
AM
12%define dirrel 20041203
13%define reltype Preview-4
e56cf118 14%else
cbb8dbd3 15%define ver 7.54
6fe34fc1
AM
16%define fix u1
17%define dirrel 20041210
cbb8dbd3 18%define reltype final
e56cf118
AM
19%endif
20
6fe34fc1
AM
21%define shver %(echo %{ver} | tr -d .)%{fix}
22%define x86_shared_rel %{dirrel}.4
655debcb 23%define x86_static_rel %{dirrel}.1
24%define sparc_shared_rel %{dirrel}.2
25%define sparc_static_rel %{dirrel}.1
26%define ppc_shared_rel %{dirrel}.2
27%define ppc_static_rel %{dirrel}.1
09f2d772 28%if %{with shared}
655debcb 29%define type shared
0d0211ae 30# We should be able to build src.rpm also on not supported archs
655debcb 31%define rel %{x86_shared_rel}
7edc0e0c 32%ifarch sparc64 sparc
655debcb 33%define rel %{sparc_shared_rel}
7edc0e0c
AM
34%endif
35%ifarch ppc
655debcb 36%define rel %{ppc_shared_rel}
7edc0e0c 37%endif
09f2d772 38%else
655debcb 39%define type static
655debcb 40%define rel %{x86_static_rel}
7edc0e0c 41%ifarch sparc sparc64
655debcb 42%define rel %{sparc_static_rel}
7edc0e0c
AM
43%endif
44%ifarch ppc
655debcb 45%define rel %{ppc_static_rel}
09f2d772 46%endif
7edc0e0c 47%endif
2dbc1636 48
b6dbc9f6
AM
49# define to 0 and then redefine to avoid
50# not defined macros
cbb8dbd3 51%define need_ix86_shared_snap 0
52%define need_sparc_shared_snap 0
53%define need_ppc_shared_snap 0
54%define need_ix86_static_snap 0
55%define need_sparc_static_snap 0
56%define need_ppc_static_snap 0
b6dbc9f6 57
cbb8dbd3 58%define need_ix86_shared 0
59%define need_sparc_shared 0
60%define need_ppc_shared 0
61%define need_ix86_static 0
62%define need_sparc_static 0
63%define need_ppc_static 0
b6dbc9f6 64
40d43d2d 65%if %{with incall}
66# with incall? [if]
67%if %{with snap}
68# with snap? [if]
69%if %{with shared}
70# with shared? [if]
71%define need_ix86_shared_snap 1
cbb8dbd3 72%define need_sparc_shared_snap 1
40d43d2d 73%define need_ppc_shared_snap 1
042a9712 74%else
40d43d2d 75# with shared: [else]
76%define need_ix86_static_snap 1
cbb8dbd3 77%define need_sparc_static_snap 1
40d43d2d 78%define need_ppc_static_snap 1
042a9712 79%endif
40d43d2d 80# with shared; [endif]
81%else
82# with snap: [else]
83%if %{with shared}
84# with shared? [if]
85%define need_ix86_shared 1
cbb8dbd3 86%define need_sparc_shared 1
40d43d2d 87%define need_ppc_shared 1
88%else
89# with shared: [else]
90%define need_ix86_static 1
cbb8dbd3 91%define need_sparc_static 1
40d43d2d 92%define need_ppc_static 1
2dbc1636 93%endif
40d43d2d 94# with shared; [endif]
ec0c336f 95%endif
40d43d2d 96# with snap; [endif]
97%else
98# with incall: [else]
99%ifarch %{ix86}
100# is ix86? [if]
101%if %{with snap}
102# with snap? [if]
103%if %{with shared}
104# with shared? [if]
105%define need_ix86_shared_snap 1
042a9712 106%else
40d43d2d 107# with shared: [else]
108%define need_ix86_static_snap 1
042a9712 109%endif
40d43d2d 110# with shared; [endif]
111%else
112# with snap: [else]
113%if %{with shared}
114# with shared? [if]
115%define need_ix86_shared 1
116%else
117# with shared: [else]
118%define need_ix86_static 1
2dbc1636 119%endif
40d43d2d 120# with shared; [endif]
ec0c336f 121%endif
40d43d2d 122# with snap; [endif]
123%endif
124# is ix86; [endif]
125%ifarch sparc sparc64
126# is sparc? [if]
127%if %{with snap}
128# with snap? [if]
129%if %{with shared}
130# with shared? [if]
131%define need_sparc_shared_snap 1
042a9712 132%else
40d43d2d 133# with shared: [else]
134%define need_sparc_static_snap 1
2dbc1636 135%endif
40d43d2d 136# with shared; [endif]
2dbc1636 137%else
40d43d2d 138# with snap: [else]
139%if %{with shared}
140# with shared? [if]
141%define need_sparc_shared 1
042a9712 142%else
40d43d2d 143# with shared: [else]
144%define need_sparc_static 1
042a9712 145%endif
40d43d2d 146# with shared; [endif]
2dbc1636 147%endif
40d43d2d 148# with snap; [endif]
ec0c336f 149%endif
40d43d2d 150# is sparc; [endif]
151%ifarch ppc
152# is ppc? [if]
153%if %{with snap}
154# with snap? [if]
155%if %{with shared}
156# with shared? [if]
157%define need_ppc_shared_snap 1
042a9712 158%else
40d43d2d 159# with shared: [else]
160%define need_ppc_static_snap 1
042a9712 161%endif
40d43d2d 162# with shared; [endif]
163%else
164# with snap: [else]
165%if %{with shared}
166# with shared? [if]
167%define need_ppc_shared 1
168%else
169# with shared: [else]
170%define need_ppc_static 1
2dbc1636 171%endif
40d43d2d 172# with shared; [endif
ec0c336f 173%endif
40d43d2d 174# with snap; [endif
2dbc1636 175%endif
40d43d2d 176# is ppc; [endif]
2dbc1636 177%endif
40d43d2d 178# with incall; [endif]
179
180Summary: World fastest web browser
181