]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- fixed distfiles errors (i hope... if not, i'll revert on demand)
[packages/opera.git] / opera.spec
CommitLineData
11dece16 1# TODO:
da8a77bf 2# - move translations into a separate, noarch package
6239047a 3#
ec0c336f
AM
4%bcond_without shared # static or shared version
5%bcond_without distributable # distributable or not
6%bcond_without incall # include all tarballs into src.rpm (but splitted into shared/static)
e56cf118 7%bcond_with snap # snap version
09f2d772 8
e56cf118 9%if %{with snap}
eca4b8ed 10%define ver 7.60
e56cf118 11%define dirrel 20040824
e56cf118
AM
12%define reltype Preview-1
13%else
14%define ver 7.54
bbd26f33 15%define dirrel 20040803
e56cf118
AM
16%define reltype final
17%endif
18
19%define shver %(echo %{ver} | tr -d .)
655debcb 20%define x86_shared_rel %{dirrel}.5
21%define x86_static_rel %{dirrel}.1
22%define sparc_shared_rel %{dirrel}.2
23%define sparc_static_rel %{dirrel}.1
24%define ppc_shared_rel %{dirrel}.2
25%define ppc_static_rel %{dirrel}.1
09f2d772 26%if %{with shared}
655debcb 27%define type shared
0d0211ae 28# We should be able to build src.rpm also on not supported archs
655debcb 29%define rel %{x86_shared_rel}
7edc0e0c 30%ifarch sparc64 sparc
655debcb 31%define rel %{sparc_shared_rel}
7edc0e0c
AM
32%endif
33%ifarch ppc
655debcb 34%define rel %{ppc_shared_rel}
7edc0e0c 35%endif
09f2d772 36%else
655debcb 37%define type static
655debcb 38%define rel %{x86_static_rel}
7edc0e0c 39%ifarch sparc sparc64
655debcb 40%define rel %{sparc_static_rel}
7edc0e0c
AM
41%endif
42%ifarch ppc
655debcb 43%define rel %{ppc_static_rel}
09f2d772 44%endif
7edc0e0c 45%endif
2dbc1636 46
40d43d2d 47%if %{with incall}
48# with incall? [if]
49%if %{with snap}
50# with snap? [if]
51%if %{with shared}
52# with shared? [if]
53%define need_ix86_shared_snap 1
54%define need_sparc_shared_snap 1
55%define need_ppc_shared_snap 1
042a9712 56%else
40d43d2d 57# with shared: [else]
58%define need_ix86_static_snap 1
59%define need_sparc_static_snap 1
60%define need_ppc_static_snap 1
042a9712 61%endif
40d43d2d 62# with shared; [endif]
63%else
64# with snap: [else]
65%if %{with shared}
66# with shared? [if]
67%define need_ix86_shared 1
68%define need_sparc_shared 1
69%define need_ppc_shared 1
70%else
71# with shared: [else]
72%define need_ix86_static 1
73%define need_sparc_static 1
74%define need_ppc_static 1
2dbc1636 75%endif
40d43d2d 76# with shared; [endif]
ec0c336f 77%endif
40d43d2d 78# with snap; [endif]
79%else
80# with incall: [else]
81%ifarch %{ix86}
82# is ix86? [if]
83%if %{with snap}
84# with snap? [if]
85%if %{with shared}
86# with shared? [if]
87%define need_ix86_shared_snap 1
042a9712 88%else
40d43d2d 89# with shared: [else]
90%define need_ix86_static_snap 1
042a9712 91%endif
40d43d2d 92# with shared; [endif]
93%else
94# with snap: [else]
95%if %{with shared}
96# with shared? [if]
97%define need_ix86_shared 1
98%else
99# with shared: [else]
100%define need_ix86_static 1
2dbc1636 101%endif
40d43d2d 102# with shared; [endif]
ec0c336f 103%endif
40d43d2d 104# with snap; [endif]
105%endif
106# is ix86; [endif]
107%ifarch sparc sparc64
108# is sparc? [if]
109%if %{with snap}
110# with snap? [if]
111%if %{with shared}
112# with shared? [if]
113%define need_sparc_shared_snap 1
042a9712 114%else
40d43d2d 115# with shared: [else]
116%define need_sparc_static_snap 1
2dbc1636 117%endif
40d43d2d 118# with shared; [endif]
2dbc1636 119%else
40d43d2d 120# with snap: [else]
121%if %{with shared}
122# with shared? [if]
123%define need_sparc_shared 1
042a9712 124%else
40d43d2d 125# with shared: [else]
126%define need_sparc_static 1
042a9712 127%endif
40d43d2d 128# with shared; [endif]
2dbc1636 129%endif
40d43d2d 130# with snap; [endif]
ec0c336f 131%endif
40d43d2d 132# is sparc; [endif]
133%ifarch ppc
134# is ppc? [if]
135%if %{with snap}
136# with snap? [if]
137%if %{with shared}
138# with shared? [if]
139%define need_ppc_shared_snap 1
042a9712 140%else
40d43d2d 141# with shared: [else]
142%define need_ppc_static_snap 1
042a9712 143%endif
40d43d2d 144# with shared; [endif]
145%else
146# with snap: [else]
147%if %{with shared}
148# with shared? [if]
149%define need_ppc_shared 1
150%else
151# with shared: [else]
152%define need_ppc_static 1
2dbc1636 153%endif
40d43d2d 154# with shared; [endif
ec0c336f 155%endif
40d43d2d 156# with snap; [endif
2dbc1636 157%endif
40d43d2d 158# is ppc; [endif]
2dbc1636 159%endif
40d43d2d 160# with incall; [endif]
161
162Summary: World fastest web browser
163