]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- more updates
[packages/opera.git] / opera.spec
CommitLineData
11dece16 1# TODO:
da8a77bf 2# - move translations into a separate, noarch package
6239047a 3#
ec0c336f
AM
4%bcond_without shared # static or shared version
5%bcond_without distributable # distributable or not
6%bcond_without incall # include all tarballs into src.rpm (but splitted into shared/static)
e56cf118 7%bcond_with snap # snap version
09f2d772 8
e56cf118 9%if %{with snap}
eca4b8ed 10%define ver 7.60
94143ec2
AM
11%define dirrel 20041115
12%define reltype Preview-3
e56cf118
AM
13%else
14%define ver 7.54
bbd26f33 15%define dirrel 20040803
e56cf118
AM
16%define reltype final
17%endif
18
19%define shver %(echo %{ver} | tr -d .)
655debcb 20%define x86_shared_rel %{dirrel}.5
21%define x86_static_rel %{dirrel}.1
22%define sparc_shared_rel %{dirrel}.2
23%define sparc_static_rel %{dirrel}.1
24%define ppc_shared_rel %{dirrel}.2
25%define ppc_static_rel %{dirrel}.1
09f2d772 26%if %{with shared}
655debcb 27%define type shared
0d0211ae 28# We should be able to build src.rpm also on not supported archs
655debcb 29%define rel %{x86_shared_rel}
7edc0e0c 30%ifarch sparc64 sparc
655debcb 31%define rel %{sparc_shared_rel}
7edc0e0c
AM
32%endif
33%ifarch ppc
655debcb 34%define rel %{ppc_shared_rel}
7edc0e0c 35%endif
09f2d772 36%else
655debcb 37%define type static
655debcb 38%define rel %{x86_static_rel}
7edc0e0c 39%ifarch sparc sparc64
655debcb 40%define rel %{sparc_static_rel}
7edc0e0c
AM
41%endif
42%ifarch ppc
655debcb 43%define rel %{ppc_static_rel}
09f2d772 44%endif
7edc0e0c 45%endif
2dbc1636 46
b6dbc9f6
AM
47# define to 0 and then redefine to avoid
48# not defined macros
49%define need_ix86_shared_snap 0
50%define need_sparc_shared_snap 0
51%define need_ppc_shared_snap 0
52%define need_ix86_static_snap 0
53%define need_sparc_static_snap 0
54%define need_ppc_static_snap 0
55
56%define need_ix86_shared 0
57%define need_sparc_shared 0
58%define need_ppc_shared 0
59%define need_ix86_static 0
60%define need_sparc_static 0
61%define need_ppc_static 0
62
40d43d2d 63%if %{with incall}
64# with incall? [if]
65%if %{with snap}
66# with snap? [if]
67%if %{with shared}
68# with shared? [if]
69%define need_ix86_shared_snap 1
70%define need_sparc_shared_snap 1
71%define need_ppc_shared_snap 1
042a9712 72%else
40d43d2d 73# with shared: [else]
74%define need_ix86_static_snap 1
75%define need_sparc_static_snap 1
76%define need_ppc_static_snap 1
042a9712 77%endif
40d43d2d 78# with shared; [endif]
79%else
80# with snap: [else]
81%if %{with shared}
82# with shared? [if]
83%define need_ix86_shared 1
84%define need_sparc_shared 1
85%define need_ppc_shared 1
86%else
87# with shared: [else]
88%define need_ix86_static 1
89%define need_sparc_static 1
90%define need_ppc_static 1
2dbc1636 91%endif
40d43d2d 92# with shared; [endif]
ec0c336f 93%endif
40d43d2d 94# with snap; [endif]
95%else
96# with incall: [else]
97%ifarch %{ix86}
98# is ix86? [if]
99%if %{with snap}
100# with snap? [if]
101%if %{with shared}
102# with shared? [if]
103%define need_ix86_shared_snap 1
042a9712 104%else
40d43d2d 105# with shared: [else]
106%define need_ix86_static_snap 1
042a9712 107%endif
40d43d2d 108# with shared; [endif]
109%else
110# with snap: [else]
111%if %{with shared}
112# with shared? [if]
113%define need_ix86_shared 1
114%else
115# with shared: [else]
116%define need_ix86_static 1
2dbc1636 117%endif
40d43d2d 118# with shared; [endif]
ec0c336f 119%endif
40d43d2d 120# with snap; [endif]
121%endif
122# is ix86; [endif]
123%ifarch sparc sparc64
124# is sparc? [if]
125%if %{with snap}
126# with snap? [if]
127%if %{with shared}
128# with shared? [if]
129%define need_sparc_shared_snap 1
042a9712 130%else
40d43d2d 131# with shared: [else]
132%define need_sparc_static_snap 1
2dbc1636 133%endif
40d43d2d 134# with shared; [endif]
2dbc1636 135%else
40d43d2d 136# with snap: [else]
137%if %{with shared}
138# with shared? [if]
139%define need_sparc_shared 1
042a9712 140%else
40d43d2d 141# with shared: [else]
142%define need_sparc_static 1
042a9712 143%endif
40d43d2d 144# with shared; [endif]
2dbc1636 145%endif
40d43d2d 146# with snap; [endif]
ec0c336f 147%endif
40d43d2d 148# is sparc; [endif]
149%ifarch ppc
150# is ppc? [if]
151%if %{with snap}
152# with snap? [if]
153%if %{with shared}
154# with shared? [if]
155%define need_ppc_shared_snap 1
042a9712 156%else
40d43d2d 157# with shared: [else]
158%define need_ppc_static_snap 1
042a9712 159%endif
40d43d2d 160# with shared; [endif]
161%else
162# with snap: [else]
163%if %{with shared}
164# with shared? [if]
165%define need_ppc_shared 1
166%else
167# with shared: [else]
168%define need_ppc_static 1
2dbc1636 169%endif
40d43d2d 170# with shared; [endif
ec0c336f 171%endif
40d43d2d 172# with snap; [endif
2dbc1636 173%endif
40d43d2d 174# is ppc; [endif]
2dbc1636 175%endif
40d43d2d 176# with incall; [endif]
177
178Summary: World fastest web browser
179