]> git.pld-linux.org Git - packages/openscad.git/blame - openscad.spec
partial adapter.
[packages/openscad.git] / openscad.spec
CommitLineData
cd307a29
ER
1#
2# Conditional build:
3%bcond_with tests # build with tests
4
5%define upversion 2015.03-1
6Summary: The Programmers Solid 3D CAD Modeller
a4cd6760
AM
7Name: openscad
8Version: 2015.03.1
a4cd6760
AM
9Release: 0.1
10# COPYING contains a linking exception for CGAL
11# Appdata file is CC0
12# Examples are CC0
13License: GPLv2 with exceptions and CC0
14Group: Applications/Engineering
a4cd6760
AM
15Source0: http://files.openscad.org/%{name}-%{upversion}.src.tar.gz
16# Source0-md5: c5994220078f5f5c13984da304e4a2fe
17Patch0: %{name}-polyclipping.patch
cd307a29 18URL: http://www.openscad.org/
a4cd6760
AM
19BuildRequires: CGAL-devel >= 3.6
20BuildRequires: ImageMagick
21BuildRequires: Mesa-dri-driver-swrast
22BuildRequires: bison >= 2.4
23BuildRequires: boost-devel >= 1.35
24BuildRequires: desktop-file-utils
25BuildRequires: eigen3
26BuildRequires: flex >= 2.5.35
27BuildRequires: fontconfig-devel >= 2.10
28BuildRequires: freetype-devel >= 2.4
29BuildRequires: gettext
30BuildRequires: glew-devel >= 1.6
31BuildRequires: glib2-devel
32BuildRequires: gmp-devel >= 5.0.0
33BuildRequires: harfbuzz-devel >= 0.9.19
34BuildRequires: mpfr-devel >= 3.0.0
35BuildRequires: opencsg-devel >= 1.3.2
36BuildRequires: polyclipping-devel >= 6.1.3
37BuildRequires: procps
38BuildRequires: python
39BuildRequires: qscintilla2-devel
40BuildRequires: qt4-build >= 4.4
41BuildRequires: xorg-xserver-Xvfb
42Requires: font(liberationmono)
43Requires: font(liberationsans)
44Requires: font(liberationserif)
cd307a29
ER
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47### LICENSES:
48
49## LGPLv2+:
50# 2Dshapes.scad
51# 3d_triangle.scad
52# fonts.scad
53# gridbeam.scad
54# hardware.scad
55# libtriangles.scad
56# multiply.scad
57# shapes.scad
58# screw.scad
59
60## LGPLv2:
61# gears.scad
62# involute_gears.scad
63# servos.scad
64# transformations.scad
65# triangles.scad
66# unregular_shapes.scad
67# bitmap/letter_necklace.scad
68
69## LGPLv3+:
70# teardrop.scad
71
72## GPLv3 or LGPLv2:
73# motors.scad
74# nuts_and_bolts.scad
75
76
77## GPLv3+ or LGPLv2:
78# metric_fastners.scad
79# regular_shapes.scad
80
81## CC-BY-SA or LGPLv2+:
82# bearing.scad
83# materials.scad
84# stepper.scad
85# utilities.scad
86
87## CC-BY-SA or LGPLv2:
88# units.scad
89
90## CC-BY:
91# polyholes.scad
92# bitmap/alphabet_block.scad
93# bitmap/bitmap.scad
94# bitmap/height_map.scad
95# bitmap/name_tag.scad
96
97## BSD
98# boxes.scad
99
100## MIT
101# constants.scad
102# curves.scad
103# math.scad
104
105## Public Domain
106# lego_compatibility.scad
107# trochoids.scad
108
109###############################################
a4cd6760
AM
110
111%description
112OpenSCAD is a software for creating solid 3D CAD objects. Unlike most
113free software for creating 3D models (such as the famous application
114Blender) it does not focus on the artistic aspects of 3D modeling but
115instead on the CAD aspects. Thus it might be the application you are
116looking for when you are planning to create 3D models of machine parts
117but pretty sure is not what you are looking for when you are more
118interested in creating computer-animated movies.
119
cd307a29 120%package MCAD
a4cd6760
AM
121Summary: OpenSCAD Parametric CAD Library
122License: LGPLv2+ and LGPLv2 and LGPLv3+ and (GPLv3 or LGPLv2) and (GPLv3+ or LGPLv2) and (CC-BY-SA or LGPLv2+) and (CC-BY-SA or LGPLv2) and CC-BY and BSD and MIT and Public Domain
123URL: https://www.github.com/openscad/MCAD
124Requires: %{name} = %{version}-%{release}
125BuildArch: noarch
126
127%description MCAD
128This library contains components commonly used in designing and
129moching up mechanical designs. It is currently unfinished and you can
130expect some API changes, however many things are already working.
131
a4cd6760
AM
132%prep
133%setup -qn %{name}-%{upversion}
134%patch0 -p1
135
136rm -rf src/polyclipping
137
138%build
139qmake-qt4 \
140 PREFIX=%{_prefix}
141%{__make}
142
143# tests
144cd tests
145install -d build
146cd build
147%{__cmake} ..
148%{__make}
149cd ../..
150
151%install
152rm -rf $RPM_BUILD_ROOT
153
154%{__make} -j1 install \
155 INSTALL_ROOT=$RPM_BUILD_ROOT
156
157rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
158
159:> %{name}.lang
160# TODO: fix this to find the files
161#%find_lang %{name}
162
163rm $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/lgpl-2.1.txt
164rm $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/README.markdown
165rm $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/TODO
166
167%if %{with tests}
168cd tests
169ctest
170cd ..
171%endif
172
173%files -f %{name}.lang
174%defattr(644,root,root,755)
175%doc README.md RELEASE_NOTES
176%attr(755,root,root) %{_bindir}/%{name}
177%{_datadir}/appdata/*.xml
178%{_desktopdir}/%{name}.desktop
179%{_pixmapsdir}/%{name}.png
180%{_datadir}/mime/packages/%{name}.xml
181%dir %{_datadir}/%{name}
182%{_datadir}/%{name}/examples
183%{_datadir}/%{name}/color-schemes
184%dir %{_datadir}/%{name}/locale
185# drop when find_lang is fixed
186%{_datadir}/%{name}/locale/*
187%dir %{_datadir}/%{name}/libraries
188%{_mandir}/man1/*
189
190%files MCAD
191%defattr(644,root,root,755)
192%doc libraries/MCAD/README.markdown libraries/MCAD/TODO
193%{_datadir}/%{name}/libraries/MCAD
194
195%changelog
196
197%clean
198rm -rf $RPM_BUILD_ROOT
This page took 0.096595 seconds and 4 git commands to generate.