]> git.pld-linux.org Git - packages/ocaml-gapi-ocaml.git/blame - ocaml-gapi-ocaml.spec
- up to 0.3.6
[packages/ocaml-gapi-ocaml.git] / ocaml-gapi-ocaml.spec
CommitLineData
dafc9a18
ER
1#
2# Conditional build:
cdfcbd46
JR
3%bcond_without ocaml_opt # skip building native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
6%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
dafc9a18 9
a2e75bf0 10%define pkgname gapi-ocaml
dafc9a18
ER
11%define debug_package %{nil}
12Summary: Google Data Protocol (GData) client library
13Name: ocaml-%{pkgname}
e787fbc9 14Version: 0.3.6
3668a499 15Release: 1
dafc9a18
ER
16License: MIT
17Group: Libraries
b5a46832 18Source0: https://github.com/astrada/gapi-ocaml/archive/v%{version}/%{name}-%{version}.tar.gz
e787fbc9
JR
19# Source0-md5: b8759b3a9010769db86786141ed374dd
20Patch0: jbuilder.patch
dafc9a18
ER
21URL: http://gapi-ocaml.forge.ocamlcore.org/
22BuildRequires: cppo >= 0.9.3
e787fbc9 23BuildRequires: ocaml >= 4.02.3
dafc9a18
ER
24BuildRequires: ocaml-biniou-devel >= 1.0.6
25BuildRequires: ocaml-cryptokit-devel >= 1.9
a655c1bd 26BuildRequires: ocaml-curl-devel >= 0.6.0
dafc9a18
ER
27BuildRequires: ocaml-easy-format-devel >= 1.0.1
28BuildRequires: ocaml-extlib-devel >= 1.5.4
29BuildRequires: ocaml-findlib >= 1.4
e787fbc9 30BuildRequires: ocaml-net-netstring-devel >= 4.1.4
dafc9a18
ER
31BuildRequires: ocaml-xmlm-devel >= 1.1.1
32BuildRequires: ocaml-yojson-devel >= 1.1.6
33%requires_eq ocaml-runtime
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37gapi-ocaml is a simple, unofficial, OCaml client for Google Services.
38The project is hosted on github, where you can find the latest
39development version, and on the OCaml forge where you can find
40releases. Reference documentation can be found here.
41
42%description -l pl.UTF-8
43Pakiet ten zawiera binaria potrzebne do uruchamiania programów
44używających tej biblioteki.
45
46%package devel
47Summary: Google Data Protocol (GData) client library - development part
48Summary(pl.UTF-8): Wiązania gapi dla OCamla - cześć programistyczna
49Group: Development/Libraries
50%requires_eq ocaml
a726fef6
JR
51Requires: ocaml-biniou-devel >= 1.0.6
52Requires: ocaml-cryptokit-devel >= 1.9
53Requires: ocaml-curl-devel >= 0.6.0
54Requires: ocaml-easy-format-devel >= 1.0.1
55Requires: ocaml-extlib-devel >= 1.5.4
56Requires: ocaml-net-netstring-devel >= 3.6
57#Requires: ocaml-net-netstring-devel >= 3.7.3
58Requires: ocaml-xmlm-devel >= 1.1.1
59Requires: ocaml-yojson-devel >= 1.1.6
dafc9a18
ER
60
61%description devel
62This package contains files needed to develop OCaml programs using
63this library.
64
65%description devel -l pl.UTF-8
66Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
67tej biblioteki.
68
69%prep
a2e75bf0 70%setup -q -n %{pkgname}-%{version}
e787fbc9 71%patch0 -p1 -R
dafc9a18
ER
72
73%build
74ocaml setup.ml -configure \
75 --destdir $RPM_BUILD_ROOT
76ocaml setup.ml -build
77
78%install
79rm -rf $RPM_BUILD_ROOT
80export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
81install -d $OCAMLFIND_DESTDIR
82ocaml setup.ml -install
83
5c44f6a8 84# move to dir pld ocamlfind looks
a2e75bf0
ER
85install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{pkgname}
86mv $OCAMLFIND_DESTDIR/%{pkgname}/META \
87 $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{pkgname}
88cat <<EOF >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{pkgname}/META
89directory="+%{pkgname}"
5c44f6a8
ER
90EOF
91
dafc9a18 92# no standard way of packaging .mli docs in pld. just drop
a2e75bf0 93%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/%{pkgname}/*.mli
dafc9a18
ER
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%files devel
99%defattr(644,root,root,755)
100%doc LICENSE
a2e75bf0 101%dir %{_libdir}/ocaml/%{pkgname}
3668a499 102%{_libdir}/ocaml/%{pkgname}/*.annot
cdfcbd46 103%{_libdir}/ocaml/%{pkgname}/*.cma
3668a499 104%{_libdir}/ocaml/%{pkgname}/*.cmt*
cdfcbd46
JR
105%{_libdir}/ocaml/%{pkgname}/*.cm[ix]
106%if %{with ocaml_opt}
a2e75bf0 107%{_libdir}/ocaml/%{pkgname}/*.a
b5a46832 108%{_libdir}/ocaml/%{pkgname}/*.cmx[as]
cdfcbd46 109%endif
a2e75bf0
ER
110%dir %{_libdir}/ocaml/site-lib/%{pkgname}
111%{_libdir}/ocaml/site-lib/%{pkgname}/META
This page took 0.283894 seconds and 4 git commands to generate.