]> git.pld-linux.org Git - packages/nginx.git/blame - nginx.spec
- cleanup with bcond
[packages/nginx.git] / nginx.spec
CommitLineData
f9e65082 1# TODO
ee4f2132 2# - /etc/sysconfig/nginx file
1c438d78 3# - missing perl build/install requires
d0c0492d 4# - prepare pld style like nginx.conf
5# - split into nginx-common, nginx, nginx-perl packages
ee4f2132 6#
362f5ab2 7# Conditional build for nginx:
056acc18 8%bcond_without light # don't build light version
9%bcond_without mail # don't build imap/mail proxy
10%bcond_without perl # don't build with perl module
d0c0492d 11%bcond_without addition # adds module
12%bcond_without dav # WebDAV
13%bcond_without flv # FLV stream
d6fc4b09 14%bcond_without sub # ngx_http_sub_module
d0c0492d 15%bcond_without poll # poll
16%bcond_without realip # real ip (behind proxy)
17%bcond_without rtsig # rtsig
18%bcond_without select # select
19%bcond_without status # stats module
20%bcond_without ssl # ssl support
056acc18 21%bcond_with http_browser # header "User-agent" parser
362f5ab2 22#
8e1389c7 23Summary: High perfomance HTTP and reverse proxy server
185313bb 24Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
f9e65082 25Name: nginx
1a62642d 26Version: 0.5.33
d6fc4b09 27Release: 0.3
51ef519b 28License: BSD-like
7d9b86c7 29Group: Networking/Daemons
f1fc9780 30Source0: http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
1a62642d 31# Source0-md5: a78be74b4fd8e009545ef02488fcac86
f1fc9780 32Source1: %{name}.init
dfef7372 33Source2: %{name}-mime.types.sh
362f5ab2 34Source3: http://www.nginx.eu/favicon.ico
35# Source3-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
36Source4: http://www.nginx.eu/download/proxy.conf
37# Source4-md5: f5263ae01c2edb18f46d5d1df2d3a5cd
894ff1f7 38Source5: http://www.nginx.eu/download/%{name}.monitrc
362f5ab2 39# Source5-md5: 1d3f5eedfd34fe95213f9e0fc19daa88
894ff1f7 40Source6: http://www.nginx.eu/download/%{name}.conf
362f5ab2 41# Source6-md5: 1c112d6f03d0f365e4acc98c1d96261a
28a25161 42Source7: %{name}.logrotate
f1fc9780 43Patch0: %{name}-config.patch
51ef519b 44URL: http://nginx.net/
dfef7372 45BuildRequires: mailcap
f9e65082 46BuildRequires: openssl-devel
f1fc9780 47BuildRequires: pcre-devel
1c438d78 48%{?with_perl:BuildRequires: perl-CGI}
d0c0492d 49%{?with_perl:BuildRequires: perl-devel}
1c438d78 50%{?with_perl:BuildRequires: rpm-perlprov}
7d9b86c7 51BuildRequires: rpmbuild(macros) >= 1.268
f9e65082 52BuildRequires: zlib-devel
7d9b86c7
ER
53Requires(post,preun): /sbin/chkconfig
54Requires(postun): /usr/sbin/groupdel
55Requires(postun): /usr/sbin/userdel
56Requires(pre): /bin/id
57Requires(pre): /usr/bin/getgid
58Requires(pre): /usr/sbin/groupadd
59Requires(pre): /usr/sbin/useradd
85600569 60Requires: %{name}-common = %{version}-%{release}
d0c0492d 61Requires: openssl
62Requires: pcre
aba2d783 63Requires: rc-scripts >= 0.2.0
d0c0492d 64Requires: zlib
ee547c00 65Provides: group(http)
66Provides: group(nginx)
67Provides: user(nginx)
7ffe7917 68Provides: webserver
2d747e44 69Conflicts: logrotate < 3.7-4
85600569 70Conflicts: %{name}-light
71Conflicts: %{name}-mail
72Conflicts: %{name}-perl
f9e65082
ER
73BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
362f5ab2 75%define _sysconfdir /etc/%{name}
76%define _nginxdir /home/services/%{name}
f9e65082
ER
77
78%description
894ff1f7
ER
79Nginx ("engine x") is a high-performance HTTP server and reverse
80proxy, as well as an IMAP/POP3 proxy server. Nginx was written by Igor
81Sysoev for Rambler.ru, Russia's second-most visited website, where it
82has been running in production for over two and a half years. Igor has
83released the source code under a BSD-like license. Although still in
84beta, Nginx is known for its stability, rich feature set, simple
85configuration, and low resource consumption.
8e1389c7 86
85600569 87This is standard nginx version, without perl support and imap, pop3,
88smtp proxy.
89
390f5b88 90%description -l pl.UTF-8
056acc18 91Nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
92a także IMAP/POP3 proxy. Nginx został napisany przez Igora Sysoev'a
93na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
94odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
95opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
2ee780b1 96