]> git.pld-linux.org Git - packages/nghttp2.git/blame - nghttp2.spec
up to 1.58.0
[packages/nghttp2.git] / nghttp2.spec
CommitLineData
b0744631 1# TODO: mruby, neverbleed?
7e68a898
JB
2#
3# Conditional build:
35859362
JB
4%bcond_with http3 # experimental HTTP/3 support
5%bcond_with libbpf # BPF support (requires CC=clang)
5ebd5855 6%bcond_without static_libs # static libraries
a8f9a0f9 7%bcond_without systemd # don't include systemd support
5ebd5855 8%bcond_without tests # "make check" call
7e68a898
JB
9
10Summary: HTTP/2.0 C library
11Summary(pl.UTF-8): Biblioteka C HTTP/2.0
12Name: nghttp2
e8127f7b 13Version: 1.58.0
c14fa1d7 14Release: 1
7e68a898
JB
15License: MIT
16Group: Libraries
27bc50c7
JB
17#Source0Download: https://github.com/nghttp2/nghttp2/releases
18Source0: https://github.com/nghttp2/nghttp2/releases/download/v%{version}/%{name}-%{version}.tar.xz
e8127f7b 19# Source0-md5: 4601542da69d9657072a3c5529f5c32e
27bc50c7 20URL: https://nghttp2.org/
7e68a898
JB
21%{?with_tests:BuildRequires: CUnit >= 2.1}
22BuildRequires: autoconf >= 2.61
23BuildRequires: automake
9f92d897 24BuildRequires: c-ares-devel >= 1.7.5
c02473f3 25BuildRequires: jansson-devel >= 2.5
35859362 26%{?with_libbpf:BuildRequires: libbpf-devel >= 0.7.0}
5ebd5855 27BuildRequires: libev-devel
9f92d897 28# for examples
7e68a898 29BuildRequires: libevent-devel >= 2.0.8
35859362 30BuildRequires: libstdc++-devel >= 6:5
7e68a898 31BuildRequires: libtool >= 2:2.2.6
b0744631 32BuildRequires: libxml2-devel >= 1:2.6.26
e8127f7b 33%{?with_http3:BuildRequires: nghttp3-devel >= 1.0.0}
57d2bbc4 34# +ngtcp2-crypto-openssl or ngtcp2-crypto-boringssl
e8127f7b 35%{?with_http3:BuildRequires: ngtcp2-devel >= 1.0.0}
7e68a898 36BuildRequires: openssl-devel >= 1.0.1
35859362 37%{?with_http3:BuildRequires: openssl-devel(quic)}
7e68a898 38BuildRequires: pkgconfig >= 1:0.20
f04ce4b6 39BuildRequires: python3 >= 1:3.8
26b1a5cb 40BuildRequires: rpmbuild(macros) >= 1.734
55ef14c3 41BuildRequires: sed >= 4.0
a8f9a0f9 42%{?with_systemd:BuildRequires: systemd-devel >= 1:209}
7e68a898
JB
43BuildRequires: tar >= 1:1.22
44BuildRequires: xz
45BuildRequires: zlib-devel >= 1.2.3
218ea8da 46Requires: %{name}-libs = %{version}-%{release}
9f92d897
JB
47Requires: c-ares >= 1.7.5
48Requires: jansson >= 2.5
49# noinst examples only
50#Requires: libevent >= 2.0.8
b0744631 51Requires: libxml2 >= 1:2.6.26
9f92d897 52Requires: openssl >= 1.0.1
9f92d897 53Requires: zlib >= 1.2.3
7e68a898
JB
54BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56%description
57This is an experimental implementation of Hypertext Transfer Protocol
58version 2.0.
59
60%description -l pl.UTF-8
61Ta biblioteka jest eksperymentalną implementacją protokołu HTTP
62(Hypertext Transfer Protocol) w wersji 2.0.
63
218ea8da
ER
64%package libs
65Summary: A library implementing the HTTP/2 protocol
27bc50c7 66Summary(pl.UTF-8): Biblioteka implementująca protokół HTTP/2
218ea8da 67Group: Libraries
034d7d03 68Obsoletes: python3-nghttp2 < 1.55.1
218ea8da
ER
69Conflicts: nghttp2 < 1.11.1-2
70
71%description libs
72libnghttp2 is a library implementing the Hypertext Transfer Protocol
73version 2 (HTTP/2) protocol in C.
74
27bc50c7
JB
75%description libs -l pl.UTF-8
76libnghttp2 to napisana w C biblioteka implementująca protokół HTTP/2
77(Hypertext Transfer Protocol w wersji 2).
78
7e68a898
JB
79%package devel
80Summary: Files needed for developing with libnghttp2
81Summary(pl.UTF-8): Pliki niezbędne do tworzenia aplikacji z użyciem libnghttp2
82Group: Development/Libraries
218ea8da 83Requires: %{name}-libs = %{version}-%{release}
7e68a898
JB
84
85%description devel
86Files needed for building applications with libnghttp2.
87
88%description devel -l pl.UTF-8
89Pliki niezbędne do tworzenia aplikacji z użyciem libnghttp2.
90
91%package static
92Summary: Static libnghttp2 library
93Summary(pl.UTF-8): Statyczna biblioteka libnghttp2
94Group: Development/Libraries
95Requires: %{name}-devel = %{version}-%{release}
96
97%description static
98Static libnghttp2 library.
99
100%description static -l pl.UTF-8
101Statyczna biblioteka libnghttp2.
102
103%prep
90ff5ae9 104%setup -q
7e68a898 105
2a3e23c4 106%{__sed} -i -e '1s,/usr/bin/env python,%{__python3},' script/fetch-ocsp-response
55ef14c3 107
7e68a898
JB
108%build
109%{__libtoolize}
110%{__aclocal} -I m4
111%{__autoconf}
112%{__autoheader}
113%{__automake}
114%configure \
5ebd5855 115 --enable-app \
5ebd5855 116 --enable-hpack-tools \
35859362 117 %{?with_http3:--enable-http3} \
2fcd3974 118 --disable-silent-rules \
5ebd5855 119 %{!?with_static_libs:--disable-static} \
35859362
JB
120 --without-jemalloc \
121 %{?with_libbpf:--with-libbpf}
7e68a898
JB
122
123%{__make}
124
125%if %{with tests}
126%{__make} check
127%endif
128
129%install
130rm -rf $RPM_BUILD_ROOT
131
132%{__make} install \
133 DESTDIR=$RPM_BUILD_ROOT
134
135# obsoleted by pkg-config
5ebd5855 136%{__rm} $RPM_BUILD_ROOT%{_libdir}/libnghttp2*.la
7e68a898
JB
137# packaged as %doc
138%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/nghttp2
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
218ea8da
ER
143%post libs -p /sbin/ldconfig
144%postun libs -p /sbin/ldconfig
7e68a898
JB
145
146%files
147%defattr(644,root,root,755)
b375e37d 148%doc AUTHORS COPYING ChangeLog README.rst
90ff5ae9 149%attr(755,root,root) %{_bindir}/deflatehd
2fcd3974 150%attr(755,root,root) %{_bindir}/h2load
90ff5ae9 151%attr(755,root,root) %{_bindir}/inflatehd
7e68a898
JB
152%attr(755,root,root) %{_bindir}/nghttp
153%attr(755,root,root) %{_bindir}/nghttpd
154%attr(755,root,root) %{_bindir}/nghttpx
55ef14c3
JB
155%dir %{_datadir}/nghttp2
156%attr(755,root,root) %{_datadir}/nghttp2/fetch-ocsp-response
2fcd3974 157%{_mandir}/man1/h2load.1*
90ff5ae9
JB
158%{_mandir}/man1/nghttp.1*
159%{_mandir}/man1/nghttpd.1*
160%{_mandir}/man1/nghttpx.1*
7e68a898 161
218ea8da
ER
162%files libs
163%defattr(644,root,root,755)
164%attr(755,root,root) %{_libdir}/libnghttp2.so.*.*.*
165%attr(755,root,root) %ghost %{_libdir}/libnghttp2.so.14
166
7e68a898
JB
167%files devel
168%defattr(644,root,root,755)
169%attr(755,root,root) %{_libdir}/libnghttp2.so
5ebd5855
JB
170%dir %{_includedir}/nghttp2
171%{_includedir}/nghttp2/nghttp2*.h
7e68a898
JB
172%{_pkgconfigdir}/libnghttp2.pc
173
174%if %{with static_libs}
175%files static
176%defattr(644,root,root,755)
177%{_libdir}/libnghttp2.a
178%endif
This page took 1.360626 seconds and 4 git commands to generate.