]> git.pld-linux.org Git - packages/nghttp2.git/blame - nghttp2.spec
- updated to 0.7.5
[packages/nghttp2.git] / nghttp2.spec
CommitLineData
7e68a898
JB
1#
2# Conditional build:
5ebd5855
JB
3%bcond_without asio # libnghttp2_asio C++ library
4%bcond_without static_libs # static libraries
5%bcond_without tests # "make check" call
7e68a898
JB
6
7Summary: HTTP/2.0 C library
8Summary(pl.UTF-8): Biblioteka C HTTP/2.0
9Name: nghttp2
5ebd5855 10Version: 0.7.5
90ff5ae9 11Release: 1
7e68a898
JB
12License: MIT
13Group: Libraries
2fcd3974
JB
14#Source0Download: https://github.com/tatsuhiro-t/nghttp2/releases
15Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/%{name}-%{version}.tar.xz
5ebd5855
JB
16# Source0-md5: d89aa34f33ac285be541198f287b77cb
17Patch0: %{name}-link.patch
7e68a898
JB
18URL: https://github.com/tatsuhiro-t/nghttp2
19%{?with_tests:BuildRequires: CUnit >= 2.1}
20BuildRequires: autoconf >= 2.61
21BuildRequires: automake
5ebd5855 22%{?with_asio:BuildRequires: boost-devel >= 1.54.0}
c02473f3 23BuildRequires: jansson-devel >= 2.5
5ebd5855 24BuildRequires: libev-devel
7e68a898 25BuildRequires: libevent-devel >= 2.0.8
5ebd5855 26BuildRequires: libstdc++-devel >= 6:4.3
7e68a898
JB
27BuildRequires: libtool >= 2:2.2.6
28BuildRequires: libxml2-devel >= 1:2.7.7
29BuildRequires: openssl-devel >= 1.0.1
30BuildRequires: pkgconfig >= 1:0.20
90ff5ae9
JB
31BuildRequires: python >= 1:2.7
32BuildRequires: python-Cython
593810f0 33BuildRequires: spdylay-devel >= 1.3.0
7e68a898
JB
34BuildRequires: tar >= 1:1.22
35BuildRequires: xz
36BuildRequires: zlib-devel >= 1.2.3
c02473f3 37Requires: jansson >= 2.5
7e68a898
JB
38Requires: libevent >= 2.0.8
39Requires: libxml2 >= 1:2.7.7
40Requires: openssl >= 1.0.1
593810f0 41Requires: spdylay >= 1.3.0
7e68a898
JB
42Requires: zlib >= 1.2.3
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
5ebd5855
JB
45# non-function symbols std::__once_call, std::__once_callable
46%define skip_post_check_so libnghttp2_asio.so.*
47
7e68a898
JB
48%description
49This is an experimental implementation of Hypertext Transfer Protocol
50version 2.0.
51
52%description -l pl.UTF-8
53Ta biblioteka jest eksperymentalną implementacją protokołu HTTP
54(Hypertext Transfer Protocol) w wersji 2.0.
55
56%package devel
57Summary: Files needed for developing with libnghttp2
58Summary(pl.UTF-8): Pliki niezbędne do tworzenia aplikacji z użyciem libnghttp2
59Group: Development/Libraries
60Requires: %{name} = %{version}-%{release}
61Requires: zlib-devel >= 1.2.3
62
63%description devel
64Files needed for building applications with libnghttp2.
65
66%description devel -l pl.UTF-8
67Pliki niezbędne do tworzenia aplikacji z użyciem libnghttp2.
68
69%package static
70Summary: Static libnghttp2 library
71Summary(pl.UTF-8): Statyczna biblioteka libnghttp2
72Group: Development/Libraries
73Requires: %{name}-devel = %{version}-%{release}
74
75%description static
76Static libnghttp2 library.
77
78%description static -l pl.UTF-8
79Statyczna biblioteka libnghttp2.
80
90ff5ae9
JB
81%package -n python-nghttp2
82Summary: Python binding to nghttp2 library
83Summary(pl.UTF-8): Wiązanie Pythona do biblioteki nghttp2
84Group: Libraries/Python
85Requires: %{name} = %{version}-%{release}
86Requires: python-libs >= 1:2.7
87
88%description -n python-nghttp2
89Python binding to nghttp2 library.
90
91%description -n python-nghttp2 -l pl.UTF-8
92Wiązanie Pythona do biblioteki nghttp2.
93
5ebd5855
JB
94%package asio
95Summary: HTTP/2.0 C++ library
96Summary(pl.UTF-8): Biblioteka C++ HTTP/2.0
97Group: Libraries
98Requires: %{name} = %{version}-%{release}
99Requires: openssl >= 1.0.1
100
101%description asio
102HTTP/2.0 C++ library.
103
104%description asio -l pl.UTF-8
105Biblioteka C++ HTTP/2.0.
106
107%package asio-devel
108Summary: Header file for nghttp2_asio library
109Summary(pl.UTF-8): Plik nagłówkowy biblioteki nghttp2_asio
110Group: Development/Libraries
111Requires: %{name}-asio = %{version}-%{release}
112Requires: %{name}-devel = %{version}-%{release}
113Requires: libstdc++-devel
114
115%description asio-devel
116Header file for nghttp2_asio library.
117
118%description asio-devel -l pl.UTF-8
119Plik nagłówkowy biblioteki nghttp2_asio.
120
121%package asio-static
122Summary: Static libnghttp2_asio library
123Summary(pl.UTF-8): Statyczna biblioteka libnghttp2_asio
124Group: Development/Libraries
125Requires: %{name}-asio-devel = %{version}-%{release}
126
127%description asio-static
128Static libnghttp2_asio library.
129
130%description asio-static -l pl.UTF-8
131Statyczna biblioteka libnghttp2_asio.
132
7e68a898 133%prep
90ff5ae9 134%setup -q
5ebd5855 135%patch0 -p1
7e68a898
JB
136
137%build
138%{__libtoolize}
139%{__aclocal} -I m4
140%{__autoconf}
141%{__autoheader}
142%{__automake}
143%configure \
5ebd5855
JB
144 --enable-app \
145 %{?with_asio:--enable-asio-lib} \
146 --enable-hpack-tools \
147 --enable-python-bindings \
2fcd3974 148 --disable-silent-rules \
5ebd5855
JB
149 %{!?with_static_libs:--disable-static} \
150 --without-jemalloc
7e68a898
JB
151
152%{__make}
153
154%if %{with tests}
155%{__make} check
156%endif
157
158%install
159rm -rf $RPM_BUILD_ROOT
160
161%{__make} install \
162 DESTDIR=$RPM_BUILD_ROOT
163
164# obsoleted by pkg-config
5ebd5855 165%{__rm} $RPM_BUILD_ROOT%{_libdir}/libnghttp2*.la
7e68a898
JB
166# packaged as %doc
167%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/nghttp2
168
169%clean
170rm -rf $RPM_BUILD_ROOT
171
172%post -p /sbin/ldconfig
173%postun -p /sbin/ldconfig
174
5ebd5855
JB
175%post asio -p /sbin/ldconfig
176%postun asio -p /sbin/ldconfig
177
7e68a898
JB
178%files
179%defattr(644,root,root,755)
180%doc AUTHORS COPYING README.rst
90ff5ae9 181%attr(755,root,root) %{_bindir}/deflatehd
2fcd3974 182%attr(755,root,root) %{_bindir}/h2load
90ff5ae9 183%attr(755,root,root) %{_bindir}/inflatehd
7e68a898
JB
184%attr(755,root,root) %{_bindir}/nghttp
185%attr(755,root,root) %{_bindir}/nghttpd
186%attr(755,root,root) %{_bindir}/nghttpx
187%attr(755,root,root) %{_libdir}/libnghttp2.so.*.*.*
593810f0 188%attr(755,root,root) %ghost %{_libdir}/libnghttp2.so.5
2fcd3974 189%{_mandir}/man1/h2load.1*
90ff5ae9
JB
190%{_mandir}/man1/nghttp.1*
191%{_mandir}/man1/nghttpd.1*
192%{_mandir}/man1/nghttpx.1*
7e68a898
JB
193
194%files devel
195%defattr(644,root,root,755)
196%attr(755,root,root) %{_libdir}/libnghttp2.so
5ebd5855
JB
197%dir %{_includedir}/nghttp2
198%{_includedir}/nghttp2/nghttp2*.h
7e68a898
JB
199%{_pkgconfigdir}/libnghttp2.pc
200
201%if %{with static_libs}
202%files static
203%defattr(644,root,root,755)
204%{_libdir}/libnghttp2.a
205%endif
90ff5ae9
JB
206
207%files -n python-nghttp2
208%defattr(644,root,root,755)
209%attr(755,root,root) %{py_sitedir}/nghttp2.so
593810f0 210%{py_sitedir}/python_nghttp2-%{version}-py*.egg-info
5ebd5855
JB
211
212%if %{with asio}
213%files asio
214%defattr(644,root,root,755)
215%attr(755,root,root) %{_libdir}/libnghttp2_asio.so.*.*.*
216%attr(755,root,root) %ghost %{_libdir}/libnghttp2_asio.so.0
217
218%files asio-devel
219%defattr(644,root,root,755)
220%attr(755,root,root) %{_libdir}/libnghttp2_asio.so
221%{_includedir}/nghttp2/asio_http2.h
222%{_pkgconfigdir}/libnghttp2_asio.pc
223
224%if %{with static_libs}
225%files asio-static
226%defattr(644,root,root,755)
227%{_libdir}/libnghttp2_asio.a
228%endif
229%endif
This page took 0.13482 seconds and 4 git commands to generate.