]> git.pld-linux.org Git - packages/neon.git/blame - neon.spec
- remove html docs installed by make
[packages/neon.git] / neon.spec
CommitLineData
d69a9291 1#
2# Conditional build:
38878d3d 3%bcond_without apidocs # do not build and package API docs
d69a9291 4%bcond_without static_libs # don't build static libraries
9065805f 5%bcond_without kerberos5 # don't build Kerberos V support
e0c5c301 6%bcond_without libproxy # don't build libproxy support
caa88408 7%bcond_without pakchois # don't build pakchois-based PKCS#11 support
38878d3d 8
94a59c75 9Summary: An HTTP and WebDAV client library
b690de02 10Summary(pl.UTF-8): Biblioteka kliencka HTTP i WebDAV
94a59c75 11Name: neon
ad370de7 12Version: 0.29.6
9dc179f0 13Release: 6
b8ab1935 14License: LGPL v2+
94a59c75 15Group: Libraries
94a59c75 16Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
ad370de7 17# Source0-md5: 591e0c82e6979e7e615211b386b8f6bc
769e704f 18URL: http://www.webdav.org/neon/
b8ab1935 19BuildRequires: autoconf >= 2.58
60170b09 20BuildRequires: automake
bb8183bd 21%{?with_kerberos5:BuildRequires: heimdal-devel}
e0c5c301 22%{?with_libproxy:BuildRequires: libproxy-devel}
f9ae6476 23BuildRequires: libtool >= 2:2.2
9dc601f3 24BuildRequires: libxml2-devel
fbe113ef 25BuildRequires: openssl-devel >= 0.9.7d
caa88408 26%{?with_pakchois:BuildRequires: pakchois-devel}
0eb136aa 27BuildRequires: pkgconfig
a8ebb846 28BuildRequires: zlib-devel
e914cc74 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94a59c75 30
31%description
32neon is an HTTP and WebDAV client library, with a C interface.
33Featuring:
882d452f 34 - High-level interface to HTTP and WebDAV methods (PUT, GET, HEAD
35 etc).
94a59c75 36 - Low-level interface to HTTP request handling, to allow implementing
37 new methods easily.
b9b2c7f8 38 - HTTP/1.1 and HTTP/1.0 persistent connections.
94a59c75 39 - RFC2617 basic and digest authentication (including auth-int,
b9b2c7f8 40 md5-sess).
41 - Proxy support (including basic/digest authentication).
42 - Generic WebDAV 207 XML response handling mechanism.
43 - XML parsing using the expat or libxml parsers.
44 - Easy generation of error messages from 207 error responses.
94a59c75 45 - WebDAV resource manipulation: MOVE, COPY, DELETE, MKCOL.
46 - WebDAV metadata support: set and remove properties, query any set of
47 properties (PROPPATCH/PROPFIND).
48
daa7576e 49%description -l pl.UTF-8
769e704f 50neon to biblioteka kliencka HTTP i WebDAV z interfejsem w C.
daa7576e 51Możliwości:
882d452f 52 - wysokopoziomowy interfejs do metod HTTP i WebDAV (PUT, GET,
53 HEAD...),
4b31dd0e 54 - niskopoziomowy interfejs do obsługi żądań HTTP pozwalający łatwo
daa7576e
JR
55 implementować nowe metody,
56 - stałe połączenia HTTP/1.1 i HTTP/1.0,
4b31dd0e
JB
57 - uwierzytelnianie podstawowe (basic) i skrótem RFC-2617 (auth-int,
58 md5-sess...),
59 - obsługa proxy (w tym uwierzytelnianie podstawowe i skrótem),
daa7576e
JR
60 - mechanizm obsługi odpowiedzi WebDAV 207 XML,
61 - analiza składniowa XML przy pomocy expat lub libxml,
62 - proste generowanie komunikatów błędów dla odpowiedzi 207,
b9b2c7f8 63 - manipulowanie zasobami WebDAV: MOVE, COPY, DELETE, MKCOL,
daa7576e
JR
64 - obsługa metadanych WebDAV: ustawianie i usuwanie atrybutów,
65 sprawdzanie dowolnego zbioru atrybutów (PROPPATCH/PROPFIND).
769e704f
JB
66
67%package devel
68Summary: Header files for neon
b690de02 69Summary(pl.UTF-8): Pliki nagłówkowe neon
769e704f 70Group: Development/Libraries
72e4cede 71Requires: %{name} = %{version}-%{release}
bb8183bd 72%{?with_kerberos5:Requires: heimdal-devel}
a3226741 73%{?with_libproxy:Requires: libproxy-devel}
caa88408 74%{?with_pakchois:Requires: pakchois-devel}
b45d8f35 75Requires: libxml2-devel
b00d07c4 76Requires: openssl-devel >= 0.9.7c
769e704f
JB
77
78%description devel
79C header files for the neon library.
80
daa7576e
JR
81%description devel -l pl.UTF-8
82Pliki nagłówkowe dla biblioteki neon.
769e704f
JB
83
84%package static
85Summary: Static libraries for neon
b690de02 86Summary(pl.UTF-8): Biblioteki statyczne neon
94a59c75 87Group: Development/Libraries
72e4cede 88Requires: %{name}-devel = %{version}-%{release}
94a59c75 89
769e704f
JB
90%description static
91Static neon libraries.
92
daa7576e 93%description static -l pl.UTF-8
769e704f 94Statyczne biblioteki neon.
94a59c75 95
38878d3d
ER
96%package apidocs
97Summary: neon API documentation
98Summary(pl.UTF-8): Dokumentacja API biblioteki neon
99Group: Documentation
100
101%description apidocs
102API and internal documentation for neon library.
103
104%description apidocs -l pl.UTF-8
105Dokumentacja API biblioteki neon.
106
94a59c75 107%prep
108%setup -q
109
110%build
318af41d 111%{__libtoolize} --install
387c948a 112%{__aclocal} -I macros
45b289d5 113%{__autoconf}
9dc601f3 114%configure \
bbe4098c 115 --with-ssl=openssl \
3aeb853f 116 --enable-threadsafe-ssl=posix \
9dc601f3 117 --enable-shared \
bbe4098c 118 --with-ca-bundle=/etc/certs/ca-certificates.crt \
caa88408 119 --with%{!?with_pakchois:out}-pakchois \
df50a546 120 %{!?with_static_libs:--disable-static} \
9065805f 121 %{!?with_kerberos5:--without-gssapi} \
e0c5c301 122 %{!?with_libproxy:--without-libproxy} \
9dc601f3
PG
123 --with-libxml2
124
94a59c75 125%{__make}
126
127%install
128rm -rf $RPM_BUILD_ROOT
769e704f 129
c8dbfeab
JB
130%{__make} install \
131 DESTDIR=$RPM_BUILD_ROOT
94a59c75 132
9dc179f0
JP
133%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html
134%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
caa88408 135
e80eb8df 136%find_lang %{name}
137
94a59c75 138%clean
139rm -rf $RPM_BUILD_ROOT
140
769e704f
JB
141%post -p /sbin/ldconfig
142%postun -p /sbin/ldconfig
94a59c75 143
e80eb8df 144%files -f %{name}.lang
94a59c75 145%defattr(644,root,root,755)
38878d3d 146%doc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
b8ab1935
JB
147%attr(755,root,root) %{_libdir}/libneon.so.*.*.*
148%attr(755,root,root) %ghost %{_libdir}/libneon.so.27
94a59c75 149
150%files devel
151%defattr(644,root,root,755)
38878d3d 152%doc doc/*.txt
2c6a6cf1 153%attr(755,root,root) %{_bindir}/neon-config
b8ab1935 154%attr(755,root,root) %{_libdir}/libneon.so
2f50aeeb 155%{_includedir}/neon
afebb879 156%{_pkgconfigdir}/neon.pc
b8ab1935
JB
157%{_mandir}/man1/neon-config.1*
158%{_mandir}/man3/ne_*.3*
159%{_mandir}/man3/neon.3*
769e704f 160
d69a9291 161%if %{with static_libs}
769e704f
JB
162%files static
163%defattr(644,root,root,755)
b8ab1935 164%{_libdir}/libneon.a
d69a9291 165%endif
38878d3d
ER
166
167%if %{with apidocs}
168%files apidocs
169%defattr(644,root,root,755)
170%doc doc/html/*
171%endif
This page took 0.055418 seconds and 4 git commands to generate.