]> git.pld-linux.org Git - packages/mythtv.git/blame - mythtv.spec
- tabs in preamble
[packages/mythtv.git] / mythtv.spec
CommitLineData
aa6db6e7 1# TODO
bc34ab39 2# - bconds: altivec joystick lcd
58422b0a 3# - lcd? (app-misc/lcdproc)
bc34ab39 4# - icons for desktop entries
58422b0a 5# - alpha, sparc, ppc arches?
8afae0cb
ER
6#
7# Specfile for MythTV
8#
9# MythTV now uses a fairly intelligent cpu-detection script, so if you are
10# building an rpm by hand on the machine it will be used on, I encourage you
11# to use "--with cpu_autodetect" to let mythtv decide for you.
12#
ed630fed 13# Conditional build:
af73c10e 14%bcond_with cpu_autodetect # enable CPU autodetection at compile time (sets "-march", "-mcpu" compile flags really)
cb059bf8
ER
15%bcond_without lirc # lirc support
16%bcond_without alsa # alsa support
9dc1d1be 17%bcond_without oss # oss support
cb059bf8
ER
18%bcond_without arts # arts support
19%bcond_without jack # jack audio connection kit
cb059bf8 20%bcond_without opengl # opengl vsync
1e5a2ed2 21%bcond_with dvb # DVB support # invalid option
bc34ab39 22%bcond_without xrandr # disable X11 resolution switching
9dc1d1be
JB
23%bcond_with ivtv # ivtv support (PVR-250, PVR-350) NFY
24%bcond_with firewire # ieee1394 (NFY)
bc34ab39 25%bcond_without xvmc # do not use XvMCW
1e5a2ed2 26%bcond_with mmx # enable mmx
32b3b293
ER
27
28# enable mmx automatically on arches having it
29%ifarch %{ix86} %{x8664}
30%ifnarch i386 i486 i586 i686
31%define with_mmx 1
32%endif
33%endif
cb059bf8 34
ea76f0ee
ER
35#define _snap 20060905
36#define _rev 11046
03ba0f65 37%define _rel 0.6
b2c9e730 38Summary: A personal video recorder (PVR) application
7456895a 39Summary(pl.UTF-8): Osobista aplikacja do nagrywania obrazu (PVR)
910a00e3 40Name: mythtv
ea76f0ee 41Version: 0.20
f1992461 42Release: %{?_snap:0.%{_snap}.%{_rev}.}%{_rel}
910a00e3 43License: GPL v2
b2c9e730 44Group: Applications/Multimedia
03ba0f65 45#Source0: http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
46Source0: %{name}-%{version}-fix.tar.bz2
47# Source0-md5: 8901d3962eb58d1dd9ec2cd3bdbdfb76
ea76f0ee 48#Source0: %{name}-%{_snap}.%{_rev}.tar.bz2
eceeddea
ER
49Source1: mythbackend.sysconfig
50Source2: mythbackend.init
51Source3: mythbackend.logrotate
4cd4742b 52Source5: mythfrontend.desktop
2360417b 53#Patch100: %{name}-branch.diff
c79fdf07 54Patch0: %{name}-lib64.patch
f1992461 55Patch1: mythtv-configure.patch
96b717a5
ER
56Patch2: %{name}-mythstream.patch
57Patch3: %{name}-ldconfig.patch
1e5a2ed2 58#Patch4: %{name}-pl.patch
96b717a5 59Patch5: %{name}-sbinpath.patch
09985e5b 60Patch7: %{name}-optflags.patch
2360417b 61Patch8: mythtv-dvdnav-shared.patch
b2c9e730 62URL: http://www.mythtv.org/
5eccad13 63#BuildRequires: DirectFB-devel
03ba0f65 64#BuildRequires: XFree86-devel
ed630fed
JB
65%{?with_alsa:BuildRequires: alsa-lib-devel}
66%{?with_arts:BuildRequires: arts-devel >= 13:0.9.5}
c0517663 67BuildRequires: freetype-devel >= 1:2.0.0
cb059bf8 68%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
c0517663 69BuildRequires: lame-libs-devel
03ba0f65 70%{?with_xvmc:BuildRequires: xorg-lib-libXvMC-devel}
c0517663 71%{?with_firewire:BuildRequires: libavc1394-devel}
96b717a5
ER
72%{?with_dvb:BuildRequires: libdvb-devel}
73BuildRequires: libdvdnav-devel
c0517663
ER
74%{?with_firewire:BuildRequires: libiec61883-devel}
75%{?with_firewire:BuildRequires: libraw1394-devel}
a3ec4ed6 76BuildRequires: linux-libc-headers >= 7:2.6.10
f3707f19 77%{?with_lirc:BuildRequires: lirc-devel}
ed630fed 78BuildRequires: mysql-devel
03ba0f65 79#BuildRequires: patchutils
ed630fed
JB
80BuildRequires: qmake >= 6:3.2.1-4
81BuildRequires: qt-devel >= 6:3.2.1-4
4cd4742b 82BuildRequires: rpmbuild(macros) >= 1.228
ed630fed 83BuildRequires: sed >= 4.0
96b717a5
ER
84# for bundled libavcodec
85BuildRequires: libdts-devel
cccbdc0c 86#BuildConflicts: libmyth-devel
97b6efdd 87ExclusiveArch: %{ix86} %{x8664} ppc
910a00e3 88BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
8afae0cb 89
96b717a5
ER
90%define myth_api_version %(echo %{version} | cut -d. -f1,2)
91
8afae0cb 92%description
910a00e3
ER
93MythTV implements the following PVR features, and more, with a unified
94graphical interface:
5eccad13
ER
95- Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV.
96- Video compression using RTjpeg or MPEG-4
97- Program listing retrieval using XMLTV
98- Themable, semi-transparent on-screen display
99- Electronic program guide
100- Scheduled recording of TV programs
101- Resolution of conflicts between scheduled recordings
102- Basic video editing
8afae0cb 103
17176342
JR
104%description -l pl.UTF-8
105MythTV implementuje następujące możliwości PVR, a nawet więcej, wraz z
ed630fed 106ujednoliconym interfejsem graficznym:
17176342
JR
107- podstawowa funkcjonalność "live-tv"; pauza, szybkie przewijanie,
108 przewijanie "żywej" telewizji
109- kompresja obrazu przy użyciu RTjpeg lub MPEG-4
110- odczyt listy programów przy użyciu XMLTV
111- pseudoprzezroczyste wyświetlanie na obrazie (OSD) z obsługą motywów
ed630fed 112- elektroniczny przewodnik po programie
17176342
JR
113- planowane nagrywanie programów telewizyjnych
114- rozwiązywanie konfliktów między planowanymi nagraniami
ed630fed 115- podstawowa edycja obrazu
a7691716 116
ed630fed
JB
117%package backend
118Summary: Server component of mythtv (a PVR)
7456895a 119Summary(pl.UTF-8): Część serwerowa mythtv (PVR)
910a00e3 120Group: Applications/Multimedia
96b717a5
ER
121Requires(post,preun): /sbin/chkconfig
122Requires(postun): /usr/sbin/groupdel
123Requires(postun): /usr/sbin/userdel
ed630fed 124Requires(pre): /bin/id
f2f4277e 125Requires(pre): /usr/bin/getgid
ed630fed
JB
126Requires(pre): /usr/sbin/groupadd
127Requires(pre): /usr/sbin/useradd
96b717a5 128Requires: libmyth = %{version}-%{release}
ed630fed 129Requires: mythtv = %{version}-%{release}
ed630fed 130Provides: group(mythtv)
96b717a5 131Provides: user(mythtv)
8afae0cb 132
ed630fed 133%description backend
910a00e3
ER
134MythTV provides a unified graphical interface for recording and
135viewing television programs. Refer to the mythtv package for more
136information.
8afae0cb 137
ed630fed
JB
138This package contains only the server software, which provides video
139and audio capture and encoding services. In order to be useful, it
140requires a mythtv-frontend installation, either on the same system or
141one reachable via the network.
142
17176342 143%description backend -l pl.UTF-8
ed630fed 144MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
17176342 145oglądania programów telewizyjnych. Więcej informacji w pakiecie
ed630fed
JB
146mythtv.
147
17176342
JR
148Ten pakiet zawiera tylko oprogramowanie serwerowe, udostępniające
149usługi przechwytywania i kodowania obrazu i dźwięku. Aby było
ed630fed 150przydatne, wymaga instalacji mythtv-frontend - na tym samym systemie,
17176342 151albo innym osiągalnym po sieci.
8afae0cb
ER
152
153%package frontend
ed630fed 154Summary: Client component of mythtv (a PVR)
7456895a 155Summary(pl.UTF-8): Część kliencka mythtv (PVR)
910a00e3 156Group: Applications/Multimedia
96b717a5 157Requires: libmyth = %{version}-%{release}
910a00e3
ER
158Requires: mythtv = %{version}-%{release}
159Requires: mythtv-themes = %{version}-%{release}
96b717a5 160Provides: mythtv-frontend-api = %{myth_api_version}
8afae0cb
ER
161
162%description frontend
910a00e3
ER
163MythTV provides a unified graphical interface for recording and
164viewing television programs. Refer to the mythtv package for more
165information.
8afae0cb
ER
166
167This package contains only the client software, which provides a
910a00e3 168front-end for playback and configuration. It requires access to a
8afae0cb
ER
169mythtv-backend installation, either on the same system or one
170reachable via the network.
171
17176342 172%description frontend -l pl.UTF-8
ed630fed 173MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
17176342 174oglądania programów telewizyjnych. Więcej informacji w pakiecie
ed630fed 175mythtv.
8afae0cb 176
17176342
JR
177Ten pakiet zawiera tylko oprogramowanie klienckie, dostarczające
178frontend do odtwarzania i konfiguracji. Wymaga dostępu do instalacji
179mythtv-backend - na tym samym systemie, albo innym osiągalnym po
ed630fed 180sieci.
8afae0cb
ER
181
182%package setup
ed630fed 183Summary: Setup the mythtv backend
7456895a 184Summary(pl.UTF-8): Konfigurator backendu mythtv
910a00e3 185Group: Applications/Multimedia
96b717a5 186Requires: libmyth = %{version}-%{release}
8afae0cb
ER
187
188%description setup
910a00e3
ER
189MythTV provides a unified graphical interface for recording and
190viewing television programs. Refer to the mythtv package for more
191information.
8afae0cb
ER
192
193This package contains only the setup software for configuring the
194mythtv backend.
195
17176342 196%description setup -l pl.UTF-8
ed630fed 197MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
17176342 198oglądania programów telewizyjnych. Więcej informacji w pakiecie
ed630fed
JB
199mythtv.
200
201Ten pakiet zawiera tylko program do konfigurowania backendu mythtv.
202
203%package themes
204Summary: Base themes for mythtv's frontend
7456895a 205Summary(pl.UTF-8): Podstawowe motywy dla frontendu mythtv
bbba3c1d
ER
206Requires: %{name}-frontend = %{version}-%{release}
207Group: Themes
ed630fed
JB
208
209%description themes
210MythTV provides a unified graphical interface for recording and
211viewing television programs. Refer to the mythtv package for more
212information.
213
214This package contains only the base themes used by the frontend and
215mythtvsetup.
216
17176342 217%description themes -l pl.UTF-8
ed630fed 218MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
17176342 219oglądania programów telewizyjnych. Więcej informacji w pakiecie
ed630fed
JB
220mythtv.
221
17176342 222Ten pakiet zawiera tylko podstawowe motywy używane przez frontend oraz
ed630fed
JB
223mythtvsetup.
224
225%package -n libmyth
226Summary: Library providing mythtv support
7456895a 227Summary(pl.UTF-8): Biblioteka udostępniająca obsługę mythtv
ed630fed
JB
228Group: Libraries
229Requires: freetype >= 1:2.0.0
230Requires: lame
231Requires: qt >= 6:3.2.1-4
232Requires: qt-plugin-mysql >= 6:3.2.1-4
233
234%description -n libmyth
235Common library code for MythTV and add-on modules (development) MythTV
236provides a unified graphical interface for recording and viewing
237television programs. Refer to the mythtv package for more information.
238
17176342
JR
239%description -n libmyth -l pl.UTF-8
240Wspólny kod biblioteki dla MythTV i dodatkowych modułów MythTV
241dostarczający ujednolicony interfejs graficzny do nagrywania i
242oglądania programów telewizyjnych. Więcej informacji w pakiecie
ed630fed
JB
243mythtv.
244
245%package -n libmyth-devel
246Summary: Development files for libmyth
7456895a 247Summary(pl.UTF-8): Pliki nagłówkowe libmyth
ed630fed
JB
248Group: Development/Libraries
249Requires: libmyth = %{version}-%{release}
ed630fed
JB
250
251%description -n libmyth-devel
252This package contains the header files for developing add-ons for
253mythtv.
254
17176342
JR
255%description -n libmyth-devel -l pl.UTF-8
256Ten pakiet zawiera pliki nagłówkowe do tworzenia dodatków dla mythtv.
ed630fed
JB
257
258%package -n libmyth-static
259Summary: Static libmyth library
7456895a 260Summary(pl.UTF-8): Statyczna biblioteka libmyth
ed630fed
JB
261Group: Development/Libraries
262Requires: libmyth-devel = %{version}-%{release}
263
264%description -n libmyth-static
265Static libmyth library.
266
17176342 267%description -n libmyth-static -l pl.UTF-8
ed630fed
JB
268Statyczna biblioteka libmyth.
269
8afae0cb 270%prep
03ba0f65 271%setup -q %{?_rev:-n %{name}} %{?_rel: -n %{name}-%{version}-fix}
96b717a5 272%if %{_lib} != "lib"
1e5a2ed2 273#%patch0 -p1
96b717a5 274%endif
f1992461 275%patch1 -p1
018c2e7e 276%patch2 -p1
0ea777bd 277%patch3 -p1
1e5a2ed2 278#%patch4 -p1 REDIFF and submit
96b717a5 279%patch5 -p1
1e5a2ed2 280
09985e5b 281%patch7 -p1
2360417b 282%patch8 -p1
8afae0cb 283
6e738c98
ER
284rm -rf database/old # not supported in PLD
285
96b717a5
ER
286# lib64 fix - enable to update patch
287%if %{_lib} != "lib" && 0
288find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
289xargs grep -l /lib . | xargs sed -i -e '
290 s,/''usr/lib/,/%{_libdir}/,g
291 s,/''lib/mythtv,/%{_lib}/mythtv,g
292 s,{PREFIX}/lib$,{PREFIX}/%{_lib},g
293'
294exit 1
295%endif
296
3c3d6f2b
ER
297# Assigning null to QMAKE_LIBDIR_QT will prevent makefiles contain
298# -L$(QTDIR)/%{_lib} and -Wl,-rpath,$(QTDIR)/%{_lib}. And that will
299# prevent compiler finding libs from system when they should be looked
300# from current buildtree.
301# but that made it link with -lqt which doesn't exist, instead of -lqt-mt
302# so we make QMAKE wrapper which will do sed subst after calling
303# qmake. this is the wrapper.
304cat > qmake-wrapper.sh <<'EOF'
305#!/bin/sh
306getmakefile() {
307 while [ $# -gt 0 ]; do
308 case "$1" in
309 -o)
310 shift
311 makefile="$1"
312 return
313 ;;
314 esac
315 shift
316 done
317}
318
319qmake "$@"
320getmakefile "$@"
321if [ "$makefile" ]; then
322 %{__sed} -i -e '
323 s;-Wl,-rpath,$(QTDIR)/%{_lib};;
324 s;-L$(QTDIR)/%{_lib};;
325 ' $makefile
326fi
327EOF
328chmod +x qmake-wrapper.sh
329
8afae0cb 330%build
018c2e7e
ER
331%if %{with cpu_autodetect}
332# Make sure we have /proc mounted
333if [ ! -r /proc/cpuinfo ]; then
334 echo "You need to have /proc mounted in order to build with cpu_autodetect!"
335 exit 1
336fi
337%endif
910a00e3 338export QTDIR="%{_prefix}"
018c2e7e 339
0ba3a484 340%if "%{_lib}" != "lib"
018c2e7e 341export QMAKE_LIBDIR_X11=%{_prefix}/X11R6/%{_lib}
96b717a5
ER
342# help configure::has_library() to locate libs
343export LD_LIBRARY_PATH=%{_libdir}
018c2e7e 344%endif
eceeddea 345
96b717a5
ER
346# NB: not autoconf configure
347export CC="%{__cc}"
348export CXX="%{__cxx}"
349./configure \
350 --prefix=%{_prefix} \
351 --libdir=%{_libdir} \
352 --mandir=%{_mandir} \
353 --disable-opts \
1b03363f 354 --disable-distcc --disable-ccache \
8e8230a1 355 --compile-type=%{?debug:debug}%{!?debug:release} \
86b7888f
ER
356 --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
357 --extra-cxxflags="%{rpmcxxflags} -fomit-frame-pointer" \
c79fdf07
ER
358%if %{with cpu_autodetect}
359 --enable-proc-opt \
360%else
c0517663 361 %ifarch %{ix86}
58422b0a 362 %ifarch athlon
d0c7b0ef 363 --arch=athlon \
58422b0a
ER
364 %else
365 --cpu=i386 --tune=pentium4 \
58422b0a 366 %endif
c0517663
ER
367 %endif
368 %ifarch %{x8664}
d0c7b0ef 369 --arch=x86_64 \
c0517663 370 %endif
32b3b293 371 %{?with_mmx:--enable-mmx} \
8afae0cb 372%endif
96b717a5 373 %{?with_dvb:--enable-dvb --dvb-path=%{_includedir} --enable-dvb-eit} \
eceeddea
ER
374 --%{?with_arts:en}%{!?with_arts:dis}able-audio-arts \
375 --%{?with_alsa:en}%{!?with_alsa:dis}able-audio-alsa \
376 --%{?with_oss:en}%{!?with_oss:dis}able-audio-oss \
6c269db6 377 --%{?with_jack:en}%{!?with_jack:dis}able-audio-jack \
c79fdf07 378 --%{?with_opengl:en}%{!?with_opengl:dis}able-opengl-vsync \
eceeddea 379 --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
cb059bf8 380 --%{?with_firewire:en}%{!?with_firewire:dis}able-firewire \
bc34ab39
ER
381 --%{?with_xrandr:en}%{!?with_xrandr:dis}able-xrandr \
382 --%{?with_xvmc:en}%{!?with_xvmc:dis}able-xvmc \
cb059bf8
ER
383 --enable-xv \
384 --enable-x11 \
96b717a5 385
a3ec4ed6 386qmake mythtv.pro
3c3d6f2b
ER
387%{__make} \
388 QMAKE=$(pwd)/qmake-wrapper.sh
8afae0cb 389
8afae0cb
ER
390%install
391rm -rf $RPM_BUILD_ROOT
2dcbef41 392install -d $RPM_BUILD_ROOT/etc/{logrotate.d,sysconfig} \
2aaa3ce4 393 $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_desktopdir}} \
4cd4742b
ER
394 $RPM_BUILD_ROOT/var/{cache,lib,log,run}/mythtv \
395 $RPM_BUILD_ROOT%{_libdir}/mythtv/plugins
eceeddea 396
a3ec4ed6 397export QTDIR="%{_prefix}"
eceeddea
ER
398%{__make} install \
399 INSTALL_ROOT=$RPM_BUILD_ROOT
400
8afae0cb 401# Install the files that we added on top of mythtv's own stuff
4cd4742b
ER
402install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mythbackend
403install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mythbackend
2dcbef41 404install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/mythbackend
4cd4742b
ER
405
406# desktop entries
4cd4742b 407install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
8afae0cb
ER
408
409# Install settings.pro so people can see the build options we used
68d88cbd
ER
410install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/build
411install config.mak settings.pro $RPM_BUILD_ROOT%{_datadir}/mythtv/build
8afae0cb 412
96b717a5
ER
413for p in mythfrontend; do
414 for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
415 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
416 done > $p.lang
417done
418
419# glibc language codes. attempt was made to change it on libmyth side,
420# but that was just asking for trouble due large coverage of
421# language.lower() usage.
422sed -i -e '
423s,%%lang(en_gb),%%lang(en_GB),
424s,%%lang(zh_tw),%%lang(zh_TW),
425s,%%lang(pt_br),%%lang(pt_BR),
426' *.lang
427
428rm -rf mythtvosd mythwelcome mythlcdserver
99d50505 429install -d mythtvosd mythwelcome
96b717a5
ER
430cp -a programs/mythtvosd/{README,*.xml} mythtvosd
431cp -a programs/mythwelcome/README mythwelcome
432cp -a programs/mythlcdserver/README mythlcdserver
433
8afae0cb
ER
434%clean
435rm -rf $RPM_BUILD_ROOT
436
ed630fed 437%pre backend
5eccad13 438%groupadd -g 149 %{name}
cb059bf8
ER
439%useradd -u 149 -d /var/lib/mythtv -g %{name} -c "MythTV User" %{name}
440%addusertogroup %{name} video
441%addusertogroup %{name} audio
442
443%post backend
68d88cbd 444/sbin/chkconfig --add mythbackend
cb059bf8
ER
445
446%preun backend
447if [ "$1" = "0" ]; then
448 %service -q mythbackend stop
449 /sbin/chkconfig --del mythbackend
450fi
8afae0cb 451
ed630fed 452%postun backend
a3eedc29
ER
453if [ "$1" = "0" ]; then
454 %userremove %{name}
455 %groupremove %{name}
456fi
8afae0cb 457
ed630fed
JB
458%post -n libmyth -p /sbin/ldconfig
459%postun -n libmyth -p /sbin/ldconfig
460
6e738c98 461%post setup
cb059bf8 462if [ "$1" = 1 ]; then
6e738c98
ER
463%banner -e %{name}-setup <<EOF
464To grant mysql permissions to mythtv, please run
465zcat %{_docdir}/%{name}-setup-%{version}/database/mc.sql.gz | mysql
466EOF
cb059bf8 467fi
6e738c98 468
8afae0cb 469%files
910a00e3 470%defattr(644,root,root,755)
2b07fa66 471%doc README* UPGRADING AUTHORS FAQ
8afae0cb 472%doc docs contrib configfiles
96b717a5 473%doc keys.txt mythtvosd mythwelcome mythlcdserver
8afae0cb
ER
474
475%files backend
910a00e3 476%defattr(644,root,root,755)
96b717a5
ER
477%attr(755,root,root) %{_sbindir}/mythbackend
478%attr(755,root,root) %{_sbindir}/mythcommflag
910a00e3 479%attr(755,root,root) %{_bindir}/mythfilldatabase
96b717a5
ER
480%attr(755,root,root) %{_sbindir}/mythjobqueue
481%attr(755,root,root) %{_sbindir}/mythlcdserver
482%attr(755,root,root) %{_bindir}/mythtranscode
f1992461 483%attr(755,root,root) %{_bindir}/mythreplex
cb059bf8
ER
484%attr(775,root,mythtv) %dir /var/lib/mythtv
485%attr(775,root,mythtv) %dir /var/cache/mythtv
486%attr(775,root,mythtv) %dir /var/run/mythtv
a3eedc29 487%attr(754,root,root) /etc/rc.d/init.d/mythbackend
96b717a5
ER
488%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mythbackend
489%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/mythbackend
cb059bf8 490%attr(775,root,mythtv) %dir %{_localstatedir}/log/mythtv
8afae0cb 491
96b717a5 492%files frontend -f mythfrontend.lang
910a00e3 493%defattr(644,root,root,755)
a3ec4ed6 494%attr(755,root,root) %{_bindir}/mythfrontend
96b717a5 495%attr(755,root,root) %{_bindir}/mythshutdown
910a00e3 496%attr(755,root,root) %{_bindir}/mythtv
910a00e3 497%attr(755,root,root) %{_bindir}/mythtvosd
96b717a5
ER
498%attr(755,root,root) %{_bindir}/mythwelcome
499%dir %{_datadir}/mythtv
bbba3c1d 500%dir %{_datadir}/mythtv/themes
96b717a5
ER
501%dir %{_libdir}/mythtv
502%{_datadir}/mythtv/*.xml
cb059bf8
ER
503%dir %{_libdir}/mythtv/filters
504%dir %{_libdir}/mythtv/plugins
505%attr(755,root,root) %{_libdir}/mythtv/filters/*.so
8afae0cb 506%{_datadir}/mythtv/*.ttf
96b717a5 507%dir %{_datadir}/mythtv/i18n
2aaa3ce4 508%{_desktopdir}/*.desktop
8afae0cb 509
ed630fed
JB
510%files setup
511%defattr(644,root,root,755)
6e738c98 512%doc database
b9307635 513%attr(755,root,root) %{_bindir}/mythtv-setup
ed630fed 514
8afae0cb 515%files themes
910a00e3 516%defattr(644,root,root,755)
bbba3c1d 517%{_datadir}/mythtv/themes/*
8afae0cb
ER
518
519%files -n libmyth
910a00e3 520%defattr(644,root,root,755)
a7691716 521%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
8afae0cb
ER
522
523%files -n libmyth-devel
910a00e3 524%defattr(644,root,root,755)
910a00e3 525%attr(755,root,root) %{_libdir}/*.so
ed630fed 526%{_includedir}/*
68d88cbd 527%{_datadir}/mythtv/build
a7691716
ER
528
529%files -n libmyth-static
530%defattr(644,root,root,755)
This page took 0.148253 seconds and 4 git commands to generate.