]> git.pld-linux.org Git - packages/mythtv.git/blame - mythtv.spec
- pl language by luzik
[packages/mythtv.git] / mythtv.spec
CommitLineData
aa6db6e7 1# TODO
bc34ab39 2# - bconds: altivec joystick lcd
58422b0a 3# - lcd? (app-misc/lcdproc)
bc34ab39 4# - icons for desktop entries
58422b0a 5# - alpha, sparc, ppc arches?
8afae0cb
ER
6#
7# Specfile for MythTV
8#
9# MythTV now uses a fairly intelligent cpu-detection script, so if you are
10# building an rpm by hand on the machine it will be used on, I encourage you
11# to use "--with cpu_autodetect" to let mythtv decide for you.
12#
ed630fed 13# Conditional build:
af73c10e 14%bcond_with cpu_autodetect # enable CPU autodetection at compile time (sets "-march", "-mcpu" compile flags really)
cb059bf8
ER
15%bcond_without lirc # lirc support
16%bcond_without alsa # alsa support
9dc1d1be 17%bcond_without oss # oss support
cb059bf8
ER
18%bcond_without arts # arts support
19%bcond_without jack # jack audio connection kit
0d011f35 20%bcond_with oggvorbis # ogg vorbis (gone?!)
cb059bf8 21%bcond_without opengl # opengl vsync
9dc1d1be 22%bcond_without dvb # DVB support
bc34ab39 23%bcond_without xrandr # disable X11 resolution switching
9dc1d1be
JB
24%bcond_with ivtv # ivtv support (PVR-250, PVR-350) NFY
25%bcond_with firewire # ieee1394 (NFY)
bc34ab39 26%bcond_without xvmc # do not use XvMCW
32b3b293
ER
27%bcond_with mmx # enable mmx
28
29# enable mmx automatically on arches having it
30%ifarch %{ix86} %{x8664}
31%ifnarch i386 i486 i586 i686
32%define with_mmx 1
33%endif
34%endif
cb059bf8 35
07f4050d
ER
36%define _snap 20060204
37%define _rev 8859
b6362033 38%define _rel 1.2
c19214e8
ER
39Summary: A personal video recorder (PVR) application
40Summary(pl): Osobista aplikacja do nagrywania obrazu (PVR)
41Name: mythtv
780087d6
ER
42Version: 0.19
43Release: 0.%{_snap}.%{_rev}.%{_rel}
910a00e3 44License: GPL v2
b2c9e730 45Group: Applications/Multimedia
0d011f35 46#Source0: http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
301b7f88 47Source0: %{name}-%{_snap}.%{_rev}.tar.bz2
07f4050d 48# Source0-md5: 8dbe20ef01c04ad70436c609ac28b4dd
eceeddea
ER
49Source1: mythbackend.sysconfig
50Source2: mythbackend.init
51Source3: mythbackend.logrotate
4cd4742b 52Source5: mythfrontend.desktop
c79fdf07
ER
53Patch0: %{name}-lib64.patch
54Patch1: %{name}-x86_64-configure.patch
70f3f0f5 55Patch2: %{name}-mythstream.patch
893ab37d 56Patch3: %{name}-ldconfig.patch
b6362033 57Patch4: %{name}-pl.patch
b2c9e730 58URL: http://www.mythtv.org/
5eccad13 59#BuildRequires: DirectFB-devel
c19214e8 60BuildRequires: XFree86-devel
ed630fed
JB
61%{?with_alsa:BuildRequires: alsa-lib-devel}
62%{?with_arts:BuildRequires: arts-devel >= 13:0.9.5}
cb059bf8 63%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
c19214e8 64%{?with_dvb:BuildRequires: libdvb-devel}
b6362033 65BuildRequires: libdvdnav-devel
cb059bf8
ER
66%{?with_oggvorbis:BuildRequires: libvorbis-devel}
67%if %{with firewire}
cb059bf8
ER
68BuildRequires: libavc1394-devel
69BuildRequires: libiec61883-devel # missing in PLD?
c19214e8 70BuildRequires: libraw1394-devel
cb059bf8 71%endif
910a00e3 72BuildRequires: freetype-devel >= 1:2.0.0
ed630fed 73BuildRequires: gcc-c++
910a00e3 74BuildRequires: lame-libs-devel
bc34ab39 75%{?with_xvmc:BuildRequires: libXvMCW-devel}
a3ec4ed6 76BuildRequires: linux-libc-headers >= 7:2.6.10
f3707f19 77%{?with_lirc:BuildRequires: lirc-devel}
ed630fed 78BuildRequires: mysql-devel
ed630fed
JB
79BuildRequires: qmake >= 6:3.2.1-4
80BuildRequires: qt-devel >= 6:3.2.1-4
4cd4742b 81BuildRequires: rpmbuild(macros) >= 1.228
ed630fed 82BuildRequires: sed >= 4.0
301b7f88
ER
83# for bundled libavcodec
84BuildRequires: libdts-devel
a73e23b4 85BuildConflicts: libmyth-devel
97b6efdd 86ExclusiveArch: %{ix86} %{x8664} ppc
910a00e3 87BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
8afae0cb 88
d0b30139
ER
89%define myth_api_version %(echo %{version} | cut -d. -f1,2)
90
8afae0cb 91%description
910a00e3
ER
92MythTV implements the following PVR features, and more, with a unified
93graphical interface:
5eccad13
ER
94- Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV.
95- Video compression using RTjpeg or MPEG-4
96- Program listing retrieval using XMLTV
97- Themable, semi-transparent on-screen display
98- Electronic program guide
99- Scheduled recording of TV programs
100- Resolution of conflicts between scheduled recordings
101- Basic video editing
8afae0cb 102
ed630fed
JB
103%description -l pl
104