]> git.pld-linux.org Git - packages/mythtv.git/blame - mythtv.spec
- updated to 0.20 snap (svn 11046)
[packages/mythtv.git] / mythtv.spec
CommitLineData
aa6db6e7 1# TODO
bc34ab39 2# - bconds: altivec joystick lcd
58422b0a 3# - lcd? (app-misc/lcdproc)
bc34ab39 4# - icons for desktop entries
58422b0a 5# - alpha, sparc, ppc arches?
8afae0cb
ER
6#
7# Specfile for MythTV
8#
9# MythTV now uses a fairly intelligent cpu-detection script, so if you are
10# building an rpm by hand on the machine it will be used on, I encourage you
11# to use "--with cpu_autodetect" to let mythtv decide for you.
12#
ed630fed 13# Conditional build:
af73c10e 14%bcond_with cpu_autodetect # enable CPU autodetection at compile time (sets "-march", "-mcpu" compile flags really)
cb059bf8
ER
15%bcond_without lirc # lirc support
16%bcond_without alsa # alsa support
9dc1d1be 17%bcond_without oss # oss support
cb059bf8
ER
18%bcond_without arts # arts support
19%bcond_without jack # jack audio connection kit
96b717a5 20%bcond_with oggvorbis # ogg vorbis (gone?!)
cb059bf8 21%bcond_without opengl # opengl vsync
1e5a2ed2 22%bcond_with dvb # DVB support # invalid option
bc34ab39 23%bcond_without xrandr # disable X11 resolution switching
9dc1d1be
JB
24%bcond_with ivtv # ivtv support (PVR-250, PVR-350) NFY
25%bcond_with firewire # ieee1394 (NFY)
bc34ab39 26%bcond_without xvmc # do not use XvMCW
1e5a2ed2 27%bcond_with mmx # enable mmx
32b3b293
ER
28
29# enable mmx automatically on arches having it
30%ifarch %{ix86} %{x8664}
31%ifnarch i386 i486 i586 i686
32%define with_mmx 1
33%endif
34%endif
cb059bf8 35
1e5a2ed2
ER
36%define _snap 20060905
37%define _rev 11046
38%define _rel 0.1
b2c9e730
JB
39Summary: A personal video recorder (PVR) application
40Summary(pl): Osobista aplikacja do nagrywania obrazu (PVR)
910a00e3 41Name: mythtv
96b717a5 42Version: 0.19
1e5a2ed2 43Release: 3.%{_snap}.%{_rev}.%{_rel}
910a00e3 44License: GPL v2
b2c9e730 45Group: Applications/Multimedia
1e5a2ed2
ER
46#Source0: http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
47Source0: %{name}-%{_snap}.%{_rev}.tar.bz2
48# Source0-md5: dd5efb98bc52052b5de3c30e228b5785
eceeddea
ER
49Source1: mythbackend.sysconfig
50Source2: mythbackend.init
51Source3: mythbackend.logrotate
4cd4742b 52Source5: mythfrontend.desktop
c79fdf07 53Patch0: %{name}-lib64.patch
1e5a2ed2 54
96b717a5
ER
55Patch2: %{name}-mythstream.patch
56Patch3: %{name}-ldconfig.patch
1e5a2ed2 57#Patch4: %{name}-pl.patch
96b717a5 58Patch5: %{name}-sbinpath.patch
1e5a2ed2 59
09985e5b 60Patch7: %{name}-optflags.patch
1e5a2ed2 61#Patch8: %{name}-branch.diff
b2c9e730 62URL: http://www.mythtv.org/
5eccad13 63#BuildRequires: DirectFB-devel
96b717a5 64BuildRequires: XFree86-devel
ed630fed
JB
65%{?with_alsa:BuildRequires: alsa-lib-devel}
66%{?with_arts:BuildRequires: arts-devel >= 13:0.9.5}
c0517663 67BuildRequires: freetype-devel >= 1:2.0.0
cb059bf8 68%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
c0517663
ER
69BuildRequires: lame-libs-devel
70%{?with_xvmc:BuildRequires: libXvMCW-devel}
71%{?with_firewire:BuildRequires: libavc1394-devel}
96b717a5
ER
72%{?with_dvb:BuildRequires: libdvb-devel}
73BuildRequires: libdvdnav-devel
c0517663
ER
74%{?with_firewire:BuildRequires: libiec61883-devel}
75%{?with_firewire:BuildRequires: libraw1394-devel}
cb059bf8 76%{?with_oggvorbis:BuildRequires: libvorbis-devel}
a3ec4ed6 77BuildRequires: linux-libc-headers >= 7:2.6.10
f3707f19 78%{?with_lirc:BuildRequires: lirc-devel}
ed630fed 79BuildRequires: mysql-devel
c0517663 80BuildRequires: patchutils
ed630fed
JB
81BuildRequires: qmake >= 6:3.2.1-4
82BuildRequires: qt-devel >= 6:3.2.1-4
4cd4742b 83BuildRequires: rpmbuild(macros) >= 1.228
ed630fed 84BuildRequires: sed >= 4.0
96b717a5
ER
85# for bundled libavcodec
86BuildRequires: libdts-devel
cccbdc0c 87#BuildConflicts: libmyth-devel
97b6efdd 88ExclusiveArch: %{ix86} %{x8664} ppc
910a00e3 89BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
8afae0cb 90
96b717a5
ER
91%define myth_api_version %(echo %{version} | cut -d. -f1,2)
92
8afae0cb 93%description
910a00e3
ER
94MythTV implements the following PVR features, and more, with a unified
95graphical interface:
5eccad13
ER
96- Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV.
97- Video compression using RTjpeg or MPEG-4
98- Program listing retrieval using XMLTV
99- Themable, semi-transparent on-screen display
100- Electronic program guide
101- Scheduled recording of TV programs
102- Resolution of conflicts between scheduled recordings
103- Basic video editing
8afae0cb 104
ed630fed
JB
105%description -l pl
106