]> git.pld-linux.org Git - packages/mythplugins.git/blame - mythplugins.spec
- mythweather plugin disabled by default
[packages/mythplugins.git] / mythplugins.spec
CommitLineData
b9965e1c 1#
b9965e1c 2# Conditional build:
3%bcond_without binary # skip building binary plugins (build only mythweb)
e0e19850 4%bcond_without mytharchive # disable mytharchive plugin
b9965e1c 5%bcond_without mythbrowser # disable building mythbrowser plugin
e0e19850 6%bcond_without mythmovies # disable mythmovies plugin
7%bcond_without mythdvd # mythvideo part
b9965e1c 8%bcond_without mythflix # disable building mythflix plugin
9%bcond_without mythgallery # disable building mythgallery plugin
10%bcond_without mythgame # disable building mythgallery plugin
11%bcond_without mythmusic # disable building mythmusic plugin
12%bcond_without mythnews # disable building mythgallery plugin
e0e19850 13%bcond_with mythphone # discontnued ??
b9965e1c 14%bcond_without mythvideo # disable building mythgallery plugin
b4f23dbd 15%bcond_with mythweather # building mythgallery plugin disabled by default
16 # it looks unusable "due to msnbc webpage structure change
b9965e1c 17%bcond_without mythweb # disable building mythgallery plugin
e0e19850 18%bcond_without mythzoneminder # disable building mythzoneminder plugin
19
b9965e1c 20%if !%{with binary}
21%undefine with_mytharchive
22%undefine with_mythbrowser
e0e19850 23%undefine with_mythmovies
24%undefine with_mythdvd
b9965e1c 25%undefine with_mythflix
26%undefine with_mythgallery
27%undefine with_mythgame
28%undefine with_mythmusic
29%undefine with_mythnews
30%undefine with_mythphone
31%undefine with_mythvideo
32%undefine with_mythweather
b9965e1c 33%endif
34
35%include /usr/lib/rpm/macros.perl
36
5235d1d7 37%define snap 20090322
b9965e1c 38#define _rev 11046
e0e19850 39#%define rel 0.1
b9965e1c 40Summary: Main MythTV plugins
41Summary(pl.UTF-8): Główne wtyczki MythTV
42Name: mythplugins
e0e19850 43Version: 0.22
44Release: 0.%{snap}.1
b9965e1c 45License: GPL v2
46Group: Applications/Multimedia
e0e19850 47Source0: %{name}-%{version}-%{snap}.tar.bz2
5235d1d7 48# Source0-md5: 3d3927c4fef380bfabdeb19e520a7aa7
b9965e1c 49Source1: mythweb.conf
5235d1d7 50#Patch0: %{name}-lib64.patch
51#Patch1: %{name}-paths.patch
e0e19850 52Patch2: mythweb-config.patch
5235d1d7 53Patch3: %{name}-qt45-workaround.patch
40ceccaf 54Patch20: %{name}-mytharchive-INT64.patch
e0e19850 55Patch100: mythtv-branch.diff
b9965e1c 56URL: http://www.mythtv.org/
57%if %{with binary}
58%if %{with mythgallery} || %{with myhtmusic}
59BuildRequires: OpenGL-devel
60%endif
cf2b1c27
SP
61BuildRequires: Qt3Support-devel
62BuildRequires: QtCore-devel
63BuildRequires: QtGui-devel
64BuildRequires: QtNetwork-devel
65BuildRequires: QtOpenGL-devel
66BuildRequires: QtSql-devel
67BuildRequires: QtWebKit-devel
68BuildRequires: QtXml-devel
b9965e1c 69BuildRequires: SDL-devel
70BuildRequires: a52dec-libs-devel
71BuildRequires: cdparanoia-III-devel
72BuildRequires: faad2-devel >= 2.0-5.2
73%{?with_mythmusic:BuildRequires: fftw-devel >= 2.1.3}
74BuildRequires: flac-devel >= 1.0.4
75BuildRequires: freetype-devel
b9965e1c 76BuildRequires: libcdaudio-devel >= 0.99.12p2
77BuildRequires: libdvdcss-devel >= 1.2.7
78BuildRequires: libdvdread-devel >= 0.9.4
79%{?with_mythgallery:BuildRequires: libexif-devel >= 1:0.6.9}
80BuildRequires: libfame-devel >= 0.9.0
81BuildRequires: libid3tag-devel
82BuildRequires: libmad-devel
e0e19850 83BuildRequires: libmyth-devel >= 0.19
b9965e1c 84BuildRequires: libstdc++-devel
85BuildRequires: libtiff-devel
86BuildRequires: libvorbis-devel >= 1:1.0
87BuildRequires: mjpegtools-devel >= 1.6.1
88BuildRequires: nasm
89BuildRequires: patchutils
cf2b1c27
SP
90BuildRequires: qt4-build
91BuildRequires: qt4-qmake
b9965e1c 92BuildRequires: rpm-perlprov >= 4.1-13
93BuildRequires: sed >= 4.0
cf2b1c27 94%{?with_mythmusic:BuildRequires: taglib-devel}
e0e19850 95%{?with_mythdvd:BuildRequires: transcode >= 0.6.8}
cf2b1c27 96BuildRequires: xorg-lib-libX11-devel
b9965e1c 97BuildRequires: xvid-devel >= 1:0.9.1
98BuildRequires: zlib-devel
b9965e1c 99%endif
100%{?with_mytharchive:Requires: mytharchive}
101%{?with_mythbrowser:Requires: mythbrowser}
e0e19850 102%{?with_mythdvd:Requires: mythdvd}
b9965e1c 103%{?with_mythflix:Requires: mythflix}
104%{?with_mythgallery:Requires: mythgallery}
105%{?with_mythgame:Requires: mythgame}
106%{?with_mythmysic:Requires: mythmusic}
107%{?with_mythnews:Requires: mythnews}
108%{?with_mythphone:Requires: mythphone}
109%{?with_mythvideo:Requires: mythvideo}
110%{?with_mythweather:Requires: mythweather}
111%{?with_mythweb:Requires: mythweb}
b9965e1c 112ExclusiveArch: %{ix86} %{x8664} ppc
113BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
115%define myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
116%define _webapps /etc/webapps
117%define _webapp mythweb
118
119%description
120This is a consolidation of all the official MythTV plugins that used
121to be distributed as separate downloads from mythtv.org.
122
123%description -l pl.UTF-8
124Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
125wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
126
127%package -n mytharchive
128Summary: A MythTV module to create and burn DVDs
129Summary(pl.UTF-8): Moduł MythTV do tworzenia i wypalania DVD
130Group: Applications/Multimedia
cf2b1c27
SP
131Requires: dvdauthor
132Requires: mjpegtools
b9965e1c 133Requires: mythtv-frontend-api = %{myth_api_version}
e0e19850 134Requires: python-MySQLdb
cf2b1c27 135Requires: python-PIL
e0e19850 136Suggests: dvdrtools-mkisofs
b9965e1c 137
138%description -n mytharchive
139MythArchive is a MythTV style plugin that uses the Mythburn Script to
140create and burn DVDs from MythTV recordings, MythVideo files or any
141video files available on a MythTV system. It can also export
142recordings to a native archive format that can then be imported back
143into a MythTV system restoring all the associated metadata.
144
145%description -n mytharchive -l pl.UTF-8
146MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
147i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
148innych plików z filmami dostępnych w systemie MythTV. Może także
149eksportować nagrania do natywnego formatu archiwum, który potem można
150zaimportować z powrotem do systemu MythTV przywracając wszystkie
151związane z nimi metadane.
152
153%package -n mythmusic
154Summary: The music player add-on module for MythTV
155Summary(pl.UTF-8): Moduł odtwarzacza muzyki dla MythTV
156Group: Applications/Multimedia
157Requires: mythtv-frontend-api = %{myth_api_version}
158
159%description -n mythmusic
160Music add-on for MythTV.
161
162%description -n mythmusic -l pl.UTF-8
163Odtwarzacz muzyki dla MythTV.
164
165%package -n mythvideo
166Summary: A generic video player frontend module for MythTV
167Summary(pl.UTF-8): Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
168Group: Applications/Multimedia
169Requires: mplayer
170Requires: mythtv-frontend-api = %{myth_api_version}
171
172%description -n mythvideo
e0e19850 173A generic video and dvd player frontend module for MythTV.
b9965e1c 174
175%description -n mythvideo -l pl.UTF-8
176Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
177
178%package -n mythweather
179Summary: A MythTV module that displays a weather forcast
180Summary(pl.UTF-8): Moduł MythTV wyświetlający prognozę pogody
181Group: Applications/Multimedia
182Requires: mythtv-frontend-api = %{myth_api_version}
183
184%description -n mythweather
185A MythTV module that displays a weather forcast.
186
187%description -n mythweather -l pl.UTF-8
188Moduł MythTV wyświetlający prognozę pogody.
189
190%package -n mythgallery
191Summary: A gallery/slideshow module for MythTV
192Summary(pl.UTF-8): Moduł galerii/pokazu slajdów dla MythTV
193Group: Applications/Multimedia
194Requires: mythtv-frontend-api = %{myth_api_version}
195
196%description -n mythgallery
197A gallery/slideshow module for MythTV.
198
199%description -n mythgallery -l pl.UTF-8
200Moduł galerii/pokazu slajdów dla MythTV.
201
202%package -n mythgame
203Summary: A game frontend (xmame, nes, snes, pc) for MythTV
204Summary(pl.UTF-8): Interfejs do gier (xmame, nes, snes, pc) dla MythTV
205Group: Applications/Multimedia
206Requires: mythtv-frontend-api = %{myth_api_version}
207
208%description -n mythgame
209A game frontend (xmame, nes, snes, pc) for MythTV.
210
211%description -n mythgame -l pl.UTF-8
212Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
213
e0e19850 214%package -n mythdvd
215Summary: A DVD ripper module for MythTV
216Summary(pl.UTF-8): Moduł rippujący DVD dla MythTV
217Group: Applications/Multimedia
218Requires: mythtv-frontend-api = %{myth_api_version}
e0e19850 219Requires: mythvideo
cf2b1c27 220Requires: transcode >= 0.6.8
e0e19850 221
222%description -n mythdvd
cf2b1c27
SP
223MythDVD is a MythTV module that allows you to rip DVD's and transcode
224their video and audio content to other (generally smaller) formats.
225The playing features are simply myth-style wrappers for your favourite
226DVD playing software (mplayer, ogle, xine, etc). The transcoding is
227based on and derived from the excellent transcode package.
e0e19850 228
229%description -n mythdvd -l pl.UTF-8
cf2b1c27
SP
230MythDVD to moduł MythTV umożliwiający rippowanie DVD oraz
231przekodowywanie obrazu i dźwięku do innych (zwykle mniej zajmujących)
232formatów. Możliwości odtwarzania to po prostu obudowanie w stylu myth
233dla ulubionego oprogramowania do odtwarzania DVD (mplayer, ogle, xine
234itp.). Przekodowywanie jest oparte i wywodzi się ze wspaniałego
e0e19850 235pakietu transcode.
236
b9965e1c 237%package -n mythnews
238Summary: A RSS News Feed plugin for MythTV
239Summary(pl.UTF-8): Wtyczka czytnika nowinek RSS dla MythTV
240Group: Applications/Multimedia
241Requires: mythtv-frontend-api = %{myth_api_version}
242
243%description -n mythnews
244A RSS News Feed plugin for MythTV.
245
246%description -n mythnews -l pl.UTF-8
247Wtyczka czytnika nowinek RSS dla MythTV.
248
249%package -n mythbrowser
250Summary: A small web browser module for MythTV
251Summary(pl.UTF-8): Moduł małej przeglądarki WWW dla MythTV
252Group: Applications/Multimedia
253Requires: mythtv-frontend-api = %{myth_api_version}
254
255%description -n mythbrowser
256MythBrowser is a full fledged web-browser (multiple tabs) to display
257webpages in full-screen mode. Simple page navigation is possible.
258Starting with version 0.13 it also has full support for mouse driven
259navigation (right mouse opens and closes the popup menu).
260
261MythBrowser also contains a BookmarkManager to manage the website
262links in a simple mythplugin.
263
264%description -n mythbrowser -l pl.UTF-8
265MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
266zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
267jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
268obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
269menu).
270
271MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
272do stron w prostej wtyczce myth.
273
274%package -n mythphone
275Summary: A video conferencing module for MythTV
276Summary(pl.UTF-8): Moduł wideokonferencji dla MythTV
277Group: Applications/Multimedia
278Requires: mythtv-frontend-api = %{myth_api_version}
279
280%description -n mythphone
281Mythphone is a phone and videophone capability on Myth using the
282standard SIP protocol. It is compatible with Microsoft XP Messenger
283and with SIP Service Providers such as Free World Dialup
284(fwd.pulver.com).
285
286%description -n mythphone -l pl.UTF-8
287Mythphone to funkcjonalność telefonu i wideofonu w Myth przy użyciu
288standardowego protokołu SIP. Jest kompatybilny z Microsoft XP
289Messengerem oraz dostawcami usług SIP, takimi jak Free World Dialup
290(fwd.pulver.com).
291
292%package -n mythweb
293Summary: The web interface to MythTV
294Summary(pl.UTF-8): Interfejs WWW do MythTV
295Group: Applications/Multimedia
b9965e1c 296Requires: php(mysql)
297Requires: php(posix)
cf2b1c27 298Requires: webapps
b9965e1c 299Requires: webserver(php) >= 4.3
cf2b1c27
SP
300#Suggests: apache(mod_auth)
301#Suggests: apache(mod_env)
b9965e1c 302
303%description -n mythweb
304The web interface to MythTV.
305
306%description -n mythweb -l pl.UTF-8
307Interfejs WWW do MythTV.
308
309%package -n mythflix
310Summary: MythFlix (A NetFlix MythTV)
311Summary(pl.UTF-8): MythFlix (NetFlix MythTV)
312Group: Applications/Multimedia
313Requires: mythtv-frontend-api = %{myth_api_version}
314
315%description -n mythflix
316MythFlix is a MythTV plugin for adding movies to your Netflix queue.
317It currently supports the ability to view your queue and add movies to
318your queue. The browse feature is based on the Netflix RSS feeds. This
319plugin is not very mature, which means things might not work right
320and/or it might break other things.
321
322%description -n mythflix -l pl.UTF-8
323MythFlix to wtyczka MythTV do dodawania filmów do kolejki Netfliksa.
324Aktualnie daje możliwość oglądania kolejki i dodawania do niej filmów.
325Przeglądanie jest oparte na kanale RSS Netfliksa. Ta wtyczka nie jest
326jeszcze zbyt dojrzała, co znaczy, że coś może nie działać lub psuć coś
327innego.
328
b9965e1c 329%package -n mythmovies
e0e19850 330Summary: MythTV cinemas timetable
331Summary(pl.UTF-8): Moduł MythTV do repertuaru kinowego
b9965e1c 332Group: Applications/Multimedia
333Requires: mythtv-frontend-api = %{myth_api_version}
334
335%description -n mythmovies
e0e19850 336MythTV cinemas timetable.
337
338
339%description -n mythmovies -l pl.UTF-8
340Moduł MythTV do repertuaru kinowego.
b9965e1c 341
342%package -n mythzoneminder
cf2b1c27
SP
343Summary: MythTV security TV manager
344Summary(pl.UTF-8): Obsługa kamer przemysłowych dla MythTV
345Group: Applications/Multimedia
cf2b1c27 346Requires: mythtv-frontend-api = %{myth_api_version}
b9965e1c 347
348%description -n mythzoneminder
e0e19850 349MythTV security TV manager.
350
b9965e1c 351
e0e19850 352%description -n mythzoneminder -l pl.UTF-8
353Obsługa kamer przemysłowych dla MythTV.
b9965e1c 354
355%prep
e0e19850 356#%setup -q %{?_snap:-n %{name}}
357%setup -q %{SOURCE0}
358#%if %{_lib} != "lib"
359#%patch0 -p1
360#%endif
361#%patch1 -p1
362#%patch2 -p1
5235d1d7 363%patch3 -p1
e0e19850 364%patch20 -p1
b9965e1c 365#filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
366
367# make it visible
e0e19850 368#mv mythweb/data/{.,}htaccess
b9965e1c 369
370# lib64 fix - enable to update patch
371%if %{_lib} != "lib" && 0
372find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
373xargs grep -l /lib/ . | xargs sed -i -e '
e0e19850 374 s,/usr/lib/,/%{_lib}/,g
b9965e1c 375 s,{PREFIX}/lib,{PREFIX}/%{_lib},g
376'
377exit 1
378%endif
379
380%build
381%if %{with binary}
382export QTDIR="%{_prefix}"
383# Not gnu configure
384%configure \
e0e19850 385 --libdir-name=`basename %{_lib}` \
b9965e1c 386 --enable-all \
387 %{!?with_mytharchive:--disable-mytharchive} \
388 %{!?with_mythbrowser:--disable-mythbrowser} \
e0e19850 389 %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
b9965e1c 390 %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
391 %{!?with_mythgame:--disable-mythgame} \
392 %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
393 %{!?with_mythnews:--disable-mythnews} \
394 %{!?with_mythphone:--disable-mythphone}%{?with_mythphone:--disable-festival} \
395 %{!?with_mythvideo:--disable-mythvideo} \
396 %{!?with_mythweather:--disable-mythweather} \
397 %{!?with_mythweb:--disable-mythweb} \
e0e19850 398 %{!?with_mythmovies:--disable-mythmovies} \
b9965e1c 399 %{!?with_mythflix:--disable-mythflix} \
400
401mv mythconfig.mak mythconfig.mak.old
402cp mythconfig.mak.old mythconfig.mak
403cat <<'EOF'>> mythconfig.mak
404QMAKE_CXX=%{__cxx}
405QMAKE_CC=%{__cc}
406OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
407ECFLAGS=%{rpmcflags} -fomit-frame-pointer
408ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
409EOF
410
411%{__make}
412%endif
413
414%install
415rm -rf $RPM_BUILD_ROOT
416
417%if %{with binary}
418export QTDIR="%{_prefix}"
419%{__make} install \
420 INSTALL_ROOT=$RPM_BUILD_ROOT
421
e0e19850 422install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
b9965e1c 423%if %{with mythgame}
424install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
425install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
426install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
427install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
428cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
429%endif
430%endif
431
432%if %{with mythweb}
433cd mythweb
434install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
435install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
436install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
e0e19850 437cp -a *.php *.pl data includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
b9965e1c 438install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
439install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
440touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
441cd -
442%endif
443
444mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
445rm $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythflix_nb.ts # i18n source
e0e19850 446for p in mytharchive mythbrowser mythmovies mythdvd mythflix mythgallery mythgame mythmusic mythnews mythphone mythvideo mythweather mythzoneminder; do
b9965e1c 447 for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
e0e19850 448 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
b9965e1c 449 done > $p.lang
450done
451
452%clean
453rm -rf $RPM_BUILD_ROOT
454
455%triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
456%webapp_register apache %{_webapp}
457
458%triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
459%webapp_unregister apache %{_webapp}
460
461%triggerin -n mythweb -- apache < 2.2.0, apache-base
462%webapp_register httpd %{_webapp}
463
464%triggerun -n mythweb -- apache < 2.2.0, apache-base
465%webapp_unregister httpd %{_webapp}
466
467%triggerpostun -n mythweb -- mythweb < 0.19
468for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
469 if [ -f /etc/mythweb/$i.rpmsave ]; then
470 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
471 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
472 fi
473done
474sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
475
476# migrate from apache-config macros
477if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
478 if [ -d /etc/apache/webapps.d ]; then
479 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
480 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
481 fi
482
483 if [ -d /etc/httpd/webapps.d ]; then
484 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
485 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
486 fi
487 rm -f /etc/mythweb/apache.conf.rpmsave
488fi
489
490if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
491 rm -f /etc/apache/conf.d/99_mythplugins.conf
492 /usr/sbin/webapp register apache %{_webapp}
493 %service -q apache reload
494fi
495if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
496 rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
497 /usr/sbin/webapp register httpd %{_webapp}
498 %service -q httpd reload
499fi
500
501%files
502%defattr(644,root,root,755)
503
504%if %{with mytharchive}
505%files -n mytharchive -f mytharchive.lang
506%defattr(644,root,root,755)
507%attr(755,root,root) %{_bindir}/mytharchivehelper
508%attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
b9965e1c 509%{_datadir}/mythtv/archivemenu.xml
e0e19850 510%{_datadir}/mythtv/archiveutils.xml
b9965e1c 511%{_datadir}/mythtv/themes/default/ma_*.png
512%{_datadir}/mythtv/themes/default/mytharchive-ui.xml
513%{_datadir}/mythtv/themes/default/mythburn-ui.xml
514%{_datadir}/mythtv/themes/default/mythnative-ui.xml
e0e19850 515%{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
516%{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
517%{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
b9965e1c 518%{_datadir}/mythtv/mytharchive
519%endif
520
521%if %{with mythmusic}
522%files -n mythmusic -f mythmusic.lang
523%defattr(644,root,root,755)
524%doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
525%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
526/var/lib/mythmusic
527%{_datadir}/mythtv/musicmenu.xml
528%{_datadir}/mythtv/music_settings.xml
529%{_datadir}/mythtv/themes/default/music-ui.xml
e0e19850 530%{_datadir}/mythtv/themes/default-wide/music-ui.xml
b9965e1c 531%{_datadir}/mythtv/themes/default/ff_button_off.png
532%{_datadir}/mythtv/themes/default/ff_button_on.png
533%{_datadir}/mythtv/themes/default/ff_button_pushed.png
e0e19850 534%{_datadir}/mythtv/themes/default/miniplayer_background.png
b9965e1c 535%{_datadir}/mythtv/themes/default/mm_*.png
536%{_datadir}/mythtv/themes/default/music-sel-bg.png
537%{_datadir}/mythtv/themes/default/next_button_off.png
538%{_datadir}/mythtv/themes/default/next_button_on.png
539%{_datadir}/mythtv/themes/default/next_button_pushed.png
540%{_datadir}/mythtv/themes/default/pause_button_off.png
541%{_datadir}/mythtv/themes/default/pause_button_on.png
542%{_datadir}/mythtv/themes/default/pause_button_pushed.png
543%{_datadir}/mythtv/themes/default/play_button_off.png
544%{_datadir}/mythtv/themes/default/play_button_on.png
545%{_datadir}/mythtv/themes/default/play_button_pushed.png
546%{_datadir}/mythtv/themes/default/prev_button_off.png
547%{_datadir}/mythtv/themes/default/prev_button_on.png
548%{_datadir}/mythtv/themes/default/prev_button_pushed.png
549%{_datadir}/mythtv/themes/default/rew_button_off.png
550%{_datadir}/mythtv/themes/default/rew_button_on.png
551%{_datadir}/mythtv/themes/default/rew_button_pushed.png
552%{_datadir}/mythtv/themes/default/selectionbar.png
553%{_datadir}/mythtv/themes/default/stop_button_off.png
554%{_datadir}/mythtv/themes/default/stop_button_on.png
555%{_datadir}/mythtv/themes/default/stop_button_pushed.png
556%{_datadir}/mythtv/themes/default/track_info_background.png
e0e19850 557%{_datadir}/mythtv/themes/default-wide/mm_*.png
558%{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
b9965e1c 559%endif
560
561%if %{with mythvideo}
562%files -n mythvideo -f mythvideo.lang
563%defattr(644,root,root,755)
564%doc mythvideo/README mythvideo/videodb
b9965e1c 565%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
b9965e1c 566%{_datadir}/mythtv/themes/default/video-ui.xml
b9965e1c 567%{_datadir}/mythtv/themes/default-wide/video-ui.xml
e0e19850 568%{_datadir}/mythtv/themes/default/mv_*.png
b9965e1c 569%{_datadir}/mythtv/themes/default-wide/mv_*.png
570%{_datadir}/mythtv/video_settings.xml
571%{_datadir}/mythtv/videomenu.xml
572%dir %{_datadir}/mythtv/mythvideo
573%dir %{_datadir}/mythtv/mythvideo/scripts
574%{_datadir}/mythtv/mythvideo/scripts/README
575%attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.pl
576%attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
e0e19850 577%dir %{_datadir}/mythtv/mythvideo/scripts/MythTV
578%attr(644,root,root)%{_datadir}/mythtv/mythvideo/scripts/MythTV/MythVideoCommon.pm
b9965e1c 579/var/lib/mythvideo
580%endif
581
582%if %{with mythweather}
583%files -n mythweather -f mythweather.lang
584%defattr(644,root,root,755)
585%doc mythweather/README
586%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
e0e19850 587%{_datadir}/mythtv/mythweather
588%{_datadir}/mythtv/weather_settings.xml
b9965e1c 589%{_datadir}/mythtv/themes/default/weather-ui.xml
e0e19850 590%{_datadir}/mythtv/themes/default-wide/weather-ui.xml
b9965e1c 591%{_datadir}/mythtv/themes/default/cloudy.png
592%{_datadir}/mythtv/themes/default/fair.png
593%{_datadir}/mythtv/themes/default/flurries.png
594%{_datadir}/mythtv/themes/default/fog.png
595%{_datadir}/mythtv/themes/default/logo.png
596%{_datadir}/mythtv/themes/default/lshowers.png
597%{_datadir}/mythtv/themes/default/mcloudy.png
598%{_datadir}/mythtv/themes/default/mw_*.png
599%{_datadir}/mythtv/themes/default/mwmain.png
600%{_datadir}/mythtv/themes/default/pcloudy.png
601%{_datadir}/mythtv/themes/default/rainsnow.png
602%{_datadir}/mythtv/themes/default/showers.png
603%{_datadir}/mythtv/themes/default/snowshow.png
604%{_datadir}/mythtv/themes/default/sunny.png
605%{_datadir}/mythtv/themes/default/thunshowers.png
606%{_datadir}/mythtv/themes/default/unknown.png
b9965e1c 607%{_datadir}/mythtv/themes/default-wide/mw-*.png
b9965e1c 608%endif
609
610%if %{with mythgallery}
611%files -n mythgallery -f mythgallery.lang
612%defattr(644,root,root,755)
613%doc mythgallery/README
614%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
615%{_datadir}/mythtv/themes/default/gallery-ui.xml
e0e19850 616%{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
b9965e1c 617%{_datadir}/mythtv/themes/default/gallery-*.png
618# FIXME: this is definately stupid path
619/var/lib/pictures
620%endif
621
622%if %{with mythgame}
623%files -n mythgame -f mythgame.lang
624%defattr(644,root,root,755)
e0e19850 625#%doc mythgame/README
b9965e1c 626%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
627%{_datadir}/mythtv/games
628%{_datadir}/mythtv/game_settings.xml
629%{_datadir}/mythtv/themes/default/game-ui.xml
e0e19850 630%{_datadir}/mythtv/themes/default-wide/game-ui.xml
631%endif
632
633%if %{with mythdvd}
634%files -n mythdvd
635%defattr(644,root,root,755)
636%attr(755,root,root) %{_bindir}/mtd
637%{_datadir}/mythtv/themes/default/dvd-ui.xml
638%{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
639%{_datadir}/mythtv/themes/default/md_*.png
b9965e1c 640%endif
641
642%if %{with mythnews}
643%files -n mythnews -f mythnews.lang
644%defattr(644,root,root,755)
645%doc mythnews/README mythnews/AUTHORS
646%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
647%{_datadir}/mythtv/mythnews
648%{_datadir}/mythtv/themes/default/news-ui.xml
b9965e1c 649# DUPLICATE WITH MYTHFLIX?
650%{_datadir}/mythtv/themes/default/news-info-bg.png
e0e19850 651%{_datadir}/mythtv/themes/default/enclosures.png
652%{_datadir}/mythtv/themes/default/need-download.png
653%{_datadir}/mythtv/themes/default/podcast.png
654%{_datadir}/mythtv/themes/default-wide/news-ui.xml
b9965e1c 655%endif
656
657%if %{with mythbrowser}
658%files -n mythbrowser -f mythbrowser.lang
659%defattr(644,root,root,755)
660%doc mythbrowser/README mythbrowser/AUTHORS
661%attr(755,root,root) %{_bindir}/mythbrowser
662%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
e0e19850 663%{_datadir}/mythtv/themes/default/mb_progress*.png
664%{_datadir}/mythtv/themes/default/browser-ui.xml
665%{_datadir}/mythtv/themes/default-wide/browser-ui.xml
b9965e1c 666%endif
667
668%if %{with mythphone}
669%files -n mythphone -f mythphone.lang
670%defattr(644,root,root,755)
671%doc mythphone/README mythphone/AUTHORS mythphone/TODO
672%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
673%{_datadir}/mythtv/themes/default/phone-ui.xml
674%{_datadir}/mythtv/themes/default/webcam-ui.xml
675%{_datadir}/mythtv/themes/default/mp_*.png
676%{_datadir}/mythtv/themes/default/phone.png
677%endif
678
679%if %{with mythweb}
680%files -n mythweb
681%defattr(644,root,root,755)
e0e19850 682%doc mythweb/README
683#%doc mythweb/data/htaccess
b9965e1c 684%dir %attr(750,root,http) %{_webapps}/%{_webapp}
685%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
686%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
687#%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
688#%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
689%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
690%{_datadir}/mythweb
691%dir %attr(771,root,http) /var/cache/mythweb
692%dir %attr(771,root,http) /var/cache/mythweb/image_cache
693%dir %attr(771,root,http) /var/cache/mythweb/php_sessions
694%dir %attr(771,root,http) /var/cache/mythweb/tv_icons
695%endif
696
697%if %{with mythflix}
698%files -n mythflix -f mythflix.lang
699%defattr(644,root,root,755)
700%doc mythflix/{AUTHORS,ChangeLog,README}
701%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythflix.so
702%dir %{_datadir}/mythtv/mythflix
703%{_datadir}/mythtv/mythflix/netflix-rss.xml
704%dir %{_datadir}/mythtv/mythflix/scripts
705%attr(755,root,root) %{_datadir}/mythtv/mythflix/scripts/netflix.pl
706%{_datadir}/mythtv/netflix_menu.xml
707%{_datadir}/mythtv/themes/default/title_netflix.png
e0e19850 708%{_datadir}/mythtv/themes/default/mythflix_background.png
b9965e1c 709%{_datadir}/mythtv/themes/default/netflix-ui.xml
e0e19850 710%{_datadir}/mythtv/themes/default-wide/netflix-ui.xml
711%{_datadir}/mythtv/themes/default-wide/netflix-bg.png
b9965e1c 712# DUPLICATE WITH MYTHNEWS?
713%{_datadir}/mythtv/themes/default/news-info-bg.png
714%endif
715
b9965e1c 716%if %{with mythmovies}
e0e19850 717%files -n mythmovies
cf2b1c27 718%defattr(644,root,root,755)
e0e19850 719#-f mythmovies.lang
b9965e1c 720%defattr(644,root,root,755)
721%doc mythmovies/{README,TODO}
722%attr(755,root,root) %{_bindir}/ignyte
723%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
724%{_datadir}/mythtv/themes/default/movies-ui.xml
725%{_datadir}/mythtv/themes/default-wide/movies-ui.xml
726%endif
727
728%if %{with mythzoneminder}
e0e19850 729%files -n mythzoneminder
cf2b1c27 730%defattr(644,root,root,755)
e0e19850 731#-f mythmovies.lang
b9965e1c 732%defattr(644,root,root,755)
e0e19850 733%doc mythzoneminder/{AUTHORS,README}
b9965e1c 734%attr(755,root,root) %{_bindir}/mythzmserver
735%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
e0e19850 736%dir %{_datadir}/mythtv/zonemindermenu.xml
b9965e1c 737%{_datadir}/mythtv/themes/default/zoneminder-ui.xml
738%{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
e0e19850 739%{_datadir}/mythtv/themes/default/mz_*png
b9965e1c 740%endif
This page took 0.152193 seconds and 4 git commands to generate.