]> git.pld-linux.org Git - packages/mplayer2.git/blame - mplayer2.spec
- add BR: libvpx and update BR: libx264
[packages/mplayer2.git] / mplayer2.spec
CommitLineData
26692d73 1#
e24f026c
BZ
2%bcond_with directfb # with DirectFB video output
3%bcond_with dxr3 # enable use of DXR3/H+ hardware MPEG decoder
4%bcond_with ggi # with ggi video output
5%bcond_with nas # with NAS audio output
6%bcond_with svga # with svgalib video output
7%bcond_without osd # with osd menu support
8%bcond_without altivec # without altivec support
9%bcond_without x264 # without x264 support
10%bcond_with xmms # with XMMS inputplugin support
11%bcond_without aalib # without aalib video output
12%bcond_without jack # without JACKD support
13%bcond_without alsa # without ALSA audio output
14%bcond_with arts # with arts audio output
15%bcond_without caca # without libcaca video output
16%bcond_without cdparanoia # without cdparanoia support
17%bcond_without dvdnav # without dvdnav support
18%bcond_without enca # disable using ENCA charset oracle library
19%bcond_with esd # enable EsounD sound support
20%bcond_without faad # disable FAAD2 (AAC) support
21%bcond_without gif # disable GIF support
22%bcond_without gui # without GTK+ GUI
23%bcond_without joystick # disable joystick support
24%bcond_without libdts # disable libdts support
25%bcond_without libdv # disable libdv en/decoding support
26%bcond_without lirc # without lirc support
27%bcond_without live # without LIVE555 libraries
28%bcond_without lzo # with LZO support (requires lzo 2.x)
29%bcond_without mad # without mad (audio MPEG) support
30%bcond_without pulseaudio # without pulseaudio output
31%bcond_without quicktime # without binary quicktime dll support
32%bcond_without real # without Real* 8/9 codecs support
33%bcond_without runtime # disable runtime cpu detection, just detect CPU
34 # in compile time (advertised by mplayer authors as working faster); in this case
35 # mplayer may not work on machine other then where it was compiled
36%bcond_without select # disable audio select() support (for example required this option ALSA or Vortex2 driver)
37%bcond_without smb # disable Samba (SMB) input support
38%bcond_without theora # without theora support
39%bcond_without win32 # without win32 codecs support
40%bcond_without vdpau # disable vdpau
41%bcond_without vidix # disable vidix
42%bcond_without vorbis # without Ogg-Vorbis audio support
43%bcond_with system_vorbis # use system libvorbis instead of internal tremor
44%bcond_without xvid # disable XviD codec
45%bcond_without mencoder # disable mencoder (a/v encoder) compilation
46%bcond_without sdl # disable SDL
47%bcond_without doc # don't build docs (slow)
e24f026c
BZ
48%bcond_without amr # enable Adaptive Multi Rate (AMR) speech codec support
49%bcond_without gnomess # disable controling gnome screensaver
50%bcond_without ssse3 # sse3 optimizations (needs binutils >= 2.16.92)
51%bcond_with system_ffmpeg # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
52%bcond_with on2 # with patches from On2 Flix Engine for Linux
53
75937e72
BZ
54%bcond_with nonfree # non free options of package
55%bcond_without va # VAAPI (Video Acceleration API)
56%bcond_without vpx # VP8, a high-quality video codec
26692d73
BZ
57
58%if %{_lib} == "lib64"
59%define _suf 64
60%else
61%define _suf 32
62%endif
63
64%define subver rc2
65%define rel 1
66Summary: MPlayer - THE Movie Player for UN*X
67Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
68Summary(es.UTF-8): Otro reproductor de películas
69Summary(ko.UTF-8): 리눅스용 미디어플레이어
70Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
71Summary(pt_BR.UTF-8): Reprodutor de filmes
72Name: mplayer2
73Version: 2.0
74Release: 0.%{subver}.%{rel}
75License: GPL
76Group: Applications/Multimedia
77Source0: http://ftp.mplayer2.org/pub/release/%{name}-build-%{version}-%{subver}.tar.xz
78# Source0-md5: 92793d629181e059384c43972fa9a701
79URL: http://www.mplayer2.org/
80BuildRequires: OpenAL-devel
81BuildRequires: OpenGL-devel
82%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
83%{?with_aalib:BuildRequires: aalib-devel}
84%{?with_alsa:BuildRequires: alsa-lib-devel}
85%{?with_arts:BuildRequires: artsc-devel}
86%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
87%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
88BuildRequires: dirac-devel
89%{?with_doc:BuildRequires: docbook-dtd412-xml}
90%{?with_doc:BuildRequires: docbook-style-xsl}
91%{?with_dxr3:BuildRequires: em8300-devel}
92%{?with_enca:BuildRequires: enca-devel}
93%{?with_esd:BuildRequires: esound-devel}
94BuildRequires: faac-devel
95%{?with_faad:BuildRequires: faad2-devel >= 2.0}
96%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 0.4.9-4.20081024.3}
97BuildRequires: freetype-devel >= 2.0.9
98BuildRequires: fribidi-devel
99BuildRequires: tar >= 1:1.22
100%{?with_vidix:BuildRequires: vidix-devel}
101%{?with_altivec:BuildRequires: gcc >= 5:4.1}
102%{?with_gnomess:BuildRequires: dbus-glib-devel}
103%{?with_gif:BuildRequires: giflib-devel}
104%{?with_gui:BuildRequires: gtk+2-devel}
105%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
106%{?with_jack:%requires_eq jack-audio-connection-kit-libs}
107BuildRequires: lame-libs-devel
108%{?with_caca:BuildRequires: libcaca-devel}
109%{?with_libdts:BuildRequires: libdts-devel}
110%{?with_libdv:BuildRequires: libdv-devel > 0.9.5}
111%{?with_dvdnav:BuildRequires: libdvdnav-devel >= 4.1.3}
112%{?with_ggi:BuildRequires: libggi-devel}
113BuildRequires: libjpeg-devel
114%{?with_mad:BuildRequires: libmad-devel}
115BuildRequires: libmng-devel
116BuildRequires: libmpcdec-devel >= 1.2.1
117BuildRequires: libpng-devel
118%{?with_smb:BuildRequires: libsmbclient-devel}
119%{?with_theora:BuildRequires: libtheora-devel}
120%{?with_vdpau:BuildRequires: libvdpau-devel}
1cabc2ac 121%{?with_vpx:BuildRequires: libvpx-devel >= 0.9.1}
26692d73 122%{?with_system_vorbis:BuildRequires: libvorbis-devel}
1cabc2ac 123%{?with_x264:BuildRequires: libx264-devel >= 0.1.3-1.20110327}
26692d73
BZ
124BuildRequires: libxslt-progs
125%{?with_lirc:BuildRequires: lirc-devel}
126%{?with_live:BuildRequires: live-devel}
127%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
128%{?with_nas:BuildRequires: nas-devel}
129BuildRequires: ncurses-devel
130%{?with_amr:BuildRequires: opencore-amr-devel}
131BuildRequires: pkgconfig
132%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
133BuildRequires: rpm >= 4.4.9-56
134BuildRequires: rpmbuild(macros) >= 1.527
135BuildRequires: schroedinger-devel
136BuildRequires: speex-devel >= 1.1
137%{?with_svga:BuildRequires: svgalib-devel}
138BuildRequires: twolame-devel
139%{?with_xmms:BuildRequires: xmms-devel}
140%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
141%ifarch %{ix86} %{x8664}
142BuildRequires: yasm
143%endif
144BuildRequires: zlib-devel
145BuildRequires: xorg-lib-libX11-devel
146BuildRequires: xorg-lib-libXScrnSaver-devel
147BuildRequires: xorg-lib-libXext-devel
148BuildRequires: xorg-lib-libXinerama-devel
149BuildRequires: xorg-lib-libXv-devel
150BuildRequires: xorg-lib-libXvMC-devel
151BuildRequires: xorg-lib-libXxf86dga-devel
152BuildRequires: xorg-lib-libXxf86vm-devel
26692d73
BZ
153Requires: OpenGL
154BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
155
156%define _noautoreqdep libGL.so.1 libGLU.so.1
157%define specflags_ia32 -fomit-frame-pointer
158%if %{with altivec}
159%define specflags_ppc -maltivec
160%endif
161
162%description
163Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
164AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
165MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
166MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
167devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
168optionally with SHM extension, X11 using overlays with the Xvideo
169extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
170Voodoo2/3 hardware, SDL v1.1.7 driver etc.
171
172If you want to use win32 codecs install w32codec package.
173
174%description -l de.UTF-8
175MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
176Kennzeichnend ist die herausragende Format- und
177Plattform-Kompatibilität.
178
179Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
180plattformexklusive, wodurch etwa Windows Media auch außerhalb von
181Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
182Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
183ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
184Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
185installierte Codecs nicht mit MPlayer kollidieren können.
186
187%description -l es.UTF-8
188Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
189MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
190(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
191de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
192Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
193G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
194overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
195G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
196v1.1.7 etc.
197
198Si quiere usar codecs Win32, instale el paquete w32codec.
199
200%description -l ko.UTF-8
201MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
202파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
203MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
204Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
205(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
206수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
207크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
208있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
209부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
210
211%description -l pl.UTF-8
212Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
213RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
214(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
215Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
216Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
217rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
218G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
219
220Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
221
222%description -l pt_BR.UTF-8
223MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
224áudio. Diferentes mecanismos de reprodução podem também ser
225escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
226
227%prep
228%setup -q -n %{name}
229
75937e72
BZ
230# set ffmpeg options:
231echo " --arch=%{_target_base_arch}" >>ffmpeg_options
75937e72
BZ
232echo " --cc="%{__cc}"" >>ffmpeg_options
233echo " --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}"" >>ffmpeg_options
234echo " --extra-ldflags="%{rpmcflags} %{rpmldflags}"" >>ffmpeg_options
235echo " --disable-debug" >>ffmpeg_options
236echo " --disable-optimizations" >>ffmpeg_options
237echo " --disable-stripping" >>ffmpeg_options
238echo " --enable-avfilter" >>ffmpeg_options
239echo " --enable-gpl" >>ffmpeg_options
240echo " --enable-version3" >>ffmpeg_options
241echo " --enable-libdc1394" >>ffmpeg_options
242echo " --enable-libdirac" >>ffmpeg_options
243#echo " --enable-libfaad" >>ffmpeg_options
244#echo " --enable-libfaadbin" >>ffmpeg_options
245# no libgsm-devel
246#echo " --enable-libgsm" >>ffmpeg_options
247echo " --enable-libmp3lame" >>ffmpeg_options
248echo " --enable-libschroedinger" >>ffmpeg_options
249echo " --enable-libspeex" >>ffmpeg_options
250echo " --enable-libtheora" >>ffmpeg_options
251echo " --enable-libvorbis" >>ffmpeg_options
252echo " %{?with_vpx:--enable-libvpx}" >>ffmpeg_options
2292c031
BZ
253# x264 API >= 0.99
254echo " --enable-libx264" >>ffmpeg_options
75937e72
BZ
255echo " --enable-libxvid" >>ffmpeg_options
256echo " --enable-libopencore-amrnb" >>ffmpeg_options
257echo " --enable-libopencore-amrwb" >>ffmpeg_options
258echo " --enable-libopenjpeg" >>ffmpeg_options
259echo " --enable-postproc" >>ffmpeg_options
260echo " --enable-pthreads" >>ffmpeg_options
261echo " --enable-swscale" >>ffmpeg_options
262echo " --enable-vdpau" >>ffmpeg_options
263echo " --enable-x11grab" >>ffmpeg_options
264%ifnarch %{ix86} %{x8664}
265echo " --disable-mmx" >>ffmpeg_options
266%endif
4fdcb1c4
BZ
267#% ifarch i386 i486
268#echo " --disable-mmx" >>ffmpeg_options
269#% endif
75937e72
BZ
270%if %{with nonfree}
271echo " --enable-nonfree" >>ffmpeg_options
272echo " --enable-libfaac" >>ffmpeg_options
273%endif
274echo " --enable-runtime-cpudetect" >>ffmpeg_options
275
276# set mplayer options:
277echo " --prefix=%{_prefix}" >>mplayer_options
e24f026c
BZ
278echo " --confdir=%{_sysconfdir}/mplayer" >>mplayer_options
279echo " --cc="%{__cc}"" >>mplayer_options
280echo " --extra-cflags="$CFLAGS"" >>mplayer_options
281#echo " --real-ldflags="%{rpmldflags}"" >>mplayer_options
282echo " --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}"" >>mplayer_options
283%if %{with system_ffmpeg}
284echo " --disable-libavutil_a" >>mplayer_options
285echo " --disable-libavcodec_a" >>mplayer_options
286echo " --disable-libavformat_a" >>mplayer_options
287echo " --disable-libpostproc_a" >>mplayer_options
288echo " --enable-libavutil_so" >>mplayer_options
289echo " --enable-libavcodec_so" >>mplayer_options
290echo " --enable-libavformat_so" >>mplayer_options
291echo " --enable-libpostproc_so" >>mplayer_options
292%endif
293%ifnarch %{ix86} %{x8664}
294echo " --disable-mmx" >>mplayer_options
295echo " --disable-mmxext" >>mplayer_options
296echo " --disable-3dnow" >>mplayer_options
297echo " --disable-3dnowext" >>mplayer_options
298echo " --disable-sse" >>mplayer_options
299echo " --disable-sse2" >>mplayer_options
300echo " --disable-fastmemcpy" >>mplayer_options
301%endif
302echo " %{__disable ssse3}" >>mplayer_options
303#echo " %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb}" >>mplayer_options
304echo " %{__enable_disable directfb}" >>mplayer_options
305echo " %{__disable dxr3}" >>mplayer_options
306echo " %{__disable ggi}" >>mplayer_options
307echo " %{__disable live}" >>mplayer_options
308echo " %{__disable lzo liblzo}" >>mplayer_options
309echo " %{__disable nas}" >>mplayer_options
310echo " %{__disable svga}" >>mplayer_options
311echo " %{__disable aalib aa}" >>mplayer_options
312echo " %{__disable jack}" >>mplayer_options
313echo " %{__enable_disable alsa}" >>mplayer_options
314echo " %{__disable arts}" >>mplayer_options
315echo " %{__disable caca}" >>mplayer_options
316echo " %{__disable cdparanoia}" >>mplayer_options
317echo " %{__disable enca}" >>mplayer_options
318echo " %{__disable esd}" >>mplayer_options
319echo " %{__disable faad}" >>mplayer_options
320echo " %{__disable gif}" >>mplayer_options
321echo " %{__enable joystick}" >>mplayer_options
322echo " %{__disable libdv}" >>mplayer_options
323echo " %{__disable libdts libdca}" >>mplayer_options
324echo " %{__enable_disable lirc}" >>mplayer_options
325echo " %{__disable mad}" >>mplayer_options
326echo " %{__disable pulseaudio pulse}" >>mplayer_options
327echo " %{__disable quicktime qtx}" >>mplayer_options
328echo " %{__disable real}" >>mplayer_options
329echo " %{__enable_disable runtime runtime-cpudetection}" >>mplayer_options
330echo " %{__disable select}" >>mplayer_options
331echo " %{__disable smb}" >>mplayer_options
332echo " %{__disable win32 win32dll}" >>mplayer_options
333echo " %{__disable vorbis tremor-internal} --disable-tremor %{__disable vorbis libvorbis}" >>mplayer_options
334echo " %{__disable_if system_vorbis tremor-internal}" >>mplayer_options
335echo " %{__enable osd menu}" >>mplayer_options
336echo " %{__disable theora}" >>mplayer_options
337echo " %{__disable x264}" >>mplayer_options
338echo " %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}}" >>mplayer_options
339echo " %{__disable xvid}" >>mplayer_options
340echo " %{__disable vidix}" >>mplayer_options
341echo " %{__disable vdpau}" >>mplayer_options
342echo " %{__disable mencoder}" >>mplayer_options
343echo " --enable-dga1" >>mplayer_options
344echo " --enable-dga2" >>mplayer_options
345echo " %{__enable_disable dvdnav}" >>mplayer_options
346echo " --enable-fbdev" >>mplayer_options
347echo " --enable-gl" >>mplayer_options
348echo " --enable-mga" >>mplayer_options
349echo " --enable-radio" >>mplayer_options
350echo " --enable-radio-capture" >>mplayer_options
351echo " %{__enable_disable sdl}" >>mplayer_options
352echo " --enable-tdfxfb" >>mplayer_options
353echo " --enable-vm" >>mplayer_options
354echo " --enable-x11" >>mplayer_options
355echo " --enable-xmga" >>mplayer_options
356echo " --enable-xv" >>mplayer_options
357echo " --enable-xvmc" >>mplayer_options
358echo " --with-xvmclib=XvMCW" >>mplayer_options
359#echo " --enable-zr" >>mplayer_options
360echo " --enable-unrarexec" >>mplayer_options
361echo " --enable-dynamic-plugins" >>mplayer_options
362echo " --enable-largefiles" >>mplayer_options
363echo " --language=all" >>mplayer_options
364echo " --codecsdir=%{_libdir}/codecs" >>mplayer_options
d9c27da3 365
26692d73
BZ
366cat mplayer/etc/example.conf > mplayer/etc/mplayer.conf
367cat <<'CONFIGADD' >> mplayer/etc/mplayer.conf
368
369######################
370# PLD Linux Defaults #
371######################
372[default]
373
374# alternate solution for CP1250-encoded subtitles
375fontconfig = yes
376subcp = cp1250
377
378# ...or if you prefer native bitmap fonts shipped with mplayer
379#fontconfig = no
380#subcp = iso-8859-1
381
382# Standard location
383unrarexec = "%{_bindir}/unrar"
384
385CONFIGADD
386
387%build
388%{__make}
389
390%install
391rm -rf $RPM_BUILD_ROOT
d9c27da3 392install -d $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer}
26692d73 393
d9c27da3 394%{__make} install DESTDIR=$RPM_BUILD_ROOT
26692d73 395
d9c27da3
BZ
396mv -f $RPM_BUILD_ROOT%{_bindir}/{mplayer,%{name}}
397# default config files
398#install mplayer/etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
26692d73
BZ
399
400# fonts
d9c27da3
BZ
401#cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
402#ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
26692d73 403
d9c27da3
BZ
404#install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
405#install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
26692d73
BZ
406
407%clean
408rm -rf $RPM_BUILD_ROOT
409
410%files
411%defattr(644,root,root,755)
d9c27da3 412%attr(755,root,root) %{_bindir}/%{name}
This page took 0.163391 seconds and 4 git commands to generate.