]> git.pld-linux.org Git - packages/mpich.git/blame - mpich.spec
- updated for 1.2.7p1
[packages/mpich.git] / mpich.spec
CommitLineData
55b4cae8 1Summary: Portable MPI Model Implementation
5807d627 2Summary(pl.UTF-8): Przenośna implementacja standardu MPI
55b4cae8 3Name: mpich
abf7a215 4Version: 1.2.6
0e91bc8e 5Release: 3
55b4cae8
JB
6License: Open source (MPICH), BSD-like (MPI-2-C++)
7Group: Development/Libraries
abf7a215
JB
8Source0: ftp://ftp.mcs.anl.gov/pub/mpi/%{name}-%{version}.tar.bz2
9# Source0-md5: 4c4e2bc23b5f1b73b577bc630f782913
55b4cae8
JB
10Patch0: %{name}-fuckssh.patch
11Patch1: %{name}-opt.patch
0ee9282b 12Patch2: http://squishy.monkeysoft.net/mpich/%{name}-1.2.5-oM.patch
55b4cae8
JB
13URL: http://www-unix.mcs.anl.gov/mpi/
14BuildRequires: gcc-g77
15BuildRequires: libstdc++-devel
0e91bc8e 16BuildRequires: sed >= 4.0
8791ac7a 17Provides: mpi
55b4cae8
JB
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21MPICH is an open-source, portable implementation of the
22Message-Passing Interface Standard. It contains a complete
23implementation of version 1.2 of the MPI Standard and also significant
24parts of MPI-2, particularly in the area of parallel I/O.
25
f33abeef
JR
26%description -l pl.UTF-8
27MPICH jest wolnodostępną implementacją standardu MPI (Message-Passing
28Interface). Zawiera pełną implementację wersji MPI 1.2 oraz znaczne
29części wersji MPI-2, szczególnie w zakresie równoległej komunikacji.
55b4cae8
JB
30
31%prep
8e991428 32%setup -q
55b4cae8 33%patch0 -p1
0dad8207
JB
34%patch1 -p1
35%patch2 -p1
55b4cae8 36
0e91bc8e
JR
37sed -i -e 's|RCPCOMMAND-rcp|RCPCOMMAND-scp|' mpid/ch_p4/mpirun.ch_p4.in
38
55b4cae8 39%build
0e91bc8e
JR
40RSHCOMMAND=/usr/bin/ssh ; export RSHCOMMAND
41RCPCOMMAND=/usr/bin/scp ; export RCPCOMMAND
55b4cae8
JB
42# note: can't run autoconf - we must patch configure not only configure.in
43# also, don't change it to %%configure - it won't work
44# no configure options for sysconfdir and messagecat_dir :/
abf7a215
JB
45sysconfdir=%{_sysconfdir} \
46messagecat_dir=%{_libdir} \
55b4cae8 47./configure \
abf7a215
JB
48 --prefix=%{_prefix} \
49 --exec_prefix=%{_prefix} \
50 --includedir=%{_includedir} \
51 --sharedlib=%{_libdir} \
52 --libdir=%{_libdir} \
53 --datadir=%{_datadir}/%{name} \
54 --bindir=%{_bindir} \
55 --sbindir=%{_sbindir} \
56 --mandir=%{_mandir} \
57 --docdir=%{_docdir} \
55b4cae8
JB
58 -opt="%{rpmcflags}"
59
60%{__make}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64
65# really awful
66DESTDIR=$RPM_BUILD_ROOT ; export DESTDIR
67%{__make} install
68
69# fix symlinks
70(cd $RPM_BUILD_ROOT%{_libdir}
71rm -f libfmpich.so libmpich.so libpmpich.so
72ln -sf libfmpich.so.*.* libfmpich.so
73ln -sf libmpich.so.*.* libmpich.so
74ln -sf libpmpich.so.*.* libpmpich.so
75)
76
77install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78mv -f $RPM_BUILD_ROOT%{_prefix}/examples/* \
79 $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
80
81(cd $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
82rm -f mpirun MPI-2-C++/mpirun
83ln -sf %{_bindir}/mpirun mpirun
84ln -sf %{_bindir}/mpirun MPI-2-C++/mpirun
85)
86
87# argh... where came that 4 from???
88for f in $RPM_BUILD_ROOT%{_mandir}/man4/*.4 ; do
89 mv -f "$f" $RPM_BUILD_ROOT%{_mandir}/man3/`basename "$f" .4`.3
90done
91
92for f in HISTORY LICENSE README TODO ; do
93 mv -f MPI-2-C++/$f $f.MPI-2-C++
94done
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%post -p /sbin/ldconfig
100%postun -p /sbin/ldconfig
101
102%files
103%defattr(644,root,root,755)
8e991428 104%doc doc/*.ps* COPYRIGHT README KnownBugs
55b4cae8
JB
105%attr(755,root,root) %{_bindir}/*
106%attr(755,root,root) %{_sbindir}/*
107%attr(755,root,root) %{_libdir}/lib*.so*
108%{_libdir}/lib*.a
0dad8207
JB
109%{_libdir}/mpe_prof.o
110%{_sysconfdir}/mpichversion.c
111%{_sysconfdir}/mpichconf.h.dat
480a9c94 112%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpi*.conf
0dad8207
JB
113%{_includedir}/*.h
114%{_includedir}/mpi2c++
55b4cae8
JB
115%{_mandir}/man1/*
116%{_mandir}/man3/*
117%{_datadir}/mpich
118%{_examplesdir}/%{name}-%{version}
This page took 0.093384 seconds and 4 git commands to generate.