]> git.pld-linux.org Git - packages/mpich.git/blame - mpich.spec
- updated to 3.1.4
[packages/mpich.git] / mpich.spec
CommitLineData
00238d6b 1# TODO: separate fortran lib/tools? c++ too?
d08d4924
JB
2#
3# Conditional build:
4%bcond_with blcr # blcr application checkpointing support (no support for recent kernels)
5#
55b4cae8 6Summary: Portable MPI Model Implementation
5807d627 7Summary(pl.UTF-8): Przenośna implementacja standardu MPI
55b4cae8 8Name: mpich
00238d6b
JB
9Version: 3.1.4
10Release: 1
dc8c0b94 11License: BSD-like
55b4cae8 12Group: Development/Libraries
00238d6b
JB
13Source0: https://www.mpich.org/static/downloads/%{version}/%{name}-%{version}.tar.gz
14# Source0-md5: 2ab544607986486562e076b83937bba2
dc8c0b94 15Patch0: %{name}-sh.patch
00238d6b
JB
16Patch1: x32-misdetected-as-i386.patch
17URL: https://www.mpich.org/
dc8c0b94
JB
18BuildRequires: autoconf >= 2.63
19BuildRequires: automake >= 1:1.12.3
d08d4924 20%{?with_blcr:BuildRequires: blcr-devel}
dc8c0b94
JB
21BuildRequires: ftb-devel
22BuildRequires: gcc-fortran
23BuildRequires: hwloc-devel >= 1.9.0
55b4cae8 24BuildRequires: libstdc++-devel
dc8c0b94
JB
25BuildRequires: libtool >= 2:2
26BuildRequires: openpa-devel
27Requires: hwloc-libs >= 1.9.0
8791ac7a 28Provides: mpi
55b4cae8
JB
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
dc8c0b94
JB
32MPICH is a high-performance and widely portable implementation of the
33MPI-3.0 standard from the Argonne National Laboratory. This release
34has all MPI 3.0 functions and features required by the standard with
35the exception of support for the "external32" portable I/O format and
36user-defined data representations for I/O.
37
38This package contains MPICH shared libraries and runtime utilities,
39including Hydra PM.
55b4cae8 40
f33abeef 41%description -l pl.UTF-8
dc8c0b94
JB
42MPICH to wysoko wydajna i przenośna implementacja standardu MPI-3.0
43pochodząca z Argonne National Laboratory. To wydanie zawiera całą
44funkcjonalność i możliwości MPI 3.0 wymagane przez standard z
45wyjątkiem obsługi przenośnego formatu we-wy "external32" oraz
46definiowanych przez użytkownika reprezentacji danych dla we/wy.
47
48Ten pakiet zawiera biblioteki współdzielone MPICH oraz narzędzia
49uruchomieniowe, w tym Hydra PM.
50
51%package devel
52Summary: MPICH header files and development tools
53Summary(pl.UTF-8): Pliki nagłówkowe oraz narzędzia programistyczne MPICH
54Group: Development
55Requires: %{name} = %{version}-%{release}
00238d6b
JB
56Requires: gcc-fortran
57Requires: libstdc++-devel
58Requires: openpa-devel
42f03ea9 59Provides: mpi-devel
dc8c0b94
JB
60
61%description devel
62MPICH header files and development tools.
63
64%description devel
65Pliki nagłówkowe oraz narzędzia programistyczne MPICH.
66
67%package static
68Summary: MPICH static libraries
69Summary(pl.UTF-8): Biblioteki statyczne MPICH
70Group: Development/Libraries
71Requires: %{name}-devel = %{version}-%{release}
42f03ea9 72Provides: mpi-static
dc8c0b94
JB
73
74%description static
75MPICH static libraries.
76
77%description static -l pl.UTF-8
78Biblioteki statyczne MPICH.
55b4cae8
JB
79
80%prep
8e991428 81%setup -q
55b4cae8 82%patch0 -p1
0dad8207 83%patch1 -p1
0e91bc8e 84
55b4cae8 85%build
dc8c0b94
JB
86%{__libtoolize}
87%{__aclocal} -I confdb
88%{__autoconf}
89%{__autoheader}
90%{__automake}
91%configure \
92 --disable-silent-rules \
d08d4924 93 %{?with_blcr:--enable-checkpointing} \
dc8c0b94 94 --with-hwloc-prefix=system \
d08d4924 95 %{!?with_blcr:--with-hydra-ckpointlib=none} \
dc8c0b94
JB
96 --with-openpa-prefix=system
97
98%{__make}
55b4cae8
JB
99
100%install
101rm -rf $RPM_BUILD_ROOT
102
dc8c0b94
JB
103%{__make} install \
104 DESTDIR=$RPM_BUILD_ROOT
55b4cae8 105
55b4cae8 106install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
dc8c0b94
JB
107cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
108%{__rm} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/{cpi,cpi.o,examples.sln}
55b4cae8 109
dc8c0b94
JB
110# see openpa.spec
111%{__rm} $RPM_BUILD_ROOT%{_libdir}/libopa.so
55b4cae8 112
dc8c0b94
JB
113# PDFs packaged as %doc
114%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/mpich
d03126ce 115
55b4cae8
JB
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120%postun -p /sbin/ldconfig
121
122%files
123%defattr(644,root,root,755)
dc8c0b94
JB
124%doc CHANGES COPYRIGHT README README.envvar RELEASE_NOTES doc/{installguide/install.pdf,logging/logging.pdf,userguide/user.pdf}
125%attr(755,root,root) %{_bindir}/hydra_nameserver
126%attr(755,root,root) %{_bindir}/hydra_persist
127%attr(755,root,root) %{_bindir}/hydra_pmi_proxy
128%attr(755,root,root) %{_bindir}/mpichversion
129%attr(755,root,root) %{_bindir}/mpiexec
130%attr(755,root,root) %{_bindir}/mpiexec.hydra
131%attr(755,root,root) %{_bindir}/mpirun
132%attr(755,root,root) %{_bindir}/mpivars
133%attr(755,root,root) %{_bindir}/parkill
134%attr(755,root,root) %{_libdir}/libmpi.so.*.*.*
135%attr(755,root,root) %ghost %{_libdir}/libmpi.so.12
136%attr(755,root,root) %{_libdir}/libmpicxx.so.*.*.*
137%attr(755,root,root) %ghost %{_libdir}/libmpicxx.so.12
138%attr(755,root,root) %{_libdir}/libmpifort.so.*.*.*
139%attr(755,root,root) %ghost %{_libdir}/libmpifort.so.12
140%{_mandir}/man1/hydra_nameserver.1*
141%{_mandir}/man1/hydra_persist.1*
142%{_mandir}/man1/hydra_pmi_proxy.1*
143%{_mandir}/man1/mpiexec.1*
144
145%files devel
146%defattr(644,root,root,755)
147%attr(755,root,root) %{_bindir}/mpic++
148%attr(755,root,root) %{_bindir}/mpicc
149%attr(755,root,root) %{_bindir}/mpicxx
150%attr(755,root,root) %{_bindir}/mpif77
151%attr(755,root,root) %{_bindir}/mpif90
152%attr(755,root,root) %{_bindir}/mpifort
153%attr(755,root,root) %{_libdir}/libmpi.so
154%attr(755,root,root) %{_libdir}/libmpicxx.so
155%attr(755,root,root) %{_libdir}/libmpifort.so
156%attr(755,root,root) %{_libdir}/libfmpich.so
157%attr(755,root,root) %{_libdir}/libmpich.so
158%attr(755,root,root) %{_libdir}/libmpichcxx.so
159%attr(755,root,root) %{_libdir}/libmpichf90.so
160%attr(755,root,root) %{_libdir}/libmpl.so
161%{_libdir}/libmpi.la
162%{_libdir}/libmpicxx.la
163%{_libdir}/libmpifort.la
164%{_includedir}/mpi*.h
165%{_includedir}/mpi*.mod
166%{_pkgconfigdir}/mpich.pc
167%{_mandir}/man1/mpicc.1*
168%{_mandir}/man1/mpicxx.1*
169%{_mandir}/man1/mpif77.1*
170%{_mandir}/man1/mpifort.1*
171%{_mandir}/man3/MPIX_*.3*
172%{_mandir}/man3/MPI_*.3*
55b4cae8 173%{_examplesdir}/%{name}-%{version}
dc8c0b94
JB
174
175%files static
176%defattr(644,root,root,755)
177%{_libdir}/libmpi.a
178%{_libdir}/libmpicxx.a
179%{_libdir}/libmpifort.a
This page took 0.225562 seconds and 4 git commands to generate.