]> git.pld-linux.org Git - packages/mozjs38.git/blame - mozjs38.spec
Added Disable-js-JIT-on-x32 and -x32 patches to fix build on x32
[packages/mozjs38.git] / mozjs38.spec
CommitLineData
9b7b3ede
MB
1Summary: SpiderMonkey 38 - JavaScript implementation
2Summary(pl.UTF-8): SpiderMonkey 38 - implementacja języka JavaScript
3Name: mozjs38
4Version: 38.8.0
5Release: 1
6License: MPL v2.0
7Group: Libraries
8Source0: https://ftp.mozilla.org/pub/firefox/releases/%{version}esr/source/firefox-%{version}esr.source.tar.bz2
9# Source0-md5: af46898414a433f8260c5373efb97d19
10Patch0: %{name}-shell-version.patch
11Patch1: %{name}-pkg-config-version.patch
12Patch2: %{name}-1269317.patch
013c854c 13Patch3: %{name}-system-virtualenv.patch
ba14323b
MB
14Patch4: Disable-js-JIT-on-x32.patch
15Patch5: %{name}-x32.patch
9b7b3ede 16URL: https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/38
9b7b3ede 17BuildRequires: libffi-devel >= 5:3.0.9
9b7b3ede
MB
18BuildRequires: libstdc++-devel >= 6:4.4
19BuildRequires: nspr-devel >= 4.9.2
20BuildRequires: perl-base >= 1:5.6
21BuildRequires: pkgconfig
22BuildRequires: python >= 1:2.5
23BuildRequires: python-virtualenv >= 1.9.1-4
24BuildRequires: readline-devel
25BuildRequires: rpm-perlprov
26BuildRequires: rpmbuild(macros) >= 1.294
27BuildRequires: zlib-devel >= 1.2.3
28Requires: nspr >= 4.9.2
29Requires: zlib >= 1.2.3
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33JavaScript Reference Implementation (codename SpiderMonkey). The
34package contains JavaScript runtime (compiler, interpreter,
35decompiler, garbage collector, atom manager, standard classes) and
36small "shell" program that can be used interactively and with .js
37files to run scripts.
38
39%description -l pl.UTF-8
40Wzorcowa implementacja JavaScriptu (o nazwie kodowej SpiderMonkey).
41Pakiet zawiera środowisko uruchomieniowe (kompilator, interpreter,
42dekompilator, odśmiecacz, standardowe klasy) i niewielką powłokę,
43która może być używana interaktywnie lub z plikami .js do uruchamiania
44skryptów.
45
46%package devel
47Summary: Header files for JavaScript reference library
48Summary(pl.UTF-8): Pliki nagłówkowe do biblioteki JavaScript
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
51Requires: libstdc++-devel
52Requires: nspr-devel >= 4.9.2
53
54%description devel
55Header files for JavaScript reference library.
56
57%description devel -l pl.UTF-8
58Pliki nagłówkowe do biblioteki JavaScript.
59
60%prep
61%setup -q -n mozilla-esr38
62%patch0 -p1
63%patch1 -p1
64%patch2 -p1
013c854c 65%patch3 -p1
ba14323b
MB
66%patch4 -p1
67%patch5 -p1
9b7b3ede
MB
68
69cd js/src
70
71# Correct sed expression for new sed
72sed -i 's|\^\[:space:\]|^\[\[:space:\]\]|g' configure
73
74%build
75export PYTHON="%{__python}"
76cd js/src
77%configure2_13 \
78 --enable-readline \
79 --enable-system-ffi \
80 --enable-threadsafe \
81 --enable-shared-js \
82 --enable-gcgenerational \
83 --with-system-nspr \
84 --with-system-icu \
85 --with-system-zlib \
86 --with-intl-api
87
88%{__make} \
89 HOST_OPTIMIZE_FLAGS= \
90 MODULE_OPTIMIZE_FLAGS= \
91 MOZ_OPTIMIZE_FLAGS="-freorder-blocks" \
92 MOZ_PGO_OPTIMIZE_FLAGS= \
93 MOZILLA_VERSION=%{version}
94
95%install
96rm -rf $RPM_BUILD_ROOT
97
98%{__make} -C js/src install \
99 DESTDIR=$RPM_BUILD_ROOT \
100 MOZILLA_VERSION=%{version}
101
102%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.ajs
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post -p /sbin/ldconfig
108%postun -p /sbin/ldconfig
109
110%files
111%defattr(644,root,root,755)
112%doc js/src/README.html
113%attr(755,root,root) %{_bindir}/js38
114%attr(755,root,root) %{_libdir}/libmozjs-38.so
115
116%files devel
117%defattr(644,root,root,755)
118%attr(755,root,root) %{_bindir}/js38-config
119%{_includedir}/mozjs-38
120%{_pkgconfigdir}/mozjs-38.pc
This page took 0.087171 seconds and 4 git commands to generate.