]> git.pld-linux.org Git - packages/mediainfo.git/blame - mediainfo.spec
- initial; builds but needs more work
[packages/mediainfo.git] / mediainfo.spec
CommitLineData
7bc0a388
AM
1Summary: Supplies technical and tag information about a video or audio file (CLI)
2Name: mediainfo
3Version: 0.7.25
4Release: 0.1
5License: GPL
6Group: Applications/Multimedia
7URL: http://mediainfo.sourceforge.net/
8Source0: http://downloads.sourceforge.net/project/mediainfo/source/mediainfo/%{version}/%{name}_%{version}.tar.bz2
9# Source0-md5: addbec472d8e20b93e9d3ba2956aea2b
10BuildRequires: dos2unix
11BuildRequires: libmediainfo-devel >= 0.7.25
12BuildRequires: libstdc++-devel
13BuildRequires: libzen-devel >= 0.4.9
14BuildRequires: pkgconfig
15BuildRequires: wxGTK2-unicode-devel
16BuildRequires: zlib-devel
17Requires: libmediainfo >= 0.7.25
18Requires: libzen >= 0.4.9
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22MediaInfo CLI (Command Line Interface).
23
24What information can I get from MediaInfo?
25- General: title, author, director, album, track number, date,
26 duration...
27- Video: codec, aspect, fps, bitrate...
28- Audio: codec, sample rate, channels, language, bitrate...
29- Text: language of subtitle
30- Chapters: number of chapters, list of chapters
31
32DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1, MPEG1,
33MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime, RealVideo,
34RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3, VOB, DVD, WMA,
35VMW, ASF, 3GP, 3GPP, 3GP2
36
37What format (container) does MediaInfo support?
38- Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1, MPEG-2,
39 MPEG-4, DVD (VOB) (Codecs: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
40- Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
41- Subtitles: SRT, SSA, ASS, SAMI
42
43%package gui
44Summary: Supplies technical and tag information about a video or audio file (GUI)
45Group: X11/Applications/Multimedia
46Requires: libmediainfo >= %{version}
47Requires: libzen >= 0.4.9
48
49%description gui
50MediaInfo (Graphical User Interface).
51
52What information can I get from MediaInfo?
53- General: title, author, director, album, track number, date,
54 duration...
55- Video: codec, aspect, fps, bitrate...
56- Audio: codec, sample rate, channels, language, bitrate...
57- Text: language of subtitle
58- Chapters: number of chapters, list of chapters
59
60DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1, MPEG1,
61MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime, RealVideo,
62RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3, VOB, DVD, WMA,
63VMW, ASF, 3GP, 3GPP, 3GP2
64
65What format (container) does MediaInfo support?
66- Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1, MPEG-2,
67 MPEG-4, DVD (VOB) (Codecs: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
68- Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
69- Subtitles: SRT, SSA, ASS, SAMI
70
71%prep
72%setup -q -n MediaInfo
73dos2unix *.html *.txt Release/*.txt
74chmod 644 *.html *.txt Release/*.txt
75
76%build
77export CFLAGS="%{rpmcflags}"
78export CPPFLAGS="%{rpmcppflags}"
79export CXXFLAGS="%{rpmcxxflags}"
80
81# build CLI
82cd Project/GNU/CLI
83 chmod +x autogen
84 ./autogen
85 %configure
86 %{__make}
87cd ../../..
88
89# now build GUI
90cd Project/GNU/GUI
91 chmod +x autogen
92 ./autogen
93 %configure \
94 --with-wx-config=%{_bindir}/wx-gtk2-unicode-config
95 %{__make}
96cd ../../..
97
98%install
99rm -rf $RPM_BUILD_ROOT
100%{__make} -C Project/GNU/CLI \
101 install \
102 DESTDIR=$RPM_BUILD_ROOT
103
104%{__make} -C Project/GNU/GUI \
105 install \
106 DESTDIR=$RPM_BUILD_ROOT
107
108# icon
109install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps
110install Source/Ressource/Image/MediaInfo.png \
111 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps/%{name}.png
112install -dm 755 $RPM_BUILD_ROOT%{_pixmapsdir}
113install Source/Ressource/Image/MediaInfo.png \
114 $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
115
116# menu-entry
117install -dm 755 $RPM_BUILD_ROOT/%{_desktopdir}
118install Project/GNU/GUI/mediainfo-gui.desktop \
119 $RPM_BUILD_ROOT/%{_desktopdir}
120install -dm 755 $RPM_BUILD_ROOT/%{_datadir}/apps/konqueror/servicemenus
121install Project/GNU/GUI/mediainfo-gui.kde3.desktop \
122 $RPM_BUILD_ROOT/%{_datadir}/apps/konqueror/servicemenus/mediainfo-gui.desktop
123install -dm 755 $RPM_BUILD_ROOT/%{_datadir}/kde4/services/ServiceMenus/
124install Project/GNU/GUI/mediainfo-gui.kde4.desktop \
125 $RPM_BUILD_ROOT/%{_datadir}/kde4/services/ServiceMenus/mediainfo-gui.desktop
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%files
131%defattr(644,root,root,755)
132%doc Release/ReadMe_CLI_Linux.txt
133%doc License.html History_CLI.txt
134%attr(755,root,root) %{_bindir}/mediainfo
135
136%files gui
137%defattr(644,root,root,755)
138%doc Release/ReadMe_GUI_Linux.txt
139%doc License.html History_GUI.txt
140%attr(755,root,root) %{_bindir}/mediainfo-gui
141%{_desktopdir}/*.desktop
142%{_pixmapsdir}/*.png
143%dir %{_iconsdir}/hicolor
144%dir %{_iconsdir}/hicolor/128x128
145%dir %{_iconsdir}/hicolor/128x128/apps
146%{_iconsdir}/hicolor/128x128/apps/*.png
147%dir %{_datadir}/apps
148%dir %{_datadir}/apps/konqueror
149%dir %{_datadir}/apps/konqueror/servicemenus
150%{_datadir}/apps/konqueror/servicemenus/*.desktop
151%dir %{_datadir}/kde4
152%dir %{_datadir}/kde4/services
153%dir %{_datadir}/kde4/services/ServiceMenus
154%{_datadir}/kde4/services/ServiceMenus/*.desktop
This page took 0.157958 seconds and 4 git commands to generate.