]> git.pld-linux.org Git - packages/mdds.git/blame - mdds.spec
- updated to 1.0.0 (now with versioned API, currently 1.0)
[packages/mdds.git] / mdds.spec
CommitLineData
17e84106
JB
1#
2# Conditional build:
3%bcond_without apidocs # doxygen/sphinx+breathe API documentation
4#
dbe2120a 5Summary: A collection of multi-dimensional data structures and indexing algorithms
021b4724 6Summary(pl.UTF-8): Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
dbe2120a 7Name: mdds
17e84106 8Version: 1.0.0
dbe2120a
AM
9Release: 1
10License: MIT
11Group: Development/Libraries
0a68325b 12#Source0Download: https://gitlab.com/mdds/mdds
032fc0ce 13Source0: http://kohei.us/files/mdds/src/%{name}_%{version}.tar.bz2
17e84106
JB
14# Source0-md5: 74e0a81c5af4137285fe6a52217f71e4
15Patch0: %{name}-doc.patch
0a68325b 16URL: https://gitlab.com/mdds/mdds
47d79994
JB
17BuildRequires: autoconf >= 2.50
18BuildRequires: boost-devel >= 1.39
17e84106 19BuildRequires: libstdc++-devel >= 6:4.7
35b5323a 20BuildRequires: rpmbuild(macros) >= 1.446
47d79994 21BuildRequires: sed >= 4.0
17e84106
JB
22%if %{with apidocs}
23BuildRequires: doxygen
24BuildRequires: python-sphinx_bootstrap_theme
25BuildRequires: sphinx-pdg
26%endif
dbe2120a 27BuildArch: noarch
843e0754 28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
dbe2120a
AM
29
30%description
31A collection of multi-dimensional data structures and indexing
32algorithms.
33
34It implements the following data structures:
35- segment tree
36- flat segment tree
37- rectangle set
38- point quad tree
39- mixed type matrix
40
021b4724
JB
41%description -l pl.UTF-8
42Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
43Zaimplementowane są następujące struktury danych:
44- drzewo segmentowe
45- płaskie drzewo segmentowe
46- zbiór prostokątów
47- drzewo czwórkowe (quadtree) dla punktów
48- macierz mieszana
49
dbe2120a 50%package devel
021b4724
JB
51Summary: A collection of multi-dimensional data structures and indexing algorithms
52Summary(pl.UTF-8): Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
dbe2120a 53Group: Development/Libraries
47d79994 54Requires: boost-devel >= 1.39
17e84106 55Requires: libstdc++-devel >= 6:4.7
dbe2120a
AM
56
57%description devel
021b4724
JB
58A collection of multi-dimensional data structures and indexing
59algorithms.
60
61It implements the following data structures:
62- segment tree
63- flat segment tree
64- rectangle set
65- point quad tree
66- mixed type matrix
67
68%description devel -l pl.UTF-8
69Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
70Zaimplementowane są następujące struktury danych:
71- drzewo segmentowe
72- płaskie drzewo segmentowe
73- zbiór prostokątów
74- drzewo czwórkowe (quadtree) dla punktów
75- macierz mieszana
dbe2120a 76
17e84106
JB
77%package apidocs
78Summary: API documentation for MDDS
79Summary(pl.UTF-8): Dokumentacja API biblioteki MDDS
80Group: Documentation
81
82%description apidocs
83API documentation for MDDS.
84
85%description apidocs -l pl.UTF-8
86Dokumentacja API biblioteki MDDS.
87
dbe2120a
AM
88%prep
89%setup -q -n %{name}_%{version}
17e84106 90%patch0 -p1
7a3941f7 91
dbe2120a 92# this is only used in tests
17e84106 93sed -i -e '/^CPPFLAGS=/s/-Os -g /%{rpmcflags} /' configure.ac
dbe2120a 94
dbe2120a 95%build
47d79994 96%{__autoconf}
17e84106
JB
97%configure
98
99%{__make} all %{?with_apidocs:build-doc} \
100 CXX="%{__cxx}"
dbe2120a
AM
101
102%install
103rm -rf $RPM_BUILD_ROOT
17e84106
JB
104
105%{__make} install \
106 DESTDIR=$RPM_BUILD_ROOT
107
108# packaged as %doc
109%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/mdds-1.0
dbe2120a
AM
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%files devel
115%defattr(644,root,root,755)
17e84106
JB
116%doc AUTHORS CHANGELOG LICENSE README.md
117%{_includedir}/mdds-1.0
118%{_npkgconfigdir}/mdds-1.0.pc
119
120%files apidocs
121%defattr(644,root,root,755)
122%doc doc/html doc/_build/{_static,*.html,*.js}
This page took 0.095745 seconds and 4 git commands to generate.