]> git.pld-linux.org Git - packages/docker-ce.git/blame - lxc-docker.spec
x86-64 only for now
[packages/docker-ce.git] / lxc-docker.spec
CommitLineData
a73bca1d
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
b2c07037 4
b877f7b7
ER
5Summary: Docker: the Linux container engine
6Name: lxc-docker
b2c07037 7Version: 0.6.1
d2670441 8Release: 2
b877f7b7
ER
9License: Apache v2.0
10Group: Applications/System
11Source0: https://github.com/dotcloud/docker/archive/v%{version}.tar.gz
b2c07037 12# Source0-md5: 487262eae6627971e9181886d65fae1a
3f5ee638
ER
13Source100: https://raw.github.com/dotcloud/docker/v0.5.3/Makefile
14# Source100-md5: 44cc86a37fc5dfe59596076d346da20d
a0edb644
ER
15Source1: https://github.com/gorilla/context/archive/master.tar.gz?/gorilla-context.tgz
16# Source1-md5: 621f599f7a49f56ca89c25a6d01ecc3a
17Source2: https://github.com/gorilla/mux/archive/master.tar.gz?/gorilla-mux.tgz
18# Source2-md5: e908c7da6b4b8b61b4733d4a348f015c
19Source3: https://github.com/kr/pty/archive/master.tar.gz?/kr-pty.tgz
b2c07037 20# Source3-md5: ffdcacc582c7b6404e71c2dce638869e
3f5ee638
ER
21Source4: https://github.com/dotcloud/tar/archive/master.tar.gz?/tar.tgz
22# Source4-md5: 7458ecaa777e56d124b61638d597b37f
23# $ PKG=code.google.com/p/go.net/ REV=84a4013f96e0; hg clone http://$PKG go.net && cd go.net && hg checkout $REV && cd .. && tar -cjf go.net.tar.gz2 --exclude-vcs go.net
24Source5: go.net.tar.bz2
25# Source5-md5: c8fd9d068430ddfa42d28d4772260eda
d2670441 26Patch0: bash-comp-2.patch
b877f7b7 27URL: http://github.com/dotcloud/docker
cc7690e4 28BuildRequires: golang >= 1.1
b5920dfc 29Requires: iptables
2015cb19 30Requires: lxc
db150373 31Requires: tar
2015cb19 32Requires: uname(release) >= 3.8
db150373 33Requires: xz
d2670441
ER
34# only runs on x64 hosts for now:
35# https://github.com/dotcloud/docker/issues/136
36# https://github.com/dotcloud/docker/issues/611
37ExclusiveArch %{x8664}
b877f7b7
ER
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
8c352669
ER
40%define bash_compdir %{_datadir}/bash-completion/completions
41
434d66d3
ER
42# binary stripped or something
43%define _enable_debug_packages 0
44
b877f7b7
ER
45%description
46Docker complements LXC with a high-level API which operates at the
47process level. It runs unix processes with strong guarantees of
48isolation and repeatability across servers.
49
50Docker is a great building block for automating distributed systems:
51large-scale web deployments, database clusters, continuous deployment
52systems, private PaaS, service-oriented architectures, etc.
53
8c352669
ER
54%package -n bash-completion-lxc-docker
55Summary: bash-completion for Docker
56Summary(pl.UTF-8): bashowe uzupełnianie nazw dla Dockera
57Group: Applications/Shells
58Requires: %{name}
59Requires: bash-completion >= 2.0
60%if "%{_rpmversion}" >= "5"
61BuildArch: noarch
62%endif
63
64%description -n bash-completion-lxc-docker
65This package provides bash-completion for Docker.
66
67%description -n bash-completion-lxc-docker -l pl.UTF-8
68Pakiet ten dostarcza bashowe uzupełnianie nazw dla Dockera.
69
b877f7b7 70%prep
3f5ee638
ER
71%setup -q -n docker-%{version} -a1 -a2 -a3 -a4 -a5
72cp -p %{SOURCE100} .
044682ca 73%patch0 -p1
a0edb644 74
3f5ee638
ER
75# handle external deps offline, these are taken from Dockerfile
76install -d .gopath/src/github.com/{gorilla,kr,dotcloud}
a0edb644
ER
77# git clone https://github.com/gorilla/context .gopath/src/github.com/gorilla/context
78mv context-master .gopath/src/github.com/gorilla/context
79# git clone https://github.com/gorilla/mux .gopath/src/github.com/gorilla/mux
80mv mux-master .gopath/src/github.com/gorilla/mux
81# git clone https://github.com/kr/pty .gopath/src/github.com/kr/pty
82mv pty-master .gopath/src/github.com/kr/pty
3f5ee638
ER
83# git clone https://github.com/dotcloud/tar .gopath/src/github.com/dotcloud/tar
84mv tar-master .gopath/src/github.com/dotcloud/tar
85# PKG=code.google.com/p/go.net/
86install -d .gopath/src/code.google.com/p
87mv go.net .gopath/src/code.google.com/p/go.net
b877f7b7
ER
88
89%build
a0edb644
ER
90# avoid interfering with builder env
91unset GIT_WORK_TREE
92unset GIT_DIR
b877f7b7
ER
93%{__make} VERBOSE=1
94
a73bca1d
ER
95%if %{with tests}
96%{__make} test
97%endif
98
b877f7b7
ER
99%install
100rm -rf $RPM_BUILD_ROOT
af991618 101install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/var/lib/docker/{containers,graph,volumes}}
b877f7b7 102install -p bin/docker $RPM_BUILD_ROOT%{_bindir}/lxc-docker
9c77b76c 103ln -s lxc-docker $RPM_BUILD_ROOT%{_bindir}/docker
b877f7b7
ER
104cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
105
8c352669
ER
106# bash completion
107install -d $RPM_BUILD_ROOT%{bash_compdir}
108cp -p contrib/docker.bash $RPM_BUILD_ROOT%{bash_compdir}/lxc-docker
109ln -s lxc-docker $RPM_BUILD_ROOT%{bash_compdir}/docker
110
b877f7b7
ER
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%files
115%defattr(644,root,root,755)
116%doc README.md CHANGELOG.md CONTRIBUTING.md FIXME LICENSE AUTHORS NOTICE MAINTAINERS
117%attr(755,root,root) %{_bindir}/lxc-docker
9c77b76c 118%attr(755,root,root) %{_bindir}/docker
b877f7b7 119%{_mandir}/man1/lxc-docker.1*
af991618
ER
120%dir %attr(700,root,root) /var/lib/docker
121%dir %attr(700,root,root) /var/lib/docker/containers
122%dir %attr(700,root,root) /var/lib/docker/graph
123%dir %attr(700,root,root) /var/lib/docker/volumes
8c352669
ER
124
125%files -n bash-completion-lxc-docker
126%defattr(644,root,root,755)
127%{bash_compdir}/lxc-docker
128%{bash_compdir}/docker
This page took 0.087519 seconds and 4 git commands to generate.