]> git.pld-linux.org Git - packages/lvm2.git/blame - lvm2.spec
- updated to 2.02.107
[packages/lvm2.git] / lvm2.spec
CommitLineData
e3a928dc 1# TODO
e3a928dc 2# - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
5f0ee085 3# - --with-replicators (=internal/shared/none, default is none)?
1b67453e 4#
99958222 5# Conditional build:
8b89021c 6%bcond_with initrd # don't build initrd version
fe052975
JR
7%bcond_without uClibc # link initrd version with uClibc
8%bcond_with dietlibc # link initrd version with dietlibc
5f0ee085 9%bcond_with glibc # link initrd version with static GLIBC
7e873dd0 10%bcond_without cluster # disable all cluster support (clvmd&cmirrord)
43435358 11%bcond_without lvmetad # disable lvmetad
c70b42f6
JR
12%bcond_without selinux # disable SELinux
13
4a323c26 14%ifarch sparc64 sparc
c70b42f6 15%define with_glibc 1
66800f6a 16%endif
c70b42f6
JR
17
18# if one of the *libc is enabled disable default dietlibc
19%if %{with dietlibc} && %{with uClibc}
20%undefine with_dietlibc
21%endif
22
f1e27504 23# with glibc disables default dietlibc
c70b42f6
JR
24%if %{with glibc} && %{with dietlibc}
25%undefine with_dietlibc
26%endif
27
f1e27504
ER
28# fallback is glibc if neither alternatives are enabled
29%if %{without dietlibc} && %{without uClibc}
30%define with_glibc 1
31%endif
32
5672aa67 33Summary: The new version of Logical Volume Manager for Linux
6536e848 34Summary(pl.UTF-8): Nowa wersja Logical Volume Managera dla Linuksa
7e72c866 35Name: lvm2
bfc9ab17 36Version: 2.02.107
0442bdaf 37Release: 1
0a81c260 38License: GPL v2 and LGPL v2.1
7e72c866 39Group: Applications/System
dc5d0e77 40Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
bfc9ab17 41# Source0-md5: efa5b0ff0245cbccf53aec1f3d8840ba
c386faf9 42Source1: %{name}-tmpfiles.conf
0d673991
JK
43Source2: clvmd.service
44Source3: clvmd.sysconfig
7210a095 45Patch0: %{name}-selinux.patch
c70b42f6 46Patch1: %{name}-diet.patch
9a00e98a 47Patch2: device-mapper-dmsetup-export.patch
4cb4934b 48Patch3: %{name}-pld_init.patch
b747c17a 49Patch4: dl-dlsym.patch
4cb4934b 50Patch6: %{name}-lvm_path.patch
7d8cfaa5 51Patch7: %{name}-sd_notify.patch
105f82c3 52Patch8: %{name}-clvmd_cmd_timeout.patch
14fc1988 53Patch9: device-mapper-dmsetup-deps-export.patch
dc5d0e77 54URL: http://sources.redhat.com/lvm2/
5f0ee085 55BuildRequires: autoconf >= 2.61
7e72c866 56BuildRequires: automake
0dc2b8f2 57%{?with_selinux:BuildRequires: libselinux-devel >= 1.10}
e4a12efb 58%{?with_selinux:BuildRequires: libsepol-devel}
5f0ee085 59BuildRequires: ncurses-devel
3657a56d 60BuildRequires: pkgconfig
5f0ee085 61BuildRequires: readline-devel
b5640c74 62BuildRequires: rpmbuild(macros) >= 1.647
e55d5c02 63BuildRequires: udev-devel >= 1:143
1ccfba6c 64%if %{with initrd}
fa9e8aeb 65%if %{with dietlibc}
39c8d1d5 66BuildRequires: dietlibc-static >= 2:0.32-7
fa9e8aeb
AM
67BuildConflicts: device-mapper-dietlibc
68%endif
b64b85c5
ER
69%if %{with glibc}
70%{?with_selinux:BuildRequires: libselinux-static}
71%{?with_selinux:BuildRequires: libsepol-static}
72%endif
c70b42f6
JR
73%{?with_glibc:BuildRequires: glibc-static}
74%{?with_uClibc:BuildRequires: uClibc-static >= 2:0.9.29}
1ccfba6c 75%endif
7e873dd0 76%if %{with cluster}
5f0ee085 77BuildRequires: corosync-devel
4cb4934b 78BuildRequires: dlm-devel >= 3.99.5
7d8cfaa5 79BuildRequires: systemd-devel
5f0ee085 80%endif
b5640c74 81Requires(post,preun,postun): systemd-units >= 38
0a81c260 82Requires(post,postun): /sbin/chkconfig
b167057a 83Requires: device-mapper >= %{version}-%{release}
0dc2b8f2 84%{?with_selinux:Requires: libselinux >= 1.10}
b5640c74 85Requires: systemd-units >= 38
1534f04d
ER
86# doesn't work with 2.4 kernels
87Requires: uname(release) >= 2.6
25b6b609 88Obsoletes: lvm
c35cea65 89Obsoletes: lvm2-systemd
7e72c866
JR
90BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92%define _sbindir /sbin
9ab13f24 93%define _usrsbindir /usr/sbin
7e72c866 94
0fbd6aae
ER
95# changing CFLAGS in the middle confuses confcache
96%undefine configure_cache
97
87a7d834
ER
98# borken on AC
99%define filterout_ld -Wl,--as-needed
100
4cb4934b
JK
101# causes: undefined reference to `__stack_chk_fail_local'
102%define filterout_c -fstack-protector
103
c70b42f6
JR
104# for some reason known only to rpm there must be "\\|" not "\|" here
105%define dietarch %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
106%define dietlibdir %{_prefix}/lib/dietlibc/lib-%{dietarch}
107
f8fa85d0
PS
108%define skip_post_check_so '.*libdevmapper-event-lvm2.so.*'
109
7e72c866
JR
110%description
111This package includes a number of utilities for creating, checking,
112and repairing logical volumes.
113
68d45726
JR
114%description -l pl.UTF-8
115Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
116logicznych wolumenów dyskowych (LVM2).
7e72c866 117
7e72c866 118%package initrd
5672aa67 119Summary: The new version of Logical Volume Manager for Linux - initrd version
6536e848 120Summary(pl.UTF-8): Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
7e72c866 121Group: Base
16ddcbd0 122Conflicts: geninitrd < 10000.18
7e72c866
JR
123
124%description initrd
125This package includes a number of utilities for creating, checking,
126and repairing logical volumes - staticaly linked for initrd.
127
68d45726
JR
128%description initrd -l pl.UTF-8
129Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
130logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
7e72c866
JR
131potrzeby initrd.
132
7e873dd0
JK
133%package clvmd
134Summary: Cluster LVM daemon
135Summary(pl.UTF-8): Demon clustra LVM
136Group: Applications/System
1aa2f585 137Requires: %{name} = %{version}-%{release}
7e873dd0
JK
138
139%description clvmd
4cb4934b
JK
140clvmd is the daemon that distributes LVM metadata updates around a
141cluster. It must be running on all nodes in the cluster and will give
142an error if a node in the cluster does not have this daemon running.
7e873dd0
JK
143
144%description clvmd -l pl.UTF-8
145clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
4cb4934b
JK
146Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
147węzeł w klastrze nie ma tego demona uruchomionego.
7e873dd0
JK
148
149%package cmirrord
150Summary: Cluster mirror log daemon
151Group: Applications/System
1aa2f585 152Requires: %{name} = %{version}-%{release}
7e873dd0
JK
153
154%description cmirrord
4cb4934b
JK
155cmirrord is the daemon that tracks mirror log information in a
156cluster. It is specific to device-mapper based mirrors (and by
157extension, LVM cluster mirrors). Cluster mirrors are not possible
158without this daemon running.
7e873dd0 159
4cb4934b
JK
160This daemon relies on the cluster infrastructure provided by the
161Cluster MANager (CMAN), which must be set up and running in order for
162cmirrord to function.
7e873dd0 163
e55d5c02
JB
164%package resource-agents
165Summary: OCF Resource Agents for LVM2 processes
166Summary(pl.UTF-8): Agenci OCF do monitorowania procesów LVM2
167Group: Applications/System
168Requires: %{name} = %{version}-%{release}
169Requires: resource-agents
170
171%description resource-agents
172OCF Resource Agents for LVM2 processes.
173
174%description resource-agents -l pl.UTF-8
175Agenci OCF do monitorowania procesów LVM2.
176
b167057a
AM
177%package -n device-mapper
178Summary: Userspace support for the device-mapper
179Summary(pl.UTF-8): Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
180Group: Base
e7dd8435 181Requires(post,postun): /sbin/ldconfig
798d7327 182Requires(post,preun,postun): systemd-units >= 38
b5640c74 183Requires: systemd-units >= 38
b167057a
AM
184
185%description -n device-mapper
186The goal of this driver is to support volume management. The driver
187enables the definition of new block devices composed of ranges of
188sectors of existing devices. This can be used to define disk
189partitions - or logical volumes. This light-weight kernel component
190can support user-space tools for logical volume management.
191
192%description -n device-mapper -l pl.UTF-8
193Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
194włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
195sektorów na istniejących urządzeniach. Może to być wykorzystane do
196definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
197składnik jądra może wspierać działające w przestrzeni użytkownika
198narzędzia do zarządzania logicznymi wolumenami.
199
200%package -n device-mapper-devel
201Summary: Header files and development documentation for %{name}
202Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do %{name}
203Group: Development/Libraries
204Requires: device-mapper = %{version}-%{release}
205%if %{with selinux}
206Requires: libselinux-devel
207Requires: libsepol-devel
208%endif
209
210%description -n device-mapper-devel
211Header files and development documentation for %{name}.
212
213%description -n device-mapper-devel -l pl.UTF-8
214Pliki nagłówkowe i dokumentacja do %{name}.
215
216%package -n device-mapper-static
217Summary: Static devmapper library
218Summary(pl.UTF-8): Statyczna biblioteka devmapper
219License: LGPL v2.1
220Group: Development/Libraries
dc900ced 221Requires: device-mapper-devel = %{version}-%{release}
b167057a
AM
222
223%description -n device-mapper-static
224Static devmapper library.
225
226%description -n device-mapper-static -l pl.UTF-8
227Statyczna biblioteka devmapper.
228
c70b42f6
JR
229%package -n device-mapper-dietlibc
230Summary: Static devmapper library built with dietlibc
231Summary(pl.UTF-8): Statyczna biblioteka devmapper zbudowana z dietlibc
232License: LGPL v2.1
233Group: Development/Libraries
234Requires: device-mapper-devel = %{version}-%{release}
235
236%description -n device-mapper-dietlibc
237Static devmapper library built with dietlibc.
238
239%description -n device-mapper-dietlibc -l pl.UTF-8
240Statyczna biblioteka devmapper zbudowana z dietlibc.
241
4a323c26
JR
242%package -n device-mapper-initrd
243Summary: Userspace support for the device-mapper - initrd version
244Summary(pl.UTF-8): Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
245Group: Base
246Obsoletes: device-mapper-initrd-devel
1f7434e8 247Conflicts: geninitrd < 10000.10
4a323c26
JR
248
249%description -n device-mapper-initrd
250The goal of this driver is to support volume management. The driver
251enables the definition of new block devices composed of ranges of
252sectors of existing devices. This can be used to define disk
253partitions - or logical volumes. This light-weight kernel component
254can support user-space tools for logical volume management.
255
256This package contains dmsetup program linked staticaly for use in
257initrd.
258
259%description -n device-mapper-initrd -l pl.UTF-8
260Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
261włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
262sektorów na istniejących urządzeniach. Może to być wykorzystane do
263definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
264składnik jądra może wspierać działające w przestrzeni użytkownika
265narzędzia do zarządzania logicznymi wolumenami.
266
267Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
268potrzeby initrd.
269
7e72c866 270%prep
ec2de926 271%setup -q -n LVM2.%{version}
7210a095 272%{?with_selinux:%patch0 -p1}
c70b42f6 273%patch1 -p1
9a00e98a 274%patch2 -p1
f0dab9f1 275%patch3 -p1
b747c17a 276%patch4 -p1
eaa437a5 277%patch6 -p1
7d8cfaa5 278%patch7 -p1
105f82c3 279%patch8 -p1
14fc1988 280%patch9 -p1
b167057a 281
39c8d1d5 282# do not force --export-symbol linker option for e.g. statically linked executables
b5eb9717
PS
283# -rdynamic compiler option drives linker in the right way.
284%{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
285
7e72c866 286%build
87a7d834
ER
287%if %{with initrd}
288echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
289%endif
242ffb9a 290cp -f /usr/share/automake/config.sub autoconf
7e72c866
JR
291%{__aclocal}
292%{__autoconf}
293
99958222 294%if %{with initrd}
6c31051f
PS
295%{?with_glibc:export CC="%{__cc}"}
296%{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
4cbea9f4 297%{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
6c31051f 298
9bdab2f4 299%configure \
a5702977 300 ac_cv_lib_dl_dlopen=no \
eaa437a5 301 %{?with_uClibc:ac_cv_func_siginterrupt=no} \
4c78aede 302 %{?debug:--enable-debug} \
43435358
JB
303 --disable-nls \
304 --disable-readline \
305 --enable-selinux%{!?with_glibc:=no} \
9bdab2f4 306 --enable-static_link \
69688a46 307 --with-lvm1=internal \
43435358 308 --with-optimisation="%{rpmcflags} -Os"
c70b42f6 309# glibc version links with normal static libdevicemapper which has selinux enabled
260d6858 310# and we need to keep these in sync between device-mapper and lvm2
4c78aede
ER
311
312%{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
0402cba0 313%{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
ec2de926 314
c7bbf0c8
AM
315%{__make} -j1 -C include
316%{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
317%{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
4cb4934b 318%{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
2afef789 319%{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
69688a46 320mv -f tools/lvm.static initrd-lvm
4a323c26 321mv -f tools/dmsetup.static initrd-dmsetup
7cef5d95
AM
322
323# check if tools works
324for tool in initrd-lvm initrd-dmsetup; do
cfa41a73 325 LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
7cef5d95 326 if [ $rc -gt 127 ]; then
cfa41a73 327 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
7cef5d95
AM
328 exit 1
329 fi
330done
331
332
c70b42f6 333%{?with_dietlibc:mv -f libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
9bdab2f4 334%{__make} clean
6c31051f
PS
335
336unset CC
7e72c866
JR
337%endif
338
9d0d1d5f 339%configure \
6e7a47a9 340 --enable-applib \
b167057a 341 --enable-cmdlib \
43435358 342 %{?debug:--enable-debug} \
b167057a 343 --enable-dmeventd \
43435358
JB
344 --enable-fsadm \
345 %{?with_lvmetad:--enable-lvmetad} \
e55d5c02 346 --enable-ocf \
43435358
JB
347 --enable-readline \
348 %{!?with_selinux:--disable-selinux} \
b167057a 349 --enable-pkgconfig \
5f0ee085
JB
350 --enable-udev_sync \
351 --enable-udev_rules \
43435358 352 --with-cluster=internal \
7e873dd0 353%if %{with cluster}
4cb4934b
JK
354 --with-clvmd=corosync \
355 --enable-cmirrord \
5cf18a89 356%endif
43435358
JB
357 --with-dmeventd-path=%{_sbindir}/dmeventd \
358 --with-interface=ioctl \
607d2229 359 --with-lvm1=internal \
43435358
JB
360 --with-mirrors=internal \
361 --with-optimisation="%{rpmcflags}" \
607d2229
AM
362 --with-pool=internal \
363 --with-snapshots=internal \
43435358 364 --with-systemdsystemunitdir=%{systemdunitdir} \
b5640c74 365 --with-thin=internal \
e55d5c02
JB
366 --with-thin-check=%{_sbindir}/thin_check \
367 --with-thin-dump=%{_sbindir}/thin_dump \
368 --with-thin-repair=%{_sbindir}/thin_repair \
589f4db4 369 --with-udev-prefix=/ \
43435358 370 --with-usrlibdir=%{_libdir}
589f4db4 371
b167057a 372%{__make} -j1
c7bbf0c8 373%{__make} -j1 -C libdm LIB_STATIC=libdevmapper.a
7e72c866
JR
374
375%install
376rm -rf $RPM_BUILD_ROOT
0d673991 377install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
c70b42f6 378%{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
7e72c866 379
9b82b6a5 380%{__make} install install_system_dirs install_systemd_units install_initscripts \
7e72c866 381 DESTDIR=$RPM_BUILD_ROOT \
1ccfba6c
AM
382 OWNER="" \
383 GROUP=""
7e72c866 384
4cb4934b 385install -d $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d
798d7327 386cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/%{name}.conf
9b82b6a5 387
0d673991 388%if %{with cluster}
798d7327
ER
389cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/clvmd.service
390cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/clvmd
0d673991
JK
391%endif
392
b167057a
AM
393mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
394for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
395 lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
396 slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
397 ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
398done
399
1cfc154f
JR
400touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
401
88c67b5b
JR
402%if %{with initrd}
403install -d $RPM_BUILD_ROOT%{_libdir}/initrd
a3569314
ER
404install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
405install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
7e72c866 406
a3569314 407%{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
1306038e 408%endif
c70b42f6 409
a3569314 410cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
b167057a 411
7e72c866
JR
412%clean
413rm -rf $RPM_BUILD_ROOT
414
6e7a47a9
AM
415%post
416/sbin/chkconfig --add lvm2-monitor
417%service lvm2-monitor restart
c35cea65 418%systemd_post lvm2-monitor.service
4cb4934b
JK
419/sbin/chkconfig --add blk-availability
420# no service blk-availability restart
421%systemd_post blk-availability.service
c35cea65
JR
422
423%preun
424%systemd_preun lvm2-monitor.service
4cb4934b 425%systemd_preun blk-availability.service
6e7a47a9
AM
426
427%postun
428if [ "$1" = "0" ]; then
429 %service lvm2-monitor stop
430 /sbin/chkconfig --del lvm2-monitor
4cb4934b
JK
431 #no service blk-availability stop
432 /sbin/chkconfig --del blk-availability
6e7a47a9 433fi
c35cea65 434%systemd_reload
6e7a47a9 435
c35cea65
JR
436%triggerpostun -- %{name} < 2.02.94-1
437%systemd_trigger lvm2-monitor.service
b167057a 438
c35cea65
JR
439%post -n device-mapper
440/sbin/ldconfig
441%systemd_post dm-event.socket
9b82b6a5 442
c35cea65
JR
443%preun -n device-mapper
444%systemd_preun dm-event.socket dm-event.service
9b82b6a5 445
c35cea65
JR
446%postun -n device-mapper
447/sbin/ldconfig
9b82b6a5
BZ
448%systemd_reload
449
c35cea65
JR
450%triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
451%systemd_trigger dm-event.socket
452
161d6a19
JK
453%post clvmd
454/sbin/chkconfig --add clvmd
455# no service restart - it breaks current locks!
456export NORESTART=1
457%systemd_post clvmd.service
458# re-exec instead
459/usr/sbin/clvmd -S 2>/dev/null || :
460
461%preun clvmd
462%systemd_preun clvmd.service
463
464%postun clvmd
465if [ "$1" = "0" ]; then
466 %service clvmd stop
467 /sbin/chkconfig --del clvmd
468fi
469%systemd_reload
470
7e72c866
JR
471%files
472%defattr(644,root,root,755)
e6ac7970 473%doc README WHATS_NEW doc/*
4cb4934b 474%attr(755,root,root) %{_sbindir}/blkdeactivate
86418c14
JB
475%attr(755,root,root) %{_sbindir}/fsadm
476%attr(755,root,root) %{_sbindir}/lv*
477%attr(755,root,root) %{_sbindir}/pv*
478%attr(755,root,root) %{_sbindir}/vg*
86418c14 479%{_mandir}/man5/lvm.conf.5*
0442bdaf 480%{_mandir}/man7/lvmthin.7*
4cb4934b 481%{_mandir}/man8/blkdeactivate.8*
86418c14
JB
482%{_mandir}/man8/fsadm.8*
483%{_mandir}/man8/lv*.8*
484%{_mandir}/man8/pv*.8*
485%{_mandir}/man8/vg*.8*
99958222 486%attr(750,root,root) %dir %{_sysconfdir}/lvm
2316bf4d 487%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
e55d5c02 488%attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
bfc9ab17
JB
489%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
490%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
491%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
ac328eef 492%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
43435358
JB
493%if %{with lvmetad}
494/lib/udev/rules.d/69-dm-lvm-metad.rules
495%endif
c35cea65 496%{_sysconfdir}/tmpfiles.d/lvm2.conf
4cb4934b 497%{systemdunitdir}/blk-availability.service
43435358
JB
498%if %{with lvmetad}
499%{systemdunitdir}/lvm2-lvmetad.service
500%{systemdunitdir}/lvm2-lvmetad.socket
501%endif
502%{systemdunitdir}/lvm2-monitor.service
503%{systemdunitdir}/lvm2-pvscan@.service
6e7a47a9
AM
504%dir %{_sysconfdir}/lvm/cache
505%ghost %{_sysconfdir}/lvm/cache/.cache
4cb4934b 506%attr(754,root,root) /etc/rc.d/init.d/blk-availability
43435358
JB
507%if %{with lvmetad}
508%attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmetad
509%endif
6e7a47a9 510%attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
5388840f 511%dir %attr(700,root,root) /var/run/lvm
7e873dd0
JK
512
513%if %{with cluster}
514%files clvmd
515%defattr(644,root,root,755)
516%attr(755,root,root) %{_usrsbindir}/clvmd
517%attr(754,root,root) /etc/rc.d/init.d/clvmd
0d673991 518%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clvmd
0442bdaf 519%attr(755,root,root) /lib/systemd/lvm2-cluster-activation
0d673991 520%{systemdunitdir}/clvmd.service
0442bdaf
JB
521%{systemdunitdir}/lvm2-cluster-activation.service
522%{systemdunitdir}/lvm2-clvmd.service
7e873dd0
JK
523%{_mandir}/man8/clvmd.8*
524
7e873dd0
JK
525%files cmirrord
526%defattr(644,root,root,755)
527%attr(755,root,root) %{_usrsbindir}/cmirrord
7e873dd0 528%attr(754,root,root) /etc/rc.d/init.d/cmirrord
0442bdaf
JB
529%{systemdunitdir}/lvm2-cmirrord.service
530%{_mandir}/man8/cmirrord.8*
7e873dd0 531%endif
7e72c866 532
e55d5c02
JB
533%files resource-agents
534%defattr(644,root,root,755)
535%dir %{_prefix}/lib/ocf/resource.d/lvm2
536%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
537
b167057a
AM
538%files -n device-mapper
539%defattr(644,root,root,755)
540%doc *_DM
c35cea65
JR
541%{systemdunitdir}/dm-event.service
542%{systemdunitdir}/dm-event.socket
589f4db4
JR
543/lib/udev/rules.d/10-dm.rules
544/lib/udev/rules.d/11-dm-lvm.rules
545/lib/udev/rules.d/13-dm-disk.rules
546/lib/udev/rules.d/95-dm-notify.rules
b167057a
AM
547%attr(755,root,root) %{_sbindir}/dmeventd
548%attr(755,root,root) %{_sbindir}/dmsetup
549%attr(755,root,root) /%{_lib}/libdevmapper*.so.*.*
6e7a47a9 550%attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
b167057a 551%attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
1306038e
AM
552%dir %{_libdir}/device-mapper
553%attr(755,root,root) %{_libdir}/device-mapper/*.so
bece12dd 554%attr(755,root,root) %{_libdir}/libdevmapper-event-*.so
b167057a 555%{_mandir}/man8/dmsetup.8*
f0dab9f1 556%{_mandir}/man8/dmeventd.8*
b167057a
AM
557
558%files -n device-mapper-devel
559%defattr(644,root,root,755)
bece12dd
JR
560%attr(755,root,root) %{_libdir}/libdevmapper.so
561%attr(755,root,root) %{_libdir}/libdevmapper-event.so
6e7a47a9 562%attr(755,root,root) %{_libdir}/liblvm2app.so
b167057a
AM
563%attr(755,root,root) %{_libdir}/liblvm2cmd.so
564%{_includedir}/libdevmapper*.h
6e7a47a9 565%{_includedir}/lvm2app.h
b167057a
AM
566%{_includedir}/lvm2cmd.h
567%{_pkgconfigdir}/devmapper*.pc
6e7a47a9 568%{_pkgconfigdir}/lvm2app.pc
b167057a
AM
569
570%files -n device-mapper-static
571%defattr(644,root,root,755)
572%{_libdir}/libdevmapper*.a
573
1306038e 574%if %{with initrd}
c70b42f6
JR
575%if %{with dietlibc}
576%files -n device-mapper-dietlibc
577%defattr(644,root,root,755)
578%{dietlibdir}/libdevmapper.a
579%endif
580
4a323c26
JR
581%files -n device-mapper-initrd
582%defattr(644,root,root,755)
88c67b5b 583%attr(755,root,root) %{_libdir}/initrd/dmsetup
4a323c26 584
7e72c866
JR
585%files initrd
586%defattr(644,root,root,755)
88c67b5b 587%attr(755,root,root) %{_libdir}/initrd/lvm
7e72c866 588%endif
This page took 0.174683 seconds and 4 git commands to generate.