]> git.pld-linux.org Git - packages/lvm2.git/blame - lvm2.spec
- disable initrd package
[packages/lvm2.git] / lvm2.spec
CommitLineData
e3a928dc 1# TODO
e3a928dc 2# - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
5f0ee085 3# - --with-replicators (=internal/shared/none, default is none)?
1b67453e 4#
99958222 5# Conditional build:
8b89021c 6%bcond_with initrd # don't build initrd version
fe052975
JR
7%bcond_without uClibc # link initrd version with uClibc
8%bcond_with dietlibc # link initrd version with dietlibc
5f0ee085 9%bcond_with glibc # link initrd version with static GLIBC
7e873dd0 10%bcond_without cluster # disable all cluster support (clvmd&cmirrord)
43435358 11%bcond_without lvmetad # disable lvmetad
c70b42f6
JR
12%bcond_without selinux # disable SELinux
13
4a323c26 14%ifarch sparc64 sparc
c70b42f6 15%define with_glibc 1
66800f6a 16%endif
c70b42f6
JR
17
18# if one of the *libc is enabled disable default dietlibc
19%if %{with dietlibc} && %{with uClibc}
20%undefine with_dietlibc
21%endif
22
f1e27504 23# with glibc disables default dietlibc
c70b42f6
JR
24%if %{with glibc} && %{with dietlibc}
25%undefine with_dietlibc
26%endif
27
f1e27504
ER
28# fallback is glibc if neither alternatives are enabled
29%if %{without dietlibc} && %{without uClibc}
30%define with_glibc 1
31%endif
32
5672aa67 33Summary: The new version of Logical Volume Manager for Linux
6536e848 34Summary(pl.UTF-8): Nowa wersja Logical Volume Managera dla Linuksa
7e72c866 35Name: lvm2
43435358 36Version: 2.02.104
8b89021c 37Release: 2
0a81c260 38License: GPL v2 and LGPL v2.1
7e72c866 39Group: Applications/System
dc5d0e77 40Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
43435358 41# Source0-md5: 3d82cdb63259b4386c0cc308b4e1f221
c386faf9 42Source1: %{name}-tmpfiles.conf
0d673991
JK
43Source2: clvmd.service
44Source3: clvmd.sysconfig
7210a095 45Patch0: %{name}-selinux.patch
c70b42f6 46Patch1: %{name}-diet.patch
9a00e98a 47Patch2: device-mapper-dmsetup-export.patch
4cb4934b 48Patch3: %{name}-pld_init.patch
b747c17a 49Patch4: dl-dlsym.patch
4cb4934b
JK
50Patch5: %{name}-wrapper.patch
51Patch6: %{name}-lvm_path.patch
7d8cfaa5 52Patch7: %{name}-sd_notify.patch
105f82c3 53Patch8: %{name}-clvmd_cmd_timeout.patch
14fc1988 54Patch9: device-mapper-dmsetup-deps-export.patch
dc5d0e77 55URL: http://sources.redhat.com/lvm2/
5f0ee085 56BuildRequires: autoconf >= 2.61
7e72c866 57BuildRequires: automake
0dc2b8f2 58%{?with_selinux:BuildRequires: libselinux-devel >= 1.10}
e4a12efb 59%{?with_selinux:BuildRequires: libsepol-devel}
5f0ee085 60BuildRequires: ncurses-devel
3657a56d 61BuildRequires: pkgconfig
5f0ee085 62BuildRequires: readline-devel
b5640c74 63BuildRequires: rpmbuild(macros) >= 1.647
e55d5c02 64BuildRequires: udev-devel >= 1:143
1ccfba6c 65%if %{with initrd}
fa9e8aeb 66%if %{with dietlibc}
39c8d1d5 67BuildRequires: dietlibc-static >= 2:0.32-7
fa9e8aeb
AM
68BuildConflicts: device-mapper-dietlibc
69%endif
b64b85c5
ER
70%if %{with glibc}
71%{?with_selinux:BuildRequires: libselinux-static}
72%{?with_selinux:BuildRequires: libsepol-static}
73%endif
c70b42f6
JR
74%{?with_glibc:BuildRequires: glibc-static}
75%{?with_uClibc:BuildRequires: uClibc-static >= 2:0.9.29}
1ccfba6c 76%endif
7e873dd0 77%if %{with cluster}
5f0ee085 78BuildRequires: corosync-devel
4cb4934b 79BuildRequires: dlm-devel >= 3.99.5
7d8cfaa5 80BuildRequires: systemd-devel
5f0ee085 81%endif
b5640c74 82Requires(post,preun,postun): systemd-units >= 38
0a81c260 83Requires(post,postun): /sbin/chkconfig
b167057a 84Requires: device-mapper >= %{version}-%{release}
0dc2b8f2 85%{?with_selinux:Requires: libselinux >= 1.10}
b5640c74 86Requires: systemd-units >= 38
1534f04d
ER
87# doesn't work with 2.4 kernels
88Requires: uname(release) >= 2.6
25b6b609 89Obsoletes: lvm
c35cea65 90Obsoletes: lvm2-systemd
7e72c866
JR
91BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93%define _sbindir /sbin
9ab13f24 94%define _usrsbindir /usr/sbin
7e72c866 95
0fbd6aae
ER
96# changing CFLAGS in the middle confuses confcache
97%undefine configure_cache
98
87a7d834
ER
99# borken on AC
100%define filterout_ld -Wl,--as-needed
101
4cb4934b
JK
102# causes: undefined reference to `__stack_chk_fail_local'
103%define filterout_c -fstack-protector
104
c70b42f6
JR
105# for some reason known only to rpm there must be "\\|" not "\|" here
106%define dietarch %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
107%define dietlibdir %{_prefix}/lib/dietlibc/lib-%{dietarch}
108
f8fa85d0
PS
109%define skip_post_check_so '.*libdevmapper-event-lvm2.so.*'
110
7e72c866
JR
111%description
112This package includes a number of utilities for creating, checking,
113and repairing logical volumes.
114
68d45726
JR
115%description -l pl.UTF-8
116Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
117logicznych wolumenów dyskowych (LVM2).
7e72c866 118
7e72c866 119%package initrd
5672aa67 120Summary: The new version of Logical Volume Manager for Linux - initrd version
6536e848 121Summary(pl.UTF-8): Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
7e72c866 122Group: Base
16ddcbd0 123Conflicts: geninitrd < 10000.18
7e72c866
JR
124
125%description initrd
126This package includes a number of utilities for creating, checking,
127and repairing logical volumes - staticaly linked for initrd.
128
68d45726
JR
129%description initrd -l pl.UTF-8
130Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
131logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
7e72c866
JR
132potrzeby initrd.
133
7e873dd0
JK
134%package clvmd
135Summary: Cluster LVM daemon
136Summary(pl.UTF-8): Demon clustra LVM
137Group: Applications/System
1aa2f585 138Requires: %{name} = %{version}-%{release}
7e873dd0
JK
139
140%description clvmd
4cb4934b
JK
141clvmd is the daemon that distributes LVM metadata updates around a
142cluster. It must be running on all nodes in the cluster and will give
143an error if a node in the cluster does not have this daemon running.
7e873dd0
JK
144
145%description clvmd -l pl.UTF-8
146clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
4cb4934b
JK
147Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
148węzeł w klastrze nie ma tego demona uruchomionego.
7e873dd0
JK
149
150%package cmirrord
151Summary: Cluster mirror log daemon
152Group: Applications/System
1aa2f585 153Requires: %{name} = %{version}-%{release}
7e873dd0
JK
154
155%description cmirrord
4cb4934b
JK
156cmirrord is the daemon that tracks mirror log information in a
157cluster. It is specific to device-mapper based mirrors (and by
158extension, LVM cluster mirrors). Cluster mirrors are not possible
159without this daemon running.
7e873dd0 160
4cb4934b
JK
161This daemon relies on the cluster infrastructure provided by the
162Cluster MANager (CMAN), which must be set up and running in order for
163cmirrord to function.
7e873dd0 164
e55d5c02
JB
165%package resource-agents
166Summary: OCF Resource Agents for LVM2 processes
167Summary(pl.UTF-8): Agenci OCF do monitorowania procesów LVM2
168Group: Applications/System
169Requires: %{name} = %{version}-%{release}
170Requires: resource-agents
171
172%description resource-agents
173OCF Resource Agents for LVM2 processes.
174
175%description resource-agents -l pl.UTF-8
176Agenci OCF do monitorowania procesów LVM2.
177
b167057a
AM
178%package -n device-mapper
179Summary: Userspace support for the device-mapper
180Summary(pl.UTF-8): Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
181Group: Base
e7dd8435 182Requires(post,postun): /sbin/ldconfig
b5640c74 183Requires: systemd-units >= 38
b167057a
AM
184
185%description -n device-mapper
186The goal of this driver is to support volume management. The driver
187enables the definition of new block devices composed of ranges of
188sectors of existing devices. This can be used to define disk
189partitions - or logical volumes. This light-weight kernel component
190can support user-space tools for logical volume management.
191
192%description -n device-mapper -l pl.UTF-8
193Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
194włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
195sektorów na istniejących urządzeniach. Może to być wykorzystane do
196definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
197składnik jądra może wspierać działające w przestrzeni użytkownika
198narzędzia do zarządzania logicznymi wolumenami.
199
200%package -n device-mapper-devel
201Summary: Header files and development documentation for %{name}
202Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do %{name}
203Group: Development/Libraries
204Requires: device-mapper = %{version}-%{release}
205%if %{with selinux}
206Requires: libselinux-devel
207Requires: libsepol-devel
208%endif
209
210%description -n device-mapper-devel
211Header files and development documentation for %{name}.
212
213%description -n device-mapper-devel -l pl.UTF-8
214Pliki nagłówkowe i dokumentacja do %{name}.
215
216%package -n device-mapper-static
217Summary: Static devmapper library
218Summary(pl.UTF-8): Statyczna biblioteka devmapper
219License: LGPL v2.1
220Group: Development/Libraries
dc900ced 221Requires: device-mapper-devel = %{version}-%{release}
b167057a
AM
222
223%description -n device-mapper-static
224Static devmapper library.
225
226%description -n device-mapper-static -l pl.UTF-8
227Statyczna biblioteka devmapper.
228
c70b42f6
JR
229%package -n device-mapper-dietlibc
230Summary: Static devmapper library built with dietlibc
231Summary(pl.UTF-8): Statyczna biblioteka devmapper zbudowana z dietlibc
232License: LGPL v2.1
233Group: Development/Libraries
234Requires: device-mapper-devel = %{version}-%{release}
235
236%description -n device-mapper-dietlibc
237Static devmapper library built with dietlibc.
238
239%description -n device-mapper-dietlibc -l pl.UTF-8
240Statyczna biblioteka devmapper zbudowana z dietlibc.
241
4a323c26
JR
242%package -n device-mapper-initrd
243Summary: Userspace support for the device-mapper - initrd version
244Summary(pl.UTF-8): Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
245Group: Base
246Obsoletes: device-mapper-initrd-devel
1f7434e8 247Conflicts: geninitrd < 10000.10
4a323c26
JR
248
249%description -n device-mapper-initrd
250The goal of this driver is to support volume management. The driver
251enables the definition of new block devices composed of ranges of
252sectors of existing devices. This can be used to define disk
253partitions - or logical volumes. This light-weight kernel component
254can support user-space tools for logical volume management.
255
256This package contains dmsetup program linked staticaly for use in
257initrd.
258
259%description -n device-mapper-initrd -l pl.UTF-8
260Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
261włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
262sektorów na istniejących urządzeniach. Może to być wykorzystane do
263definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
264składnik jądra może wspierać działające w przestrzeni użytkownika
265narzędzia do zarządzania logicznymi wolumenami.
266
267Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
268potrzeby initrd.
269
7e72c866 270%prep
ec2de926 271%setup -q -n LVM2.%{version}
7210a095 272%{?with_selinux:%patch0 -p1}
c70b42f6 273%patch1 -p1
9a00e98a 274%patch2 -p1
f0dab9f1 275%patch3 -p1
b747c17a 276%patch4 -p1
b08139b7 277%patch5 -p1
eaa437a5 278%patch6 -p1
7d8cfaa5 279%patch7 -p1
105f82c3 280%patch8 -p1
14fc1988 281%patch9 -p1
b167057a 282
39c8d1d5 283# do not force --export-symbol linker option for e.g. statically linked executables
b5eb9717
PS
284# -rdynamic compiler option drives linker in the right way.
285%{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
286
7e72c866 287%build
87a7d834
ER
288%if %{with initrd}
289echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
290%endif
242ffb9a 291cp -f /usr/share/automake/config.sub autoconf
7e72c866
JR
292%{__aclocal}
293%{__autoconf}
294
99958222 295%if %{with initrd}
6c31051f
PS
296%{?with_glibc:export CC="%{__cc}"}
297%{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
4cbea9f4 298%{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
6c31051f 299
9bdab2f4 300%configure \
a5702977 301 ac_cv_lib_dl_dlopen=no \
eaa437a5 302 %{?with_uClibc:ac_cv_func_siginterrupt=no} \
4c78aede 303 %{?debug:--enable-debug} \
43435358
JB
304 --disable-nls \
305 --disable-readline \
306 --enable-selinux%{!?with_glibc:=no} \
9bdab2f4 307 --enable-static_link \
69688a46 308 --with-lvm1=internal \
43435358 309 --with-optimisation="%{rpmcflags} -Os"
c70b42f6 310# glibc version links with normal static libdevicemapper which has selinux enabled
260d6858 311# and we need to keep these in sync between device-mapper and lvm2
4c78aede
ER
312
313%{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
0402cba0 314%{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
ec2de926 315
c7bbf0c8
AM
316%{__make} -j1 -C include
317%{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
318%{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
4cb4934b 319%{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
2afef789 320%{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
69688a46 321mv -f tools/lvm.static initrd-lvm
4a323c26 322mv -f tools/dmsetup.static initrd-dmsetup
7cef5d95
AM
323
324# check if tools works
325for tool in initrd-lvm initrd-dmsetup; do
cfa41a73 326 LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
7cef5d95 327 if [ $rc -gt 127 ]; then
cfa41a73 328 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
7cef5d95
AM
329 exit 1
330 fi
331done
332
333
c70b42f6 334%{?with_dietlibc:mv -f libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
9bdab2f4 335%{__make} clean
6c31051f
PS
336
337unset CC
7e72c866
JR
338%endif
339
9d0d1d5f 340%configure \
6e7a47a9 341 --enable-applib \
b167057a 342 --enable-cmdlib \
43435358 343 %{?debug:--enable-debug} \
b167057a 344 --enable-dmeventd \
43435358
JB
345 --enable-fsadm \
346 %{?with_lvmetad:--enable-lvmetad} \
e55d5c02 347 --enable-ocf \
43435358
JB
348 --enable-readline \
349 %{!?with_selinux:--disable-selinux} \
b167057a 350 --enable-pkgconfig \
5f0ee085
JB
351 --enable-udev_sync \
352 --enable-udev_rules \
43435358 353 --with-cluster=internal \
7e873dd0 354%if %{with cluster}
4cb4934b
JK
355 --with-clvmd=corosync \
356 --enable-cmirrord \
5cf18a89 357%endif
43435358
JB
358 --with-dmeventd-path=%{_sbindir}/dmeventd \
359 --with-interface=ioctl \
607d2229 360 --with-lvm1=internal \
43435358
JB
361 --with-mirrors=internal \
362 --with-optimisation="%{rpmcflags}" \
607d2229
AM
363 --with-pool=internal \
364 --with-snapshots=internal \
43435358 365 --with-systemdsystemunitdir=%{systemdunitdir} \
b5640c74 366 --with-thin=internal \
e55d5c02
JB
367 --with-thin-check=%{_sbindir}/thin_check \
368 --with-thin-dump=%{_sbindir}/thin_dump \
369 --with-thin-repair=%{_sbindir}/thin_repair \
589f4db4 370 --with-udev-prefix=/ \
43435358 371 --with-usrlibdir=%{_libdir}
589f4db4 372
b167057a 373%{__make} -j1
c7bbf0c8 374%{__make} -j1 -C libdm LIB_STATIC=libdevmapper.a
7e72c866
JR
375
376%install
377rm -rf $RPM_BUILD_ROOT
0d673991 378install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
c70b42f6 379%{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
7e72c866 380
9b82b6a5 381%{__make} install install_system_dirs install_systemd_units install_initscripts \
7e72c866 382 DESTDIR=$RPM_BUILD_ROOT \
1ccfba6c
AM
383 OWNER="" \
384 GROUP=""
7e72c866 385
4cb4934b
JK
386install -d $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d
387install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/%{name}.conf
9b82b6a5 388
0d673991
JK
389%if %{with cluster}
390install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/clvmd.service
391install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/clvmd
392%endif
393
b167057a
AM
394mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
395for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
396 lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
397 slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
398 ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
399done
400
1cfc154f
JR
401touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
402
88c67b5b
JR
403%if %{with initrd}
404install -d $RPM_BUILD_ROOT%{_libdir}/initrd
a3569314
ER
405install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
406install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
7e72c866 407
a3569314 408%{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
1306038e 409%endif
c70b42f6 410
a3569314 411cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
b167057a 412
7e72c866
JR
413%clean
414rm -rf $RPM_BUILD_ROOT
415
6e7a47a9
AM
416%post
417/sbin/chkconfig --add lvm2-monitor
418%service lvm2-monitor restart
c35cea65 419%systemd_post lvm2-monitor.service
4cb4934b
JK
420/sbin/chkconfig --add blk-availability
421# no service blk-availability restart
422%systemd_post blk-availability.service
c35cea65
JR
423
424%preun
425%systemd_preun lvm2-monitor.service
4cb4934b 426%systemd_preun blk-availability.service
6e7a47a9
AM
427
428%postun
429if [ "$1" = "0" ]; then
430 %service lvm2-monitor stop
431 /sbin/chkconfig --del lvm2-monitor
4cb4934b
JK
432 #no service blk-availability stop
433 /sbin/chkconfig --del blk-availability
6e7a47a9 434fi
c35cea65 435%systemd_reload
6e7a47a9 436
c35cea65
JR
437%triggerpostun -- %{name} < 2.02.94-1
438%systemd_trigger lvm2-monitor.service
b167057a 439
c35cea65
JR
440%post -n device-mapper
441/sbin/ldconfig
442%systemd_post dm-event.socket
9b82b6a5 443
c35cea65
JR
444%preun -n device-mapper
445%systemd_preun dm-event.socket dm-event.service
9b82b6a5 446
c35cea65
JR
447%postun -n device-mapper
448/sbin/ldconfig
9b82b6a5
BZ
449%systemd_reload
450
c35cea65
JR
451%triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
452%systemd_trigger dm-event.socket
453
161d6a19
JK
454%post clvmd
455/sbin/chkconfig --add clvmd
456# no service restart - it breaks current locks!
457export NORESTART=1
458%systemd_post clvmd.service
459# re-exec instead
460/usr/sbin/clvmd -S 2>/dev/null || :
461
462%preun clvmd
463%systemd_preun clvmd.service
464
465%postun clvmd
466if [ "$1" = "0" ]; then
467 %service clvmd stop
468 /sbin/chkconfig --del clvmd
469fi
470%systemd_reload
471
7e72c866
JR
472%files
473%defattr(644,root,root,755)
e6ac7970 474%doc README WHATS_NEW doc/*
4cb4934b 475%attr(755,root,root) %{_sbindir}/blkdeactivate
86418c14
JB
476%attr(755,root,root) %{_sbindir}/fsadm
477%attr(755,root,root) %{_sbindir}/lv*
478%attr(755,root,root) %{_sbindir}/pv*
479%attr(755,root,root) %{_sbindir}/vg*
86418c14 480%{_mandir}/man5/lvm.conf.5*
4cb4934b 481%{_mandir}/man8/blkdeactivate.8*
86418c14
JB
482%{_mandir}/man8/fsadm.8*
483%{_mandir}/man8/lv*.8*
484%{_mandir}/man8/pv*.8*
485%{_mandir}/man8/vg*.8*
99958222 486%attr(750,root,root) %dir %{_sysconfdir}/lvm
2316bf4d 487%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
e55d5c02
JB
488%attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
489%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/default.profile
ac328eef 490%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
43435358
JB
491%if %{with lvmetad}
492/lib/udev/rules.d/69-dm-lvm-metad.rules
493%endif
c35cea65 494%{_sysconfdir}/tmpfiles.d/lvm2.conf
4cb4934b 495%{systemdunitdir}/blk-availability.service
43435358
JB
496%if %{with lvmetad}
497%{systemdunitdir}/lvm2-lvmetad.service
498%{systemdunitdir}/lvm2-lvmetad.socket
499%endif
500%{systemdunitdir}/lvm2-monitor.service
501%{systemdunitdir}/lvm2-pvscan@.service
6e7a47a9
AM
502%dir %{_sysconfdir}/lvm/cache
503%ghost %{_sysconfdir}/lvm/cache/.cache
4cb4934b 504%attr(754,root,root) /etc/rc.d/init.d/blk-availability
43435358
JB
505%if %{with lvmetad}
506%attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmetad
507%endif
6e7a47a9 508%attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
5388840f 509%dir %attr(700,root,root) /var/run/lvm
7e873dd0
JK
510
511%if %{with cluster}
512%files clvmd
513%defattr(644,root,root,755)
514%attr(755,root,root) %{_usrsbindir}/clvmd
515%attr(754,root,root) /etc/rc.d/init.d/clvmd
0d673991
JK
516%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clvmd
517%{systemdunitdir}/clvmd.service
7e873dd0
JK
518%{_mandir}/man8/clvmd.8*
519
7e873dd0
JK
520%files cmirrord
521%defattr(644,root,root,755)
522%attr(755,root,root) %{_usrsbindir}/cmirrord
523%{_mandir}/man8/cmirrord.8*
524%attr(754,root,root) /etc/rc.d/init.d/cmirrord
525%endif
7e72c866 526
e55d5c02
JB
527%files resource-agents
528%defattr(644,root,root,755)
529%dir %{_prefix}/lib/ocf/resource.d/lvm2
530%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
531
b167057a
AM
532%files -n device-mapper
533%defattr(644,root,root,755)
534%doc *_DM
c35cea65
JR
535%{systemdunitdir}/dm-event.service
536%{systemdunitdir}/dm-event.socket
589f4db4
JR
537/lib/udev/rules.d/10-dm.rules
538/lib/udev/rules.d/11-dm-lvm.rules
539/lib/udev/rules.d/13-dm-disk.rules
540/lib/udev/rules.d/95-dm-notify.rules
b167057a
AM
541%attr(755,root,root) %{_sbindir}/dmeventd
542%attr(755,root,root) %{_sbindir}/dmsetup
543%attr(755,root,root) /%{_lib}/libdevmapper*.so.*.*
6e7a47a9 544%attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
b167057a 545%attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
1306038e
AM
546%dir %{_libdir}/device-mapper
547%attr(755,root,root) %{_libdir}/device-mapper/*.so
bece12dd 548%attr(755,root,root) %{_libdir}/libdevmapper-event-*.so
b167057a 549%{_mandir}/man8/dmsetup.8*
f0dab9f1 550%{_mandir}/man8/dmeventd.8*
b167057a
AM
551
552%files -n device-mapper-devel
553%defattr(644,root,root,755)
bece12dd
JR
554%attr(755,root,root) %{_libdir}/libdevmapper.so
555%attr(755,root,root) %{_libdir}/libdevmapper-event.so
6e7a47a9 556%attr(755,root,root) %{_libdir}/liblvm2app.so
b167057a
AM
557%attr(755,root,root) %{_libdir}/liblvm2cmd.so
558%{_includedir}/libdevmapper*.h
6e7a47a9 559%{_includedir}/lvm2app.h
b167057a
AM
560%{_includedir}/lvm2cmd.h
561%{_pkgconfigdir}/devmapper*.pc
6e7a47a9 562%{_pkgconfigdir}/lvm2app.pc
b167057a
AM
563
564%files -n device-mapper-static
565%defattr(644,root,root,755)
566%{_libdir}/libdevmapper*.a
567
1306038e 568%if %{with initrd}
c70b42f6
JR
569%if %{with dietlibc}
570%files -n device-mapper-dietlibc
571%defattr(644,root,root,755)
572%{dietlibdir}/libdevmapper.a
573%endif
574
4a323c26
JR
575%files -n device-mapper-initrd
576%defattr(644,root,root,755)
88c67b5b 577%attr(755,root,root) %{_libdir}/initrd/dmsetup
4a323c26 578
7e72c866
JR
579%files initrd
580%defattr(644,root,root,755)
88c67b5b 581%attr(755,root,root) %{_libdir}/initrd/lvm
7e72c866 582%endif
This page took 0.157738 seconds and 4 git commands to generate.