]> git.pld-linux.org Git - packages/lvm2.git/blame - lvm2.spec
- make sure initrd tools work
[packages/lvm2.git] / lvm2.spec
CommitLineData
e3a928dc 1# TODO
e3a928dc 2# - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
5f0ee085
JB
3# - --with-replicators (=internal/shared/none, default is none)?
4# - OCF agents?
1b67453e 5#
99958222 6# Conditional build:
c70b42f6 7%bcond_without initrd # don't build initrd version
a94caa6a
JR
8%bcond_without uClibc # link initrd version with uClibc
9%bcond_with dietlibc # link initrd version with dietlibc
5f0ee085 10%bcond_with glibc # link initrd version with static GLIBC
c70b42f6 11%bcond_without clvmd # don't build clvmd
5f0ee085
JB
12%bcond_with clvmd3 # build clvmd for 3rd generation of cluster
13%bcond_with openais # enable corosync&openais managers and cmirrord
c70b42f6
JR
14%bcond_without selinux # disable SELinux
15
4a323c26 16%ifarch sparc64 sparc
c70b42f6 17%define with_glibc 1
66800f6a 18%endif
c70b42f6
JR
19
20# if one of the *libc is enabled disable default dietlibc
21%if %{with dietlibc} && %{with uClibc}
22%undefine with_dietlibc
23%endif
24
f1e27504 25# with glibc disables default dietlibc
c70b42f6
JR
26%if %{with glibc} && %{with dietlibc}
27%undefine with_dietlibc
28%endif
29
f1e27504
ER
30# fallback is glibc if neither alternatives are enabled
31%if %{without dietlibc} && %{without uClibc}
32%define with_glibc 1
33%endif
34
87a7d834 35%if %{with clvmd3}
f0dab9f1 36%undefine with_clvmd
37%endif
38
5672aa67 39Summary: The new version of Logical Volume Manager for Linux
6536e848 40Summary(pl.UTF-8): Nowa wersja Logical Volume Managera dla Linuksa
7e72c866 41Name: lvm2
c35cea65 42Version: 2.02.94
a94caa6a 43Release: 2
1738b891 44License: GPL v2
7e72c866 45Group: Applications/System
dc5d0e77 46Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
c35cea65 47# Source0-md5: 5ca593ec1a0b15902ce3da0fb13ea17b
bf171b20
JR
48Source1: %{name}-initramfs-hook
49Source2: %{name}-initramfs-local-top
9b82b6a5 50Source3: %{name}-tmpfiles.conf
7210a095 51Patch0: %{name}-selinux.patch
c70b42f6 52Patch1: %{name}-diet.patch
9a00e98a 53Patch2: device-mapper-dmsetup-export.patch
f0dab9f1 54Patch3: %{name}-clvmd_init.patch
b747c17a 55Patch4: dl-dlsym.patch
b08139b7 56Patch5: pldize_lvm2_monitor.patch
eaa437a5 57Patch6: %{name}-wrapper.patch
dc5d0e77 58URL: http://sources.redhat.com/lvm2/
5f0ee085 59BuildRequires: autoconf >= 2.61
7e72c866 60BuildRequires: automake
0dc2b8f2 61%{?with_selinux:BuildRequires: libselinux-devel >= 1.10}
e4a12efb 62%{?with_selinux:BuildRequires: libsepol-devel}
5f0ee085 63BuildRequires: ncurses-devel
3657a56d 64BuildRequires: pkgconfig
5f0ee085 65BuildRequires: readline-devel
9b82b6a5 66BuildRequires: rpmbuild(macros) >= 1.628
5f0ee085 67BuildRequires: udev-devel >= 143
1ccfba6c 68%if %{with initrd}
fa9e8aeb 69%if %{with dietlibc}
39c8d1d5 70BuildRequires: dietlibc-static >= 2:0.32-7
fa9e8aeb
AM
71BuildConflicts: device-mapper-dietlibc
72%endif
b64b85c5
ER
73%if %{with glibc}
74%{?with_selinux:BuildRequires: libselinux-static}
75%{?with_selinux:BuildRequires: libsepol-static}
76%endif
c70b42f6
JR
77%{?with_glibc:BuildRequires: glibc-static}
78%{?with_uClibc:BuildRequires: uClibc-static >= 2:0.9.29}
1ccfba6c 79%endif
c97b4c11 80%if %{with clvmd}
1b67453e 81BuildRequires: cman-devel >= 1.0
4c78aede 82BuildRequires: dlm-devel >= 1.0-0.pre21.2
1b67453e 83%endif
f0dab9f1 84%if %{with clvmd3}
85BuildRequires: cluster-cman-devel
86BuildRequires: cluster-dlm-devel
87%endif
5f0ee085
JB
88%if %{with openais}
89BuildRequires: corosync-devel
90BuildRequires: openais-devel >= 1.0
91%endif
b167057a 92Requires: device-mapper >= %{version}-%{release}
1b67453e 93%if %{with clvmd}
ed044ab4 94Requires: cman-libs >= 1.0
b678d191 95Requires: dlm >= 1.0-0.pre21.2
1b67453e 96%endif
f0dab9f1 97%if %{with clvmd3}
98Requires: cluster-cman-libs
99Requires: cluster-dlm
100%endif
0dc2b8f2 101%{?with_selinux:Requires: libselinux >= 1.10}
1534f04d
ER
102# doesn't work with 2.4 kernels
103Requires: uname(release) >= 2.6
25b6b609 104Obsoletes: lvm
c35cea65 105Obsoletes: lvm2-systemd
7e72c866
JR
106BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108%define _sbindir /sbin
9ab13f24 109%define _usrsbindir /usr/sbin
7e72c866 110
0fbd6aae
ER
111# changing CFLAGS in the middle confuses confcache
112%undefine configure_cache
113
87a7d834
ER
114# borken on AC
115%define filterout_ld -Wl,--as-needed
116
c70b42f6
JR
117# for some reason known only to rpm there must be "\\|" not "\|" here
118%define dietarch %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
119%define dietlibdir %{_prefix}/lib/dietlibc/lib-%{dietarch}
120
f8fa85d0
PS
121%define skip_post_check_so '.*libdevmapper-event-lvm2.so.*'
122
7e72c866
JR
123%description
124This package includes a number of utilities for creating, checking,
125and repairing logical volumes.
126
68d45726
JR
127%description -l pl.UTF-8
128Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
129logicznych wolumenów dyskowych (LVM2).
7e72c866 130
7e72c866 131%package initrd
5672aa67 132Summary: The new version of Logical Volume Manager for Linux - initrd version
6536e848 133Summary(pl.UTF-8): Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
7e72c866 134Group: Base
16ddcbd0 135Conflicts: geninitrd < 10000.18
7e72c866
JR
136
137%description initrd
138This package includes a number of utilities for creating, checking,
139and repairing logical volumes - staticaly linked for initrd.
140
68d45726
JR
141%description initrd -l pl.UTF-8
142Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
143logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
7e72c866
JR
144potrzeby initrd.
145
b167057a
AM
146%package -n device-mapper
147Summary: Userspace support for the device-mapper
148Summary(pl.UTF-8): Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
149Group: Base
150
151%description -n device-mapper
152The goal of this driver is to support volume management. The driver
153enables the definition of new block devices composed of ranges of
154sectors of existing devices. This can be used to define disk
155partitions - or logical volumes. This light-weight kernel component
156can support user-space tools for logical volume management.
157
158%description -n device-mapper -l pl.UTF-8
159Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
160włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
161sektorów na istniejących urządzeniach. Może to być wykorzystane do
162definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
163składnik jądra może wspierać działające w przestrzeni użytkownika
164narzędzia do zarządzania logicznymi wolumenami.
165
166%package -n device-mapper-devel
167Summary: Header files and development documentation for %{name}
168Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do %{name}
169Group: Development/Libraries
170Requires: device-mapper = %{version}-%{release}
171%if %{with selinux}
172Requires: libselinux-devel
173Requires: libsepol-devel
174%endif
175
176%description -n device-mapper-devel
177Header files and development documentation for %{name}.
178
179%description -n device-mapper-devel -l pl.UTF-8
180Pliki nagłówkowe i dokumentacja do %{name}.
181
182%package -n device-mapper-static
183Summary: Static devmapper library
184Summary(pl.UTF-8): Statyczna biblioteka devmapper
185License: LGPL v2.1
186Group: Development/Libraries
dc900ced 187Requires: device-mapper-devel = %{version}-%{release}
b167057a
AM
188
189%description -n device-mapper-static
190Static devmapper library.
191
192%description -n device-mapper-static -l pl.UTF-8
193Statyczna biblioteka devmapper.
194
c70b42f6
JR
195%package -n device-mapper-dietlibc
196Summary: Static devmapper library built with dietlibc
197Summary(pl.UTF-8): Statyczna biblioteka devmapper zbudowana z dietlibc
198License: LGPL v2.1
199Group: Development/Libraries
200Requires: device-mapper-devel = %{version}-%{release}
201
202%description -n device-mapper-dietlibc
203Static devmapper library built with dietlibc.
204
205%description -n device-mapper-dietlibc -l pl.UTF-8
206Statyczna biblioteka devmapper zbudowana z dietlibc.
207
4a323c26
JR
208%package -n device-mapper-initrd
209Summary: Userspace support for the device-mapper - initrd version
210Summary(pl.UTF-8): Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
211Group: Base
212Obsoletes: device-mapper-initrd-devel
1f7434e8 213Conflicts: geninitrd < 10000.10
4a323c26
JR
214
215%description -n device-mapper-initrd
216The goal of this driver is to support volume management. The driver
217enables the definition of new block devices composed of ranges of
218sectors of existing devices. This can be used to define disk
219partitions - or logical volumes. This light-weight kernel component
220can support user-space tools for logical volume management.
221
222This package contains dmsetup program linked staticaly for use in
223initrd.
224
225%description -n device-mapper-initrd -l pl.UTF-8
226Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
227włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
228sektorów na istniejących urządzeniach. Może to być wykorzystane do
229definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
230składnik jądra może wspierać działające w przestrzeni użytkownika
231narzędzia do zarządzania logicznymi wolumenami.
232
233Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
234potrzeby initrd.
235
906ac01a
JR
236%package initramfs
237Summary: The new version of Logical Volume Manager for Linux - support scripts for initramfs-tools
238Summary(pl.UTF-8): Nowa wersja Logical Volume Managera dla Linuksa - skrypty dla initramfs-tools
239Group: Base
240Requires: %{name} = %{version}-%{release}
241Requires: initramfs-tools
242
243%description initramfs
3657a56d 244The new version of Logical Volume Manager for Linux - support scripts
245for initramfs-tools.
906ac01a
JR
246
247%description initramfs -l pl.UTF-8
248Nowa wersja Logical Volume Managera dla Linuksa - skrypty dla
249initramfs-tools.
250
7e72c866 251%prep
ec2de926 252%setup -q -n LVM2.%{version}
7210a095 253%{?with_selinux:%patch0 -p1}
c70b42f6 254%patch1 -p1
9a00e98a 255%patch2 -p1
f0dab9f1 256%patch3 -p1
b747c17a 257%patch4 -p1
b08139b7 258%patch5 -p1
eaa437a5 259%patch6 -p1
b167057a 260
39c8d1d5 261# do not force --export-symbol linker option for e.g. statically linked executables
b5eb9717
PS
262# -rdynamic compiler option drives linker in the right way.
263%{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
264
7e72c866 265%build
87a7d834
ER
266%if %{with initrd}
267echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
268%endif
242ffb9a 269cp -f /usr/share/automake/config.sub autoconf
7e72c866
JR
270%{__aclocal}
271%{__autoconf}
272
99958222 273%if %{with initrd}
6c31051f
PS
274%{?with_glibc:export CC="%{__cc}"}
275%{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
4cbea9f4 276%{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
6c31051f 277
9bdab2f4 278%configure \
a5702977 279 ac_cv_lib_dl_dlopen=no \
eaa437a5 280 %{?with_uClibc:ac_cv_func_siginterrupt=no} \
4c78aede 281 %{?debug:--enable-debug} \
e6cf1072 282 --with-optimisation="%{rpmcflags} -Os" \
9bdab2f4 283 --enable-static_link \
69688a46 284 --with-lvm1=internal \
b0e6f8e2 285 --disable-selinux \
c70b42f6 286 --%{?with_glibc:en}%{!?with_glibc:dis}able-selinux \
260d6858 287 --disable-readline \
ef3dbc1a 288 --disable-nls
c70b42f6 289# glibc version links with normal static libdevicemapper which has selinux enabled
260d6858 290# and we need to keep these in sync between device-mapper and lvm2
4c78aede
ER
291
292%{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
0402cba0 293%{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
ec2de926 294
c7bbf0c8
AM
295%{__make} -j1 -C include
296%{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
297%{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
2afef789 298%{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
69688a46 299mv -f tools/lvm.static initrd-lvm
4a323c26 300mv -f tools/dmsetup.static initrd-dmsetup
7cef5d95
AM
301
302# check if tools works
303for tool in initrd-lvm initrd-dmsetup; do
304 LVM_SYSTEM_DIR=$(pwd) ./${tool} help > /dev/null 2>&1
305 rc=$?
306 if [ $rc -gt 127 ]; then
307 echo "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!" >&2
308 exit 1
309 fi
310done
311
312
c70b42f6 313%{?with_dietlibc:mv -f libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
9bdab2f4 314%{__make} clean
6c31051f
PS
315
316unset CC
7e72c866
JR
317%endif
318
9d0d1d5f 319%configure \
b167057a 320 --with-usrlibdir=%{_libdir} \
4c78aede 321 %{?debug:--enable-debug} \
b167057a 322 --with-optimisation="%{rpmcflags}" \
607d2229
AM
323 --enable-readline \
324 --enable-fsadm \
6e7a47a9 325 --enable-applib \
b167057a 326 --enable-cmdlib \
5f0ee085 327 %{?with_openais:--enable-cmirrord} \
b167057a
AM
328 --enable-dmeventd \
329 --enable-pkgconfig \
5f0ee085
JB
330 --enable-udev_sync \
331 --enable-udev_rules \
332 %{?with_clvmd:--with-clvmd=cman%{?with_openais:,corosync,openais}} \
607d2229
AM
333 --with-lvm1=internal \
334 --with-pool=internal \
3852b0e2 335 --with-cluster=internal \
607d2229 336 --with-snapshots=internal \
0dc2b8f2 337 --with-mirrors=internal \
b167057a 338 --with-interface=ioctl \
589f4db4 339 --with-udev-prefix=/ \
9b82b6a5
BZ
340 --with-systemd_dir=%{systemdunitdir} \
341 %{!?with_selinux:--disable-selinux}
589f4db4 342
b167057a 343%{__make} -j1
c7bbf0c8 344%{__make} -j1 -C libdm LIB_STATIC=libdevmapper.a
7e72c866
JR
345
346%install
347rm -rf $RPM_BUILD_ROOT
906ac01a
JR
348install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm} \
349 $RPM_BUILD_ROOT%{_datadir}/initramfs-tools/{hooks,scripts/local-top}
c70b42f6 350%{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
7e72c866 351
9b82b6a5 352%{__make} install install_system_dirs install_systemd_units install_initscripts \
7e72c866 353 DESTDIR=$RPM_BUILD_ROOT \
1ccfba6c
AM
354 OWNER="" \
355 GROUP=""
7e72c866 356
9b82b6a5
BZ
357mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d
358install -m 0644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/%{name}.conf
359
b167057a
AM
360mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
361for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
362 lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
363 slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
364 ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
365done
366
1cfc154f
JR
367touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
368
88c67b5b
JR
369%if %{with initrd}
370install -d $RPM_BUILD_ROOT%{_libdir}/initrd
a3569314
ER
371install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
372install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
7e72c866 373
a3569314 374%{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
1306038e 375%endif
c70b42f6 376
a3569314
ER
377install -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/initramfs-tools/hooks/lvm2
378install -p %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/initramfs-tools/scripts/local-top/lvm2
906ac01a 379
a3569314 380cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
b167057a 381
7e72c866
JR
382%clean
383rm -rf $RPM_BUILD_ROOT
384
6e7a47a9
AM
385%post
386/sbin/chkconfig --add lvm2-monitor
387%service lvm2-monitor restart
c35cea65
JR
388%systemd_post lvm2-monitor.service
389
390%preun
391%systemd_preun lvm2-monitor.service
6e7a47a9
AM
392
393%postun
394if [ "$1" = "0" ]; then
395 %service lvm2-monitor stop
396 /sbin/chkconfig --del lvm2-monitor
397fi
c35cea65 398%systemd_reload
6e7a47a9 399
c35cea65
JR
400%triggerpostun -- %{name} < 2.02.94-1
401%systemd_trigger lvm2-monitor.service
b167057a 402
c35cea65
JR
403%post -n device-mapper
404/sbin/ldconfig
405%systemd_post dm-event.socket
9b82b6a5 406
c35cea65
JR
407%preun -n device-mapper
408%systemd_preun dm-event.socket dm-event.service
9b82b6a5 409
c35cea65
JR
410%postun -n device-mapper
411/sbin/ldconfig
9b82b6a5
BZ
412%systemd_reload
413
c35cea65
JR
414%triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
415%systemd_trigger dm-event.socket
416
7e72c866
JR
417%files
418%defattr(644,root,root,755)
e6ac7970 419%doc README WHATS_NEW doc/*
86418c14
JB
420%attr(755,root,root) %{_sbindir}/fsadm
421%attr(755,root,root) %{_sbindir}/lv*
422%attr(755,root,root) %{_sbindir}/pv*
423%attr(755,root,root) %{_sbindir}/vg*
1ccc459a 424%{?with_clvmd:%attr(755,root,root) %{_usrsbindir}/clvmd}
86418c14
JB
425%{_mandir}/man5/lvm.conf.5*
426%{?with_clvmd:%{_mandir}/man8/clvmd.8*}
427%{_mandir}/man8/fsadm.8*
428%{_mandir}/man8/lv*.8*
429%{_mandir}/man8/pv*.8*
430%{_mandir}/man8/vg*.8*
99958222 431%attr(750,root,root) %dir %{_sysconfdir}/lvm
2316bf4d 432%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
c35cea65
JR
433%{_sysconfdir}/tmpfiles.d/lvm2.conf
434%{systemdunitdir}/lvm2-monitor.service
6e7a47a9
AM
435%dir %{_sysconfdir}/lvm/cache
436%ghost %{_sysconfdir}/lvm/cache/.cache
437%attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
ba208651 438%{?with_clvmd:%attr(754,root,root) /etc/rc.d/init.d/clvmd}
7e72c866 439
b167057a
AM
440%files -n device-mapper
441%defattr(644,root,root,755)
442%doc *_DM
c35cea65
JR
443%{systemdunitdir}/dm-event.service
444%{systemdunitdir}/dm-event.socket
589f4db4
JR
445/lib/udev/rules.d/10-dm.rules
446/lib/udev/rules.d/11-dm-lvm.rules
447/lib/udev/rules.d/13-dm-disk.rules
448/lib/udev/rules.d/95-dm-notify.rules
b167057a
AM
449%attr(755,root,root) %{_sbindir}/dmeventd
450%attr(755,root,root) %{_sbindir}/dmsetup
451%attr(755,root,root) /%{_lib}/libdevmapper*.so.*.*
6e7a47a9 452%attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
b167057a 453%attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
1306038e
AM
454%dir %{_libdir}/device-mapper
455%attr(755,root,root) %{_libdir}/device-mapper/*.so
b167057a 456%{_mandir}/man8/dmsetup.8*
f0dab9f1 457%{_mandir}/man8/dmeventd.8*
b167057a
AM
458
459%files -n device-mapper-devel
460%defattr(644,root,root,755)
461%attr(755,root,root) %{_libdir}/libdevmapper*.so
6e7a47a9 462%attr(755,root,root) %{_libdir}/liblvm2app.so
b167057a
AM
463%attr(755,root,root) %{_libdir}/liblvm2cmd.so
464%{_includedir}/libdevmapper*.h
6e7a47a9 465%{_includedir}/lvm2app.h
b167057a
AM
466%{_includedir}/lvm2cmd.h
467%{_pkgconfigdir}/devmapper*.pc
6e7a47a9 468%{_pkgconfigdir}/lvm2app.pc
b167057a
AM
469
470%files -n device-mapper-static
471%defattr(644,root,root,755)
472%{_libdir}/libdevmapper*.a
473
1306038e 474%if %{with initrd}
c70b42f6
JR
475%if %{with dietlibc}
476%files -n device-mapper-dietlibc
477%defattr(644,root,root,755)
478%{dietlibdir}/libdevmapper.a
479%endif
480
4a323c26
JR
481%files -n device-mapper-initrd
482%defattr(644,root,root,755)
88c67b5b 483%attr(755,root,root) %{_libdir}/initrd/dmsetup
4a323c26 484
7e72c866
JR
485%files initrd
486%defattr(644,root,root,755)
88c67b5b 487%attr(755,root,root) %{_libdir}/initrd/lvm
7e72c866 488%endif
906ac01a
JR
489
490%files initramfs
491%defattr(644,root,root,755)
492%attr(755,root,root) %{_datadir}/initramfs-tools/hooks/lvm2
493%attr(755,root,root) %{_datadir}/initramfs-tools/scripts/local-top/lvm2
This page took 1.042915 seconds and 4 git commands to generate.