]> git.pld-linux.org Git - packages/lvm2.git/blame - lvm2.spec
systemd unit and sysconfig file for clvmd added
[packages/lvm2.git] / lvm2.spec
CommitLineData
e3a928dc 1# TODO
e3a928dc 2# - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
5f0ee085
JB
3# - --with-replicators (=internal/shared/none, default is none)?
4# - OCF agents?
1b67453e 5#
99958222 6# Conditional build:
c70b42f6 7%bcond_without initrd # don't build initrd version
fe052975
JR
8%bcond_without uClibc # link initrd version with uClibc
9%bcond_with dietlibc # link initrd version with dietlibc
5f0ee085 10%bcond_with glibc # link initrd version with static GLIBC
7e873dd0 11%bcond_without cluster # disable all cluster support (clvmd&cmirrord)
d3778cc3 12%bcond_with lvmetad # enable lvmetad
c70b42f6
JR
13%bcond_without selinux # disable SELinux
14
4a323c26 15%ifarch sparc64 sparc
c70b42f6 16%define with_glibc 1
66800f6a 17%endif
c70b42f6
JR
18
19# if one of the *libc is enabled disable default dietlibc
20%if %{with dietlibc} && %{with uClibc}
21%undefine with_dietlibc
22%endif
23
f1e27504 24# with glibc disables default dietlibc
c70b42f6
JR
25%if %{with glibc} && %{with dietlibc}
26%undefine with_dietlibc
27%endif
28
f1e27504
ER
29# fallback is glibc if neither alternatives are enabled
30%if %{without dietlibc} && %{without uClibc}
31%define with_glibc 1
32%endif
33
5672aa67 34Summary: The new version of Logical Volume Manager for Linux
6536e848 35Summary(pl.UTF-8): Nowa wersja Logical Volume Managera dla Linuksa
7e72c866 36Name: lvm2
4cb4934b
JK
37Version: 2.02.98
38Release: 1
1738b891 39License: GPL v2
7e72c866 40Group: Applications/System
dc5d0e77 41Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
4cb4934b 42# Source0-md5: 1ce5b7f9981e1d02dfd1d3857c8d9fbe
c386faf9 43Source1: %{name}-tmpfiles.conf
0d673991
JK
44Source2: clvmd.service
45Source3: clvmd.sysconfig
7210a095 46Patch0: %{name}-selinux.patch
c70b42f6 47Patch1: %{name}-diet.patch
9a00e98a 48Patch2: device-mapper-dmsetup-export.patch
4cb4934b 49Patch3: %{name}-pld_init.patch
b747c17a 50Patch4: dl-dlsym.patch
4cb4934b
JK
51Patch5: %{name}-wrapper.patch
52Patch6: %{name}-lvm_path.patch
dc5d0e77 53URL: http://sources.redhat.com/lvm2/
5f0ee085 54BuildRequires: autoconf >= 2.61
7e72c866 55BuildRequires: automake
0dc2b8f2 56%{?with_selinux:BuildRequires: libselinux-devel >= 1.10}
e4a12efb 57%{?with_selinux:BuildRequires: libsepol-devel}
5f0ee085 58BuildRequires: ncurses-devel
3657a56d 59BuildRequires: pkgconfig
5f0ee085 60BuildRequires: readline-devel
b5640c74 61BuildRequires: rpmbuild(macros) >= 1.647
5f0ee085 62BuildRequires: udev-devel >= 143
1ccfba6c 63%if %{with initrd}
fa9e8aeb 64%if %{with dietlibc}
39c8d1d5 65BuildRequires: dietlibc-static >= 2:0.32-7
fa9e8aeb
AM
66BuildConflicts: device-mapper-dietlibc
67%endif
b64b85c5
ER
68%if %{with glibc}
69%{?with_selinux:BuildRequires: libselinux-static}
70%{?with_selinux:BuildRequires: libsepol-static}
71%endif
c70b42f6
JR
72%{?with_glibc:BuildRequires: glibc-static}
73%{?with_uClibc:BuildRequires: uClibc-static >= 2:0.9.29}
1ccfba6c 74%endif
7e873dd0 75%if %{with cluster}
5f0ee085 76BuildRequires: corosync-devel
4cb4934b 77BuildRequires: dlm-devel >= 3.99.5
5f0ee085 78%endif
b5640c74 79Requires(post,preun,postun): systemd-units >= 38
b167057a 80Requires: device-mapper >= %{version}-%{release}
0dc2b8f2 81%{?with_selinux:Requires: libselinux >= 1.10}
b5640c74 82Requires: systemd-units >= 38
1534f04d
ER
83# doesn't work with 2.4 kernels
84Requires: uname(release) >= 2.6
25b6b609 85Obsoletes: lvm
c35cea65 86Obsoletes: lvm2-systemd
7e72c866
JR
87BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89%define _sbindir /sbin
9ab13f24 90%define _usrsbindir /usr/sbin
7e72c866 91
0fbd6aae
ER
92# changing CFLAGS in the middle confuses confcache
93%undefine configure_cache
94
87a7d834
ER
95# borken on AC
96%define filterout_ld -Wl,--as-needed
97
4cb4934b
JK
98# causes: undefined reference to `__stack_chk_fail_local'
99%define filterout_c -fstack-protector
100
c70b42f6
JR
101# for some reason known only to rpm there must be "\\|" not "\|" here
102%define dietarch %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
103%define dietlibdir %{_prefix}/lib/dietlibc/lib-%{dietarch}
104
f8fa85d0
PS
105%define skip_post_check_so '.*libdevmapper-event-lvm2.so.*'
106
7e72c866
JR
107%description
108This package includes a number of utilities for creating, checking,
109and repairing logical volumes.
110
68d45726
JR
111%description -l pl.UTF-8
112Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
113logicznych wolumenów dyskowych (LVM2).
7e72c866 114
7e72c866 115%package initrd
5672aa67 116Summary: The new version of Logical Volume Manager for Linux - initrd version
6536e848 117Summary(pl.UTF-8): Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
7e72c866 118Group: Base
16ddcbd0 119Conflicts: geninitrd < 10000.18
7e72c866
JR
120
121%description initrd
122This package includes a number of utilities for creating, checking,
123and repairing logical volumes - staticaly linked for initrd.
124
68d45726
JR
125%description initrd -l pl.UTF-8
126Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
127logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
7e72c866
JR
128potrzeby initrd.
129
7e873dd0
JK
130%package clvmd
131Summary: Cluster LVM daemon
132Summary(pl.UTF-8): Demon clustra LVM
133Group: Applications/System
1aa2f585 134Requires: %{name} = %{version}-%{release}
7e873dd0
JK
135
136%description clvmd
4cb4934b
JK
137clvmd is the daemon that distributes LVM metadata updates around a
138cluster. It must be running on all nodes in the cluster and will give
139an error if a node in the cluster does not have this daemon running.
7e873dd0
JK
140
141%description clvmd -l pl.UTF-8
142clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
4cb4934b
JK
143Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
144węzeł w klastrze nie ma tego demona uruchomionego.
7e873dd0
JK
145
146%package cmirrord
147Summary: Cluster mirror log daemon
148Group: Applications/System
1aa2f585 149Requires: %{name} = %{version}-%{release}
7e873dd0
JK
150
151%description cmirrord
4cb4934b
JK
152cmirrord is the daemon that tracks mirror log information in a
153cluster. It is specific to device-mapper based mirrors (and by
154extension, LVM cluster mirrors). Cluster mirrors are not possible
155without this daemon running.
7e873dd0 156
4cb4934b
JK
157This daemon relies on the cluster infrastructure provided by the
158Cluster MANager (CMAN), which must be set up and running in order for
159cmirrord to function.
7e873dd0 160
b167057a
AM
161%package -n device-mapper
162Summary: Userspace support for the device-mapper
163Summary(pl.UTF-8): Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
164Group: Base
b5640c74
JR
165Requires(post,preun,postun): systemd-units >= 38
166Requires: systemd-units >= 38
b167057a
AM
167
168%description -n device-mapper
169The goal of this driver is to support volume management. The driver
170enables the definition of new block devices composed of ranges of
171sectors of existing devices. This can be used to define disk
172partitions - or logical volumes. This light-weight kernel component
173can support user-space tools for logical volume management.
174
175%description -n device-mapper -l pl.UTF-8
176Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
177włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
178sektorów na istniejących urządzeniach. Może to być wykorzystane do
179definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
180składnik jądra może wspierać działające w przestrzeni użytkownika
181narzędzia do zarządzania logicznymi wolumenami.
182
183%package -n device-mapper-devel
184Summary: Header files and development documentation for %{name}
185Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do %{name}
186Group: Development/Libraries
187Requires: device-mapper = %{version}-%{release}
188%if %{with selinux}
189Requires: libselinux-devel
190Requires: libsepol-devel
191%endif
192
193%description -n device-mapper-devel
194Header files and development documentation for %{name}.
195
196%description -n device-mapper-devel -l pl.UTF-8
197Pliki nagłówkowe i dokumentacja do %{name}.
198
199%package -n device-mapper-static
200Summary: Static devmapper library
201Summary(pl.UTF-8): Statyczna biblioteka devmapper
202License: LGPL v2.1
203Group: Development/Libraries
dc900ced 204Requires: device-mapper-devel = %{version}-%{release}
b167057a
AM
205
206%description -n device-mapper-static
207Static devmapper library.
208
209%description -n device-mapper-static -l pl.UTF-8
210Statyczna biblioteka devmapper.
211
c70b42f6
JR
212%package -n device-mapper-dietlibc
213Summary: Static devmapper library built with dietlibc
214Summary(pl.UTF-8): Statyczna biblioteka devmapper zbudowana z dietlibc
215License: LGPL v2.1
216Group: Development/Libraries
217Requires: device-mapper-devel = %{version}-%{release}
218
219%description -n device-mapper-dietlibc
220Static devmapper library built with dietlibc.
221
222%description -n device-mapper-dietlibc -l pl.UTF-8
223Statyczna biblioteka devmapper zbudowana z dietlibc.
224
4a323c26
JR
225%package -n device-mapper-initrd
226Summary: Userspace support for the device-mapper - initrd version
227Summary(pl.UTF-8): Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
228Group: Base
229Obsoletes: device-mapper-initrd-devel
1f7434e8 230Conflicts: geninitrd < 10000.10
4a323c26
JR
231
232%description -n device-mapper-initrd
233The goal of this driver is to support volume management. The driver
234enables the definition of new block devices composed of ranges of
235sectors of existing devices. This can be used to define disk
236partitions - or logical volumes. This light-weight kernel component
237can support user-space tools for logical volume management.
238
239This package contains dmsetup program linked staticaly for use in
240initrd.
241
242%description -n device-mapper-initrd -l pl.UTF-8
243Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
244włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
245sektorów na istniejących urządzeniach. Może to być wykorzystane do
246definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
247składnik jądra może wspierać działające w przestrzeni użytkownika
248narzędzia do zarządzania logicznymi wolumenami.
249
250Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
251potrzeby initrd.
252
7e72c866 253%prep
ec2de926 254%setup -q -n LVM2.%{version}
7210a095 255%{?with_selinux:%patch0 -p1}
c70b42f6 256%patch1 -p1
9a00e98a 257%patch2 -p1
f0dab9f1 258%patch3 -p1
b747c17a 259%patch4 -p1
b08139b7 260%patch5 -p1
eaa437a5 261%patch6 -p1
b167057a 262
39c8d1d5 263# do not force --export-symbol linker option for e.g. statically linked executables
b5eb9717
PS
264# -rdynamic compiler option drives linker in the right way.
265%{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
266
7e72c866 267%build
87a7d834
ER
268%if %{with initrd}
269echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
270%endif
242ffb9a 271cp -f /usr/share/automake/config.sub autoconf
7e72c866
JR
272%{__aclocal}
273%{__autoconf}
274
99958222 275%if %{with initrd}
6c31051f
PS
276%{?with_glibc:export CC="%{__cc}"}
277%{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
4cbea9f4 278%{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
6c31051f 279
9bdab2f4 280%configure \
a5702977 281 ac_cv_lib_dl_dlopen=no \
eaa437a5 282 %{?with_uClibc:ac_cv_func_siginterrupt=no} \
4c78aede 283 %{?debug:--enable-debug} \
e6cf1072 284 --with-optimisation="%{rpmcflags} -Os" \
9bdab2f4 285 --enable-static_link \
69688a46 286 --with-lvm1=internal \
b0e6f8e2 287 --disable-selinux \
c70b42f6 288 --%{?with_glibc:en}%{!?with_glibc:dis}able-selinux \
260d6858 289 --disable-readline \
ef3dbc1a 290 --disable-nls
c70b42f6 291# glibc version links with normal static libdevicemapper which has selinux enabled
260d6858 292# and we need to keep these in sync between device-mapper and lvm2
4c78aede
ER
293
294%{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
0402cba0 295%{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
ec2de926 296
c7bbf0c8
AM
297%{__make} -j1 -C include
298%{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
299%{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
4cb4934b 300%{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
2afef789 301%{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
69688a46 302mv -f tools/lvm.static initrd-lvm
4a323c26 303mv -f tools/dmsetup.static initrd-dmsetup
7cef5d95
AM
304
305# check if tools works
306for tool in initrd-lvm initrd-dmsetup; do
cfa41a73 307 LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
7cef5d95 308 if [ $rc -gt 127 ]; then
cfa41a73 309 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
7cef5d95
AM
310 exit 1
311 fi
312done
313
314
c70b42f6 315%{?with_dietlibc:mv -f libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
9bdab2f4 316%{__make} clean
6c31051f
PS
317
318unset CC
7e72c866
JR
319%endif
320
9d0d1d5f 321%configure \
b167057a 322 --with-usrlibdir=%{_libdir} \
4c78aede 323 %{?debug:--enable-debug} \
b167057a 324 --with-optimisation="%{rpmcflags}" \
607d2229
AM
325 --enable-readline \
326 --enable-fsadm \
6e7a47a9 327 --enable-applib \
b167057a 328 --enable-cmdlib \
d3778cc3 329 %{?with_lvmetad:--enable-lvmetad} \
b167057a 330 --enable-dmeventd \
93d018f8 331 --with-dmeventd-path=%{_sbindir}/dmeventd \
b167057a 332 --enable-pkgconfig \
5f0ee085
JB
333 --enable-udev_sync \
334 --enable-udev_rules \
7e873dd0 335%if %{with cluster}
4cb4934b
JK
336 --with-clvmd=corosync \
337 --enable-cmirrord \
5cf18a89 338%endif
607d2229
AM
339 --with-lvm1=internal \
340 --with-pool=internal \
3852b0e2 341 --with-cluster=internal \
607d2229 342 --with-snapshots=internal \
0dc2b8f2 343 --with-mirrors=internal \
b5640c74 344 --with-thin=internal \
4cb4934b 345 --with-thin-check="" \
b167057a 346 --with-interface=ioctl \
589f4db4 347 --with-udev-prefix=/ \
9b82b6a5 348 --with-systemd_dir=%{systemdunitdir} \
cfa41a73 349 %{!?with_selinux:--disable-selinux}
589f4db4 350
b167057a 351%{__make} -j1
c7bbf0c8 352%{__make} -j1 -C libdm LIB_STATIC=libdevmapper.a
7e72c866
JR
353
354%install
355rm -rf $RPM_BUILD_ROOT
0d673991 356install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
c70b42f6 357%{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
7e72c866 358
9b82b6a5 359%{__make} install install_system_dirs install_systemd_units install_initscripts \
7e72c866 360 DESTDIR=$RPM_BUILD_ROOT \
1ccfba6c
AM
361 OWNER="" \
362 GROUP=""
7e72c866 363
4cb4934b
JK
364install -d $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d
365install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/%{name}.conf
9b82b6a5 366
0d673991
JK
367%if %{with cluster}
368install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/clvmd.service
369install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/clvmd
370%endif
371
b167057a
AM
372mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
373for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
374 lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
375 slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
376 ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
377done
378
1cfc154f
JR
379touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
380
88c67b5b
JR
381%if %{with initrd}
382install -d $RPM_BUILD_ROOT%{_libdir}/initrd
a3569314
ER
383install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
384install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
7e72c866 385
a3569314 386%{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
1306038e 387%endif
c70b42f6 388
a3569314 389cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
b167057a 390
7e72c866
JR
391%clean
392rm -rf $RPM_BUILD_ROOT
393
6e7a47a9
AM
394%post
395/sbin/chkconfig --add lvm2-monitor
396%service lvm2-monitor restart
c35cea65 397%systemd_post lvm2-monitor.service
4cb4934b
JK
398/sbin/chkconfig --add blk-availability
399# no service blk-availability restart
400%systemd_post blk-availability.service
c35cea65
JR
401
402%preun
403%systemd_preun lvm2-monitor.service
4cb4934b 404%systemd_preun blk-availability.service
6e7a47a9
AM
405
406%postun
407if [ "$1" = "0" ]; then
408 %service lvm2-monitor stop
409 /sbin/chkconfig --del lvm2-monitor
4cb4934b
JK
410 #no service blk-availability stop
411 /sbin/chkconfig --del blk-availability
6e7a47a9 412fi
c35cea65 413%systemd_reload
6e7a47a9 414
c35cea65
JR
415%triggerpostun -- %{name} < 2.02.94-1
416%systemd_trigger lvm2-monitor.service
b167057a 417
c35cea65
JR
418%post -n device-mapper
419/sbin/ldconfig
420%systemd_post dm-event.socket
9b82b6a5 421
c35cea65
JR
422%preun -n device-mapper
423%systemd_preun dm-event.socket dm-event.service
9b82b6a5 424
c35cea65
JR
425%postun -n device-mapper
426/sbin/ldconfig
9b82b6a5
BZ
427%systemd_reload
428
c35cea65
JR
429%triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
430%systemd_trigger dm-event.socket
431
7e72c866
JR
432%files
433%defattr(644,root,root,755)
e6ac7970 434%doc README WHATS_NEW doc/*
4cb4934b 435%attr(755,root,root) %{_sbindir}/blkdeactivate
86418c14
JB
436%attr(755,root,root) %{_sbindir}/fsadm
437%attr(755,root,root) %{_sbindir}/lv*
438%attr(755,root,root) %{_sbindir}/pv*
439%attr(755,root,root) %{_sbindir}/vg*
86418c14 440%{_mandir}/man5/lvm.conf.5*
4cb4934b 441%{_mandir}/man8/blkdeactivate.8*
86418c14
JB
442%{_mandir}/man8/fsadm.8*
443%{_mandir}/man8/lv*.8*
444%{_mandir}/man8/pv*.8*
445%{_mandir}/man8/vg*.8*
99958222 446%attr(750,root,root) %dir %{_sysconfdir}/lvm
2316bf4d 447%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
c35cea65
JR
448%{_sysconfdir}/tmpfiles.d/lvm2.conf
449%{systemdunitdir}/lvm2-monitor.service
4cb4934b 450%{systemdunitdir}/blk-availability.service
6e7a47a9
AM
451%dir %{_sysconfdir}/lvm/cache
452%ghost %{_sysconfdir}/lvm/cache/.cache
4cb4934b 453%attr(754,root,root) /etc/rc.d/init.d/blk-availability
6e7a47a9 454%attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
7e873dd0
JK
455
456%if %{with cluster}
457%files clvmd
458%defattr(644,root,root,755)
459%attr(755,root,root) %{_usrsbindir}/clvmd
460%attr(754,root,root) /etc/rc.d/init.d/clvmd
0d673991
JK
461%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clvmd
462%{systemdunitdir}/clvmd.service
7e873dd0
JK
463%{_mandir}/man8/clvmd.8*
464
7e873dd0
JK
465%files cmirrord
466%defattr(644,root,root,755)
467%attr(755,root,root) %{_usrsbindir}/cmirrord
468%{_mandir}/man8/cmirrord.8*
469%attr(754,root,root) /etc/rc.d/init.d/cmirrord
470%endif
7e72c866 471
b167057a
AM
472%files -n device-mapper
473%defattr(644,root,root,755)
474%doc *_DM
c35cea65
JR
475%{systemdunitdir}/dm-event.service
476%{systemdunitdir}/dm-event.socket
589f4db4
JR
477/lib/udev/rules.d/10-dm.rules
478/lib/udev/rules.d/11-dm-lvm.rules
479/lib/udev/rules.d/13-dm-disk.rules
480/lib/udev/rules.d/95-dm-notify.rules
b167057a
AM
481%attr(755,root,root) %{_sbindir}/dmeventd
482%attr(755,root,root) %{_sbindir}/dmsetup
483%attr(755,root,root) /%{_lib}/libdevmapper*.so.*.*
6e7a47a9 484%attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
b167057a 485%attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
1306038e
AM
486%dir %{_libdir}/device-mapper
487%attr(755,root,root) %{_libdir}/device-mapper/*.so
bece12dd 488%attr(755,root,root) %{_libdir}/libdevmapper-event-*.so
b167057a 489%{_mandir}/man8/dmsetup.8*
f0dab9f1 490%{_mandir}/man8/dmeventd.8*
b167057a
AM
491
492%files -n device-mapper-devel
493%defattr(644,root,root,755)
bece12dd
JR
494%attr(755,root,root) %{_libdir}/libdevmapper.so
495%attr(755,root,root) %{_libdir}/libdevmapper-event.so
6e7a47a9 496%attr(755,root,root) %{_libdir}/liblvm2app.so
b167057a
AM
497%attr(755,root,root) %{_libdir}/liblvm2cmd.so
498%{_includedir}/libdevmapper*.h
6e7a47a9 499%{_includedir}/lvm2app.h
b167057a
AM
500%{_includedir}/lvm2cmd.h
501%{_pkgconfigdir}/devmapper*.pc
6e7a47a9 502%{_pkgconfigdir}/lvm2app.pc
b167057a
AM
503
504%files -n device-mapper-static
505%defattr(644,root,root,755)
506%{_libdir}/libdevmapper*.a
507
1306038e 508%if %{with initrd}
c70b42f6
JR
509%if %{with dietlibc}
510%files -n device-mapper-dietlibc
511%defattr(644,root,root,755)
512%{dietlibdir}/libdevmapper.a
513%endif
514
4a323c26
JR
515%files -n device-mapper-initrd
516%defattr(644,root,root,755)
88c67b5b 517%attr(755,root,root) %{_libdir}/initrd/dmsetup
4a323c26 518
7e72c866
JR
519%files initrd
520%defattr(644,root,root,755)
88c67b5b 521%attr(755,root,root) %{_libdir}/initrd/lvm
7e72c866 522%endif
This page took 0.14734 seconds and 4 git commands to generate.