]> git.pld-linux.org Git - packages/lvm2.git/blame - lvm2.spec
update dmsetup export patch from suse, current one prints garbage
[packages/lvm2.git] / lvm2.spec
CommitLineData
e3a928dc 1# TODO
e3a928dc 2# - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
5f0ee085
JB
3# - --with-replicators (=internal/shared/none, default is none)?
4# - OCF agents?
1b67453e 5#
99958222 6# Conditional build:
c70b42f6 7%bcond_without initrd # don't build initrd version
fe052975
JR
8%bcond_without uClibc # link initrd version with uClibc
9%bcond_with dietlibc # link initrd version with dietlibc
5f0ee085 10%bcond_with glibc # link initrd version with static GLIBC
7e873dd0 11%bcond_without cluster # disable all cluster support (clvmd&cmirrord)
d3778cc3 12%bcond_with lvmetad # enable lvmetad
c70b42f6
JR
13%bcond_without selinux # disable SELinux
14
4a323c26 15%ifarch sparc64 sparc
c70b42f6 16%define with_glibc 1
66800f6a 17%endif
c70b42f6
JR
18
19# if one of the *libc is enabled disable default dietlibc
20%if %{with dietlibc} && %{with uClibc}
21%undefine with_dietlibc
22%endif
23
f1e27504 24# with glibc disables default dietlibc
c70b42f6
JR
25%if %{with glibc} && %{with dietlibc}
26%undefine with_dietlibc
27%endif
28
f1e27504
ER
29# fallback is glibc if neither alternatives are enabled
30%if %{without dietlibc} && %{without uClibc}
31%define with_glibc 1
32%endif
33
5672aa67 34Summary: The new version of Logical Volume Manager for Linux
6536e848 35Summary(pl.UTF-8): Nowa wersja Logical Volume Managera dla Linuksa
7e72c866 36Name: lvm2
4cb4934b 37Version: 2.02.98
0a81c260
ER
38Release: 3
39License: GPL v2 and LGPL v2.1
7e72c866 40Group: Applications/System
dc5d0e77 41Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
4cb4934b 42# Source0-md5: 1ce5b7f9981e1d02dfd1d3857c8d9fbe
c386faf9 43Source1: %{name}-tmpfiles.conf
0d673991
JK
44Source2: clvmd.service
45Source3: clvmd.sysconfig
7210a095 46Patch0: %{name}-selinux.patch
c70b42f6 47Patch1: %{name}-diet.patch
9a00e98a 48Patch2: device-mapper-dmsetup-export.patch
4cb4934b 49Patch3: %{name}-pld_init.patch
b747c17a 50Patch4: dl-dlsym.patch
4cb4934b
JK
51Patch5: %{name}-wrapper.patch
52Patch6: %{name}-lvm_path.patch
7d8cfaa5 53Patch7: %{name}-sd_notify.patch
105f82c3 54Patch8: %{name}-clvmd_cmd_timeout.patch
dc5d0e77 55URL: http://sources.redhat.com/lvm2/
5f0ee085 56BuildRequires: autoconf >= 2.61
7e72c866 57BuildRequires: automake
0dc2b8f2 58%{?with_selinux:BuildRequires: libselinux-devel >= 1.10}
e4a12efb 59%{?with_selinux:BuildRequires: libsepol-devel}
5f0ee085 60BuildRequires: ncurses-devel
3657a56d 61BuildRequires: pkgconfig
5f0ee085 62BuildRequires: readline-devel
b5640c74 63BuildRequires: rpmbuild(macros) >= 1.647
5f0ee085 64BuildRequires: udev-devel >= 143
1ccfba6c 65%if %{with initrd}
fa9e8aeb 66%if %{with dietlibc}
39c8d1d5 67BuildRequires: dietlibc-static >= 2:0.32-7
fa9e8aeb
AM
68BuildConflicts: device-mapper-dietlibc
69%endif
b64b85c5
ER
70%if %{with glibc}
71%{?with_selinux:BuildRequires: libselinux-static}
72%{?with_selinux:BuildRequires: libsepol-static}
73%endif
c70b42f6
JR
74%{?with_glibc:BuildRequires: glibc-static}
75%{?with_uClibc:BuildRequires: uClibc-static >= 2:0.9.29}
1ccfba6c 76%endif
7e873dd0 77%if %{with cluster}
5f0ee085 78BuildRequires: corosync-devel
4cb4934b 79BuildRequires: dlm-devel >= 3.99.5
7d8cfaa5 80BuildRequires: systemd-devel
5f0ee085 81%endif
b5640c74 82Requires(post,preun,postun): systemd-units >= 38
0a81c260 83Requires(post,postun): /sbin/chkconfig
b167057a 84Requires: device-mapper >= %{version}-%{release}
0dc2b8f2 85%{?with_selinux:Requires: libselinux >= 1.10}
b5640c74 86Requires: systemd-units >= 38
1534f04d
ER
87# doesn't work with 2.4 kernels
88Requires: uname(release) >= 2.6
25b6b609 89Obsoletes: lvm
c35cea65 90Obsoletes: lvm2-systemd
7e72c866
JR
91BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93%define _sbindir /sbin
9ab13f24 94%define _usrsbindir /usr/sbin
7e72c866 95
0fbd6aae
ER
96# changing CFLAGS in the middle confuses confcache
97%undefine configure_cache
98
87a7d834
ER
99# borken on AC
100%define filterout_ld -Wl,--as-needed
101
4cb4934b
JK
102# causes: undefined reference to `__stack_chk_fail_local'
103%define filterout_c -fstack-protector
104
c70b42f6
JR
105# for some reason known only to rpm there must be "\\|" not "\|" here
106%define dietarch %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
107%define dietlibdir %{_prefix}/lib/dietlibc/lib-%{dietarch}
108
f8fa85d0
PS
109%define skip_post_check_so '.*libdevmapper-event-lvm2.so.*'
110
7e72c866
JR
111%description
112This package includes a number of utilities for creating, checking,
113and repairing logical volumes.
114
68d45726
JR
115%description -l pl.UTF-8
116Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
117logicznych wolumenów dyskowych (LVM2).
7e72c866 118
7e72c866 119%package initrd
5672aa67 120Summary: The new version of Logical Volume Manager for Linux - initrd version
6536e848 121Summary(pl.UTF-8): Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
7e72c866 122Group: Base
16ddcbd0 123Conflicts: geninitrd < 10000.18
7e72c866
JR
124
125%description initrd
126This package includes a number of utilities for creating, checking,
127and repairing logical volumes - staticaly linked for initrd.
128
68d45726
JR
129%description initrd -l pl.UTF-8
130Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
131logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
7e72c866
JR
132potrzeby initrd.
133
7e873dd0
JK
134%package clvmd
135Summary: Cluster LVM daemon
136Summary(pl.UTF-8): Demon clustra LVM
137Group: Applications/System
1aa2f585 138Requires: %{name} = %{version}-%{release}
7e873dd0
JK
139
140%description clvmd
4cb4934b
JK
141clvmd is the daemon that distributes LVM metadata updates around a
142cluster. It must be running on all nodes in the cluster and will give
143an error if a node in the cluster does not have this daemon running.
7e873dd0
JK
144
145%description clvmd -l pl.UTF-8
146clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
4cb4934b
JK
147Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
148węzeł w klastrze nie ma tego demona uruchomionego.
7e873dd0
JK
149
150%package cmirrord
151Summary: Cluster mirror log daemon
152Group: Applications/System
1aa2f585 153Requires: %{name} = %{version}-%{release}
7e873dd0
JK
154
155%description cmirrord
4cb4934b
JK
156cmirrord is the daemon that tracks mirror log information in a
157cluster. It is specific to device-mapper based mirrors (and by
158extension, LVM cluster mirrors). Cluster mirrors are not possible
159without this daemon running.
7e873dd0 160
4cb4934b
JK
161This daemon relies on the cluster infrastructure provided by the
162Cluster MANager (CMAN), which must be set up and running in order for
163cmirrord to function.
7e873dd0 164
b167057a
AM
165%package -n device-mapper
166Summary: Userspace support for the device-mapper
167Summary(pl.UTF-8): Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
168Group: Base
b5640c74
JR
169Requires(post,preun,postun): systemd-units >= 38
170Requires: systemd-units >= 38
b167057a
AM
171
172%description -n device-mapper
173The goal of this driver is to support volume management. The driver
174enables the definition of new block devices composed of ranges of
175sectors of existing devices. This can be used to define disk
176partitions - or logical volumes. This light-weight kernel component
177can support user-space tools for logical volume management.
178
179%description -n device-mapper -l pl.UTF-8
180Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
181włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
182sektorów na istniejących urządzeniach. Może to być wykorzystane do
183definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
184składnik jądra może wspierać działające w przestrzeni użytkownika
185narzędzia do zarządzania logicznymi wolumenami.
186
187%package -n device-mapper-devel
188Summary: Header files and development documentation for %{name}
189Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do %{name}
190Group: Development/Libraries
191Requires: device-mapper = %{version}-%{release}
192%if %{with selinux}
193Requires: libselinux-devel
194Requires: libsepol-devel
195%endif
196
197%description -n device-mapper-devel
198Header files and development documentation for %{name}.
199
200%description -n device-mapper-devel -l pl.UTF-8
201Pliki nagłówkowe i dokumentacja do %{name}.
202
203%package -n device-mapper-static
204Summary: Static devmapper library
205Summary(pl.UTF-8): Statyczna biblioteka devmapper
206License: LGPL v2.1
207Group: Development/Libraries
dc900ced 208Requires: device-mapper-devel = %{version}-%{release}
b167057a
AM
209
210%description -n device-mapper-static
211Static devmapper library.
212
213%description -n device-mapper-static -l pl.UTF-8
214Statyczna biblioteka devmapper.
215
c70b42f6
JR
216%package -n device-mapper-dietlibc
217Summary: Static devmapper library built with dietlibc
218Summary(pl.UTF-8): Statyczna biblioteka devmapper zbudowana z dietlibc
219License: LGPL v2.1
220Group: Development/Libraries
221Requires: device-mapper-devel = %{version}-%{release}
222
223%description -n device-mapper-dietlibc
224Static devmapper library built with dietlibc.
225
226%description -n device-mapper-dietlibc -l pl.UTF-8
227Statyczna biblioteka devmapper zbudowana z dietlibc.
228
4a323c26
JR
229%package -n device-mapper-initrd
230Summary: Userspace support for the device-mapper - initrd version
231Summary(pl.UTF-8): Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
232Group: Base
233Obsoletes: device-mapper-initrd-devel
1f7434e8 234Conflicts: geninitrd < 10000.10
4a323c26
JR
235
236%description -n device-mapper-initrd
237The goal of this driver is to support volume management. The driver
238enables the definition of new block devices composed of ranges of
239sectors of existing devices. This can be used to define disk
240partitions - or logical volumes. This light-weight kernel component
241can support user-space tools for logical volume management.
242
243This package contains dmsetup program linked staticaly for use in
244initrd.
245
246%description -n device-mapper-initrd -l pl.UTF-8
247Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
248włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
249sektorów na istniejących urządzeniach. Może to być wykorzystane do
250definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
251składnik jądra może wspierać działające w przestrzeni użytkownika
252narzędzia do zarządzania logicznymi wolumenami.
253
254Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
255potrzeby initrd.
256
7e72c866 257%prep
ec2de926 258%setup -q -n LVM2.%{version}
7210a095 259%{?with_selinux:%patch0 -p1}
c70b42f6 260%patch1 -p1
9a00e98a 261%patch2 -p1
f0dab9f1 262%patch3 -p1
b747c17a 263%patch4 -p1
b08139b7 264%patch5 -p1
eaa437a5 265%patch6 -p1
7d8cfaa5 266%patch7 -p1
105f82c3 267%patch8 -p1
b167057a 268
39c8d1d5 269# do not force --export-symbol linker option for e.g. statically linked executables
b5eb9717
PS
270# -rdynamic compiler option drives linker in the right way.
271%{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
272
7e72c866 273%build
87a7d834
ER
274%if %{with initrd}
275echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
276%endif
242ffb9a 277cp -f /usr/share/automake/config.sub autoconf
7e72c866
JR
278%{__aclocal}
279%{__autoconf}
280
99958222 281%if %{with initrd}
6c31051f
PS
282%{?with_glibc:export CC="%{__cc}"}
283%{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
4cbea9f4 284%{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
6c31051f 285
9bdab2f4 286%configure \
a5702977 287 ac_cv_lib_dl_dlopen=no \
eaa437a5 288 %{?with_uClibc:ac_cv_func_siginterrupt=no} \
4c78aede 289 %{?debug:--enable-debug} \
e6cf1072 290 --with-optimisation="%{rpmcflags} -Os" \
9bdab2f4 291 --enable-static_link \
69688a46 292 --with-lvm1=internal \
b0e6f8e2 293 --disable-selinux \
c70b42f6 294 --%{?with_glibc:en}%{!?with_glibc:dis}able-selinux \
260d6858 295 --disable-readline \
ef3dbc1a 296 --disable-nls
c70b42f6 297# glibc version links with normal static libdevicemapper which has selinux enabled
260d6858 298# and we need to keep these in sync between device-mapper and lvm2
4c78aede
ER
299
300%{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
0402cba0 301%{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
ec2de926 302
c7bbf0c8
AM
303%{__make} -j1 -C include
304%{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
305%{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
4cb4934b 306%{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
2afef789 307%{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
69688a46 308mv -f tools/lvm.static initrd-lvm
4a323c26 309mv -f tools/dmsetup.static initrd-dmsetup
7cef5d95
AM
310
311# check if tools works
312for tool in initrd-lvm initrd-dmsetup; do
cfa41a73 313 LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
7cef5d95 314 if [ $rc -gt 127 ]; then
cfa41a73 315 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
7cef5d95
AM
316 exit 1
317 fi
318done
319
320
c70b42f6 321%{?with_dietlibc:mv -f libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
9bdab2f4 322%{__make} clean
6c31051f
PS
323
324unset CC
7e72c866
JR
325%endif
326
9d0d1d5f 327%configure \
b167057a 328 --with-usrlibdir=%{_libdir} \
4c78aede 329 %{?debug:--enable-debug} \
b167057a 330 --with-optimisation="%{rpmcflags}" \
607d2229
AM
331 --enable-readline \
332 --enable-fsadm \
6e7a47a9 333 --enable-applib \
b167057a 334 --enable-cmdlib \
d3778cc3 335 %{?with_lvmetad:--enable-lvmetad} \
b167057a 336 --enable-dmeventd \
93d018f8 337 --with-dmeventd-path=%{_sbindir}/dmeventd \
b167057a 338 --enable-pkgconfig \
5f0ee085
JB
339 --enable-udev_sync \
340 --enable-udev_rules \
7e873dd0 341%if %{with cluster}
4cb4934b
JK
342 --with-clvmd=corosync \
343 --enable-cmirrord \
5cf18a89 344%endif
607d2229
AM
345 --with-lvm1=internal \
346 --with-pool=internal \
3852b0e2 347 --with-cluster=internal \
607d2229 348 --with-snapshots=internal \
0dc2b8f2 349 --with-mirrors=internal \
b5640c74 350 --with-thin=internal \
4cb4934b 351 --with-thin-check="" \
b167057a 352 --with-interface=ioctl \
589f4db4 353 --with-udev-prefix=/ \
9b82b6a5 354 --with-systemd_dir=%{systemdunitdir} \
cfa41a73 355 %{!?with_selinux:--disable-selinux}
589f4db4 356
b167057a 357%{__make} -j1
c7bbf0c8 358%{__make} -j1 -C libdm LIB_STATIC=libdevmapper.a
7e72c866
JR
359
360%install
361rm -rf $RPM_BUILD_ROOT
0d673991 362install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
c70b42f6 363%{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
7e72c866 364
9b82b6a5 365%{__make} install install_system_dirs install_systemd_units install_initscripts \
7e72c866 366 DESTDIR=$RPM_BUILD_ROOT \
1ccfba6c
AM
367 OWNER="" \
368 GROUP=""
7e72c866 369
4cb4934b
JK
370install -d $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d
371install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/%{name}.conf
9b82b6a5 372
0d673991
JK
373%if %{with cluster}
374install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/clvmd.service
375install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/clvmd
376%endif
377
b167057a
AM
378mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
379for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
380 lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
381 slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
382 ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
383done
384
1cfc154f
JR
385touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
386
88c67b5b
JR
387%if %{with initrd}
388install -d $RPM_BUILD_ROOT%{_libdir}/initrd
a3569314
ER
389install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
390install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
7e72c866 391
a3569314 392%{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
1306038e 393%endif
c70b42f6 394
a3569314 395cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
b167057a 396
7e72c866
JR
397%clean
398rm -rf $RPM_BUILD_ROOT
399
6e7a47a9
AM
400%post
401/sbin/chkconfig --add lvm2-monitor
402%service lvm2-monitor restart
c35cea65 403%systemd_post lvm2-monitor.service
4cb4934b
JK
404/sbin/chkconfig --add blk-availability
405# no service blk-availability restart
406%systemd_post blk-availability.service
c35cea65
JR
407
408%preun
409%systemd_preun lvm2-monitor.service
4cb4934b 410%systemd_preun blk-availability.service
6e7a47a9
AM
411
412%postun
413if [ "$1" = "0" ]; then
414 %service lvm2-monitor stop
415 /sbin/chkconfig --del lvm2-monitor
4cb4934b
JK
416 #no service blk-availability stop
417 /sbin/chkconfig --del blk-availability
6e7a47a9 418fi
c35cea65 419%systemd_reload
6e7a47a9 420
c35cea65
JR
421%triggerpostun -- %{name} < 2.02.94-1
422%systemd_trigger lvm2-monitor.service
b167057a 423
c35cea65
JR
424%post -n device-mapper
425/sbin/ldconfig
426%systemd_post dm-event.socket
9b82b6a5 427
c35cea65
JR
428%preun -n device-mapper
429%systemd_preun dm-event.socket dm-event.service
9b82b6a5 430
c35cea65
JR
431%postun -n device-mapper
432/sbin/ldconfig
9b82b6a5
BZ
433%systemd_reload
434
c35cea65
JR
435%triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
436%systemd_trigger dm-event.socket
437
161d6a19
JK
438%post clvmd
439/sbin/chkconfig --add clvmd
440# no service restart - it breaks current locks!
441export NORESTART=1
442%systemd_post clvmd.service
443# re-exec instead
444/usr/sbin/clvmd -S 2>/dev/null || :
445
446%preun clvmd
447%systemd_preun clvmd.service
448
449%postun clvmd
450if [ "$1" = "0" ]; then
451 %service clvmd stop
452 /sbin/chkconfig --del clvmd
453fi
454%systemd_reload
455
7e72c866
JR
456%files
457%defattr(644,root,root,755)
e6ac7970 458%doc README WHATS_NEW doc/*
4cb4934b 459%attr(755,root,root) %{_sbindir}/blkdeactivate
86418c14
JB
460%attr(755,root,root) %{_sbindir}/fsadm
461%attr(755,root,root) %{_sbindir}/lv*
462%attr(755,root,root) %{_sbindir}/pv*
463%attr(755,root,root) %{_sbindir}/vg*
86418c14 464%{_mandir}/man5/lvm.conf.5*
4cb4934b 465%{_mandir}/man8/blkdeactivate.8*
86418c14
JB
466%{_mandir}/man8/fsadm.8*
467%{_mandir}/man8/lv*.8*
468%{_mandir}/man8/pv*.8*
469%{_mandir}/man8/vg*.8*
99958222 470%attr(750,root,root) %dir %{_sysconfdir}/lvm
2316bf4d 471%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
c35cea65
JR
472%{_sysconfdir}/tmpfiles.d/lvm2.conf
473%{systemdunitdir}/lvm2-monitor.service
4cb4934b 474%{systemdunitdir}/blk-availability.service
6e7a47a9
AM
475%dir %{_sysconfdir}/lvm/cache
476%ghost %{_sysconfdir}/lvm/cache/.cache
4cb4934b 477%attr(754,root,root) /etc/rc.d/init.d/blk-availability
6e7a47a9 478%attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
5388840f 479%dir %attr(700,root,root) /var/run/lvm
7e873dd0
JK
480
481%if %{with cluster}
482%files clvmd
483%defattr(644,root,root,755)
484%attr(755,root,root) %{_usrsbindir}/clvmd
485%attr(754,root,root) /etc/rc.d/init.d/clvmd
0d673991
JK
486%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clvmd
487%{systemdunitdir}/clvmd.service
7e873dd0
JK
488%{_mandir}/man8/clvmd.8*
489
7e873dd0
JK
490%files cmirrord
491%defattr(644,root,root,755)
492%attr(755,root,root) %{_usrsbindir}/cmirrord
493%{_mandir}/man8/cmirrord.8*
494%attr(754,root,root) /etc/rc.d/init.d/cmirrord
495%endif
7e72c866 496
b167057a
AM
497%files -n device-mapper
498%defattr(644,root,root,755)
499%doc *_DM
c35cea65
JR
500%{systemdunitdir}/dm-event.service
501%{systemdunitdir}/dm-event.socket
589f4db4
JR
502/lib/udev/rules.d/10-dm.rules
503/lib/udev/rules.d/11-dm-lvm.rules
504/lib/udev/rules.d/13-dm-disk.rules
505/lib/udev/rules.d/95-dm-notify.rules
b167057a
AM
506%attr(755,root,root) %{_sbindir}/dmeventd
507%attr(755,root,root) %{_sbindir}/dmsetup
508%attr(755,root,root) /%{_lib}/libdevmapper*.so.*.*
6e7a47a9 509%attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
b167057a 510%attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
1306038e
AM
511%dir %{_libdir}/device-mapper
512%attr(755,root,root) %{_libdir}/device-mapper/*.so
bece12dd 513%attr(755,root,root) %{_libdir}/libdevmapper-event-*.so
b167057a 514%{_mandir}/man8/dmsetup.8*
f0dab9f1 515%{_mandir}/man8/dmeventd.8*
b167057a
AM
516
517%files -n device-mapper-devel
518%defattr(644,root,root,755)
bece12dd
JR
519%attr(755,root,root) %{_libdir}/libdevmapper.so
520%attr(755,root,root) %{_libdir}/libdevmapper-event.so
6e7a47a9 521%attr(755,root,root) %{_libdir}/liblvm2app.so
b167057a
AM
522%attr(755,root,root) %{_libdir}/liblvm2cmd.so
523%{_includedir}/libdevmapper*.h
6e7a47a9 524%{_includedir}/lvm2app.h
b167057a
AM
525%{_includedir}/lvm2cmd.h
526%{_pkgconfigdir}/devmapper*.pc
6e7a47a9 527%{_pkgconfigdir}/lvm2app.pc
b167057a
AM
528
529%files -n device-mapper-static
530%defattr(644,root,root,755)
531%{_libdir}/libdevmapper*.a
532
1306038e 533%if %{with initrd}
c70b42f6
JR
534%if %{with dietlibc}
535%files -n device-mapper-dietlibc
536%defattr(644,root,root,755)
537%{dietlibdir}/libdevmapper.a
538%endif
539
4a323c26
JR
540%files -n device-mapper-initrd
541%defattr(644,root,root,755)
88c67b5b 542%attr(755,root,root) %{_libdir}/initrd/dmsetup
4a323c26 543
7e72c866
JR
544%files initrd
545%defattr(644,root,root,755)
88c67b5b 546%attr(755,root,root) %{_libdir}/initrd/lvm
7e72c866 547%endif
This page took 0.140744 seconds and 4 git commands to generate.