]> git.pld-linux.org Git - packages/linux-gpib.git/blame - linux-gpib.spec
perl 5.38.0 rebuild
[packages/linux-gpib.git] / linux-gpib.spec
CommitLineData
d4054fe9 1#
d4054fe9 2# Conditional build:
2ee896be 3%bcond_without kernel # kernel modules
25beb8e8 4%bcond_without drivers_isa # ISA kernel drivers [ix86 only]
25beb8e8 5%bcond_without drivers_usb # USB kernel drivers
2ee896be
JB
6%bcond_without userspace # userspace packages
7%bcond_without verbose # verbose modules build (V=1)
df990a65 8
635db00a 9%bcond_without doc # documentation build
08f3bc97 10%bcond_with hotplug # legacy hotplug support
2ee896be 11%bcond_without static_libs # static library
91dbb874 12%bcond_without guile # guile binding
2ee896be 13%bcond_without perl # Perl binding
b3693ec1 14%bcond_with php # PHP binding
fb21f50f
JB
15%bcond_without python # Python (any) binding
16%bcond_without python2 # Python 2.x binding
2ee896be 17%bcond_without tcl # Tcl binding
df990a65 18
4c4f156c
JR
19# The goal here is to have main, userspace, package built once with
20# simple release number, and only rebuild kernel packages with kernel
21# version as part of release number, without the need to bump release
22# with every kernel change.
23%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24%{error:kernel and userspace cannot be built at the same time on PLD builders}
25exit 1
26%endif
27
eda43fa2
JR
28%if %{without userspace}
29# nothing to be placed to debuginfo package
30%define _enable_debug_packages 0
31%endif
32
25beb8e8
JB
33%ifnarch %{ix86}
34%undefine with_drivers_isa
fb21f50f
JB
35%endif
36%if %{without python}
37%undefine with_python2
25beb8e8 38%endif
4c4f156c 39
76a67c9a 40%define php_name php%{?php_suffix}
4c4f156c 41
7fbd29a7 42%define rel 10
4c4f156c 43%define pname linux-gpib
2ee896be
JB
44Summary: GPIB (IEEE 488) Linux support
45Summary(pl.UTF-8): Obsługa GPIB (IEEE 488) dla Linuksa
4c4f156c 46Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
00074c36 47Version: 4.3.4
2d0c8827 48Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
2ee896be 49License: GPL v2+
cc64c2aa 50Group: Applications/System
996e3d04 51Source0: http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
00074c36 52# Source0-md5: d42b04d3b27a601c9b893915d5fded37
4c4f156c
JR
53Patch2: %{pname}-python.patch
54Patch3: %{pname}-perl.patch
55Patch4: %{pname}-firmwaredir.patch
56Patch5: %{pname}-guile2.patch
57Patch6: %{pname}-php7.patch
82a3ed18 58Patch8: kernel-5.2.patch
403be2a0 59Patch9: kernel-5.10.patch
659cb172 60Patch10: pkgconfig-version.patch
346fe22b 61Patch11: linux-gpib-guile3.patch
d4054fe9 62URL: http://linux-gpib.sourceforge.net/
2ee896be
JB
63BuildRequires: autoconf >= 2.50
64BuildRequires: automake
65BuildRequires: libtool
fb21f50f 66BuildRequires: rpmbuild(macros) >= 1.745
0a86a1d5 67%{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.32}}
2ee896be
JB
68%if %{with userspace}
69BuildRequires: bison
635db00a 70%{?with_doc:BuildRequires: docbook-utils}
2ee896be 71BuildRequires: flex
91dbb874 72%{?with_guile:BuildRequires: guile-devel >= 1.4}
df990a65 73%{?with_perl:BuildRequires: perl-devel}
76a67c9a 74%{?with_php:BuildRequires: %{php_name}-devel >= 3:5}
2ee896be
JB
75%{?with_python:BuildRequires: python-devel >= 2}
76BuildRequires: readline-devel
df990a65 77%{?with_tcl:BuildRequires: tcl-devel}
2ee896be 78%endif
4c4f156c 79Requires: %{pname}-libs = %{version}-%{release}
4ffc9310
JB
80# for agilent_82357a and ni_usb_gpib
81Suggests: fxload
82# for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
83Suggests: linux-gpib-firmware
d4054fe9 84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86%description
cc64c2aa 87The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
d4054fe9 88
bc9733fa
JR
89%description -l pl.UTF-8
90Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
d4054fe9 91
08f3bc97
JB
92%package hotplug
93Summary: Linux GPIB support for legacy USB hotplug
94Summary(pl.UTF-8): Obsługa Linux GPIB dla starego systemu hotplug USB
95Group: Applications/System
4c4f156c 96Requires: %{pname} = %{version}-%{release}
08f3bc97
JB
97Requires: hotplug
98
99%description hotplug
100Linux GPIB support for legacy USB hotplug.
101
102%description hotplug -l pl.UTF-8
103Obsługa Linux GPIB dla starego systemu hotplug USB.
104
2ee896be
JB
105%package libs
106Summary: Shared GPIB library
107Summary(pl.UTF-8): Biblioteka współdzielona GPIB
108Group: Libraries
d7b3679a 109
2ee896be
JB
110%description libs
111Shared GPIB library.
112
113%description libs -l pl.UTF-8
114Biblioteka współdzielona GPIB.
115
116%package devel
117Summary: Header file for GPIB library
118Summary(pl.UTF-8): Plik nagłówkowy biblioteki GPIB
119Group: Development/Libraries
4c4f156c 120Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
121
122%description devel
123Header file for GPIB library.
124
125%description devel -l pl.UTF-8
126Plik nagłówkowy biblioteki GPIB.
127
128%package static
129Summary: Static GPIB library
130Summary(pl.UTF-8): Biblioteka statyczna GPIB
131Group: Development/Libraries
4c4f156c 132Requires: %{pname}-devel = %{version}-%{release}
2ee896be
JB
133
134%description static
135Static GPIB library.
136
137%description static -l pl.UTF-8
138Biblioteka statyczna GPIB.
139
91dbb874
JB
140%package -n guile-gpib
141Summary: Guile bindings for GPIB library
142Summary(pl.UTF-8): Wiązania Guile do biblioteki GPIB
143Group: Development/Languages/Perl
4c4f156c 144Requires: %{pname}-libs = %{version}-%{release}
91dbb874
JB
145Requires: guile-libs
146
147%description -n guile-gpib
148Guile bindings for GPIB library.
149
150%description -n guile-gpib -l pl.UTF-8
151Wiązania Guile do biblioteki GPIB.
152
2ee896be
JB
153%package -n perl-gpib
154Summary: Perl bindings for GPIB library
155Summary(pl.UTF-8): Wiązania Perla do biblioteki GPIB
156Group: Development/Languages/Perl
4c4f156c 157Requires: %{pname}-libs = %{version}-%{release}
d7b3679a 158
2ee896be
JB
159%description -n perl-gpib
160Perl bindings for GPIB library.
d7b3679a 161
2ee896be
JB
162%description -n perl-gpib -l pl.UTF-8
163Wiązania Perla do biblioteki GPIB.
d7b3679a 164
76a67c9a
JB
165%package -n %{php_name}-gpib
166Summary: PHP bindings for GPIB library
167Summary(pl.UTF-8): Wiązania PHP do biblioteki GPIB
168Group: Development/Languages/PHP
169Provides: php(gpib) = %{version}
4c4f156c 170Requires: %{pname}-libs = %{version}-%{release}
76a67c9a
JB
171%{?requires_php_extension}
172
173%description -n %{php_name}-gpib
174PHP bindings for GPIB library.
175
176%description -n %{php_name}-gpib -l pl.UTF-8
177Wiązania PHP do biblioteki GPIB.
178
2ee896be 179%package -n python-gpib
fb21f50f
JB
180Summary: Python 2 bindings for GPIB library
181Summary(pl.UTF-8): Wiązania Pythona 2 do biblioteki GPIB
2ee896be 182Group: Libraries/Python
4c4f156c 183Requires: %{pname}-libs = %{version}-%{release}
2ee896be 184Requires: python-libs
d7b3679a 185
2ee896be 186%description -n python-gpib
fb21f50f 187Python 2 bindings for GPIB library.
2ee896be
JB
188
189%description -n python-gpib -l pl.UTF-8
fb21f50f
JB
190Wiązania Pythona 2 do biblioteki GPIB.
191
192%package -n python3-gpib
193Summary: Python 3 bindings for GPIB library
194Summary(pl.UTF-8): Wiązania Pythona 3 do biblioteki GPIB
195Group: Libraries/Python
196Requires: %{pname}-libs = %{version}-%{release}
197Requires: python3-libs
198
199%description -n python3-gpib
200Python 3 bindings for GPIB library.
201
202%description -n python3-gpib -l pl.UTF-8
203Wiązania Pythona 3 do biblioteki GPIB.
2ee896be
JB
204
205%package -n tcl-gpib
206Summary: Tcl bindings for GPIB library
207Summary(pl.UTF-8): Wiązania Tcl-a do biblioteki GPIB
208Group: Libraries
4c4f156c 209Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
210Requires: tcl
211
212%description -n tcl-gpib
213Tcl bindings for GPIB library.
214
215%description -n tcl-gpib -l pl.UTF-8
216Wiązania Tcl-a do biblioteki GPIB.
217
218%package doc
219Summary: Linux-GPIB tools and library documentation
220Summary(pl.UTF-8): Dokumentacja narzędzi i biblioteki Linux-GPIB
221License: GFDL v1.2+ or GPL v2+
222Group: Documentation
223
224%description doc
225Linux-GPIB tools and library documentation.
226
227%description doc -l pl.UTF-8
228Dokumentacja narzędzi i biblioteki Linux-GPIB.
229
230%define kernel_pkg()\
231%package -n kernel%{_alt_kernel}-gpib\
232Summary: Linux GPIB drivers\
233Summary(pl.UTF-8): Sterowniki GPIB dla Linuksa\
234Release: %{rel}@%{_kernel_ver_str}\
235Group: Base/Kernel\
236Requires(post,postun): /sbin/depmod\
237%requires_releq_kernel\
238Requires(postun): %releq_kernel\
239\
240%description -n kernel%{_alt_kernel}-gpib\
241This package contains Linux drivers for GPIB (IEEE 488) hardware.\
242\
243%description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
244Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
245\
246%if %{with kernel}\
247%files -n kernel%{_alt_kernel}-gpib\
248%defattr(644,root,root,755)\
249/lib/modules/%{_kernel_ver}/kernel/gpib\
250%endif\
251\
252%post -n kernel%{_alt_kernel}-gpib\
253%depmod %{_kernel_ver}\
254\
255%postun -n kernel%{_alt_kernel}-gpib\
256%depmod %{_kernel_ver}\
257%{nil}
258
259%define build_kernel_pkg()\
13cab497 260%{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir} clean\
55cbc6e3 261%{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir}\
2ee896be 262cd drivers/gpib\
403be2a0
JR
263%if %{_kernel_version_code} < %{_kernel_version_magic 5 10 0}\
264%if %{with drivers_usb}\
265%install_kernel_modules -D installed -m lpvo_usb_gpib/lpvo_usb_gpib -d kernel/gpib\
266%endif\
267%endif\
82a3ed18 268%ifarch %{ix86}\
403be2a0 269%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
82a3ed18 270%else\
403be2a0 271%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
82a3ed18 272%endif\
b69cc3e0 273cd ../..\
2ee896be
JB
274%{nil}
275
276%define install_kernel_pkg()\
277%{nil}
278
279%{?with_kernel:%{expand:%create_kernel_packages}}
d7b3679a 280
d4054fe9 281%prep
996e3d04 282%setup -q -n %{pname}-%{version}
16f00101
JR
283%if %{with userspace}
284tar xzf linux-gpib-user-%{version}.tar.gz
285cd linux-gpib-user-%{version}
2ee896be
JB
286%patch2 -p1
287%patch3 -p1
08f3bc97 288%patch4 -p1
91dbb874 289%patch5 -p1
16f00101 290#%patch6 -p1
659cb172 291%patch10 -p1
346fe22b 292%patch11 -p1
16f00101
JR
293cd ..
294%endif
295
296%if %{with kernel}
297tar xzf linux-gpib-kernel-%{version}.tar.gz
298cd linux-gpib-kernel-%{version}
41ab8c5b 299%patch9 -p1
5e300ced
JR
300%ifarch %{ix86}
301%patch8 -p1
302%endif
16f00101 303%endif
d7b3679a 304
d4054fe9 305%build
16f00101
JR
306%if %{with userspace}
307cd linux-gpib-user-%{version}
302b72f6
JR
308%{__libtoolize}
309%{__aclocal}
310%{__autoconf}
311%{__autoheader}
312%{__automake}
91dbb874 313%if %{with guile}
346fe22b 314CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/3.0"
91dbb874 315%endif
d7b3679a 316%configure \
55cbc6e3 317 --with-udev-libdir=/lib/udev \
635db00a 318 %{!?with_doc:--disable-documentation} \
2ee896be
JB
319 %{!?with_guile:--disable-guile-binding} \
320 %{!?with_perl:--disable-perl-binding} \
321 %{!?with_php:--disable-php-binding} \
322 %{!?with_python:--disable-python-binding} \
323 %{?with_static_libs:--enable-static} \
16f00101 324 %{!?with_tcl:--disable-tcl-binding}
d7b3679a 325
9e3b7024 326%{__make}
fb21f50f
JB
327
328%if %{with python2}
329cd language/python
330%py_build
331cd ../..
332%endif
16f00101 333cd ..
2ee896be 334%endif
d7b3679a 335
2ee896be 336%if %{with kernel}
16f00101 337cd linux-gpib-kernel-%{version}
2ee896be
JB
338%{expand:%build_kernel_packages}
339%endif
d4054fe9 340
341%install
342rm -rf $RPM_BUILD_ROOT
2ee896be 343install -d $RPM_BUILD_ROOT%{_examplesdir}
d4054fe9 344
8eefbf3b 345%if %{with kernel}
16f00101 346cd linux-gpib-kernel-%{version}
2ee896be
JB
347%{expand:%install_kernel_packages}
348cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
302b72f6 349cd ..
8eefbf3b
MWP
350%endif
351
d4054fe9 352%if %{with userspace}
302b72f6
JR
353cd linux-gpib-user-%{version}
354%{__make} install \
08f3bc97
JB
355 DESTDIR=$RPM_BUILD_ROOT \
356 HOTPLUG_USB_CONF_DIR=/lib/udev \
357 UDEV_RULES_DIR=/lib/udev/rules.d \
358 USB_FIRMWARE_DIR=/lib/firmware
25beb8e8 359
fb21f50f
JB
360%if %{with python2}
361cd language/python
362%py_install
363cd ../..
364%endif
365
25beb8e8 366%if %{with hotplug}
08f3bc97
JB
367# use udev paths as base and legacy hotplug as addon (not the opposite)
368install -d $RPM_BUILD_ROOT/etc/hotplug/usb
369%{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
370ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
371ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
25beb8e8 372%endif
2ee896be
JB
373
374# obsoleted by pkg-config
375%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
376
91dbb874
JB
377%if %{with guile}
378%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
379%if %{with static_libs}
380%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
381%endif
382%endif
383
2ee896be
JB
384%if %{with perl}
385%{__make} -C language/perl pure_install \
386 DESTDIR=$RPM_BUILD_ROOT
76a67c9a 387
2ee896be 388cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
76a67c9a 389
2ee896be
JB
390%{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
391%endif
392
76a67c9a
JB
393%if %{with php}
394install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
395cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
396; Enable gpib extension module
397extension=gpib_php.so
398EOF
399
400%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
401%if %{with static_libs}
402%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
403%endif
404%endif
405
2ee896be
JB
406%if %{with python}
407%py_postclean
408%endif
409
410%if %{with tcl}
411cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
76a67c9a 412
2ee896be
JB
413%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
414%if %{with static_libs}
415%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
416%endif
417%endif
418
635db00a 419%if %{with doc}
2ee896be 420# packaged as %doc
302b72f6 421%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib-user/html
d4054fe9 422%endif
82a3ed18 423%endif
d4054fe9 424
d4054fe9 425%clean
426rm -rf $RPM_BUILD_ROOT
427
2ee896be
JB
428%post libs -p /sbin/ldconfig
429%postun libs -p /sbin/ldconfig
d4054fe9 430
91dbb874
JB
431%post -n guile-gpib -p /sbin/ldconfig
432%postun -n guile-gpib -p /sbin/ldconfig
433
434%post -n tcl-gpib -p /sbin/ldconfig
435%postun -n tcl-gpib -p /sbin/ldconfig
436
76a67c9a
JB
437%post -n %{php_name}-gpib
438%php_webserver_restart
439
440%postun -n %{php_name}-gpib
441if [ "$1" = 0 ]; then
442 %php_webserver_restart
443fi
444
2ee896be
JB
445%if %{with userspace}
446%files
447%defattr(644,root,root,755)
302b72f6 448%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gpib.conf
2ee896be
JB
449%attr(755,root,root) %{_bindir}/ibterm
450%attr(755,root,root) %{_bindir}/ibtest
00074c36 451%attr(755,root,root) %{_bindir}/findlisteners
2ee896be 452%attr(755,root,root) %{_sbindir}/gpib_config
55cbc6e3 453/lib/udev/rules.d/98-gpib-generic.rules
08f3bc97 454/lib/udev/rules.d/99-agilent_82357a.rules
00074c36 455/lib/udev/rules.d/99-lpvo_usb_gpib.rules
08f3bc97 456/lib/udev/rules.d/99-ni_usb_gpib.rules
55cbc6e3
JR
457%attr(755,root,root) /lib/udev/gpib_udev_config
458%attr(755,root,root) /lib/udev/gpib_udev_fxloader
459%attr(755,root,root) /lib/udev/gpib_udevadm_wrapper
08f3bc97
JB
460
461%if %{with hotplug}
462%files hotplug
463%defattr(644,root,root,755)
2ee896be
JB
464%attr(755,root,root) /etc/hotplug/usb/agilent_82357a
465%attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
466/etc/hotplug/usb/agilent_82357a.usermap
467/etc/hotplug/usb/ni_usb_gpib.usermap
08f3bc97 468%endif
d4054fe9 469
2ee896be 470%files libs
0e4898e2 471%defattr(644,root,root,755)
302b72f6 472%doc linux-gpib-user-%{version}/{AUTHORS,ChangeLog,README,README.HAMEG,README.hp82335,TODO}
2ee896be
JB
473%attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
474%attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
475
476%files devel
477%defattr(644,root,root,755)
478%attr(755,root,root) %{_libdir}/libgpib.so
479%{_includedir}/gpib
480%{_pkgconfigdir}/libgpib.pc
481
482%if %{with static_libs}
483%files static
484%defattr(644,root,root,755)
485%{_libdir}/libgpib.a
486%endif
487
91dbb874
JB
488%if %{with guile}
489%files -n guile-gpib
490%defattr(644,root,root,755)
996e3d04 491%attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
91dbb874
JB
492%attr(755,root,root) %{_libdir}/libgpib-guile.so
493%endif
494
2ee896be
JB
495%if %{with perl}
496%files -n perl-gpib
497%defattr(644,root,root,755)
302b72f6 498%doc linux-gpib-user-%{version}/language/perl/{Changes,README}
2ee896be
JB
499%{perl_vendorarch}/LinuxGpib.pm
500%dir %{perl_vendorarch}/auto/LinuxGpib
501%attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
502%{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
503%{_mandir}/man3/LinuxGpib.3pm*
504%{_examplesdir}/perl-gpib-%{version}
505%endif
506
76a67c9a
JB
507%if %{with php}
508%files -n %{php_name}-gpib
509%defattr(644,root,root,755)
510%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
996e3d04 511%attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
76a67c9a
JB
512%attr(755,root,root) %{php_extensiondir}/gpib_php.so
513%endif
514
fb21f50f 515%if %{with python2}
2ee896be
JB
516%files -n python-gpib
517%defattr(644,root,root,755)
302b72f6 518%doc linux-gpib-user-%{version}/language/python/README
2ee896be
JB
519%attr(755,root,root) %{py_sitedir}/gpib.so
520%{py_sitedir}/Gpib.py[co]
521%{py_sitedir}/gpib-1.0-py*.egg-info
522%endif
523
fb21f50f
JB
524%if %{with python}
525%files -n python3-gpib
526%defattr(644,root,root,755)
527%doc linux-gpib-user-%{version}/language/python/README
528%attr(755,root,root) %{py3_sitedir}/gpib.cpython-*.so
529%{py3_sitedir}/Gpib.py
530%{py3_sitedir}/__pycache__/Gpib.cpython-*.py[co]
531%{py3_sitedir}/gpib-1.0-py*.egg-info
532%endif
533
2ee896be
JB
534%if %{with tcl}
535%files -n tcl-gpib
536%defattr(644,root,root,755)
302b72f6 537%doc linux-gpib-user-%{version}/language/tcl/README
996e3d04 538%attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
2ee896be
JB
539%attr(755,root,root) %{_libdir}/libgpib_tcl.so
540%{_examplesdir}/tcl-gpib-%{version}
541%endif
542
635db00a 543%if %{with doc}
2ee896be
JB
544%files doc
545%defattr(644,root,root,755)
302b72f6 546%doc linux-gpib-user-%{version}/doc/doc_html/*
2ee896be 547%endif
1fc85825 548%endif
This page took 0.168951 seconds and 4 git commands to generate.