]> git.pld-linux.org Git - packages/linux-gpib.git/blame - linux-gpib.spec
- unified doc bcond name
[packages/linux-gpib.git] / linux-gpib.spec
CommitLineData
d4054fe9 1#
d4054fe9 2# Conditional build:
2ee896be 3%bcond_without kernel # kernel modules
25beb8e8
JB
4%bcond_without drivers_isa # ISA kernel drivers [ix86 only]
5%bcond_without drivers_pcmcia # PCMCIA support in kernel drivers
6%bcond_without drivers_usb # USB kernel drivers
2ee896be
JB
7%bcond_without userspace # userspace packages
8%bcond_without verbose # verbose modules build (V=1)
df990a65 9
635db00a 10%bcond_without doc # documentation build
08f3bc97 11%bcond_with hotplug # legacy hotplug support
2ee896be 12%bcond_without static_libs # static library
91dbb874 13%bcond_without guile # guile binding
2ee896be 14%bcond_without perl # Perl binding
b3693ec1 15%bcond_with php # PHP binding
2ee896be
JB
16%bcond_without python # Python binding
17%bcond_without tcl # Tcl binding
df990a65 18
4c4f156c
JR
19# The goal here is to have main, userspace, package built once with
20# simple release number, and only rebuild kernel packages with kernel
21# version as part of release number, without the need to bump release
22# with every kernel change.
23%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24%{error:kernel and userspace cannot be built at the same time on PLD builders}
25exit 1
26%endif
27
25beb8e8
JB
28%ifnarch %{ix86}
29%undefine with_drivers_isa
30%undefine with_drivers_pcmcia
31%endif
4c4f156c 32
76a67c9a 33%define php_name php%{?php_suffix}
4c4f156c 34
b323fda4 35%define rel 6
4c4f156c 36%define pname linux-gpib
2ee896be
JB
37Summary: GPIB (IEEE 488) Linux support
38Summary(pl.UTF-8): Obsługa GPIB (IEEE 488) dla Linuksa
4c4f156c 39Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
55cbc6e3 40Version: 4.3.0
2d0c8827 41Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
2ee896be 42License: GPL v2+
cc64c2aa 43Group: Applications/System
996e3d04 44Source0: http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
55cbc6e3 45# Source0-md5: 3085422695baf210b866601db6108860
4c4f156c
JR
46Patch2: %{pname}-python.patch
47Patch3: %{pname}-perl.patch
48Patch4: %{pname}-firmwaredir.patch
49Patch5: %{pname}-guile2.patch
50Patch6: %{pname}-php7.patch
82a3ed18 51Patch8: kernel-5.2.patch
b323fda4 52Patch9: kernel-5.6.patch
d4054fe9 53URL: http://linux-gpib.sourceforge.net/
2ee896be
JB
54BuildRequires: autoconf >= 2.50
55BuildRequires: automake
56BuildRequires: libtool
57BuildRequires: rpmbuild(macros) >= 1.614
d4054fe9 58%if %{with kernel}
2ee896be 59BuildRequires: kernel-module-build >= 3:2.6.8
d4054fe9 60%endif
2ee896be
JB
61%if %{with userspace}
62BuildRequires: bison
635db00a 63%{?with_doc:BuildRequires: docbook-utils}
2ee896be 64BuildRequires: flex
91dbb874 65%{?with_guile:BuildRequires: guile-devel >= 1.4}
df990a65 66%{?with_perl:BuildRequires: perl-devel}
76a67c9a 67%{?with_php:BuildRequires: %{php_name}-devel >= 3:5}
2ee896be
JB
68%{?with_python:BuildRequires: python-devel >= 2}
69BuildRequires: readline-devel
df990a65 70%{?with_tcl:BuildRequires: tcl-devel}
2ee896be 71%endif
4c4f156c 72Requires: %{pname}-libs = %{version}-%{release}
4ffc9310
JB
73# for agilent_82357a and ni_usb_gpib
74Suggests: fxload
75# for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
76Suggests: linux-gpib-firmware
d4054fe9 77BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79%description
cc64c2aa 80The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
d4054fe9 81
bc9733fa
JR
82%description -l pl.UTF-8
83Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
d4054fe9 84
08f3bc97
JB
85%package hotplug
86Summary: Linux GPIB support for legacy USB hotplug
87Summary(pl.UTF-8): Obsługa Linux GPIB dla starego systemu hotplug USB
88Group: Applications/System
4c4f156c 89Requires: %{pname} = %{version}-%{release}
08f3bc97
JB
90Requires: hotplug
91
92%description hotplug
93Linux GPIB support for legacy USB hotplug.
94
95%description hotplug -l pl.UTF-8
96Obsługa Linux GPIB dla starego systemu hotplug USB.
97
2ee896be
JB
98%package libs
99Summary: Shared GPIB library
100Summary(pl.UTF-8): Biblioteka współdzielona GPIB
101Group: Libraries
d7b3679a 102
2ee896be
JB
103%description libs
104Shared GPIB library.
105
106%description libs -l pl.UTF-8
107Biblioteka współdzielona GPIB.
108
109%package devel
110Summary: Header file for GPIB library
111Summary(pl.UTF-8): Plik nagłówkowy biblioteki GPIB
112Group: Development/Libraries
4c4f156c 113Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
114
115%description devel
116Header file for GPIB library.
117
118%description devel -l pl.UTF-8
119Plik nagłówkowy biblioteki GPIB.
120
121%package static
122Summary: Static GPIB library
123Summary(pl.UTF-8): Biblioteka statyczna GPIB
124Group: Development/Libraries
4c4f156c 125Requires: %{pname}-devel = %{version}-%{release}
2ee896be
JB
126
127%description static
128Static GPIB library.
129
130%description static -l pl.UTF-8
131Biblioteka statyczna GPIB.
132
91dbb874
JB
133%package -n guile-gpib
134Summary: Guile bindings for GPIB library
135Summary(pl.UTF-8): Wiązania Guile do biblioteki GPIB
136Group: Development/Languages/Perl
4c4f156c 137Requires: %{pname}-libs = %{version}-%{release}
91dbb874
JB
138Requires: guile-libs
139
140%description -n guile-gpib
141Guile bindings for GPIB library.
142
143%description -n guile-gpib -l pl.UTF-8
144Wiązania Guile do biblioteki GPIB.
145
2ee896be
JB
146%package -n perl-gpib
147Summary: Perl bindings for GPIB library
148Summary(pl.UTF-8): Wiązania Perla do biblioteki GPIB
149Group: Development/Languages/Perl
4c4f156c 150Requires: %{pname}-libs = %{version}-%{release}
d7b3679a 151
2ee896be
JB
152%description -n perl-gpib
153Perl bindings for GPIB library.
d7b3679a 154
2ee896be
JB
155%description -n perl-gpib -l pl.UTF-8
156Wiązania Perla do biblioteki GPIB.
d7b3679a 157
76a67c9a
JB
158%package -n %{php_name}-gpib
159Summary: PHP bindings for GPIB library
160Summary(pl.UTF-8): Wiązania PHP do biblioteki GPIB
161Group: Development/Languages/PHP
162Provides: php(gpib) = %{version}
4c4f156c 163Requires: %{pname}-libs = %{version}-%{release}
76a67c9a
JB
164%{?requires_php_extension}
165
166%description -n %{php_name}-gpib
167PHP bindings for GPIB library.
168
169%description -n %{php_name}-gpib -l pl.UTF-8
170Wiązania PHP do biblioteki GPIB.
171
2ee896be
JB
172%package -n python-gpib
173Summary: Python bindings for GPIB library
174Summary(pl.UTF-8): Wiązania Pythona do biblioteki GPIB
175Group: Libraries/Python
4c4f156c 176Requires: %{pname}-libs = %{version}-%{release}
2ee896be 177Requires: python-libs
d7b3679a 178
2ee896be
JB
179%description -n python-gpib
180Python bindings for GPIB library.
181
182%description -n python-gpib -l pl.UTF-8
183Wiązania Pythona do biblioteki GPIB.
184
185%package -n tcl-gpib
186Summary: Tcl bindings for GPIB library
187Summary(pl.UTF-8): Wiązania Tcl-a do biblioteki GPIB
188Group: Libraries
4c4f156c 189Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
190Requires: tcl
191
192%description -n tcl-gpib
193Tcl bindings for GPIB library.
194
195%description -n tcl-gpib -l pl.UTF-8
196Wiązania Tcl-a do biblioteki GPIB.
197
198%package doc
199Summary: Linux-GPIB tools and library documentation
200Summary(pl.UTF-8): Dokumentacja narzędzi i biblioteki Linux-GPIB
201License: GFDL v1.2+ or GPL v2+
202Group: Documentation
203
204%description doc
205Linux-GPIB tools and library documentation.
206
207%description doc -l pl.UTF-8
208Dokumentacja narzędzi i biblioteki Linux-GPIB.
209
210%define kernel_pkg()\
211%package -n kernel%{_alt_kernel}-gpib\
212Summary: Linux GPIB drivers\
213Summary(pl.UTF-8): Sterowniki GPIB dla Linuksa\
214Release: %{rel}@%{_kernel_ver_str}\
215Group: Base/Kernel\
216Requires(post,postun): /sbin/depmod\
217%requires_releq_kernel\
218Requires(postun): %releq_kernel\
219\
220%description -n kernel%{_alt_kernel}-gpib\
221This package contains Linux drivers for GPIB (IEEE 488) hardware.\
222\
223%description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
224Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
225\
226%if %{with kernel}\
227%files -n kernel%{_alt_kernel}-gpib\
228%defattr(644,root,root,755)\
229/lib/modules/%{_kernel_ver}/kernel/gpib\
230%endif\
231\
232%post -n kernel%{_alt_kernel}-gpib\
233%depmod %{_kernel_ver}\
234\
235%postun -n kernel%{_alt_kernel}-gpib\
236%depmod %{_kernel_ver}\
237%{nil}
238
239%define build_kernel_pkg()\
55cbc6e3 240%{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir}\
2ee896be 241cd drivers/gpib\
82a3ed18
JR
242%ifarch %{ix86}\
243%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,lpvo_usb_gpib/lpvo_usb_gpib,ni_usb/ni_usb_gpib} -d kernel/gpib\
244%else\
25beb8e8 245%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,lpvo_usb_gpib/lpvo_usb_gpib,ni_usb/ni_usb_gpib} -d kernel/gpib\
82a3ed18 246%endif\
b69cc3e0 247cd ../..\
2ee896be
JB
248%{nil}
249
250%define install_kernel_pkg()\
251%{nil}
252
253%{?with_kernel:%{expand:%create_kernel_packages}}
d7b3679a 254
d4054fe9 255%prep
996e3d04 256%setup -q -n %{pname}-%{version}
16f00101
JR
257%if %{with userspace}
258tar xzf linux-gpib-user-%{version}.tar.gz
259cd linux-gpib-user-%{version}
2ee896be
JB
260%patch2 -p1
261%patch3 -p1
08f3bc97 262%patch4 -p1
91dbb874 263%patch5 -p1
16f00101
JR
264#%patch6 -p1
265cd ..
266%endif
267
268%if %{with kernel}
269tar xzf linux-gpib-kernel-%{version}.tar.gz
270cd linux-gpib-kernel-%{version}
5e300ced
JR
271%ifarch %{ix86}
272%patch8 -p1
273%endif
b323fda4 274%patch9 -p1
16f00101 275%endif
d7b3679a 276
d4054fe9 277%build
16f00101
JR
278%if %{with userspace}
279cd linux-gpib-user-%{version}
302b72f6
JR
280%{__libtoolize}
281%{__aclocal}
282%{__autoconf}
283%{__autoheader}
284%{__automake}
91dbb874 285%if %{with guile}
d53b2ad5 286CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.2"
91dbb874 287%endif
d7b3679a 288%configure \
55cbc6e3 289 --with-udev-libdir=/lib/udev \
25beb8e8
JB
290 %{?with_drivers_isa:--enable-isa} \
291 %{?with_drivers_pcmcia:--enable-pcmcia} \
635db00a 292 %{!?with_doc:--disable-documentation} \
2ee896be
JB
293 %{!?with_guile:--disable-guile-binding} \
294 %{!?with_perl:--disable-perl-binding} \
295 %{!?with_php:--disable-php-binding} \
296 %{!?with_python:--disable-python-binding} \
297 %{?with_static_libs:--enable-static} \
16f00101 298 %{!?with_tcl:--disable-tcl-binding}
d7b3679a 299
9e3b7024 300%{__make}
16f00101 301cd ..
2ee896be 302%endif
d7b3679a 303
2ee896be 304%if %{with kernel}
16f00101 305cd linux-gpib-kernel-%{version}
2ee896be
JB
306%{expand:%build_kernel_packages}
307%endif
d4054fe9 308
309%install
310rm -rf $RPM_BUILD_ROOT
2ee896be 311install -d $RPM_BUILD_ROOT%{_examplesdir}
d4054fe9 312
8eefbf3b 313%if %{with kernel}
16f00101 314cd linux-gpib-kernel-%{version}
2ee896be
JB
315%{expand:%install_kernel_packages}
316cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
302b72f6 317cd ..
8eefbf3b
MWP
318%endif
319
d4054fe9 320%if %{with userspace}
302b72f6
JR
321cd linux-gpib-user-%{version}
322%{__make} install \
08f3bc97
JB
323 DESTDIR=$RPM_BUILD_ROOT \
324 HOTPLUG_USB_CONF_DIR=/lib/udev \
325 UDEV_RULES_DIR=/lib/udev/rules.d \
326 USB_FIRMWARE_DIR=/lib/firmware
25beb8e8
JB
327
328%if %{with hotplug}
08f3bc97
JB
329# use udev paths as base and legacy hotplug as addon (not the opposite)
330install -d $RPM_BUILD_ROOT/etc/hotplug/usb
331%{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
332ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
333ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
25beb8e8 334%endif
2ee896be
JB
335
336# obsoleted by pkg-config
337%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
338
91dbb874
JB
339%if %{with guile}
340%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
341%if %{with static_libs}
342%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
343%endif
344%endif
345
2ee896be
JB
346%if %{with perl}
347%{__make} -C language/perl pure_install \
348 DESTDIR=$RPM_BUILD_ROOT
76a67c9a 349
2ee896be 350cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
76a67c9a 351
2ee896be
JB
352%{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
353%endif
354
76a67c9a
JB
355%if %{with php}
356install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
357cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
358; Enable gpib extension module
359extension=gpib_php.so
360EOF
361
362%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
363%if %{with static_libs}
364%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
365%endif
366%endif
367
2ee896be
JB
368%if %{with python}
369%py_postclean
370%endif
371
372%if %{with tcl}
373cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
76a67c9a 374
2ee896be
JB
375%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
376%if %{with static_libs}
377%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
378%endif
379%endif
380
635db00a 381%if %{with doc}
2ee896be 382# packaged as %doc
302b72f6 383%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib-user/html
d4054fe9 384%endif
82a3ed18 385%endif
d4054fe9 386
d4054fe9 387%clean
388rm -rf $RPM_BUILD_ROOT
389
2ee896be
JB
390%post libs -p /sbin/ldconfig
391%postun libs -p /sbin/ldconfig
d4054fe9 392
91dbb874
JB
393%post -n guile-gpib -p /sbin/ldconfig
394%postun -n guile-gpib -p /sbin/ldconfig
395
396%post -n tcl-gpib -p /sbin/ldconfig
397%postun -n tcl-gpib -p /sbin/ldconfig
398
76a67c9a
JB
399%post -n %{php_name}-gpib
400%php_webserver_restart
401
402%postun -n %{php_name}-gpib
403if [ "$1" = 0 ]; then
404 %php_webserver_restart
405fi
406
2ee896be
JB
407%if %{with userspace}
408%files
409%defattr(644,root,root,755)
302b72f6 410%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gpib.conf
2ee896be
JB
411%attr(755,root,root) %{_bindir}/ibterm
412%attr(755,root,root) %{_bindir}/ibtest
413%attr(755,root,root) %{_sbindir}/gpib_config
55cbc6e3 414/lib/udev/rules.d/98-gpib-generic.rules
08f3bc97 415/lib/udev/rules.d/99-agilent_82357a.rules
08f3bc97 416/lib/udev/rules.d/99-ni_usb_gpib.rules
55cbc6e3
JR
417%attr(755,root,root) /lib/udev/gpib_udev_config
418%attr(755,root,root) /lib/udev/gpib_udev_fxloader
419%attr(755,root,root) /lib/udev/gpib_udevadm_wrapper
08f3bc97
JB
420
421%if %{with hotplug}
422%files hotplug
423%defattr(644,root,root,755)
2ee896be
JB
424%attr(755,root,root) /etc/hotplug/usb/agilent_82357a
425%attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
426/etc/hotplug/usb/agilent_82357a.usermap
427/etc/hotplug/usb/ni_usb_gpib.usermap
08f3bc97 428%endif
d4054fe9 429
2ee896be 430%files libs
0e4898e2 431%defattr(644,root,root,755)
302b72f6 432%doc linux-gpib-user-%{version}/{AUTHORS,ChangeLog,README,README.HAMEG,README.hp82335,TODO}
2ee896be
JB
433%attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
434%attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
435
436%files devel
437%defattr(644,root,root,755)
438%attr(755,root,root) %{_libdir}/libgpib.so
439%{_includedir}/gpib
440%{_pkgconfigdir}/libgpib.pc
441
442%if %{with static_libs}
443%files static
444%defattr(644,root,root,755)
445%{_libdir}/libgpib.a
446%endif
447
91dbb874
JB
448%if %{with guile}
449%files -n guile-gpib
450%defattr(644,root,root,755)
996e3d04 451%attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
91dbb874
JB
452%attr(755,root,root) %{_libdir}/libgpib-guile.so
453%endif
454
2ee896be
JB
455%if %{with perl}
456%files -n perl-gpib
457%defattr(644,root,root,755)
302b72f6 458%doc linux-gpib-user-%{version}/language/perl/{Changes,README}
2ee896be
JB
459%{perl_vendorarch}/LinuxGpib.pm
460%dir %{perl_vendorarch}/auto/LinuxGpib
461%attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
462%{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
463%{_mandir}/man3/LinuxGpib.3pm*
464%{_examplesdir}/perl-gpib-%{version}
465%endif
466
76a67c9a
JB
467%if %{with php}
468%files -n %{php_name}-gpib
469%defattr(644,root,root,755)
470%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
996e3d04 471%attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
76a67c9a
JB
472%attr(755,root,root) %{php_extensiondir}/gpib_php.so
473%endif
474
2ee896be
JB
475%if %{with python}
476%files -n python-gpib
477%defattr(644,root,root,755)
302b72f6 478%doc linux-gpib-user-%{version}/language/python/README
2ee896be
JB
479%attr(755,root,root) %{py_sitedir}/gpib.so
480%{py_sitedir}/Gpib.py[co]
481%{py_sitedir}/gpib-1.0-py*.egg-info
482%endif
483
484%if %{with tcl}
485%files -n tcl-gpib
486%defattr(644,root,root,755)
302b72f6 487%doc linux-gpib-user-%{version}/language/tcl/README
996e3d04 488%attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
2ee896be
JB
489%attr(755,root,root) %{_libdir}/libgpib_tcl.so
490%{_examplesdir}/tcl-gpib-%{version}
491%endif
492
635db00a 493%if %{with doc}
2ee896be
JB
494%files doc
495%defattr(644,root,root,755)
302b72f6 496%doc linux-gpib-user-%{version}/doc/doc_html/*
2ee896be 497%endif
1fc85825 498%endif
This page took 0.163522 seconds and 4 git commands to generate.