]> git.pld-linux.org Git - packages/linux-gpib.git/blame - linux-gpib.spec
- upstream: disable driver that does not build on kernel 5.10
[packages/linux-gpib.git] / linux-gpib.spec
CommitLineData
d4054fe9 1#
d4054fe9 2# Conditional build:
2ee896be 3%bcond_without kernel # kernel modules
25beb8e8 4%bcond_without drivers_isa # ISA kernel drivers [ix86 only]
25beb8e8 5%bcond_without drivers_usb # USB kernel drivers
2ee896be
JB
6%bcond_without userspace # userspace packages
7%bcond_without verbose # verbose modules build (V=1)
df990a65 8
635db00a 9%bcond_without doc # documentation build
08f3bc97 10%bcond_with hotplug # legacy hotplug support
2ee896be 11%bcond_without static_libs # static library
91dbb874 12%bcond_without guile # guile binding
2ee896be 13%bcond_without perl # Perl binding
b3693ec1 14%bcond_with php # PHP binding
fb21f50f
JB
15%bcond_without python # Python (any) binding
16%bcond_without python2 # Python 2.x binding
2ee896be 17%bcond_without tcl # Tcl binding
df990a65 18
4c4f156c
JR
19# The goal here is to have main, userspace, package built once with
20# simple release number, and only rebuild kernel packages with kernel
21# version as part of release number, without the need to bump release
22# with every kernel change.
23%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24%{error:kernel and userspace cannot be built at the same time on PLD builders}
25exit 1
26%endif
27
25beb8e8
JB
28%ifnarch %{ix86}
29%undefine with_drivers_isa
fb21f50f
JB
30%endif
31%if %{without python}
32%undefine with_python2
25beb8e8 33%endif
4c4f156c 34
76a67c9a 35%define php_name php%{?php_suffix}
4c4f156c 36
403be2a0 37%define rel 2
4c4f156c 38%define pname linux-gpib
2ee896be
JB
39Summary: GPIB (IEEE 488) Linux support
40Summary(pl.UTF-8): Obsługa GPIB (IEEE 488) dla Linuksa
4c4f156c 41Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
fb21f50f 42Version: 4.3.3
2d0c8827 43Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
2ee896be 44License: GPL v2+
cc64c2aa 45Group: Applications/System
996e3d04 46Source0: http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
fb21f50f 47# Source0-md5: 1243aa44f788cf23f9b40ded54c14685
4c4f156c
JR
48Patch2: %{pname}-python.patch
49Patch3: %{pname}-perl.patch
50Patch4: %{pname}-firmwaredir.patch
51Patch5: %{pname}-guile2.patch
52Patch6: %{pname}-php7.patch
82a3ed18 53Patch8: kernel-5.2.patch
403be2a0 54Patch9: kernel-5.10.patch
d4054fe9 55URL: http://linux-gpib.sourceforge.net/
2ee896be
JB
56BuildRequires: autoconf >= 2.50
57BuildRequires: automake
58BuildRequires: libtool
fb21f50f 59BuildRequires: rpmbuild(macros) >= 1.745
d4054fe9 60%if %{with kernel}
2ee896be 61BuildRequires: kernel-module-build >= 3:2.6.8
d4054fe9 62%endif
2ee896be
JB
63%if %{with userspace}
64BuildRequires: bison
635db00a 65%{?with_doc:BuildRequires: docbook-utils}
2ee896be 66BuildRequires: flex
91dbb874 67%{?with_guile:BuildRequires: guile-devel >= 1.4}
df990a65 68%{?with_perl:BuildRequires: perl-devel}
76a67c9a 69%{?with_php:BuildRequires: %{php_name}-devel >= 3:5}
2ee896be
JB
70%{?with_python:BuildRequires: python-devel >= 2}
71BuildRequires: readline-devel
df990a65 72%{?with_tcl:BuildRequires: tcl-devel}
2ee896be 73%endif
4c4f156c 74Requires: %{pname}-libs = %{version}-%{release}
4ffc9310
JB
75# for agilent_82357a and ni_usb_gpib
76Suggests: fxload
77# for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
78Suggests: linux-gpib-firmware
d4054fe9 79BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81%description
cc64c2aa 82The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
d4054fe9 83
bc9733fa
JR
84%description -l pl.UTF-8
85Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
d4054fe9 86
08f3bc97
JB
87%package hotplug
88Summary: Linux GPIB support for legacy USB hotplug
89Summary(pl.UTF-8): Obsługa Linux GPIB dla starego systemu hotplug USB
90Group: Applications/System
4c4f156c 91Requires: %{pname} = %{version}-%{release}
08f3bc97
JB
92Requires: hotplug
93
94%description hotplug
95Linux GPIB support for legacy USB hotplug.
96
97%description hotplug -l pl.UTF-8
98Obsługa Linux GPIB dla starego systemu hotplug USB.
99
2ee896be
JB
100%package libs
101Summary: Shared GPIB library
102Summary(pl.UTF-8): Biblioteka współdzielona GPIB
103Group: Libraries
d7b3679a 104
2ee896be
JB
105%description libs
106Shared GPIB library.
107
108%description libs -l pl.UTF-8
109Biblioteka współdzielona GPIB.
110
111%package devel
112Summary: Header file for GPIB library
113Summary(pl.UTF-8): Plik nagłówkowy biblioteki GPIB
114Group: Development/Libraries
4c4f156c 115Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
116
117%description devel
118Header file for GPIB library.
119
120%description devel -l pl.UTF-8
121Plik nagłówkowy biblioteki GPIB.
122
123%package static
124Summary: Static GPIB library
125Summary(pl.UTF-8): Biblioteka statyczna GPIB
126Group: Development/Libraries
4c4f156c 127Requires: %{pname}-devel = %{version}-%{release}
2ee896be
JB
128
129%description static
130Static GPIB library.
131
132%description static -l pl.UTF-8
133Biblioteka statyczna GPIB.
134
91dbb874
JB
135%package -n guile-gpib
136Summary: Guile bindings for GPIB library
137Summary(pl.UTF-8): Wiązania Guile do biblioteki GPIB
138Group: Development/Languages/Perl
4c4f156c 139Requires: %{pname}-libs = %{version}-%{release}
91dbb874
JB
140Requires: guile-libs
141
142%description -n guile-gpib
143Guile bindings for GPIB library.
144
145%description -n guile-gpib -l pl.UTF-8
146Wiązania Guile do biblioteki GPIB.
147
2ee896be
JB
148%package -n perl-gpib
149Summary: Perl bindings for GPIB library
150Summary(pl.UTF-8): Wiązania Perla do biblioteki GPIB
151Group: Development/Languages/Perl
4c4f156c 152Requires: %{pname}-libs = %{version}-%{release}
d7b3679a 153
2ee896be
JB
154%description -n perl-gpib
155Perl bindings for GPIB library.
d7b3679a 156
2ee896be
JB
157%description -n perl-gpib -l pl.UTF-8
158Wiązania Perla do biblioteki GPIB.
d7b3679a 159
76a67c9a
JB
160%package -n %{php_name}-gpib
161Summary: PHP bindings for GPIB library
162Summary(pl.UTF-8): Wiązania PHP do biblioteki GPIB
163Group: Development/Languages/PHP
164Provides: php(gpib) = %{version}
4c4f156c 165Requires: %{pname}-libs = %{version}-%{release}
76a67c9a
JB
166%{?requires_php_extension}
167
168%description -n %{php_name}-gpib
169PHP bindings for GPIB library.
170
171%description -n %{php_name}-gpib -l pl.UTF-8
172Wiązania PHP do biblioteki GPIB.
173
2ee896be 174%package -n python-gpib
fb21f50f
JB
175Summary: Python 2 bindings for GPIB library
176Summary(pl.UTF-8): Wiązania Pythona 2 do biblioteki GPIB
2ee896be 177Group: Libraries/Python
4c4f156c 178Requires: %{pname}-libs = %{version}-%{release}
2ee896be 179Requires: python-libs
d7b3679a 180
2ee896be 181%description -n python-gpib
fb21f50f 182Python 2 bindings for GPIB library.
2ee896be
JB
183
184%description -n python-gpib -l pl.UTF-8
fb21f50f
JB
185Wiązania Pythona 2 do biblioteki GPIB.
186
187%package -n python3-gpib
188Summary: Python 3 bindings for GPIB library
189Summary(pl.UTF-8): Wiązania Pythona 3 do biblioteki GPIB
190Group: Libraries/Python
191Requires: %{pname}-libs = %{version}-%{release}
192Requires: python3-libs
193
194%description -n python3-gpib
195Python 3 bindings for GPIB library.
196
197%description -n python3-gpib -l pl.UTF-8
198Wiązania Pythona 3 do biblioteki GPIB.
2ee896be
JB
199
200%package -n tcl-gpib
201Summary: Tcl bindings for GPIB library
202Summary(pl.UTF-8): Wiązania Tcl-a do biblioteki GPIB
203Group: Libraries
4c4f156c 204Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
205Requires: tcl
206
207%description -n tcl-gpib
208Tcl bindings for GPIB library.
209
210%description -n tcl-gpib -l pl.UTF-8
211Wiązania Tcl-a do biblioteki GPIB.
212
213%package doc
214Summary: Linux-GPIB tools and library documentation
215Summary(pl.UTF-8): Dokumentacja narzędzi i biblioteki Linux-GPIB
216License: GFDL v1.2+ or GPL v2+
217Group: Documentation
218
219%description doc
220Linux-GPIB tools and library documentation.
221
222%description doc -l pl.UTF-8
223Dokumentacja narzędzi i biblioteki Linux-GPIB.
224
225%define kernel_pkg()\
226%package -n kernel%{_alt_kernel}-gpib\
227Summary: Linux GPIB drivers\
228Summary(pl.UTF-8): Sterowniki GPIB dla Linuksa\
229Release: %{rel}@%{_kernel_ver_str}\
230Group: Base/Kernel\
231Requires(post,postun): /sbin/depmod\
232%requires_releq_kernel\
233Requires(postun): %releq_kernel\
234\
235%description -n kernel%{_alt_kernel}-gpib\
236This package contains Linux drivers for GPIB (IEEE 488) hardware.\
237\
238%description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
239Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
240\
241%if %{with kernel}\
242%files -n kernel%{_alt_kernel}-gpib\
243%defattr(644,root,root,755)\
244/lib/modules/%{_kernel_ver}/kernel/gpib\
245%endif\
246\
247%post -n kernel%{_alt_kernel}-gpib\
248%depmod %{_kernel_ver}\
249\
250%postun -n kernel%{_alt_kernel}-gpib\
251%depmod %{_kernel_ver}\
252%{nil}
253
254%define build_kernel_pkg()\
55cbc6e3 255%{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir}\
2ee896be 256cd drivers/gpib\
403be2a0
JR
257%if %{_kernel_version_code} < %{_kernel_version_magic 5 10 0}\
258%if %{with drivers_usb}\
259%install_kernel_modules -D installed -m lpvo_usb_gpib/lpvo_usb_gpib -d kernel/gpib\
260%endif\
261%endif\
82a3ed18 262%ifarch %{ix86}\
403be2a0 263%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
82a3ed18 264%else\
403be2a0 265%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
82a3ed18 266%endif\
b69cc3e0 267cd ../..\
2ee896be
JB
268%{nil}
269
270%define install_kernel_pkg()\
271%{nil}
272
273%{?with_kernel:%{expand:%create_kernel_packages}}
d7b3679a 274
d4054fe9 275%prep
996e3d04 276%setup -q -n %{pname}-%{version}
16f00101
JR
277%if %{with userspace}
278tar xzf linux-gpib-user-%{version}.tar.gz
279cd linux-gpib-user-%{version}
2ee896be
JB
280%patch2 -p1
281%patch3 -p1
08f3bc97 282%patch4 -p1
91dbb874 283%patch5 -p1
16f00101
JR
284#%patch6 -p1
285cd ..
286%endif
287
288%if %{with kernel}
289tar xzf linux-gpib-kernel-%{version}.tar.gz
290cd linux-gpib-kernel-%{version}
5e300ced
JR
291%ifarch %{ix86}
292%patch8 -p1
293%endif
403be2a0 294%patch9 -p1
16f00101 295%endif
d7b3679a 296
d4054fe9 297%build
16f00101
JR
298%if %{with userspace}
299cd linux-gpib-user-%{version}
302b72f6
JR
300%{__libtoolize}
301%{__aclocal}
302%{__autoconf}
303%{__autoheader}
304%{__automake}
91dbb874 305%if %{with guile}
d53b2ad5 306CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.2"
91dbb874 307%endif
d7b3679a 308%configure \
55cbc6e3 309 --with-udev-libdir=/lib/udev \
635db00a 310 %{!?with_doc:--disable-documentation} \
2ee896be
JB
311 %{!?with_guile:--disable-guile-binding} \
312 %{!?with_perl:--disable-perl-binding} \
313 %{!?with_php:--disable-php-binding} \
314 %{!?with_python:--disable-python-binding} \
315 %{?with_static_libs:--enable-static} \
16f00101 316 %{!?with_tcl:--disable-tcl-binding}
d7b3679a 317
9e3b7024 318%{__make}
fb21f50f
JB
319
320%if %{with python2}
321cd language/python
322%py_build
323cd ../..
324%endif
16f00101 325cd ..
2ee896be 326%endif
d7b3679a 327
2ee896be 328%if %{with kernel}
16f00101 329cd linux-gpib-kernel-%{version}
2ee896be
JB
330%{expand:%build_kernel_packages}
331%endif
d4054fe9 332
333%install
334rm -rf $RPM_BUILD_ROOT
2ee896be 335install -d $RPM_BUILD_ROOT%{_examplesdir}
d4054fe9 336
8eefbf3b 337%if %{with kernel}
16f00101 338cd linux-gpib-kernel-%{version}
2ee896be
JB
339%{expand:%install_kernel_packages}
340cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
302b72f6 341cd ..
8eefbf3b
MWP
342%endif
343
d4054fe9 344%if %{with userspace}
302b72f6
JR
345cd linux-gpib-user-%{version}
346%{__make} install \
08f3bc97
JB
347 DESTDIR=$RPM_BUILD_ROOT \
348 HOTPLUG_USB_CONF_DIR=/lib/udev \
349 UDEV_RULES_DIR=/lib/udev/rules.d \
350 USB_FIRMWARE_DIR=/lib/firmware
25beb8e8 351
fb21f50f
JB
352%if %{with python2}
353cd language/python
354%py_install
355cd ../..
356%endif
357
25beb8e8 358%if %{with hotplug}
08f3bc97
JB
359# use udev paths as base and legacy hotplug as addon (not the opposite)
360install -d $RPM_BUILD_ROOT/etc/hotplug/usb
361%{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
362ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
363ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
25beb8e8 364%endif
2ee896be
JB
365
366# obsoleted by pkg-config
367%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
368
91dbb874
JB
369%if %{with guile}
370%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
371%if %{with static_libs}
372%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
373%endif
374%endif
375
2ee896be
JB
376%if %{with perl}
377%{__make} -C language/perl pure_install \
378 DESTDIR=$RPM_BUILD_ROOT
76a67c9a 379
2ee896be 380cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
76a67c9a 381
2ee896be
JB
382%{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
383%endif
384
76a67c9a
JB
385%if %{with php}
386install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
387cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
388; Enable gpib extension module
389extension=gpib_php.so
390EOF
391
392%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
393%if %{with static_libs}
394%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
395%endif
396%endif
397
2ee896be
JB
398%if %{with python}
399%py_postclean
400%endif
401
402%if %{with tcl}
403cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
76a67c9a 404
2ee896be
JB
405%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
406%if %{with static_libs}
407%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
408%endif
409%endif
410
635db00a 411%if %{with doc}
2ee896be 412# packaged as %doc
302b72f6 413%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib-user/html
d4054fe9 414%endif
82a3ed18 415%endif
d4054fe9 416
d4054fe9 417%clean
418rm -rf $RPM_BUILD_ROOT
419
2ee896be
JB
420%post libs -p /sbin/ldconfig
421%postun libs -p /sbin/ldconfig
d4054fe9 422
91dbb874
JB
423%post -n guile-gpib -p /sbin/ldconfig
424%postun -n guile-gpib -p /sbin/ldconfig
425
426%post -n tcl-gpib -p /sbin/ldconfig
427%postun -n tcl-gpib -p /sbin/ldconfig
428
76a67c9a
JB
429%post -n %{php_name}-gpib
430%php_webserver_restart
431
432%postun -n %{php_name}-gpib
433if [ "$1" = 0 ]; then
434 %php_webserver_restart
435fi
436
2ee896be
JB
437%if %{with userspace}
438%files
439%defattr(644,root,root,755)
302b72f6 440%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gpib.conf
2ee896be
JB
441%attr(755,root,root) %{_bindir}/ibterm
442%attr(755,root,root) %{_bindir}/ibtest
443%attr(755,root,root) %{_sbindir}/gpib_config
55cbc6e3 444/lib/udev/rules.d/98-gpib-generic.rules
08f3bc97 445/lib/udev/rules.d/99-agilent_82357a.rules
08f3bc97 446/lib/udev/rules.d/99-ni_usb_gpib.rules
55cbc6e3
JR
447%attr(755,root,root) /lib/udev/gpib_udev_config
448%attr(755,root,root) /lib/udev/gpib_udev_fxloader
449%attr(755,root,root) /lib/udev/gpib_udevadm_wrapper
08f3bc97
JB
450
451%if %{with hotplug}
452%files hotplug
453%defattr(644,root,root,755)
2ee896be
JB
454%attr(755,root,root) /etc/hotplug/usb/agilent_82357a
455%attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
456/etc/hotplug/usb/agilent_82357a.usermap
457/etc/hotplug/usb/ni_usb_gpib.usermap
08f3bc97 458%endif
d4054fe9 459
2ee896be 460%files libs
0e4898e2 461%defattr(644,root,root,755)
302b72f6 462%doc linux-gpib-user-%{version}/{AUTHORS,ChangeLog,README,README.HAMEG,README.hp82335,TODO}
2ee896be
JB
463%attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
464%attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
465
466%files devel
467%defattr(644,root,root,755)
468%attr(755,root,root) %{_libdir}/libgpib.so
469%{_includedir}/gpib
470%{_pkgconfigdir}/libgpib.pc
471
472%if %{with static_libs}
473%files static
474%defattr(644,root,root,755)
475%{_libdir}/libgpib.a
476%endif
477
91dbb874
JB
478%if %{with guile}
479%files -n guile-gpib
480%defattr(644,root,root,755)
996e3d04 481%attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
91dbb874
JB
482%attr(755,root,root) %{_libdir}/libgpib-guile.so
483%endif
484
2ee896be
JB
485%if %{with perl}
486%files -n perl-gpib
487%defattr(644,root,root,755)
302b72f6 488%doc linux-gpib-user-%{version}/language/perl/{Changes,README}
2ee896be
JB
489%{perl_vendorarch}/LinuxGpib.pm
490%dir %{perl_vendorarch}/auto/LinuxGpib
491%attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
492%{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
493%{_mandir}/man3/LinuxGpib.3pm*
494%{_examplesdir}/perl-gpib-%{version}
495%endif
496
76a67c9a
JB
497%if %{with php}
498%files -n %{php_name}-gpib
499%defattr(644,root,root,755)
500%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
996e3d04 501%attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
76a67c9a
JB
502%attr(755,root,root) %{php_extensiondir}/gpib_php.so
503%endif
504
fb21f50f 505%if %{with python2}
2ee896be
JB
506%files -n python-gpib
507%defattr(644,root,root,755)
302b72f6 508%doc linux-gpib-user-%{version}/language/python/README
2ee896be
JB
509%attr(755,root,root) %{py_sitedir}/gpib.so
510%{py_sitedir}/Gpib.py[co]
511%{py_sitedir}/gpib-1.0-py*.egg-info
512%endif
513
fb21f50f
JB
514%if %{with python}
515%files -n python3-gpib
516%defattr(644,root,root,755)
517%doc linux-gpib-user-%{version}/language/python/README
518%attr(755,root,root) %{py3_sitedir}/gpib.cpython-*.so
519%{py3_sitedir}/Gpib.py
520%{py3_sitedir}/__pycache__/Gpib.cpython-*.py[co]
521%{py3_sitedir}/gpib-1.0-py*.egg-info
522%endif
523
2ee896be
JB
524%if %{with tcl}
525%files -n tcl-gpib
526%defattr(644,root,root,755)
302b72f6 527%doc linux-gpib-user-%{version}/language/tcl/README
996e3d04 528%attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
2ee896be
JB
529%attr(755,root,root) %{_libdir}/libgpib_tcl.so
530%{_examplesdir}/tcl-gpib-%{version}
531%endif
532
635db00a 533%if %{with doc}
2ee896be
JB
534%files doc
535%defattr(644,root,root,755)
302b72f6 536%doc linux-gpib-user-%{version}/doc/doc_html/*
2ee896be 537%endif
1fc85825 538%endif
This page took 0.150065 seconds and 4 git commands to generate.